Forum software upgrade on 11/17/2017 technical issues thread

Talk about anything and everything here within reason.
User avatar
neptronix
100 GW
100 GW
Posts: 13061
Joined: Jun 15, 2010 5:56 pm
Location: People's republic of Petrolistan ( Utah, USA )
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by neptronix » Nov 18, 2017 1:03 am

I see the initial poster's name on the left in this view. But not their icon.
2017-11-17 21_56_12-Endless Sphere - Active topics.png
2017-11-17 21_56_12-Endless Sphere - Active topics.png (25.14 KiB) Viewed 175 times
Just keep in mind that the old forum did not even show poster icons at all. The one on the right is shown only thanks to an add-on ( phpbb still can't do that! )

I do wonder if i can jam the original poster's avatar in on the left in this theme. i'll add that to my list of things to investigate once we shake any/all bugs out of this round of changes.
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
fechter
100 GW
100 GW
Posts: 11822
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Forum software upgrade happening on 11/16/17

Post by fechter » Nov 18, 2017 1:04 am

The Prosilver theme will show the OP username in the index.

Is there a way to edit the themes? I miss the old SubSilver, but anything that's easy on the eyes would be great.
"One test is worth a thousand opinions"

User avatar
neptronix
100 GW
100 GW
Posts: 13061
Joined: Jun 15, 2010 5:56 pm
Location: People's republic of Petrolistan ( Utah, USA )
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by neptronix » Nov 18, 2017 1:21 am

The Prosilver theme will show the OP username in the index.

Is there a way to edit the themes? I miss the old SubSilver, but anything that's easy on the eyes would be great.
The themes for this version of phpbb are much more difficult to edit this time around, due to them being mobile compatible. Do you know css, html, and javascript? :shock: :cry:

The closest you're going to get to subsilver for the moment is se_square_left for now. ( i also miss subsilver )

Gammaray found a huge bug. Moderator's categories are missing from view, even though the permissions appear to be set correctly. I tried to fix it to no avail tonight. Will give it another stab when i have time tomorrow.

Another moderator PS: see user profile pages for the 'hammer.. it's there, trust me ;)

We are also missing the edit history modification. I'm putting that on my list.
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
amberwolf
100 GW
100 GW
Posts: 23942
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by amberwolf » Nov 18, 2017 5:16 am

Maybe this would be the better thread for them (now that I see others are listing issues here), but I posted a number of problems (and have more to do once I'm able) over here in the "differences" thread:

https://endless-sphere.com/forums/viewt ... =1&t=91553

User avatar
eCue
100 W
100 W
Posts: 115
Joined: Nov 03, 2017 5:14 pm
Location: Vancouver Island , Canada

Re: Forum software upgrade happening on 11/16/17

Post by eCue » Nov 18, 2017 10:27 am

I like the new look

Tip , if the fonts were larger it would make for easier reading as Im having to zoom
"98 Quintana roo Panamint 350w mxus build link - https://endless-sphere.com/forums/view ... =6&t=91627

User avatar
neptronix
100 GW
100 GW
Posts: 13061
Joined: Jun 15, 2010 5:56 pm
Location: People's republic of Petrolistan ( Utah, USA )
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by neptronix » Nov 18, 2017 2:46 pm

eCue wrote:
Nov 18, 2017 10:27 am
I like the new look

Tip , if the fonts were larger it would make for easier reading as Im having to zoom
Your wish is granted, since a few others users mentioned this as being a problem. I was able to bump up many font sizes around 10-15%.
Let me know how that works for you.
I am not sure if i can get the fonts much larger without doing multi day / multi week surgery on the main theme.
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
eCue
100 W
100 W
Posts: 115
Joined: Nov 03, 2017 5:14 pm
Location: Vancouver Island , Canada

Re: Forum software upgrade happening on 11/16/17

Post by eCue » Nov 18, 2017 3:37 pm

Perfect fix !
Thanks a bunch its very EASY to read now ! sweeet
"98 Quintana roo Panamint 350w mxus build link - https://endless-sphere.com/forums/view ... =6&t=91627

User avatar
speedmd
100 MW
100 MW
Posts: 2748
Joined: Nov 14, 2012 12:16 pm
Location: new england

Re: Forum software upgrade happening on 11/16/17

Post by speedmd » Nov 18, 2017 4:38 pm

Nice update. Thanks Nep with the help making the best forum even better.

User avatar
The fingers
100 GW
100 GW
Posts: 5854
Joined: Mar 11, 2012 11:22 pm
Location: Desert Pacific Cali USA

Re: Forum software upgrade happening on 11/16/17

Post by The fingers » Nov 19, 2017 12:53 am

Much more favorable view on my I phone. On the tablet, not as much. :|
Black Schwinn High Sierra
Blue Schwinn Cruiser 5
Blue Schwinn High Plains
Black Fiore Cruzer 5: Amped Warp Drive 26" Front DD/SLA kit
http://ghostbikes.org/
http://www.rideofsilence.org/main.php
Hebrews 9:27

User avatar
dingoEsride
100 kW
100 kW
Posts: 1153
Joined: Apr 15, 2010 2:09 am
Location: Perth, Australia
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by dingoEsride » Nov 19, 2017 2:33 am

The fingers wrote:
Nov 19, 2017 12:53 am
Much more favorable view on my I phone. On the tablet, not as much. :|
works perfect for me on laptop and android phone (tho haven't looked for faults),
Thanks Nep
ride like the wind

User avatar
TheBeastie
1 MW
1 MW
Posts: 1636
Joined: Jul 28, 2012 12:31 am
Location: Melbourne Australia

Re: Forum software upgrade happening on 11/16/17

Post by TheBeastie » Nov 19, 2017 2:56 am

I think I used to be a subsilver user but I probably changed to that view mode the day I joined and forgot it wasn't default.
I am now using the Square NX style and it looks/works great for me.

Well done on the upgrade.
Speed Kills Range, 10mph = 46 miles range, 20mph = 20 miles, 30mph = 8 miles range http://goo.gl/1JNL53
Over Charging Kills ur battery bit.ly/1hzWKl4
Beware of dodgy 18650 cells! youtu.be/eOshOXcSkDA
Consider PAS as your only throttle http://goo.gl/m17J9j
CO2 is core to Photosynthesis https://youtu.be/t5mvDONB6FI
Check out the Bill Gates nuclear reactor https://goo.gl/Rtky9q
10 Square Miles of solar panels = 0.12GW average power! https://goo.gl/Ub1S39

User avatar
dogman dan
100 GW
100 GW
Posts: 34308
Joined: May 17, 2008 12:53 pm
Location: Las Cruces New Mexico USA

Re: Forum software upgrade happening on 11/16/17

Post by dogman dan » Nov 19, 2017 5:52 am

I found the moderator tools to edit a post ok, and the moderator control panel. But I can't find the moderator discussion area now.

User avatar
eCue
100 W
100 W
Posts: 115
Joined: Nov 03, 2017 5:14 pm
Location: Vancouver Island , Canada

Re: Forum software upgrade happening on 11/16/17

Post by eCue » Nov 19, 2017 10:11 am

It makes for smooth reading having the avatars etc on the right side allowing us to read from left to right instead of middle to right .. I like it !
PS noticed the edit warning change time - Double sweeeet as I'm always fixing spelling errors..
"98 Quintana roo Panamint 350w mxus build link - https://endless-sphere.com/forums/view ... =6&t=91627

User avatar
fechter
100 GW
100 GW
Posts: 11822
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Forum software upgrade happening on 11/16/17

Post by fechter » Nov 19, 2017 1:17 pm

dogman dan wrote:
Nov 19, 2017 5:52 am
I found the moderator tools to edit a post ok, and the moderator control panel. But I can't find the moderator discussion area now.
I checked the permissions and as far as I can tell, the global moderators should have full access to that forum. Not sure what's up.
"One test is worth a thousand opinions"

mark5
100 kW
100 kW
Posts: 1053
Joined: Dec 28, 2011 9:26 pm
Location: USA

Re: Forum software upgrade happening on 11/16/17

Post by mark5 » Nov 19, 2017 2:09 pm

fechter wrote:
Nov 19, 2017 1:17 pm
dogman dan wrote:
Nov 19, 2017 5:52 am
I found the moderator tools to edit a post ok, and the moderator control panel. But I can't find the moderator discussion area now.
I checked the permissions and as far as I can tell, the global moderators should have full access to that forum. Not sure what's up.
That subforum's no longer visible to me but I happen to have a couple of threads in it bookmarked. When I try to go to the bookmarks, I get the error message "You are not authorised to read this forum."

User avatar
fechter
100 GW
100 GW
Posts: 11822
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Forum software upgrade happening on 11/16/17

Post by fechter » Nov 19, 2017 3:54 pm

I checked the forum permissions page again, and I can see it's messed up, but I when I try to make changes, it doesn't stick. Like my permissions are not working either.
"One test is worth a thousand opinions"

mark5
100 kW
100 kW
Posts: 1053
Joined: Dec 28, 2011 9:26 pm
Location: USA

Re: Forum software upgrade happening on 11/16/17

Post by mark5 » Nov 19, 2017 5:03 pm

alanski in https://www.phpbb.com/community/viewtopic.php?f=556&t=2443756 wrote:GLobal moderators cannot access forum

Have upgraded from 3.1. to 3.2.1 and using the prosilver template.
Have successfully migrated but we seem to have a few serious hiccups.

May moderators are getting "You are not authorised to read this forum."

Have checked their permissions, making sure user is in correct group and permissions are set but nothing seems to allow them to view and moderate posts.
.
.
.
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Updated board
Please describe your problem. Members of global moderator group cannot see moderation tools or access private board which Global mods are assigned to. Providing a login would not shiw the problem since it kinda is the problem
.
.
.
So this seemed to be an odd edge case cookie issue. Solved by resetting and cache clearing
Ah, the old odd edge case cookie issue... :)

User avatar
neptronix
100 GW
100 GW
Posts: 13061
Joined: Jun 15, 2010 5:56 pm
Location: People's republic of Petrolistan ( Utah, USA )
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by neptronix » Nov 19, 2017 5:18 pm

Thank you for that lead!
This did not happen in our test run of 3.2.0.. so there is something weird about 3.2.1.

Fechter and other mods, let me know if this fixes things for you.. otherwise i'm back to work on monday to try to figure out WTF is going on with that.

I thought i was going to take a break over the weekend, but there have been quite a few fires to put out since this transition.. thanks for being patient.. i will work on getting the protected categories back starting on monday..
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
neptronix
100 GW
100 GW
Posts: 13061
Joined: Jun 15, 2010 5:56 pm
Location: People's republic of Petrolistan ( Utah, USA )
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by neptronix » Nov 19, 2017 6:06 pm

Put out another fire today / last night.

Turns out this new version of apache webserver we are running was vulnerable to slow loris attacks, despite me replicating the security settings the previous server had. Turns out that on the newer OS, a few of the security components no longer work the same way. They simply ignore the former settings that work..
Ah, the joys of working with open source software.. :lol:

Our server was temporarily inaccessible last night around 10PM PST, and after some analysis of logs, i found that the reason for the downtime was the same kind of DDOS attack that was plaguing this forum before i came on as a system administrator :roll:

I have an updated security rule set in place. Me and gammaray have tested this and found that the system is no longer vulnerable to this attack.

However, these new security settings are a bit on the strict side. Please let me know if you experience any erratic behavior from our web server as a result.
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
fechter
100 GW
100 GW
Posts: 11822
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Forum software upgrade happening on 11/16/17

Post by fechter » Nov 19, 2017 9:50 pm

I still have issues in the ACP, but I think I found a workaround for the moderator forum. Moderators please check it out. Look for the new topic.
"One test is worth a thousand opinions"

mark5
100 kW
100 kW
Posts: 1053
Joined: Dec 28, 2011 9:26 pm
Location: USA

Re: Forum software upgrade happening on 11/16/17

Post by mark5 » Nov 19, 2017 10:39 pm

For myself, I don't see a new forum nor a new post about this under active topics view. Maybe others will.

User avatar
fechter
100 GW
100 GW
Posts: 11822
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Forum software upgrade happening on 11/16/17

Post by fechter » Nov 20, 2017 8:25 pm

mark5 wrote:
Nov 19, 2017 10:39 pm
For myself, I don't see a new forum nor a new post about this under active topics view. Maybe others will.
Hmm... bummer. Can you see the Moderator Forum at all?
"One test is worth a thousand opinions"

User avatar
Alan B
100 GW
100 GW
Posts: 7025
Joined: Sep 11, 2010 7:43 am
Location: San Francisco Bay Area, USA
Contact:

Re: Forum software upgrade happening on 11/16/17

Post by Alan B » Nov 20, 2017 8:34 pm

I haven't seen the moderator forum since the change.

However I haven't had to log in again either.

Chrome here.

mark5
100 kW
100 kW
Posts: 1053
Joined: Dec 28, 2011 9:26 pm
Location: USA

Re: Forum software upgrade happening on 11/16/17

Post by mark5 » Nov 20, 2017 8:35 pm

No, can't see that forum at all.

User avatar
fechter
100 GW
100 GW
Posts: 11822
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Forum software upgrade happening on 11/16/17

Post by fechter » Nov 20, 2017 10:55 pm

Ypedal can see it, but he's an administrator. I checked the settings again, but maybe I just don't know how to do it. When I click on things, nothing happens.
"One test is worth a thousand opinions"

Post Reply