Need help troubleshooting

General Discussion about large electric scooters and motorcycles and other things with no pedals.
Post Reply
Rsam
1 µW
1 µW
Posts: 2
Joined: Oct 14, 2017 11:29 am

Need help troubleshooting

Post by Rsam » Oct 14, 2017 11:48 am

Hi guys

I'm new here. Looking for some help please. I'm also new to the electric scooter world. I just bought a new scooter online from a no name company in china; yes yes I know not a super wise decision. But a few friends of mine bought the exact same one and it's been working great for them for several months. Here's the problem. I fully charge the battteries and off I go. At random times, happened twice already, everything will just cut out even though it said I have full battery before it shut down. I can't even get the display to turn back on. I managed to get going on a downhill and I turned the display on and see that the battery indicator was flashing with no bars. I got the scooter home and plugged it in for literally 5 seconds just enough time to get the display on and it showed full battery. I disconnected the charger and it worked fine again. The range is supposed to be about 80-100 kms and I had only done about 7 kms when it decided to disconnect on me. Not sure what is going on but both times I plugged it in for a few seconds and then it worked again and I continued using it the rest of the day. The specs are as follows: 48V 21 ah batt, 500w motor

Any and all help greatly appreciated
Cheers

User avatar
Mapyx
10 mW
10 mW
Posts: 22
Joined: Oct 13, 2017 1:07 pm
Location: ITALY

Re: Need help troubleshooting

Post by Mapyx » Oct 20, 2017 12:49 pm

Rsam wrote: The specs are as follows: 48V 21 ah batt, 500w motor
Lithium or Lead batt.?

Rsam
1 µW
1 µW
Posts: 2
Joined: Oct 14, 2017 11:29 am

Re: Need help troubleshooting

Post by Rsam » Oct 20, 2017 3:19 pm

Lithium

User avatar
Mapyx
10 mW
10 mW
Posts: 22
Joined: Oct 13, 2017 1:07 pm
Location: ITALY

Re: Need help troubleshooting

Post by Mapyx » Oct 22, 2017 2:54 pm

it looks like a battery problem. if you bought it as new, you should be able to take advantage of the warranty. Let us know, company, model and some more info

User avatar
fechter
100 GW
100 GW
Posts: 12418
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Need help troubleshooting

Post by fechter » Oct 22, 2017 7:40 pm

I agree it sounds like some cells in the battery are bad.
"One test is worth a thousand opinions"

Post Reply