links in notification mails not shown anymore?

This section will contain posting guidelines for the forum along with any other information that is relevant to this forum.
User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Dec 03, 2014 9:05 am

Someone is f*** with us
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
amberwolf
100 GW
100 GW
Posts: 23938
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: links in notification mails not shown anymore?

Post by amberwolf » Dec 03, 2014 9:37 am

pucksterpete wrote:Things are different today, no more links in the emails, I'm going to have to guess that this is a forum setting problem, bummer!
No, as discussed above, it is almost certainly a Google problem. They have bunches of servers so some of them may have the problem while others don't, at any one time, depending on what they happen to be changing within their software at any moment.

User avatar
gogo
100 MW
100 MW
Posts: 2598
Joined: Mar 17, 2008 2:20 pm
Location: Iowa USA

Re: links in notification mails not shown anymore?

Post by gogo » Dec 03, 2014 12:15 pm

I like Amberwolf's explanation. Its fixed for me again. :roll:

[EDIT] Maybe its the N ES A setting up dummy repeater servers. 8)
"A conclusion is the place where you got tired of thinking." -Steven Wright

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Dec 05, 2014 11:15 am

amberwolf wrote:
pucksterpete wrote:Things are different today, no more links in the emails, I'm going to have to guess that this is a forum setting problem, bummer!
No, as discussed above, it is almost certainly a Google problem. They have bunches of servers so some of them may have the problem while others don't, at any one time, depending on what they happen to be changing within their software at any moment.
If its a google problem, then why would it only affect emails sent from endless sphere and not others?

Pete
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
amberwolf
100 GW
100 GW
Posts: 23938
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: links in notification mails not shown anymore?

Post by amberwolf » Dec 05, 2014 11:56 am

pucksterpete wrote:If its a google problem, then why would it only affect emails sent from endless sphere and not others?
It does, just not evenly. Could have to do with whether or not the email i9tself is already in HTML and already linkified, or wehther it is sent in plain text expecting yoru email client or browser to linkify it (which will still happen correctly if yours is capable of doign so and enabled for that), or it could have to do with what google servers are having hte polbme and whether the email passes thru one of those at the time--idifferent emails may well go thru different server chains depenidng on their physical origin location vs destination location).

I don't actually *know* that it is a google problem, but based on the evidence presented so far it is the one that makes the most sense, since AFAICT all of the reports of the problme are people using gmail to receive the notifications, and people using gmails webmail to view them.

As far as I can determine without actually seeing the ES server's sources, the actual emails sent do not contain an actual html URL anyway, only a plain text link, which has to be linkified by your client reader under normal circuimstances

Gmail's servers nrmally take any URL in a plain text email and linkify it with a google prefix so it first goes to google's servers and then redirects you to the URL in question, presumably to track your web usage. When this problem occurs there is no linkification and no redirection.

If anyone cares to verify they could setup a non google account and change their ES email to that, and continue to monitor the notification emails for linkification of URLs (assuming that that email provider does any likification, which they may not).

Or simply use a local client, like Thunderbird that I use here, and set it to linkify URLs if it doesn't already do that by default (mine does; not sure if that can even be turned off). Then thre is always linkification, and there is never redirection, either (and presumably web usage is thus *slightly* more private as only the ISP would then be logging usage, instead of also having google do it via teh redirects).

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Dec 05, 2014 12:27 pm

Thanks for the info :)
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
Metallover
10 kW
10 kW
Posts: 524
Joined: Jul 08, 2009 8:09 pm
Location: South Dakota

Re: links in notification mails not shown anymore?

Post by Metallover » Dec 10, 2014 12:01 pm

My links haven't been working for the last month or so either. Don't have a clue of how to fix it.. Surprised to find this thread! But no solution yet.. :?

It's not happening now, but occasionally (over the last.. year?) my browser (chrome) will say "Endless-sphere.com isn't safe", or "security certificate is bad". Then I have to either "proceed anway" or (lately) click 'advanced' then "continue to endless-sphere.com".

[generic image]
Image

Maybe this is related to the email link problem?
Add your bike to the Unofficial E-Bike Garage! - http://spreadsheets2.google.com/ccc?key ... OWcg&hl=en
My Build - Vector Frame, 20s 25Ah LiPo, Max-E, Cromotor - 10.89HP on the Dyno

User avatar
izeman
10 GW
10 GW
Posts: 4500
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Dec 10, 2014 12:11 pm

could be that gmail removes "suspicious" links, and as the certificate may have a problem this is why google removes the links from the mails.

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Dec 10, 2014 4:41 pm

Metallover wrote:My links haven't been working for the last month or so either. Don't have a clue of how to fix it.. Surprised to find this thread! But no solution yet.. :?

It's not happening now, but occasionally (over the last.. year?) my browser (chrome) will say "Endless-sphere.com isn't safe", or "security certificate is bad". Then I have to either "proceed anway" or (lately) click 'advanced' then "continue to endless-sphere.com".

[generic image]
Image

Maybe this is related to the email link problem?
Same here, ever so often I get the same error message, I usually just proceed., links still not working in gmail :(
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
Metallover
10 kW
10 kW
Posts: 524
Joined: Jul 08, 2009 8:09 pm
Location: South Dakota

Re: links in notification mails not shown anymore?

Post by Metallover » Dec 13, 2014 11:56 am

I got the error this morning.

I am using Chrome "Version 39.0.2171.95 m" on windows 8

Image

Then I click "advanced"

Image

click "proceed to endless-sphere.com (unsafe)"

Image
Add your bike to the Unofficial E-Bike Garage! - http://spreadsheets2.google.com/ccc?key ... OWcg&hl=en
My Build - Vector Frame, 20s 25Ah LiPo, Max-E, Cromotor - 10.89HP on the Dyno

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Dec 13, 2014 1:57 pm

Got the same error you got while clicking the link in my email for your reply to this thread, but links work now, for how long though!!!
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993


Post Reply