Plugging in Mean Well power supplies and it trips the house!

General Discussion about electric bicycles.
Post Reply
camerons98   100 mW

100 mW
Posts: 38
Joined: May 29 2015 5:33pm
Location: United Kingdom, England

Plugging in Mean Well power supplies and it trips the house!

Post by camerons98 » Sep 12 2015 7:16am

I just purchased some Mean Well power supplies from ebay to charge my new 72v 14aH pack for my latest build but I've hooked 3 up in series to get 72v and whenever I plug it into the mains it trips the whole house instantly.
I was under the impression that I could plug these directly into my battery and charge it?
Atteched is a picture of how i've got it wired up, any help would be greatly appreciated as I need to charge my pack ASAP!

Thanks, Cameron.
Attachments
20150912_112923.jpg

User avatar
wesnewell   100 GW

100 GW
Posts: 7168
Joined: Jan 31 2011 6:25pm
Location: Wylie, TX, USA

Re: Plugging in Mean Well power supplies and it trips the ho

Post by wesnewell » Sep 12 2015 7:43am

It seems you isolated the cases but then tied them together again with the earth ground. Try removing the earth ground between them.
Need Advice? https://endless-sphere.com/forums/viewt ... =3&t=66302
Mongoose 26" Ledge 2.1 mtb bike $99, yescomusa.com 48V 1000W rear hub kit $200, Hua Tong 72V 40A controller $35, 10ah 24s lipo $217=~43mph, range=45 miles @ 20mph. 25K miles and still going strong.
Huffy Fortress 3.0 with MXUS 3000 4T motor, 24s lipo, 96V 60A controller. Total cost with extras <$700. Top speed ~50mph
My videos https://www.youtube.com/channel/UC0KW4U ... _G2wQhptMg

camerons98   100 mW

100 mW
Posts: 38
Joined: May 29 2015 5:33pm
Location: United Kingdom, England

Re: Plugging in Mean Well power supplies and it trips the ho

Post by camerons98 » Sep 12 2015 8:02am

Removed the earth and they're powering up perfectly, thanks!!
Final question.. do I just adjust the voltage pots so that its outputting 74v which is the nominal of my battery and then plug the battery in and it will charge by itself?

Thanks!

User avatar
teslanv   100 MW

100 MW
Posts: 2675
Joined: Nov 03 2013 8:42pm
Location: Bellevue, WA - USA
Contact:

Re: Plugging in Mean Well power supplies and it trips the ho

Post by teslanv » Sep 12 2015 9:07am

camerons98 wrote:Removed the earth and they're powering up perfectly, thanks!!
Final question.. do I just adjust the voltage pots so that its outputting 74v which is the nominal of my battery and then plug the battery in and it will charge by itself?

Thanks!
Set the voltage for the fully charged voltage. If your battery is a 20S LiCo or LiPo variety, that would be 4.2V per cell or 84V total.

You can charge at a lower voltage (say 82V) if you want to limit to ~90% max SOC. That will extend the lifespan of the battery, but reduce the capacity (range) by 10%
DD Hubs, Batteries, Controllers & Custom Ebikes.
http://westcoastelectrics.com
West Coast Electric Cycles
Bellevue, WA
USA

User avatar
MadRhino   100 GW

100 GW
Posts: 6019
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: Plugging in Mean Well power supplies and it trips the ho

Post by MadRhino » Sep 12 2015 9:09am

Look on the face plate, it is printed the place where is the POT to adjust voltage up or down. Use a small screwdriver, you can adjust one only for this should give you enough range to match your battery.
Make it fool-proof, and I will make a better fool.
Current bikes
Street: https://s20.postimg.org/ewrvugywt/Session_04_2015.jpg
Dirt: https://s20.postimg.org/lbqwr55ml/IMG_0157.jpg

camerons98   100 mW

100 mW
Posts: 38
Joined: May 29 2015 5:33pm
Location: United Kingdom, England

Re: Plugging in Mean Well power supplies and it trips the ho

Post by camerons98 » Sep 12 2015 9:41am

Thanks for all your help guys its working perfectly! fully charged in just an hour and a half!

dnmun   100 GW

100 GW
Posts: 16190
Joined: Jun 09 2008 1:32pm
Location: portland, or and loveland, co

Re: Plugging in Mean Well power supplies and it trips the ho

Post by dnmun » Sep 12 2015 10:42am

was this circuit breaker a GFCI type breaker? you may have a high voltage short to the case that blew the breaker. otherwise removing the ground would have no effect.

camerons98   100 mW

100 mW
Posts: 38
Joined: May 29 2015 5:33pm
Location: United Kingdom, England

Re: Plugging in Mean Well power supplies and it trips the ho

Post by camerons98 » Sep 13 2015 6:03am

how do I check what type of breaker it is? all the chargers are working fine now so surely everything is okay?

Post Reply