Forum software upgrade on 11/17/2017 technical issues thread

Talk about anything and everything here within reason.
User avatar
eCue   10 kW

10 kW
Posts: 631
Joined: Nov 03 2017 5:14pm
Location: Vancouver Island , Canada

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by eCue » Dec 27 2017 2:14pm

amberwolf wrote:
Dec 27 2017 12:58am
FWIW, if you just hover your moust over the Youtube button, the tooltip tells you what to do. ;)

Image I struggled with this for a Month !
Solar charge station on wheels join the Revolution

User avatar
jonescg   1 GW

1 GW
Posts: 3304
Joined: Aug 07 2009 9:22pm
Location: Perth, Western Australia

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by jonescg » Jan 07 2018 8:27pm

Hi all,

Why do I have to constantly enter my username and password every time I open the 'Sphere? I cleared my browser history the other day and it's been weird ever since.

Cheers,
Chris

User avatar
fechter   100 GW

100 GW
Posts: 12907
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by fechter » Jan 07 2018 10:25pm

jonescg wrote:
Jan 07 2018 8:27pm
Hi all,

Why do I have to constantly enter my username and password every time I open the 'Sphere? I cleared my browser history the other day and it's been weird ever since.

Cheers,
Chris
Make sure the URL in your Favorites starts with https:// and not http://
"One test is worth a thousand opinions"

User avatar
jonescg   1 GW

1 GW
Posts: 3304
Joined: Aug 07 2009 9:22pm
Location: Perth, Western Australia

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by jonescg » Jan 07 2018 10:51pm

I keep getting the same issue though...

"Not Secure"

mark5   100 kW

100 kW
Posts: 1172
Joined: Dec 28 2011 9:26pm
Location: USA

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by mark5 » Jan 08 2018 1:44am

Jones, you're saying you don't have the need to login problem any more because you did what fechter recommended and now instead you have a not secure error message? What is the url to the page you're trying to get to?

But you're saying "I keep getting the same issue though..." so it's hard to know. If you're still having the need to login problem, here's a couple of neptronix's quotes on the subject.
neptronix wrote:
Nov 21 2017 9:56pm
Harold in CR wrote:
Nov 21 2017 2:15pm
Still always requires login even though I have the remember password box checked [...]
My suspicion is that you have a bookmark for https://endless-sphere.com or something.
https:// and http:// are considered different sites by cookies.

[...]
I think that https live link to E-S above beginning with neptronix saying "My suspicion" should read http but it's been rewritten by phpbb.
neptronix wrote:
Nov 29 2017 10:44am
If you still have problems with suddenly being logged out, you are clicking a link from http:// instead of https://. The only way to retain your login status is to change these bookmarks to https:// ( certain browsers consider http:// and https:// to be separate sites and lose cookies if you switch back/forth. )
Unfortunately we'll be seeing this issue until 2018 when our SSL certificate provider finally allows wildcard certificates so that i can force forward all traffic to https://, which should fix this issue.

User avatar
jonescg   1 GW

1 GW
Posts: 3304
Joined: Aug 07 2009 9:22pm
Location: Perth, Western Australia

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by jonescg » Jan 08 2018 2:05am

Yeah I get this:
Capture.JPG
Capture.JPG (25.49 KiB) Viewed 2778 times
Might be time to clear cookies and start again with https://www.endless-sphere.com/forums ?

mark5   100 kW

100 kW
Posts: 1172
Joined: Dec 28 2011 9:26pm
Location: USA

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by mark5 » Jan 08 2018 2:11am

jonescg wrote:
Jan 08 2018 2:05am
Might be time to clear cookies and start again with https://endless-sphere.com/forums ?
Yeah, I'd try doing that. You can press the "Delete all board cookies" link at the bottom of this webpage.

Knighthonor   1 µW

1 µW
Posts: 2
Joined: Feb 01 2018 4:12pm

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by Knighthonor » Feb 01 2018 4:59pm

Hi new here. Tapatalk aspect of the forum don't work.

User avatar
amberwolf   100 GW

100 GW
Posts: 25119
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by amberwolf » Feb 03 2018 3:03am


User avatar
danielrlee   1 kW

1 kW
Posts: 440
Joined: Mar 29 2013 8:30am
Location: Wiltshire, UK

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by danielrlee » Feb 04 2018 6:43am

I noted today that Endless Sphere has dropped right off the Tapatalk map and the link to the forum from the app has disappeared. Guess that's the final nail in the coffin for ES on Tapatalk. Shame really since it really was a nicer way of accessing the site from a mobile.

User avatar
izeman   10 GW

10 GW
Posts: 4690
Joined: Jun 21 2011 8:25am
Location: vienna, austria
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by izeman » Feb 21 2018 4:22am

Is there a plan to add tapatalk support again?

User avatar
Alan B   100 GW

100 GW
Posts: 7486
Joined: Sep 11 2010 7:43am
Location: San Francisco Bay Area, USA
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by Alan B » Feb 26 2018 7:06pm

Emails from the forum have http:// links which require a new login.

RobertC   1 W

1 W
Posts: 54
Joined: Jun 14 2015 7:46am
Location: Hanoi, Viet Nam

Spaminess of new version?

Post by RobertC » Mar 12 2018 5:48am

I follow a few forum threads, and wish to reduce the number of emails.

I used to get one email if there was a new post, now I get dozens for busy threads. How do I fix this?

User avatar
amberwolf   100 GW

100 GW
Posts: 25119
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by amberwolf » Mar 12 2018 6:38am

The only way I found (even with the old version) was to set my email setup to delete all the ES thread emails (filtered by subject) and instead I just use this page:
https://endless-sphere.com/forums/ucp.p ... subscribed
to see what's new that I"m subscribed to.

RobertC   1 W

1 W
Posts: 54
Joined: Jun 14 2015 7:46am
Location: Hanoi, Viet Nam

Old version vs. new

Post by RobertC » Mar 12 2018 8:22am

Old version I received one email, now I get dozens.

I think something broke here.

User avatar
neptronix   100 GW

100 GW
Posts: 12707
Joined: Jun 15 2010 5:56pm
Location: California refugee living in Utah, USA
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by neptronix » Mar 20 2018 2:19pm

Alan B wrote:
Feb 26 2018 7:06pm
Emails from the forum have http:// links which require a new login.
Crud. I have that delegated to Samson for now. We can finally get security certificates that fix this http/https and www./no www. issue now, but our provider has yet to actually give instructions on how to install them ( yeah, thanks guys.. )
izeman wrote:
Feb 21 2018 4:22am
Is there a plan to add tapatalk support again?
A lot of people have requested this. I don't like it for security and complexity reasons.. but i think i might have to budge on this one.

Currently working 3 jobs. ES gets it's next round of improvements and bug fixes sometime around the summer when my work levels off.
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
izeman   10 GW

10 GW
Posts: 4690
Joined: Jun 21 2011 8:25am
Location: vienna, austria
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by izeman » Mar 21 2018 5:36am

neptronix wrote:
Mar 20 2018 2:19pm
A lot of people have requested this. I don't like it for security and complexity reasons.. but i think i might have to budge on this one.
that would be AWESOME! reading the forum on a mobile device's broswer is a PITA compared to tapatalk. the app itself becomes worse and worse, adds more unneeded sh*t like a central hub, recommendations that noone needs and other stuff, but for pure reading you can't beat it.

nieles   10 kW

10 kW
Posts: 635
Joined: Jul 14 2008 5:39pm
Location: The Netherlands

Re: Old version vs. new

Post by nieles » Mar 27 2018 4:23am

RobertC wrote:
Mar 12 2018 8:22am
Old version I received one email, now I get dozens.

I think something broke here.
Same for me!

mark5   100 kW

100 kW
Posts: 1172
Joined: Dec 28 2011 9:26pm
Location: USA

Re: Old version vs. new

Post by mark5 » Mar 27 2018 10:25am

nieles wrote:
Mar 27 2018 4:23am
RobertC wrote:
Mar 12 2018 8:22am
Old version I received one email, now I get dozens.

I think something broke here.
Same for me!
Might be you're experiencing a bug in the forum software.

Re: Multiple email notifications for topic subscriptions
https://www.phpbb.com/community/viewtop ... #p14776076

Re: Multiple email notifications for topic subscriptions
https://www.phpbb.com/community/viewtop ... #p14776276

PHPBB3-14754: Receive too many topic email notifications when "notification.method.board" is off.
https://tracker.phpbb.com/browse/PHPBB3-14754
https://tracker.phpbb.com/browse/PHPBB3-14754 wrote:Description

In 3.2 it is possible to be choose to be notified only by email (see PHPBB3-11967)

When choosing to be notified only by email, subscribing to a topic sends an email for every single reply to that topic. This is far too much email spam and contradicts what the email says it will do.

When choosing to be notified by both email and board notification, you will receive an email and won't receive a new email until you visit the topic.

The notification email says:
"You are receiving this notification because you are watching the topic "Test" at "forumname.com". This topic has received a reply by TestUser123 since your last visit. No more notifications will be sent until you visit the topic."

The ideal solution in my mind would be to have the same behaviour when users choose to be notified only by email.

User avatar
Cresh   100 W

100 W
Posts: 213
Joined: Dec 17 2011 9:33am
Location: Va, USA

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by Cresh » Apr 03 2018 8:39am

I’ve been away for a while and plan to get back to my ebike commuting this summer, but tapatalk doesn’t work now? Bummer. It’s a lot easier using tapatalk on mobile.
I need to replace my broken adappto max-e.

User avatar
neptronix   100 GW

100 GW
Posts: 12707
Joined: Jun 15 2010 5:56pm
Location: California refugee living in Utah, USA
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by neptronix » Apr 24 2018 11:31am

Hey guys; i have some good news.

A major piece of the puzzle is place for a fix of the http/https issue, and work will commence in the next week or two on the final fix :)

Also, i modified the 'new posts' link to show a longer list of new posts. I had to patch the phpbb code to do this, as there's no settings in phpbb to determine the length of time that the system considers posts 'new'. Many times, 'new posts' would often just show 10 posts..... how useful is that? :pancake:

There were some funky things that happened in certain mobile resolutions ( usually tablets or low resolution screens/zoom modes ) that i also fixed in the CSS.

Tapatalk is certainly on the list of things i want to tackle in the future. My job is to make the forum more convenient for you guys to use. No promises on when, but probably within this month?
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
Alan B   100 GW

100 GW
Posts: 7486
Joined: Sep 11 2010 7:43am
Location: San Francisco Bay Area, USA
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by Alan B » Apr 24 2018 3:07pm

Thanks for your effort!

User avatar
fechter   100 GW

100 GW
Posts: 12907
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by fechter » Apr 24 2018 3:12pm

Alan B wrote:
Apr 24 2018 3:07pm
Thanks for your effort!
+1

I wish I could do more of it myself but I have a poor track record with databases.
"One test is worth a thousand opinions"

User avatar
neptronix   100 GW

100 GW
Posts: 12707
Joined: Jun 15 2010 5:56pm
Location: California refugee living in Utah, USA
Contact:

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by neptronix » Apr 29 2018 7:56pm

Hey guys. I fixed the http/https issue finally, by getting a wildcard certificate and forcing to https.
The login issue that's been haunting this system should go away.

Let me know if you guys still experience the issue or not. Would be cool to unsticky this thread and move on.

Also i fixed the wrapping profile display in the private messages.. that was annoying.
-neppy
My first major build: 8T MAC motor on a Trek 4500.
The new all-arounder: Leafmotor 1500w on a Turner O2 full suspension.
The wheelie machine: 20" Rear Magic Pie II on a Trek 4300 MTB

"The best time to plant a tree was 20 years ago. The second best time is now."- Chinese Proverb

User avatar
TheBeastie   1 MW

1 MW
Posts: 1745
Joined: Jul 28 2012 12:31am
Location: Melbourne Australia

Re: Forum software upgrade on 11/17/2017 technical issues thread

Post by TheBeastie » Apr 30 2018 12:07am

Yeah I think I remember suffering from that problem, where it constantly asks you to login again on a new browser session?
I realized it was caused by the non-secure http url..
I just booked marked the httpS url of endlessphere and it totally went away, seems silly not to use the https anyway.
Speed Kills Range, 10mph = 46 miles range, 20mph = 20 miles, 30mph = 8 miles range https://goo.gl/1JNL53
Over Charging Kills ur battery bit.ly/1hzWKl4
Consider PAS as your only throttle https://goo.gl/Kg1F8F
Fuel-Cell is the ultimate battery coupled with 4th-gen Nuclear https://goo.gl/ZhFFot
https://goo.gl/gfa215
10 Square Miles of solar panels = 0.12GW average power! https://goo.gl/Ub1S39

Post Reply