Battery connection issues

Talk about anything and everything here within reason.
Post Reply
Ebike fan
1 µW
1 µW
Posts: 2
Joined: Jan 13, 2018 5:30 pm

Battery connection issues

Post by Ebike fan » Jan 13, 2018 5:57 pm

Hi am fairly new to ebikes have bought a second hand bike and love it but battery failing. Have bought a new one and same voltage 36 v but Although connector is the same the bike won't power up. Have tested the four pin connector on the new battery and
is wired differently to the old one. Can anyone help please cheers Paul

DAND214
1 GW
1 GW
Posts: 3285
Joined: Aug 10, 2008 8:28 pm
Location: Chicagoland nw suburb Mt. Prospect IL. USA

Re: Battery connection issues

Post by DAND214 » Jan 13, 2018 6:04 pm

Pictures might help. Connector and the battery itself.
Even with pics your gonna have to match polarity or it won't work. Hope that it has a good BMS or the controller is more than likely done.

Dan

e-beach
10 MW
10 MW
Posts: 2495
Joined: Jan 10, 2012 9:48 pm
Location: Any Los Angeles area beach I am at. Or Santa Monica or possibly the south bay beaches.

Re: Battery connection issues

Post by e-beach » Jan 13, 2018 6:48 pm

Pictures are the best way to help on this one. Make sure they are in good focus. Make sure they are no bigger then 640x480.

Also what is the make and model of your ebike.

:D
Favorite Quote: "This is L.A., sugar. There is no 'over the top." --- Chris Erskine

Current build: Liahona w/ cheap front suspension and suspension seat post. Yescomusa 36v 800w generic front hub motor. 15ah Headway triangle mounted pack. Tronsung 30 amp,

Previous Build:1992 Trek Antelope 800 - Bone Crusher (no suspension) - Yescomusa 800 watt 36 volt front wheel kit. Don't do it! Get suspension!!!

Ebike fan
1 µW
1 µW
Posts: 2
Joined: Jan 13, 2018 5:30 pm

Re: Battery connection issues

Post by Ebike fan » Jan 14, 2018 7:29 am

Hi many thanks for the reply. I think the connection from the new battery to the connector on the controller is the issue.the type of connector is a GX16 aviation plug. It has four pins ( male on battery and female from controller on e bike. There is only one way the aviation plug will connect together obviously in order for correct polarities to come together with the pins. I have tested the pins on the old battery and the negative and the positive pins are in a different position on both male connectors. This concludes why the battery is not connecting properly to the controller. I guess I will have to re solder the wires onto controller aviation plug to correspond with the battery male connector. The +and- are obvious but not sure about the other two wires in the plug. Wonder if you can buy an adapter. Any thoughts ? Cheers Paul

DAND214
1 GW
1 GW
Posts: 3285
Joined: Aug 10, 2008 8:28 pm
Location: Chicagoland nw suburb Mt. Prospect IL. USA

Re: Battery connection issues

Post by DAND214 » Jan 14, 2018 2:57 pm

Still think pictures would be important. Does the battery use the same plug to charge and to power the bike? If so you really need to change the battery wiring.

Dan

User avatar
Rassy
1 MW
1 MW
Posts: 1954
Joined: Apr 08, 2007 10:58 am
Location: Eugene, Oregon USA

Re: Battery connection issues

Post by Rassy » Jan 14, 2018 4:01 pm

I don't know anything about those connectors, but once you figure out the correct wiring it is sometimes a lot easier to cut the wires back away from the plug (carefully, and keep them apart because they will be hot directly from the battery), and then just connect the proper wires by making simple wire splices. The splices can be soldered, or you can use butt connectors. I like to use butt connectors, but with some conductive silver epoxy in the connectors and on the wires before crimping.

As mentioned above I hope you haven't damaged anything by inadvertently connecting it up while the wiring was wrong.
-Rassy-
One Tadpole Trike equipped with a Bafang BBS02
https://endless-sphere.com/forums/viewt ... 28&t=69419
One Delta Trike equipped with a Bafang BBS02
https://endless-sphere.com/forums/viewt ... 0#p1291260

User avatar
amberwolf
100 GW
100 GW
Posts: 25040
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Battery connection issues

Post by amberwolf » Jan 14, 2018 8:19 pm

Ebike fan wrote:
Jan 14, 2018 7:29 am
the type of connector is a GX16 aviation plug. It has four pins ( male on battery and female from controller on e bike.
FWIW, if you stick with that kind of connector, I'd swap those, becuase having a connector with exposed male pins that could be shorted together on a battery is a Really Bad Idea. I'd always use a



The +and- are obvious but not sure about the other two wires in the plug. Wonder if you can buy an adapter. Any thoughts ?
You'd have to trace the wires from the plug to the inside of the battery and the charger and / or controller, to see where they go. They might not be hooked up, or they might be sensors, or even serial data wires. Depending on what they are, if they're not correct, it could just not function, or it could damage things in the battery or controller/etc.

Also note that as others have said, if the polarity wasn't correct on the main battery/controller connection to start with, there may be damage to either or both now, especially if the batteyr power wires were connected to what might be low-voltage data lines.

Post Reply