Thumb throttle not activating controller

Talk about anything and everything here within reason.
Post Reply
Monkeypowah   1 mW

1 mW
Posts: 18
Joined: Nov 22 2017 5:04pm

Thumb throttle not activating controller

Post by Monkeypowah » Jan 30 2018 4:06pm

Got a 25 amp generic Chinese controller..trying to add a cheap thumb controller, no drive.
When I connect the red and black the voltage drops to 2.5v and nothing comes out on the green.
If I short the green from the controller to the red 5v+..it runs ..flat out obviously.
The volt drop worries me..ordered a new thumb throttle..or is the controller faulty.

DAND214   1 GW

1 GW
Posts: 3062
Joined: Aug 10 2008 8:28pm
Location: About 1200 miles south of Chicago, in sunny/rainny Port Richey, Florida!

Re: Thumb throttle not activating controller

Post by DAND214 » Jan 30 2018 4:39pm

I would think it's the throttle, since you connect red to green and it runs.
Do you have a pas connected? Not sure if that might cause a problem, never had one.

Dan

User avatar
dogman dan   100 GW

100 GW
Posts: 34353
Joined: May 17 2008 12:53pm
Location: Las Cruces New Mexico USA

Re: Thumb throttle not activating controller

Post by dogman dan » Feb 02 2018 8:03am

Sounds like the fix is replace the throttle, asking the vendor for a new one free.

Don't take the thing apart yet, till you get a refund or replacement.

Monkeypowah   1 mW

1 mW
Posts: 18
Joined: Nov 22 2017 5:04pm

Re: Thumb throttle not activating controller

Post by Monkeypowah » Feb 06 2018 3:28pm

Thanks , it was the throttle, spent a bit more and new one works fine.

Post Reply