Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

General Discussion about large electric scooters and motorcycles and other things with no pedals.
MrBeeeeee   1 mW

1 mW
Posts: 19
Joined: Nov 09 2018 2:27am

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by MrBeeeeee » Jan 07 2019 10:00pm

So, I've been back and forth with Fany for over a month now, and the problem persists.

Right off the line, there's a pretty huge amount of torque that falls off almost immediately once the scooter is moving. It won't climb past 20 mph. The throttle output is smooth across its range. I even tried a completely different throttle (Hall type) to no avail.

I'm starting to think the controller is damaged. When the scooter is up on stands, I'll give it about half throttle, then I'll place a DC clamp-style ammeter over the individual leads going to the motor. One leg (W) always reads about 1.5A with the motor unloaded. The other two legs (U and V) don't get higher than 0.5A. I would think a healthy controller would be more consistent across the phases, but this test doesn't feel especially valid to me. Is there a better way to check if the controller is damaged?

User avatar
amberwolf   100 GW

100 GW
Posts: 27531
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by amberwolf » Jan 07 2019 10:57pm

Since the current in any one leg has to also flow thru another, I don't see how you can have higher current in only one leg.

Higher in two and lower in one, sure, I suppose, but not higher in one and lower in two.


If you've already verified all the phase connections between controller and motor, then you might check the FET resistances when not connected to power or the motor. There's some troubleshooting info on http://ebikes.ca on the Learn - Troubleshooting tab, if it helps.

MrBeeeeee   1 mW

1 mW
Posts: 19
Joined: Nov 09 2018 2:27am

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by MrBeeeeee » Jan 08 2019 10:17pm

So I took the controller out and got the following resistance values between the phase lugs and the battery terminals. This is with the controller completely disconnected and on a bench:

B+ to U: 95.0 K ohm
B- to U: 93.0 K ohm

B+ to V: 92.9 K ohm
B- to V: 90.9 K ohm

B+ to W: 97.0 K ohm
B- to W: 95.7 K ohm

This all seems normal. Could my problem just be that the controller is hugely overmatched for my tiny 1.8Kw motor? I was under the impression that the motor would simply run much hotter when it was pushed past its rated current and voltage values.

User avatar
amberwolf   100 GW

100 GW
Posts: 27531
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by amberwolf » Jan 08 2019 11:14pm

Those values seem normal (and consistent with each other), so the FETs are probably ok.

A big controller on small motor would normally work fine, other than potentially overheating it if you used it hard.

It seems as if it might simply be some setting within the controller itself. I don't know kelly settings/etc., but here's a few things that in general I've read about in various programmable controllers here on ES:


If the throttle settings in it don't match what your throttle range actually is, your throttle might not be able to output enough voltage to cause the controller to use the full power.

Or if power seems normal up to some point, then falls off if the throttle is pushed beyond that, then the throttle may have a higher voltage range than the controller is setup for, so that it goes into some error or failsafe mode, thinking something is wrong with the throttle.

If it doesn't matter what kind of terrain you're on, or what power is actually being used at the moment, but the max speed is still always exactly the same speed, then maybe the controller has a speed limit set in it. If the motor will not go beyond a certain speed even off-ground, then this is even more likely.

Sometimes if a controller is not correctly reading / detecting hall signals, then above some speed it may not be able to time the pulses of power to the motor correctly, so it doesnt' get what it expects as feedback, and "refuses" to push any further. If you get errors trying to setup hall/phase wiring/timing in the setup program, then that might be the cause.


There are a number of threads where people have done troubleshooting on kelly controller settings for various problems, so you might find the info you need in one of those (unfortunately I have no direct links, so the search below is the best I can offer; I doubt much is relevant):

https://endless-sphere.com/forums/searc ... mit=Search

MrBeeeeee   1 mW

1 mW
Posts: 19
Joined: Nov 09 2018 2:27am

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by MrBeeeeee » Feb 16 2019 12:35pm

So I tried the controller on a Mars Electric motor I got from a friend and it ran great on a bench. The throttle response was predictable and it got going really fast (pretty scary actually). I'm shifting my focus on to the hall sensors of my motor and proceeded to take the entire sensor to assemble off the backside of the motor before resorting to replacing it with an entirely different motor.

To my surprise, there was another sensor wheel underneath the encoder wheel that drove a three sensor hall array with a four-pole magnetic reluctor to drive them. The sensors are A1132 Bipolar hall-effect switches with an operating range of 4.5v to 24v. They operate in the range of 32 gauss and release at -20 gauss. Since Kelly recommends the Honeywell S443, which is a unipolar sensor; I'm going to go ahead and replace the sensors with those. If this doesn't work, the AMT31 is my last resort before going with a completely different motor.

I have some Infineon TLE4905L (unipolar) hall sensors that I was going to try in a pinch, but they seem to be giving a linear output based on the proximity of the magnet as opposed to a constant amplitude output based on a whether or not the magnetic threshold is reached. Anyone know what that's about? The datasheet lists it as a unipolar non-latching type.

Album of hall sensors since the picture upload seems to be broken.

User avatar
amberwolf   100 GW

100 GW
Posts: 27531
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by amberwolf » Feb 17 2019 1:39am

For position sensing with three hall sensors, the common 'UVW" type of sensing, you want bipolar latching.

Linear output types are used for SIN-COS encoders, and throttles, etc.

MrBeeeeee   1 mW

1 mW
Posts: 19
Joined: Nov 09 2018 2:27am

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by MrBeeeeee » Mar 16 2019 10:48pm

Okay, so I replaced the hall sensor on the motor with Honeywell SS443A hall sensors. That didn't fix much of anything. Apparently, the issue is that the motor just isn't getting enough voltage from my battery pack to overcome the back-EMF the motor is creating at the top-end. So when the controller tries to allow more current to flow the motor coils freak out and I get undesired motor operation.

So I'm going to go ahead and replace the rear-end with a 10" hub motor from QS Motor that I've already ordered. While I'm waiting, I wanted to experiment with the Gen4 Sevcon controller I have. I already have the IXXAT to CANBus interface kit, but I don't have the DVT software. I thought that saw one of the usual suspects (Thunderstruck, Electric Motor Sport, etc.) selling stand-alone licenses without the programming hardware, but now I can't find one. Where are people getting DVT from these days? It's hard to even find a reference to it on the Sevcon website.

LeftieBiker   10 kW

10 kW
Posts: 566
Joined: Nov 06 2012 1:33am
Location: Upstate NY, United States

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by LeftieBiker » Mar 16 2019 11:41pm

Okay, so I replaced the hall sensor on the motor with Honeywell SS443A hall sensors. That didn't fix much of anything. Apparently, the issue is that the motor just isn't getting enough voltage from my battery pack to overcome the back-EMF the motor is creating at the top-end. So when the controller tries to allow more current to flow the motor coils freak out and I get undesired motor operation.
IOW, as I told you many posts ago, that motor is already screaming at 25MPH, and the only good way to add speed is to change the gearing, not try to make it both provide more power and spin even faster...

MrBeeeeee   1 mW

1 mW
Posts: 19
Joined: Nov 09 2018 2:27am

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by MrBeeeeee » Mar 19 2019 6:58pm

Having owned a Lepton for almost 10 years, I'd say you're barking up the wrong EV. This is a great little scooter, but the drive motor is geared so that it's screaming at 25MPH (and it isn't a hub motor, folks, it's a chain drive with the motor near the swingarm). It isn't stopping at 25MPH because it's under-powered - it's doing that to protect it from blowing the motor with regular overrevving. To get more speed you'd have to find a way to change the final gearing. The easiest way to do that is with the tallest rear tire that will fit in the space. That might get you 30MPH. Beyond that you'd need to change the front sprocket and make a new chain cover.
Your explanation didn't demonstrate that you knew anything about DC motor control theory. You also misidentified the Lepton as having a "Chain drive" when it's actually an HTD belt drive. I feel someone who has owned a Lepton for 10 years would know that. I couldn't even be sure you actually owned a Lepton. Lastly, motors do not "protect themselves." If you were referring to a thermal trip/breaker, there's nothing like that on this motor.

The original battery pack was 48v and I'm now running a 72v pack. More voltage should be able to overcome the back EMF of the motor as it spins faster to push the top-end speed higher. It actually has improved the top end speed and even climbs the same hills better, but it didn't improve to the point that I thought it would. It's a marginal improvement at best.

I appreciate you replying to my posts, but I also appreciate actionable advice I can trust that isn't anecdotal.

LeftieBiker   10 kW

10 kW
Posts: 566
Joined: Nov 06 2012 1:33am
Location: Upstate NY, United States

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by LeftieBiker » Mar 19 2019 11:52pm

I didn't try to get into motor control theory because I was pretty sure that further increasing the power input to a motor that was well-designed, but designed to already run at the fastest speed that would yield longevity, would be at best pointless and at worst destructive. (I also don't know a hell of a lot about small AC motors.) I followed people who tried to modify Leptons for more speed for the ~10 years I owned and rode mine. The reliability plummeted even with the most conservative limiter mod to bring the top speed to just ~30MPH, so I never mucked about with mine (which still ran perfectly, on the original SLA batteries when I sold it). You can certainly argue that it was short-sighted of Oxygen (an Italian company - or at least factory - rather than the typical Chinese scooter builders) to assume that the 25MPH NEV standard would be around forever, and to design a scooter that was running at maximum safe RPM at that speed, but they did it. I suggested two ways to get to about 30MPH without compromising the drivetrain. It's true that I never opened that guide over the belt, but I was told by someone who ought to have known that it was a long-life chain in there, and I never had any need to open it. That actually had no effect on the soundness of my advice - if anything it would have been easier and cleaner to change the pulleys to get a taller ratio. By all means ignore anything I write in the future, as that would likely eliminate much of the fun to be had modifying and replacing hall sensors, drive motors and controllers...

Oh, forgot one: I didn't write that the motor "protects itself." The controller limits the motor speed, obviously - as in 'the scooter protects itself from over-revving.' Here is a thread from another site that mentions this, and has links to a few other sources. Enjoy:

https://visforvoltage.org/forum-topic/m ... pton-speed

MrBeeeeee   1 mW

1 mW
Posts: 19
Joined: Nov 09 2018 2:27am

Re: Modifying an Oxygen Lepton with Leaf Batteries and a Kelly Controller

Post by MrBeeeeee » Jul 26 2019 4:42pm

Okay, so I ended up removing the motor and rear suspension altogether and replaced it with a custom fabricated single sided swingarm to facilitate a QS Motor 10" 4kW hub motor. I've also attached the two-way throttle from a Vectrix VX-1 and am currently using it with the Kelly controller in joystick throttle mode. The Vectrix throttle is working, but needs some serious work before I can relax and count on it to stop the scooter.

My next priority is uprating the front brake. The stopping power on the original Lepton is woefully lacking for a 4kW hub motor and I have to do something about it immediately.

I'm not familiar with powersports in general, but I want to swap the front wheel out for a larger one with a nice disc brake. Presently I have a 10" hub on the front with a cable actuated drum brake. If I put a 13 " or 12" wheel in, I know I would need to swap forks out for a set that has mounts for a disc brake caliper, but what other considerations do I need to make? What other hardware would I potentially need to replace?

I think my front hub is roughly 4.5" wide, but I haven't removed it to measure accurately.

Post Reply