Vintage Electric MX (YZ80)

Show off your E-Scooter or Motorcycle creation here.
Post Reply
Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Vintage Electric MX (YZ80)

Post by Rickard m » Dec 20 2017 4:02pm

Hi, I never got a dirt bike when I was young, but my dream was one of these:
Image

A few weeks ago I found these really cheap
Image
Image

Some new parts arrived
Image

Started to fabricate
Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Image

Starting to look like a bike again :D
Image

Rube   100 W

100 W
Posts: 241
Joined: Jun 25 2016 10:18pm
Location: Brisbane, Australia

Re: Vintage Electric MX (YZ80)

Post by Rube » Dec 20 2017 8:27pm

Woohoo for nostalgic dreams, I rode one of these and a KX when I was growing up. Excellent fabrication skills, looks like it's going to be a very tidy build.
Last edited by Rube on Dec 20 2017 9:31pm, edited 1 time in total.

User avatar
skeetab5780   10 MW

10 MW
Posts: 2125
Joined: Jun 15 2009 10:58pm
Location: MA
Contact:

Re: Vintage Electric MX (YZ80)

Post by skeetab5780 » Dec 20 2017 8:32pm

Ya nice fab skills and great bike. My first bike was a 1985 kx80 then a 1992 yz125

Cant wait to see the video!

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Dec 21 2017 12:33am

Thank You! Made in Japan, perfected in Sweden with parts from China :D

I don't know so much about this, just try and error, exited to try it out, see how things work out together. The build part is sooo fun, hopefully fun to drive too.

I went with the original size chain 428, the smallest front sprocket I found for 20mm axle was 11. The bikes came with 42 resp 49 theet. I choose 49, still feels small when I look at your other builds, but remember the rear tire is tiny... :roll: bigger rear ones I have found online.

The battery is 72v 30ah, How do I keep it alive as long as possible, charge often or only when emty? Now when it came it was 70,8v shall I charge before first ride? (There is no memory in these I assume)

AMM118   1 mW

1 mW
Posts: 16
Joined: Dec 07 2017 10:11am

Re: Vintage Electric MX (YZ80)

Post by AMM118 » Dec 22 2017 12:10am

Cool build bro!

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Dec 25 2017 4:21am

Merry christmas! Tried it for a short spin yesterday :D
[youtube]https://youtu.be/72pG6jHKTBM[/youtube]

My daughter i shouting that it is slippery and that I can fall. So I did after the video... :roll: the bike managed but my jeans broke on the knee :wink:

I think I would like to increase the throttle response, how do I do that? What parameter shall I adjust? (The golden motor controllers) I have an usb cable connected to the controller, but I have not managed to get it in the computer yet.

dustNbone   10 kW

10 kW
Posts: 622
Joined: Mar 13 2016 9:59pm
Location: Vancouver, BC

Re: Vintage Electric MX (YZ80)

Post by dustNbone » Dec 25 2017 8:27am

Ahhh the old Whizzer 80. My first dirtbike was a 1992, aside from frequent top end rebuilds (pretty much par for these little 2 strokes ridden hard), it's always served me well. The only failure I ever had was when the Yamaha dealer didn't reassemble the airbox correctly and a steel washer found it's way into the (brand new) cylinder at high RPM. That ended poorly.

But I still have the bike, I've never been able to sell a motorcycle in my life :(

About your battery:

Lithium batteries don't have "memory" as such but they don't like being drained fully or left fully charged (or empty) for extended periods. A fully charged 72V battery should be around 84V, 70.4 is quite low so I'd give that a charge before you ride it. I'm surprised they shipped it at that voltage. Try to have it around 50% full for storage purposes.

Search around ES here and you'll find lots of solid info on battery care, real world experiences not theoreticals.

Best of luck and much fun with your new toy!

User avatar
gogo   10 MW

10 MW
Posts: 2429
Joined: Mar 17 2008 2:20pm
Location: Iowa USA

Re: Vintage Electric MX (YZ80)

Post by gogo » Dec 25 2017 8:27pm

If those swingarms are steel you could mount the motor on one to get more battery space.
"A conclusion is the place where you got tired of thinking." -Steven Wright

User avatar
fechter   100 GW

100 GW
Posts: 12875
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Vintage Electric MX (YZ80)

Post by fechter » Dec 25 2017 9:57pm

Great sheet metal skills there.

For sure charge that battery up fully and watch it like a hawk toward end of charge. You want to make sure the cells are all balanced before you go out and discharge it. If you plan to not use if for more than a day or so, then a lower level of charge is good.
"One test is worth a thousand opinions"

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Dec 27 2017 3:43pm

I' sort of done now. Drilled a hole in the "gas tank" put in some cables with over lenght there.
Image

I also have the charging port under the noraml gas cap.
Image
Filling up takes longer time in the "future" :lol:
As you can see, I also printed out a storage container for the right side of the tank so I had something to screw the radiator shroud to.

Like I said prevously, I would like to get little better throttle response. But I have problems with conecting to the controller. I have the GM programe PI-800 and a programing USB-cable. But it won't connect. I have Window 10. Do I need some sort of extra driver? Where can I get that? ( i'm not good at computers(!)) :oops:
Image

But I'm very pleased with the looks, almost looks like the first advertising picture from 1983 that I started this tread with :cool:
Image

User avatar
fechter   100 GW

100 GW
Posts: 12875
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Vintage Electric MX (YZ80)

Post by fechter » Dec 27 2017 8:09pm

Yes, you need a driver for the USB cable. It should come from whoever made the cable.
You may also need to change the COM port setting in the programming software to match whatever number your computer assigns to that cable.
"One test is worth a thousand opinions"

User avatar
skeetab5780   10 MW

10 MW
Posts: 2125
Joined: Jun 15 2009 10:58pm
Location: MA
Contact:

Re: Vintage Electric MX (YZ80)

Post by skeetab5780 » Dec 28 2017 10:06am

That thing looks so sweet! I love it

Keep the motor where it is!

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Jan 01 2018 12:36pm

Thank you!
I had two small piecis of the extruded aluminum cooling fins left, I guess you can't get to cool so I bended one piece to fit the motor and one piece can sit in front of the controller, is there some kind of glue that transfer heat? "steel epoxi"?
Image

I got hold of the cable driver from golden motors, The driver didn't work on my Windows 10 laptop but I tried on my old one from 2003 with XP, there it worked and I seemed to get connected now :D .

Like I said I want to get better response/ torque-feeling, want to optimize the parameters before I go into gearing/sprockets. Don't really know what could be optimized. (the battery I have is a 72V said to have: Maximum Continuous Discharge Current (A) 50A, instantaneous Maximum Discharge Current (A) 150A )

Please have a quick look at the print screen pictures below of what is say now, what do you recomend me to change? :
Image

Initally it said 200rpm/s on the acceleration, I changed that to 800rpm/s now. I assume that is a big difference if it have the power to do it.. I have not been able to test it yet since the rain have been pouring down the whole day.

So what else do you think, what will "enable" boost do? (sounds fun at least ) Is there where I shall set 150A since that is my maximum discharge current?

Otherwise I have also found a slightely bigger rear sprocket, 54 instead of my 49 I have now, I don't really need the top speed. I prefer to be able to lift the front wheel :twisted:

Buk___   10 kW

10 kW
Posts: 750
Joined: Jul 28 2017 5:59pm

Re: Vintage Electric MX (YZ80)

Post by Buk___ » Jan 01 2018 3:13pm

Rickard m wrote:
Jan 01 2018 12:36pm
is there some kind of glue that transfer heat? "steel epoxi"?
Something like Elecolit

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Jan 03 2018 6:16pm

Now I have tested the bike with 800rpm/s setting, big improvement. Starting to get funny now :twisted: obviously it is possible to go all the way to 1200rpm/s. I Shall try that next time. EDIT, tried but got error message when I entered greater than 800. Seems to be the limit any how. ((rpm/s):50.0 jÜxjÜ)

Also then I'm little comfused about the current settings. My battery is 72v and Maximum Continuous Discharge Current 50A, instantaneous Maximum Discharge Current 150A . Must the controller settings be Below that or is it recomended to have higher Numbers than the rated battery? And it just gives as much as possible? If I look in the available parameterns there is Also one called start, How long is the start current valid? (Standard value 15A seems low, or?) Difference between rated and maximum current? 190A resp. 210A as initial standard setting. (The controler Rated continuous current is 80A, Maximum phase current: 220A.) When do I get the motors Said 6kW peak power? During those 10 seconds Max duration as it says now? What/when is boost then? Shall I enable that? That is sat on 80A now,(disabled at the moment) diffrence to maximum? Could someone with better hang on these please give me some advice, Thank you!

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Jan 29 2018 11:34am

Anyone with thoughts/help about optimizing the settings??

In the mean time I made a ramp so I can bring it easy on the hook in the back of the car.
Image

Also I have changed the gearing now I run 11front sproket och 54 rear. Also changed the brakes and bearings when I had it apart.
Image

Also the rear original supension was really soft (made for younger kids riding 80cc..) Found a thicker one on eBay that almost could fit. 39,3cm between fixing holes, new was 43cm.
Image

Modified the lower end to fit and also raised the rear almost to the swing arm stop, new lenght became 40,3cm. In place:
Image

Back togheter.
Image

Crowded in the toy factory.. :D (the bike to the right is a 2WD hybrid, friction drive - petrol in front (SOLEX from 1964) and 400W electric on rear)
Image

Wounder what to fabricate next, maybe it would be fun to make something like this :rolleyes:
Image

for hard snow, narrow track to fit in the swing arm... Do you think the motor would mange this? And any hints of were to find a light suitable rubber track? :D

User avatar
fechter   100 GW

100 GW
Posts: 12875
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Vintage Electric MX (YZ80)

Post by fechter » Jan 29 2018 2:15pm

Rickard m wrote:
Jan 29 2018 11:34am
for hard snow, narrow track to fit in the swing arm... Do you think the motor would mange this? And any hints of were to find a light suitable rubber track? :D
There was a thing called a Ktrak made for bicycles. Not sure if they sell just replacement belts.
ktrak-snow-bike-kit-2.jpg
ktrak-snow-bike-kit-2.jpg (40.52 KiB) Viewed 1622 times

You might get more ideas here:
http://www.snowmobile.com/products/insi ... -2002.html
"One test is worth a thousand opinions"

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Jan 30 2018 1:38am

Thank you for the links Fechter,

I saw there were copies of Ktrak on Alibaba now, would maybe be a good start to modify. But I could easily fit a 100 mm wide track, I assume they are only about half that if they are supposed to fit a normal bicycle.

Rube   100 W

100 W
Posts: 241
Joined: Jun 25 2016 10:18pm
Location: Brisbane, Australia

Re: Vintage Electric MX (YZ80)

Post by Rube » Jan 30 2018 4:05am

Love the build, looks like a metric shed load of fun. Love the porka in the toy shed.

Rickard m   1 mW

1 mW
Posts: 11
Joined: Dec 20 2017 3:04pm

Re: Vintage Electric MX (YZ80)

Post by Rickard m » Feb 18 2018 7:48am

Now I have had time to drive a little more, everything works great. Topspeed is 70km/h, I think that is enough for forest riding. But I would like to have it slightely more agressive from zero, The power seems to be there but comes after a short "ketchup effect"..
Any advice on what to adjust?

A short film from the local pumptrack, so fun :lol:
[youtube]https://www.youtube.com/watch?v=LVvD0Isf7Oc[/youtube]

I have also now bought some real spike tires, I will put them on my extra rims, then I shall drive on the frozen lake. :twisted:
Image
Image
The grip is sooo good on ice, better than rubber in the summer, now I would almost want more power :roll:

I also happend to buy a toy for my kids, small and weak (500W) but will be good to see if they like this kind of things. :D
Image

Post Reply