Server having problems sending out emails.

This section will contain posting guidelines for the forum along with any other information that is relevant to this forum.
Post Reply
User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Server having problems sending out emails.

Post by neptronix » Aug 12 2021 9:05pm

Our server is having issues sending out emails for new signups, private messages, etc.
For one reason or another, gmail is not having problem receiving email from us, but other services are.
This is known about and being worked on as we speak.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 13 2021 3:21pm

Okay, not having success. downloading a virtual machine copy of ES because the process for debugging this will interrupt all of you on the main server.

If i do not have success then we i am going to push all other clients aside and expedite the move to xenforo. I suspect the issue is with the phpbb platform itself being behind the curve in how it sends out email.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
marty   100 MW

100 MW
Posts: 2594
Joined: Apr 19 2007 5:44pm
Location: Buffalo, New York USA
Contact:

Re: Server having problems sending out emails.

Post by marty » Aug 14 2021 8:11am

phpbb.com > search > email
https://www.phpbb.com/search/?q=email
Matteo's Mobile Bicycle repair
https://matteosbikerepair.com

User avatar
marty   100 MW

100 MW
Posts: 2594
Joined: Apr 19 2007 5:44pm
Location: Buffalo, New York USA
Contact:

Re: Server having problems sending out emails.

Post by marty » Aug 14 2021 8:48am

Could be that some email services think that your new server is sending spam emails and they are blocking it.

GoDaddy @voltev.com My own domain. Is receiving.
Matteo's Mobile Bicycle repair
https://matteosbikerepair.com

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 14 2021 12:43pm

We had email problems after our server move too. It had something to do with our hosting provider, dns, SPAM filters and/or mail relays. I can't remember what the exact issue was but you might check with your hosting provider. I think you said your hosting is with Cloudfare. I found this article https://support.cloudflare.com/hc/en-us ... Cloudflare. Our issue eventually went away but I'm not sure if it was intervention or time that fixed it.
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
marty   100 MW

100 MW
Posts: 2594
Joined: Apr 19 2007 5:44pm
Location: Buffalo, New York USA
Contact:

Re: Server having problems sending out emails.

Post by marty » Aug 14 2021 5:33pm

kauaicycler wrote:
Aug 14 2021 12:43pm
I think you said your hosting is with Cloudfare.
Looked here https://hostingchecker.com/
See:

endless-sphere.com

It is hosted by: Amazon.com, Inc.

WHOIS information: Click here

Organization name: AWS EC2 (us-west-2)

IP address: 44.225.224.39

AS(autonomous system) number and organization: AS16509 Amazon.com, Inc.

AS name: AMAZON-02

Reverse DNS of the IP: ec2-44-225-224-39.us-west-2.compute.amazonaws.com

City: Portland

Country: United States
Matteo's Mobile Bicycle repair
https://matteosbikerepair.com

User avatar
marty   100 MW

100 MW
Posts: 2594
Joined: Apr 19 2007 5:44pm
Location: Buffalo, New York USA
Contact:

Re: Server having problems sending out emails.

Post by marty » Aug 14 2021 5:38pm

For a better understanding of how email flys from computer to computer. See animated GIF.
mr1email.gif
You do not have the required permissions to view the files attached to this post.
Matteo's Mobile Bicycle repair
https://matteosbikerepair.com

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 15 2021 11:12am

I'm receiving email but I use gmail. I don't know if this will help or if the problem is fixed but this was in my mail header.
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 15 2021 11:37am

marty wrote:
Aug 14 2021 5:33pm
Looked here https://hostingchecker.com/
I got a security warning in Firefox at this url.

Here's some information about SPF Records: https://datatracker.ietf.org/doc/html/rfc7208#section-3
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 16 2021 2:44pm

Thanks for the note, kauai-san.
The issue is related to some misunderstanding between amazon SES and phpbb.

SPF is properly set and passes mxtoolbox' check and passes all tests. When phpbb sends a test email, the emails pass spf/dkim/dmarc. When phpbb sends notifications about signup, private messages, etc, it uses another routine that fails the SPF check. Phpbb is likely sending the wrong headers.

The configuration i have here is a copy/paste of a known working configuration on 3 systems.

I'm going to try another angle today and see. But i would rather focus on the xenforo move.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 16 2021 3:24pm

Pm notification between me and kauai shows spf=pass.
On my end, i get a pass for dkim, dmarc, and spf with loose settings.
Everything looks right.

Anyone here have a hotmail, office365, or some other microsoft account as your email?
If so, send me a PM and i'll send you one back.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 16 2021 4:07pm

neptronix wrote:
Aug 16 2021 3:24pm
Pm notification between me and kauai shows spf=pass.
On my end, i get a pass for dkim, dmarc, and spf with loose settings.
Everything looks right.

Anyone here have a hotmail, office365, or some other microsoft account as your email?
If so, send me a PM and i'll send you one back.
Reply to this post if you want and I can check the headers on the automated notification as I noted in a pm.
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 16 2021 6:00pm

boop
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 16 2021 6:33pm

Subject: Topic reply notification - "Server having problems sending out emails."
Created at: Mon, Aug 16, 2021 at 7:01 PM (Delivered after 3 seconds)
SPF: FAIL with IP 2600:1901:101:0:0:0:0:0
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 16 2021 6:36pm

Okay so it fails when the server randomly decides to send out as ipv6.
What's weird is that the test email on the admin side always succeeds.

This may be a weird SES problem.
I suppose i should setup sendmail as a quick fix ( we don't need incoming mail). Do you have a good configuration for sendmail or something similar to do smtp out? otherwise i'll discover one ( haven't used it in eons - everything has externally hosted email these days )
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 17 2021 8:27am

neptronix wrote:
Aug 16 2021 6:36pm
Okay so it fails when the server randomly decides to send out as ipv6.
What's weird is that the test email on the admin side always succeeds.

This may be a weird SES problem.
I suppose i should setup sendmail as a quick fix ( we don't need incoming mail). Do you have a good configuration for sendmail or something similar to do smtp out? otherwise i'll discover one ( haven't used it in eons - everything has externally hosted email these days )
Sorry I don't. I've been thinking about a new project and it's going to need to send email too so I'll be searching for a good send mail solution as well. I had problems with this in the past where I somehow opened up my server to be used as a relay or something so I'm going to proceed with caution.

Email is complicated, there are developers that specialize in it. Sending a good looking secure email is harder than a web page in a browser because there are way more email clients than browsers these days.
What's weird is that the test email on the admin side always succeeds.

Infamous "it works on my machine" developer issues. I'd be happy to be your other set of eyes when needed.
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
marty   100 MW

100 MW
Posts: 2594
Joined: Apr 19 2007 5:44pm
Location: Buffalo, New York USA
Contact:

Re: Server having problems sending out emails.

Post by marty » Aug 17 2021 11:42am

Matteo's Mobile Bicycle repair
https://matteosbikerepair.com

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 17 2021 11:50am

kauaicycler wrote:
Aug 17 2021 8:27am
Sorry I don't. I've been thinking about a new project and it's going to need to send email too so I'll be searching for a good send mail solution as well. I had problems with this in the past where I somehow opened up my server to be used as a relay or something so I'm going to proceed with caution.
Yes, if you don't know what you are doing, you're hosed. I wouldn't allow remote connections in any direction other than outwards, so that would eliminate the chance for inexperience causing issues. It's not necessarily a route i'd like to take. But it is a route to use sendmail. I have more reading to do before implementing it.

Deliver-ability of email is my biggest concern.
kauaicycler wrote:
Aug 17 2021 8:27am
Email is complicated, there are developers that specialize in it. Sending a good looking secure email is harder than a web page in a browser because there are way more email clients than browsers these days.
Setting up email securely is absolutely a pain in the ass, complicated by some email sending providers' various technical issues. You can't debug on the reciever's end, and that makes diagnosis a longer process than it needs to be. Yes, it's painful.

Thanks for lending me another set of eyes.


Marty, i've ruled out basic and easy fixes like that already.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 17 2021 1:23pm

I'm not sure how severe this issue is. I'm getting the email but I guess some users aren't? I'm wondering if the move to the new forum software will fix this issue or complicate it. Eyeballs standing by...
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 17 2021 1:29pm

The big problem is that people with some mail providers aren't getting email address confirmations when signing up.
That's bad.

Will be plopping a copy of our forum converted to xenforo format on as a tester to see if it sends emails differently to rule out the problem. I'd rather rule that out first.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

Addy   100 W

100 W
Posts: 287
Joined: Aug 11 2017 11:15am
Location: BC, Canada

Re: Server having problems sending out emails.

Post by Addy » Aug 17 2021 1:30pm

I doubt this is a viable solution, but it's what I use for my self-hosted stuff because my ISP doesn't allow any email sending. I just created a gmail account to do the mailing and set up my scripts/software to use the gmail account when they need to send out mail. It works for my small scale stuff but I doubt google would be happy if I started sending out a larger volume of emails.

User avatar
kauaicycler   100 W

100 W
Posts: 167
Joined: May 18 2019 1:37pm
Location: Cocoa, FL
Contact:

Re: Server having problems sending out emails.

Post by kauaicycler » Aug 17 2021 1:49pm

neptronix wrote:
Aug 17 2021 1:29pm
The big problem is that people with some mail providers aren't getting email address confirmations when signing up.
That's bad.

Will be plopping a copy of our forum converted to xenforo format on as a tester to see if it sends emails differently to rule out the problem. I'd rather rule that out first.
Yeah that's bad! If the new software works at least you know the problem is in the phpBB software. Feel free to send me email from the test server.
Addy wrote:
Aug 17 2021 1:30pm
I doubt this is a viable solution, but it's what I use for my self-hosted stuff because my ISP doesn't allow any email sending. I just created a gmail account to do the mailing and set up my scripts/software to use the gmail account when they need to send out mail. It works for my small scale stuff but I doubt google would be happy if I started sending out a larger volume of emails.
I've done this for small sites but I think gmail has a limit of about 500 per day.
Build Thread: Meet Miss Mino'aka (Hawaiian for smile) Electra Lux 7D Fat Tire with a BBSHD

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 17 2021 1:51pm

Oh yeah, google will eventually put an unfixable, undiagnosable black mark on one's account if you do that at scale. Seen it happen to a few clients already. Not sacrificing my own personal account for the cause ;)
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

User avatar
neptronix   100 GW

100 GW
Posts: 16346
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Server having problems sending out emails.

Post by neptronix » Aug 18 2021 7:39pm

I flicked a couple settings and hopefully email deliverability improved further. I'm getting new private message notifications correctly to a gmail account.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

Post Reply