Allowed HTML Tags (will have to be revised, no longer works)

This section will contain posting guidelines for the forum along with any other information that is relevant to this forum.
User avatar
Kingfish
10 GW
10 GW
Posts: 4275
Joined: Feb 03, 2010 11:23 am
Location: Redmond, WA-USA, Earth, Sol, Orion–Cygnus Arm, Milky Way. Age: > yesterday < tomorrow
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Kingfish » Mar 01, 2011 3:37 pm

Bug: Imported files & images no longer appear.

Steps to reproduce:
  1. Go to Doing the Math thread
  2. Find the missing image and click on it.
  3. See the value below.
The selected attachment does not exist anymore.

The file ./../files/15191_3b7db0f0fb5f9f3aed9089ccb9fb508a does not exist.
Every imported image on the thread is like this. Same problem with files.

If the bug has been previously reported, then please accept my apoligies. Hopefully this will get cleared up soon.
~KF
* My 2WD Garden Wall
* Kinaye MotorSports
* Primary ride: 2WD Disc 9C 2806-equiv / Dual Lyen 12FET / 20S7P LiPo.
* Epics: Going to California: 2011 8)
* 50-mph, 101, 10k-Club. 12,527 miles-to-date, 7037 as 2WD.

It is by caffeine alone I set my mind in motion.
It is by the beans of Java that thoughts acquire speed.
The hands acquire shakes, the shakes become a warning.
It is by caffeine alone I set my mind in motion.

User avatar
Lock
10 GW
10 GW
Posts: 4621
Joined: May 24, 2007 5:46 pm
Location: Toronto Harbour
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Lock » Mar 02, 2011 6:24 am

Also looks like extended characters were lost in the upgrade... eg André-Marie Ampère now displays as André-Marie Ampère
tks
Lock
If you like this message feel free to donate BeerCoins (BTC) to:
1LxAXWmbjY6SeMf8r9HHhSKt6pWyPvWg6L

Toronto Electric Riders Association:
http://www.ebikeriders.com/
Canada, eh?

User avatar
Lock
10 GW
10 GW
Posts: 4621
Joined: May 24, 2007 5:46 pm
Location: Toronto Harbour
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Lock » Mar 02, 2011 8:25 am

Any word on this please?
Attachments.jpg
I'd rather see 3-4 days of messages lost rather than 3-4 years of attachments!

tks
LocK
You do not have the required permissions to view the files attached to this post.
If you like this message feel free to donate BeerCoins (BTC) to:
1LxAXWmbjY6SeMf8r9HHhSKt6pWyPvWg6L

Toronto Electric Riders Association:
http://www.ebikeriders.com/
Canada, eh?

User avatar
Lock
10 GW
10 GW
Posts: 4621
Joined: May 24, 2007 5:46 pm
Location: Toronto Harbour
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Lock » Mar 02, 2011 2:22 pm

Lock wrote:Any word on this please?
Attachments.jpg
I'd rather see 3-4 days of messages lost rather than 3-4 years of attachments!
tks
LocK
Getting there! This one for example still missing in action:
https://endless-sphere.com/forums/downlo ... p?id=53524
Image
If you like this message feel free to donate BeerCoins (BTC) to:
1LxAXWmbjY6SeMf8r9HHhSKt6pWyPvWg6L

Toronto Electric Riders Association:
http://www.ebikeriders.com/
Canada, eh?

User avatar
Lock
10 GW
10 GW
Posts: 4621
Joined: May 24, 2007 5:46 pm
Location: Toronto Harbour
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Lock » Mar 02, 2011 6:28 pm

watt looks like jpg files aren't displaying but can be downloaded then give this error msg:
FileFormat.jpg
tks
L
You do not have the required permissions to view the files attached to this post.
If you like this message feel free to donate BeerCoins (BTC) to:
1LxAXWmbjY6SeMf8r9HHhSKt6pWyPvWg6L

Toronto Electric Riders Association:
http://www.ebikeriders.com/
Canada, eh?

D-Man
1 MW
1 MW
Posts: 1547
Joined: Nov 28, 2006 8:43 pm

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by D-Man » Mar 03, 2011 12:10 am

I'll bet that they will be lost forever.
408 front hub
15000+ miles on sla's.
Michelin pilot sport 2.3 tires

User avatar
Jeremy Harris
10 GW
10 GW
Posts: 4568
Joined: Oct 23, 2007 4:15 pm
Location: Salisbury, UK

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Jeremy Harris » Mar 03, 2011 3:44 am

D-Man wrote:I'll bet that they will be lost forever.
I hope not, as there is masses of fantastic information in all those attachments. The extra work it will mean in answering questions when we can't reference old threads with the answers will be enormous.

Here's hoping it's just a glitch with the database and not a total loss of all attachments.

Jeremy
Please ask questions on the forum, rather than by PM, as it helps others and you'll get a better range of answers.

User avatar
Kingfish
10 GW
10 GW
Posts: 4275
Joined: Feb 03, 2010 11:23 am
Location: Redmond, WA-USA, Earth, Sol, Orion–Cygnus Arm, Milky Way. Age: > yesterday < tomorrow
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Kingfish » Mar 03, 2011 11:17 am

Kingfish wrote:Bug: Imported files & images no longer appear.

Steps to reproduce:
  1. Go to Doing the Math thread
  2. Find the missing image and click on it.
  3. See the value below.
The selected attachment does not exist anymore.

The file ./../files/15191_3b7db0f0fb5f9f3aed9089ccb9fb508a does not exist.
Every imported image on the thread is like this. Same problem with files.

If the bug has been previously reported, then please accept my apologies. Hopefully this will get cleared up soon.
~KF
Update: We have progress! JPGs appear to work as do ZIP files now, however PNGs still do not render. Particular characters from pre-update are still corrupted (there's one in my sig).
~KF
* My 2WD Garden Wall
* Kinaye MotorSports
* Primary ride: 2WD Disc 9C 2806-equiv / Dual Lyen 12FET / 20S7P LiPo.
* Epics: Going to California: 2011 8)
* 50-mph, 101, 10k-Club. 12,527 miles-to-date, 7037 as 2WD.

It is by caffeine alone I set my mind in motion.
It is by the beans of Java that thoughts acquire speed.
The hands acquire shakes, the shakes become a warning.
It is by caffeine alone I set my mind in motion.

User avatar
Lock
10 GW
10 GW
Posts: 4621
Joined: May 24, 2007 5:46 pm
Location: Toronto Harbour
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Lock » Mar 04, 2011 12:30 pm

Kingfish wrote:JPGs appear to work...
Not all:
https://endless-sphere.com/forums/downlo ... p?id=53816

(filename displays in the thread as Rudge_Coventry_Rotary.jpg)

tks
Lock
If you like this message feel free to donate BeerCoins (BTC) to:
1LxAXWmbjY6SeMf8r9HHhSKt6pWyPvWg6L

Toronto Electric Riders Association:
http://www.ebikeriders.com/
Canada, eh?

User avatar
Kingfish
10 GW
10 GW
Posts: 4275
Joined: Feb 03, 2010 11:23 am
Location: Redmond, WA-USA, Earth, Sol, Orion–Cygnus Arm, Milky Way. Age: > yesterday < tomorrow
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by Kingfish » Mar 04, 2011 12:55 pm

Agreed; this is restoration in progress :|

I have resolved to edit my posts where I uploaded attachments and retarget them back to my domain. I am hesitant to edit the incurred typos because this can be corrected through a couple paths, namely:
  • Restoration from backup with proper character translation
  • Development of substitution scripts
It’s not rocket science; I do this pretty often as part of my normal gig. Sadly I am standing on the sidelines watching the imagined drama unfold and unable to help because the technology that I know and use is incompatible with the host and environment.

Think about it: This began on Feb 28th and now we’re a week later and there are still problems. This tells me a lot about the ES as an application. I don’t think it is much of a stretch to guess that the part that is missing is a rock-solid daily backup & restoration plan with a reliable host.

Now it could be that the host was targeted and the files corrupted, but that shouldn’t affect the previous day or two or twelve if the content is burned off to BR; kinda hard to corrupt a history of physical data. But this gets into supposition, though difficult to ignore given the state of today and the evidence at hand.

Regardless, my modus operandi is changed henceforth, and all future resources will derive from my servers.

O’ cruel is the world, KF
* My 2WD Garden Wall
* Kinaye MotorSports
* Primary ride: 2WD Disc 9C 2806-equiv / Dual Lyen 12FET / 20S7P LiPo.
* Epics: Going to California: 2011 8)
* 50-mph, 101, 10k-Club. 12,527 miles-to-date, 7037 as 2WD.

It is by caffeine alone I set my mind in motion.
It is by the beans of Java that thoughts acquire speed.
The hands acquire shakes, the shakes become a warning.
It is by caffeine alone I set my mind in motion.

phyllis
10 W
10 W
Posts: 68
Joined: Feb 12, 2011 9:11 am

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by phyllis » Mar 04, 2011 7:44 pm

Most of the pics are broken, some have strange colors below the break too.
You do not have the required permissions to view the files attached to this post.

User avatar
arkmundi
1 GW
1 GW
Posts: 3444
Joined: Jul 08, 2012 11:14 am
Location: Worcester, MA USofA

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by arkmundi » Jul 14, 2015 3:14 pm

The "[youtube][/youtube]" HTML on phpbb no longer works for me, after using it for the longest time.
I deleted the Adobe Flash plugin from my machine. I use the Firefox browser on top of Ubuntu.

If you had not noticed, there have been a slew of recent news articles like this: Facebook info security chief: 'Death to Adobe Flash'. For a couple of months now, the Flash plug-in has been been blocked, requiring "activation" for each site where it was used. I had activated it for the endless-sphere forum as "always allow". But it was getting tedious.

So I looked up http://askubuntu.com/questions/562035/a ... s=1|1.3257 and their answer
The best solution to the problem of a vulnerable, out-of-date Flash installation--or even an up-to-date one that works poorly--may be to uninstall Flash entirely. Often it is not needed, as HTML5 has largely taken over. Thus removing Flash is a real solution for many people, and should probably be considered first before moving on to other solutions that attempt to keep Flash installed while maintaining it in a current (or semi-current) state.
Adobe no longer provides support for Linux installations, so getting an 'update" was not plausible - I had done that and had the latest and last version available.

So I uninstalled it. Everything, more-or-less is kosher - I see all videos, including at Youtube. But I just tried to embed a YouTube video at https://endless-sphere.com/forums/viewto ... 0#p1072014 and what displays is:
PluginNeeded.png
Note that at the source page - http://ecowatch.com/2015/07/14/elon-musk-tesla-model-s/ - what I see is
NotNeeded.png
Same video, on a website displaying it with no plugin, using HTML5, and here on our phpbb based forum. This is a problem for the forum that may be encountered by others. Hope there's a fix to be found.
_________
Update: I found a fix that works. Its the No Flash Firefox add-on "that replaces embedded YouTube and Vimeo Flash video players on third-party websites by HTML5." Note the fact this confirms phpbb youtube tags are calling for Flash or compatible plug-ins (which I don't have) and that HTML5 works great. Someone needs to get fixing the phpbb youtube script.
You do not have the required permissions to view the files attached to this post.

User avatar
r3volved
1 MW
1 MW
Posts: 1605
Joined: Jul 24, 2013 4:01 pm
Location: Waterloo, Ontario, Canada

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by r3volved » Jul 14, 2015 5:03 pm

Did you update your chrome?
I had the same thing today until chrome updated

...I mean your FF. my problem was chrome

User avatar
kd8cgo
100 W
100 W
Posts: 119
Joined: May 31, 2009 3:06 pm
Location: Northern Constitution-Free Border Zone, Homeland Security Region 5 - Corporate States of America

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by kd8cgo » Jul 14, 2015 9:28 pm

The No Flash addon I think is the best all around solution - you can use an add-on to use the Chrome Pepper flash module, or Chrome itself, but then you're back at using proprietary junk software again. Most YT vids will work with the HTML5 player.

On phpbb, there is a Advanced BBCode Box 3.1 extension that allows you to embed YT (and many other) videos, but unfortunately it still uses the legacy shockwave iframe embed code if someone posts the common "https://www.youtube.com/watch?v=ABCDEF123" link style. It does however support the proper "https://www.youtube.com/embed/ABCDEF123" format which will then use the HTML5 player, but this is left to the user - so many links would still be using the antiquated format depending on the user. Of course with phpBB you can write a proper custom embed BB code, but I've not seen one so far in the pre-coded offerings that uses the modern embedding style on the phpbb.com extension repository.

There is also s9e/mediaembed which just parses links to videos, twitter feeds, and a bunch of other junk and does the embed on the fly based on just posting the URL which is really cool and user friendly. The downside? YT links are embedded in the antiquated shockwave garbage iframe code of yesteryear! :P

User avatar
arkmundi
1 GW
1 GW
Posts: 3444
Joined: Jul 08, 2012 11:14 am
Location: Worcester, MA USofA

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by arkmundi » Jul 15, 2015 7:55 am

Wired: Flash. Must. Die.
After all, the newly discovered critical vulnerability that led Mozilla to quarantine Firefox from Flash was the third problem of its kind discovered this week thanks to a data breach of controversial digital surveillance firm Hacking Team.
Wow, the media campaign has stepped up on this. Anyway, explains my dilemma with Firefox. Am good. phpBB, not so.

User avatar
amberwolf
100 GW
100 GW
Posts: 23938
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Allowed HTML Tags (will have to be revised, no longer wo

Post by amberwolf » Sep 08, 2015 9:09 pm

From Cowardlyduck, perhaps a way to add Vimeo video:
Cowardlyduck wrote:I was wondering if it would be possible to get Vimeo video embedding enabled in the forum?
I see from this link that it looks possible in this type of forum:
http://www.friendsofhdvideo.com/forum/v ... f=32&t=275

Post Reply