links in notification mails not shown anymore?

This section will contain posting guidelines for the forum along with any other information that is relevant to this forum.
User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

links in notification mails not shown anymore?

Post by izeman » Nov 12, 2014 12:55 pm

i can see some strange behaviour within the notification mails sent by the forum when i receive a new post in one of my subscribed topics for 2 days now.
before that i could just click the links, and now the links are gone. if i forward the notification mail to myself if works fine.
any idea what's going wrong? i can see that in chrome and iexplorer as well.
Capture.JPG
Capture.JPG
You do not have the required permissions to view the files attached to this post.

User avatar
amberwolf
100 GW
100 GW
Posts: 23950
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: links in notification mails not shown anymore?

Post by amberwolf » Nov 13, 2014 11:55 pm

Could be your ISP / email provider's way of displaying the page.

I use Gmail's webmail in HTML mode, and it doesn't linkify the URLs. (same with the other modes)

But if I open it in Thunderbird (local email client) it does linkify them--it's part of the program and not the email itself, though.


Gmail's servers USED to actually alter all of my emails as they were displayed to me (but not the source of them if I downloaded them to Thunderbird), so that a link would be like this:

Code: Select all

https://www.google.com/url?q=https%3A%2F%2Fforums.adafruit.com%2Fviewtopic.php%3Ff%3D8%26t%3D7755%26p%3D286161%26e%3D286161&sa=D&sntz=1&usg=AFQjCNF8El1qX8ZhKKAxbcgtOTP5M_7lRg
whcih would cause it to always go to Google's redirector page first, and then automatically take me to the original linked page, instead of just being the actual URL that was in the message:

Code: Select all

https://forums.adafruit.com/viewtopic.php?f=8&t=7755&p=286161&e=286161
When that was happening (which Gmail doesn't do anymore, probably because of complaints?), it would actually "save" the altered version in my online webmail version of saved emails, but the version I can then download via POP to my local client (thunderbird in this case) is only the original unaltered one.

The sources of older and newer notifications are the same: no actual "link" in the text itself, just a URL.

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Nov 14, 2014 3:42 am

that sounds reasonable to me. opening the mails on my iphone they are still complete with links. if i forward them to my very same gmail account email adress they are ok as well.
and eg multiwii forum's (which uses the very same forum software and sends the same links) notification mails are shown correctly from the very beginning.
it's just strange as this was working ok 3 days ago and then suddenly stopped. so i guess it's got something today with my gmail web view.
thanks

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Nov 14, 2014 3:55 am

same here, they don't shop up anymore
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Nov 14, 2014 4:00 am

pucksterpete wrote:same here, they don't shop up anymore
since when? the last "working" on i got was from november 9th.

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Nov 14, 2014 8:52 am

Same, Nov 9, I don't understand why, I am using chrome

links
Image
no links
Image
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Nov 14, 2014 8:54 am

Strange. I googled for it but didn't get any results.
@amberwolf: you can confirm that there were no changes on the forum's software side?

User avatar
cal3thousand
10 GW
10 GW
Posts: 4044
Joined: Mar 26, 2012 4:47 pm
Location: California

Re: links in notification mails not shown anymore?

Post by cal3thousand » Nov 14, 2014 10:53 am

Same for me.... I was just doing to search to find out and I can't find anything.

I think Chrome is the common 'link'
Get a Cycle Analyst and a Multimeter, you're still a noob if you don't have at least one of each.

Planning on posting questions or buying anything on this site? Put up your country (at minimum) on your profile. This is a worldwide forum and we haven't reached clairvoyance.

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Nov 14, 2014 11:02 am

cal3thousand wrote:... I think Chrome is the common 'link'
no i don't think so because

.) i get phpBB mails from other forums that still "work"
.) the mail's are displayed the same in "internet explorer"
.) if you poll the mails and display them on your smartphone they are "ok"
.) if you forward them to some other mail adress they also are "ok"

so imho it's either

.) google gmail
.) some phpBB setting (that may have been changed, willingly or during an update?)

User avatar
cal3thousand
10 GW
10 GW
Posts: 4044
Joined: Mar 26, 2012 4:47 pm
Location: California

Re: links in notification mails not shown anymore?

Post by cal3thousand » Nov 14, 2014 12:37 pm

izeman wrote:
cal3thousand wrote:... I think Chrome is the common 'link'
no i don't think so because

.) i get phpBB mails from other forums that still "work"
.) the mail's are displayed the same in "internet explorer"
.) if you poll the mails and display them on your smartphone they are "ok"
.) if you forward them to some other mail adress they also are "ok"

so imho it's either

.) google gmail
.) some phpBB setting (that may have been changed, willingly or during an update?)
You're right. I just checked in FireFox and it was the same issue. For now, I triple click the link to select all of it, right click and choose 'Go'
Get a Cycle Analyst and a Multimeter, you're still a noob if you don't have at least one of each.

Planning on posting questions or buying anything on this site? Put up your country (at minimum) on your profile. This is a worldwide forum and we haven't reached clairvoyance.

User avatar
amberwolf
100 GW
100 GW
Posts: 23950
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: links in notification mails not shown anymore?

Post by amberwolf » Nov 14, 2014 2:47 pm

I don't know that anything changed in the forum sw or settings.

However, I just dug thru the trash of my gmail webmail, and found that some other PHPBB forum notifications, mailing list digests, and private emails *are* still being linkified, and some are not (whereas all were before).

So I suspect (but can't be certain) it's at Gmail's end, not the forum software, just because of that.

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Nov 14, 2014 3:59 pm

So, I forward the endlessphere email to another gmail account account I have, the links are there, and then back to the original email account, the links are there too, hmmm
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Nov 17, 2014 7:55 am

seems to be a very old issue. i didn't find a lot. only this: https://productforums.google.com/forum/ ... xX-ehenYTQ
and there is no solution for it. the question remains: why now? and what has changed and what to do against it?

I HATE THAT :(

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Nov 21, 2014 4:32 am

So, I have posted a problem with Google groups and here are some of the responses I got regarding this problem. I have tried all of them and still NO links.
________________________________________

Kalina M.Expert - Google Products25 Best Answers
Nov 19


Hi Pete,

Thanks for posting in the Gmail forum. It's possible there is something off with Chrome that might be interfering with the links. Try a couple troubleshooting techniques on Chrome, and let me know if that helps!
Be sure that Chrome is up to date.
Clear your Cache and Cookies
In Gmail, go to Settings> Labs> Disable Labs
In Chrome, go to Menu> Tools> Extensions> Disable your extensions
Open an Incognito Window in Chrome and access your Gmail. Does it still happen?
If that makes links visible, you'll need to disable all your extensions/add-ons manually and then add them one at a time.
Best,
Kalina
0 0 Mark as best answer



meLevel 1 (Pete change)
Nov 20 (22 hours ago)


Hello Kalina,

Thanks for replying back. Unfortunately, I tried everything you suggested and I still have the same problem, even in Incognito. The links that are not showing up in emails are only coming from one forum, other forums that I belong to or other emails are fine.

One other person from the forum is experiencing the same problem. We spoken with one of the moderators of the forum and they had no changes or update has been made to the php type forum.

I was getting links in emails that I could click on from the forum back on Nov 9th and before, after Nov 9th is when the problem started.

I have tried from my smart phone and 2 other computers same problem.

Thanks again for helping

Pete



wdurhamTop Contributor1,000 Best Answers
Nov 20 (22 hours ago)


Pete - are you sure the links are gone, and not just hiding under an ellipsis icon ( like this "...") at the bottom of your message?
0 0 Mark as best answer



meLevel 1 (Pete change)
Nov 20 (19 hours ago)


Hello wdurham,

Here are 2 screenshots of an emails from the forum

just a sig under the ...

thanks for the help

Pete




Attachments (2)
links.jpg
57 KB View Download
no links.jpg
55 KB View Download



wdurhamTop Contributor1,000 Best Answers
Nov 20 (19 hours ago)


Ah, OK, I get it. The links are there, but just not clickable.

In that case it's quite possible that your security package is working overtime and preventing links from being clickable to "protect" you from clicking on something nasty!

Try opening a new incognito window in Chrome, (which will suppress your installed extensions) and signing in to Gmail - does that help? If it does, then one of your extensions is preventing the links from working. Disable them all, and then add them back till you find the troublemaker.

Also, check your security package and make sure it doesn't interfere at all with your incoming mail - there's no need for these over-zealous apps to be interfering with your mail at all, as Gmail itself, and virtually all email clients have pretty powerful anti-nasty protection built in.
0 0 Mark as best answer



meLevel 1 (Pete change)
Nov 20 (19 hours ago)


Thanks again for your help. I have tried the incognito, still the same result, I have disabled all extensions too, same thing. I will check into security, for now I just have windows 8 basic firewall setup, no other spyware or security system running.

thanks



Kalina M.Expert - Google Products25 Best Answers
1:08 AM (9 hours ago)


Hi Pete,

Could you try accessing your Gmail from a different browser other than Chrome? If that doesn't work, could you also try viewing in basic HTML mode?

Thanks,
Kalina
0 0 Mark as best answer
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Nov 21, 2014 4:52 am

strange, strange. since YESTERDAY links are working again. :)
i tried in iexplorer, as this seems to be a GMAIL problem and NOT browser related. opened a notification from today, and i got a link to click. i thought - damn! it must be chrome. but it isn't. all notifications from today work in iexplorer and chrome, and those that don't work work neither in iexplorer nore in chrome.
so it's working good again :)

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Nov 21, 2014 5:07 am

your right, 1st one of the day your reply sent me a notification email and the links work, lets hope it stays this way :D
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
cal3thousand
10 GW
10 GW
Posts: 4044
Joined: Mar 26, 2012 4:47 pm
Location: California

Re: links in notification mails not shown anymore?

Post by cal3thousand » Nov 21, 2014 5:57 pm

Same here... weird
Get a Cycle Analyst and a Multimeter, you're still a noob if you don't have at least one of each.

Planning on posting questions or buying anything on this site? Put up your country (at minimum) on your profile. This is a worldwide forum and we haven't reached clairvoyance.

User avatar
gogo
100 MW
100 MW
Posts: 2598
Joined: Mar 17, 2008 2:20 pm
Location: Iowa USA

Re: links in notification mails not shown anymore?

Post by gogo » Nov 21, 2014 7:38 pm

Gmail fixed it sometime between 6AM and 3PM today for me.
"A conclusion is the place where you got tired of thinking." -Steven Wright

User avatar
gogo
100 MW
100 MW
Posts: 2598
Joined: Mar 17, 2008 2:20 pm
Location: Iowa USA

Re: links in notification mails not shown anymore?

Post by gogo » Dec 02, 2014 2:02 pm

Broken again as of yesterday (Dec. 1).
"A conclusion is the place where you got tired of thinking." -Steven Wright

User avatar
amberwolf
100 GW
100 GW
Posts: 23950
Joined: Aug 17, 2009 6:43 am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: links in notification mails not shown anymore?

Post by amberwolf » Dec 02, 2014 2:17 pm

Still working in my HTML-only gmail, so far.
https://mail.google.com/mail/h/

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Dec 02, 2014 2:53 pm

gogo wrote:Broken again as of yesterday (Dec. 1).
no problem here

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Dec 02, 2014 3:12 pm

same, all is fine, using chrome and gmail
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
pucksterpete
1 kW
1 kW
Posts: 324
Joined: Apr 15, 2011 11:11 am
Location: Paris France
Contact:

Re: links in notification mails not shown anymore?

Post by pucksterpete » Dec 03, 2014 3:19 am

Things are different today, no more links in the emails, I'm going to have to guess that this is a forum setting problem, bummer!

with links
Image

no links
Image
Optim Alp Hardtail with MXUS Motor
20S 2P Turnigy 5.0 Hard Case
Top speed 38mph tops :)
Hyena Special
https://endless-sphere.com/forums/viewto ... 97#p585997
-------
Excelsior/Strong GTS with Cromotor
24S 3P Turnigy 5.0 Hard Case
Top speed so far 53mph
https://endless-sphere.com/forums/viewto ... =6&t=46993

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Dec 03, 2014 4:19 am

you're right. it stopped working again between 1:23 (last good mail) and 2:00 (first bad one) this night. which is UTC+0 time.

User avatar
izeman
10 GW
10 GW
Posts: 4502
Joined: Jun 21, 2011 8:25 am
Location: vienna, austria
Contact:

Re: links in notification mails not shown anymore?

Post by izeman » Dec 03, 2014 8:50 am

and since one hour back it's working again. strange ...

Post Reply