Battery problem, voltage but no current

Batteries, Chargers, and Battery Management Systems.
Post Reply
sayshell   100 µW

100 µW
Posts: 8
Joined: Oct 07 2016 7:48pm

Battery problem, voltage but no current

Post by sayshell » Jan 17 2018 9:51pm

Hi the bms crapped out on a battery so we changed it. Now it's reading around 49 volts, but there is no current. As soon as I turn the display on it drops to zero volts and shuts off. Does anyone know what is causing this? How can there be voltage but no current?

I don't think the connection is the problem, the voltage is reading correctly. The battery pack is about 2/3 charged. We just put on a new bms I think it should be working fine.

User avatar
dogman dan   100 GW

100 GW
Posts: 34425
Joined: May 17 2008 12:53pm
Location: Las Cruces New Mexico USA

Re: Battery problem, voltage but no current

Post by dogman dan » Jan 18 2018 8:44am

New bms might not fix crapped out battery.

Charge full, and get it balanced before you decide its the bms. You might simply be so out of balance that one set of cells is nowhere near 2/3 charged. So the bms shuts it off as it is supposed to.

User avatar
fechter   100 GW

100 GW
Posts: 13087
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Battery problem, voltage but no current

Post by fechter » Jan 18 2018 9:20am

Right, it sounds like the BMS is doing its job and it's tripped. When it cuts off the output, you will still see voltage if measured with a voltmeter, but it will drop to zero with a load.

You need to check all the individual cell voltages. Most likely there is one that is out of range. I do this by inserting little wires into the BMS connector and attaching them to my voltmeter.
"One test is worth a thousand opinions"

Joachim   1 kW

1 kW
Posts: 302
Joined: Jul 30 2015 1:02pm

Re: Battery problem, voltage but no current

Post by Joachim » Jan 18 2018 12:34pm

the bms doesnt like the current peak to charge the empty controller caps....a smal coil between battery and controller will wurk.

User avatar
fechter   100 GW

100 GW
Posts: 13087
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Battery problem, voltage but no current

Post by fechter » Jan 18 2018 2:03pm

Joachim wrote:
Jan 18 2018 12:34pm
the bms doesnt like the current peak to charge the empty controller caps....a smal coil between battery and controller will wurk.
That can happen sometimes too. You'd see a pretty good spark when you make the connection if this was the case. If the BMS is already tripped, you would get no spark.
"One test is worth a thousand opinions"

Post Reply