Hyperion EOS 1420i NET3 14s Balance Charger...

Batteries, Chargers, and Battery Management Systems.
Rutiger   100 W

100 W
Posts: 116
Joined: Jan 03 2013 6:04am
Location: Brisbane, Australia

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by Rutiger » Apr 14 2014 2:55am

Thanks again. Will do.

999zip999   100 GW

100 GW
Posts: 9738
Joined: Jan 10 2010 1:40pm
Location: Dana Point So. Cal

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by 999zip999 » Apr 16 2014 4:08pm

I have two 12s A123 20ah I use as 24s no bms just charge as 12s on my 1420. The no.1 cell charged to 3.7v as the other 11 were at 3.5v ? I thought one of the A123 20ah pouches was going south. I hooked it up the other 12s to the 1420 and cell no, 1 on the second pack did the same thing. 3.7v all the rest at 3.5v. what's up ? I tought it was a buck charger and just bleed down the first hi cell or cells to balance how can one cell race to 3.7v. ???? I will discharge and try again in next time. Funbky hyperion I thought when I repaled the balance boards and balance wires two months ago all things were worked out. I wish the 1420 worked better as I would like to charge with two of them at once for 24s. Damm funcky cold madana.

User avatar
Ratking   1 kW

1 kW
Posts: 499
Joined: May 20 2010 5:27am
Location: Norway

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by Ratking » Apr 16 2014 6:00pm

Hello,

I just got a surprise when trying to start my charger a couple of weeks ago. I got no response, dead and no smell or other signs of damage.
Do the chargers have a history of dying silently, and which component is often the problem?
I would rather get a few hints than trying to understand the PCB, thank you

stonezone   100 W

100 W
Posts: 217
Joined: Mar 12 2014 4:25pm
Location: Oahu, Hawaii

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by stonezone » Apr 16 2014 6:39pm

would this power supply be adequate for the 1420i:
http://cgi.ebay.com/ws/eBayISAPI.dll?Vi ... ink:top:en

other suggestions?

thanks!

SZ
LR-BB on 2014 Glory
Sur-Ron
B B S-HD on some sort of DH Kona frame
2017 GG GP 300 <3

RIP Bobarella

Rutiger   100 W

100 W
Posts: 116
Joined: Jan 03 2013 6:04am
Location: Brisbane, Australia

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by Rutiger » Apr 16 2014 8:07pm

stonezone wrote:would this power supply be adequate for the 1420i:
http://cgi.ebay.com/ws/eBayISAPI.dll?Vi ... ink:top:en

other suggestions?

thanks!

SZ
While it's in the right voltage range, you're not going to be able to charge very fast (or maybe not at all) with a 25w/1.1A PSU.

Mine is 24v and capable of maxing out at 70A, or basically 1600/1700w.

I'm guessing you would need something around 24v and 800w to run the 1420 charger at full steam comfortably?

999zip999   100 GW

100 GW
Posts: 9738
Joined: Jan 10 2010 1:40pm
Location: Dana Point So. Cal

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by 999zip999 » Apr 16 2014 10:53pm

I use two hp 12v 550 watt computer power supples. About 50usd. all wired to go. Check In the sales section. Or there is a thread you wire it up with the right pin outs and slow down the fan.
Edit : that's at 24v 1000watts.
Last edited by 999zip999 on Apr 17 2014 1:17am, edited 1 time in total.

User avatar
wesnewell   100 GW

100 GW
Posts: 7170
Joined: Jan 31 2011 6:25pm
Location: Wylie, TX, USA

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by wesnewell » Apr 17 2014 12:47am

stonezone wrote:would this power supply be adequate for the 1420i:
http://cgi.ebay.com/ws/eBayISAPI.dll?Vi ... ink:top:en
No. And it's not even a power supply per se. It's a dc/dc converter. For best results get at least a 600W 24V PSU. I lucked out and found a used one for $21 shipped over 3 years ago that's still going strong. Good luck finding another deal like that. Here's a new one that will work.
http://www.ebay.com/itm/600W-24V-25A-Sw ... 0832953136
Need Advice? https://endless-sphere.com/forums/viewt ... =3&t=66302
Mongoose 26" Ledge 2.1 mtb bike $99, yescomusa.com 48V 1000W rear hub kit $200, Hua Tong 72V 40A controller $35, 10ah 24s lipo $217=~43mph, range=45 miles @ 20mph. 25K miles and still going strong.
Huffy Fortress 3.0 with MXUS 3000 4T motor, 24s lipo, 96V 60A controller. Total cost with extras <$700. Top speed ~50mph
My videos https://www.youtube.com/channel/UC0KW4U ... _G2wQhptMg

stonezone   100 W

100 W
Posts: 217
Joined: Mar 12 2014 4:25pm
Location: Oahu, Hawaii

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by stonezone » Apr 17 2014 3:06am

dc to dc, guess i misread that... thanks i should be on the right path now :)
LR-BB on 2014 Glory
Sur-Ron
B B S-HD on some sort of DH Kona frame
2017 GG GP 300 <3

RIP Bobarella

999zip999   100 GW

100 GW
Posts: 9738
Joined: Jan 10 2010 1:40pm
Location: Dana Point So. Cal

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by 999zip999 » Apr 17 2014 12:21pm

ratking I had that happen and I just unplugged the sense wires from the unit and replugged good luck. As the 1420 is over sensitve and acts funky often.

User avatar
drutledge   10 W

10 W
Posts: 80
Joined: Mar 28 2011 11:06am
Location: Washington, DC

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by drutledge » Apr 18 2014 11:56am

Ratking wrote:I just got a surprise when trying to start my charger a couple of weeks ago. I got no response, dead and no smell or other signs of damage.
Do the chargers have a history of dying silently, and which component is often the problem?
In my experience: Yes. I just had my third 1420i die on me. All three died with no smoke, no warning, just dead one day. They replaced the first two but this time I'm just not even sure if I want to bother with it. 9-12 months then dead. My charger just sits mounted on a wall, never moved, dropped or even bumped. It has great ventilation. This last death was during the winter when it's not even hardly used.

FWIW, I've been using a Thunder 1220 this spring, so far so good but I've had to reduce my A123 20Ah battery down to 12 cells.

stonezone   100 W

100 W
Posts: 217
Joined: Mar 12 2014 4:25pm
Location: Oahu, Hawaii

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by stonezone » Apr 18 2014 1:56pm

would one of these work as a PS for the 1420? They're available pretty cheap especially if you can get free shipping...

http://www.ebay.com/itm/Cisco-Catalyst- ... 4ac87fef2d
http://www.cisco.com/c/en/us/td/docs/sw ... #wp1026397
Power supply output

•100/120 VAC operation
–15.5 A @ +3.3 VDC
–5 A @ +5 VDC
–10 A @ +12 VDC
–27.5 A @ +42 VDC
LR-BB on 2014 Glory
Sur-Ron
B B S-HD on some sort of DH Kona frame
2017 GG GP 300 <3

RIP Bobarella

User avatar
wesnewell   100 GW

100 GW
Posts: 7170
Joined: Jan 31 2011 6:25pm
Location: Wylie, TX, USA

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by wesnewell » Apr 18 2014 3:57pm

it would work, but you'd be limited to ~100W using the 12v 10A rail. To make full usage of the 1420i you need a 24V 600W supply minimum. If you've got a couple of old computer PSU's you can wire the 12V in series for 24V. There's instructions for this one the web.
https://sites.google.com/site/tjinguyte ... vert-pc-ps
https://sites.google.com/site/tjinguyte ... iy-24v-47a
Need Advice? https://endless-sphere.com/forums/viewt ... =3&t=66302
Mongoose 26" Ledge 2.1 mtb bike $99, yescomusa.com 48V 1000W rear hub kit $200, Hua Tong 72V 40A controller $35, 10ah 24s lipo $217=~43mph, range=45 miles @ 20mph. 25K miles and still going strong.
Huffy Fortress 3.0 with MXUS 3000 4T motor, 24s lipo, 96V 60A controller. Total cost with extras <$700. Top speed ~50mph
My videos https://www.youtube.com/channel/UC0KW4U ... _G2wQhptMg

mvly   10 kW

10 kW
Posts: 915
Joined: May 25 2011 11:50am

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by mvly » Apr 21 2014 12:46pm

Seems like there is no more Hyperion EOS 1420i chargers. Amazon use to have them for cheap and a few other places. Now they seem to be out of stock at reliable places. Luckily I bought myself a few extras. : )

Guess it's time to move on to the Thunderpower 1430C! 1000W and 14s capable. 28s for those how parallel when charging.

upek   10 W

10 W
Posts: 78
Joined: May 22 2013 6:00pm
Location: Poland, dolnoslaskie

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by upek » Apr 21 2014 4:01pm

But Thunderpower 1430C is only capable of 588W when charging 12-14s Li-po pack. Hyperion can put out about 450W but it was almost two times cheaper.

999zip999   100 GW

100 GW
Posts: 9738
Joined: Jan 10 2010 1:40pm
Location: Dana Point So. Cal

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by 999zip999 » Apr 21 2014 4:36pm

Lot's of sites are not going to reorder the 1420 ? Could be a sign ?

dnmun   100 GW

100 GW
Posts: 16190
Joined: Jun 09 2008 1:32pm
Location: portland, or and loveland, co

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by dnmun » Apr 21 2014 5:48pm

do you guys with the dead 1420s wanna try to figure out how the died and see if there a simple and common fix for them?

it would help to just have pictures inside and info about the type of power supply you used and how you powered up and how it died.

if it is just bad mosfets on the switch mode side then they could be replaced and the 1420 would work again. if it is the voltage regulator or other simple part then it might be easy enuff to find replacements on ebay.

kiwifiat   100 W

100 W
Posts: 229
Joined: Mar 16 2013 5:49pm
Location: Vancouver, Canada

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by kiwifiat » Apr 24 2014 2:28am

999zip999 wrote:Lot's of sites are not going to reorder the 1420 ? Could be a sign ?
I received this from Hyperion today:

"Thank you very much for the inquiry!

We are so sorry to inform you that EOS 1420i charger has been discontinued for some time now.

Please check Empire Hobbies’ website in the next few months again, see if you can find some new chargers that is suitable for you.

Thanks again for your interest in Hyperion chargers.

Best regards,

Kaori Lam
Hyperion HK Ltd., Sales"

So no more genuine 1420i's aside from the odd retailer with old stock.
“You never know if quotes on the internet are genuine.” - Abraham Lincoln

User avatar
Ratking   1 kW

1 kW
Posts: 499
Joined: May 20 2010 5:27am
Location: Norway

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by Ratking » Apr 24 2014 5:49am

dnmun wrote:do you guys with the dead 1420s wanna try to figure out how the died and see if there a simple and common fix for them?

it would help to just have pictures inside and info about the type of power supply you used and how you powered up and how it died.

if it is just bad mosfets on the switch mode side then they could be replaced and the 1420 would work again. if it is the voltage regulator or other simple part then it might be easy enuff to find replacements on ebay.

I would really like to know how mine died, but I have a friend looking at it. If he finds out what the problems is, I will tell you guys in this tread :)

dnmun   100 GW

100 GW
Posts: 16190
Joined: Jun 09 2008 1:32pm
Location: portland, or and loveland, co

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by dnmun » Apr 24 2014 9:09am

if you can get him to take pictures inside we can walk him through how to examine it.

User avatar
bee   100 W

100 W
Posts: 228
Joined: Aug 07 2012 11:22am
Location: Waterloo, Ontario

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by bee » May 01 2014 3:21pm

kiwifiat wrote:
999zip999 wrote:Lot's of sites are not going to reorder the 1420 ? Could be a sign ?
I received this from Hyperion today:

"Thank you very much for the inquiry!

We are so sorry to inform you that EOS 1420i charger has been discontinued for some time now.

Please check Empire Hobbies’ website in the next few months again, see if you can find some new chargers that is suitable for you.

Thanks again for your interest in Hyperion chargers.

Best regards,

Kaori Lam
Hyperion HK Ltd., Sales"

So no more genuine 1420i's aside from the odd retailer with old stock.
rcflightstore in BC still has 3 in stock:

http://rcflightstore.com/product_info.p ... ts_id=3669

I just got a 2nd one from them recently, great shop.
Chalo wrote:Hydraulic [suspension] is just vanity and moto-fetishism at anything in the range of attainable bicycle speeds.
2002 Devinci Magma - 117v GNG

kiwifiat   100 W

100 W
Posts: 229
Joined: Mar 16 2013 5:49pm
Location: Vancouver, Canada

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by kiwifiat » May 07 2014 1:24am

bee wrote: rcflightstore in BC still has 3 in stock:

http://rcflightstore.com/product_info.p ... ts_id=3669

I just got a 2nd one from them recently, great shop.
Thanks for the link bee, I waited months trying to source one from Empire Hobbies who are the North American agents for Hyperion and ended up getting one from GoNitro in New York. Looks like I could have driven into Delta and picked one up all along! :oops:
“You never know if quotes on the internet are genuine.” - Abraham Lincoln

speedpower99   10 mW

10 mW
Posts: 29
Joined: May 05 2014 8:29pm
Location: Vancouver Canada

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by speedpower99 » May 08 2014 1:22am

kiwifiat wrote:
bee wrote: rcflightstore in BC still has 3 in stock:

http://rcflightstore.com/product_info.p ... ts_id=3669

I just got a 2nd one from them recently, great shop.
Thanks for the link bee, I waited months trying to source one from Empire Hobbies who are the North American agents for Hyperion and ended up getting one from GoNitro in New York. Looks like I could have driven into Delta and picked one up all along! :oops:
No. They don't provide pick up service.
Flat rate shipping for Canadian is only $6.50 (actually cost them $8.46 to ship to me)

Better hurry up for those still want to buy. After I bought one and they jack up the price to $145 now :shock: (139.99 before)

maca55   10 mW

10 mW
Posts: 21
Joined: May 01 2013 6:54am
Location: Chadstone, Australia

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by maca55 » May 12 2014 6:43am

dnmun wrote:do you guys with the dead 1420s wanna try to figure out how the died and see if there a simple and common fix for them?
Yes!! I think with the number of these that seem to be failing that it would be an excellent idea to make this thread a resource on how to repair what really is an excellent charger when they are working!
dnmun wrote: if it is just bad mosfets on the switch mode side then they could be replaced and the 1420 would work again. if it is the voltage regulator or other simple part then it might be easy enuff to find replacements on ebay.
I have three 1420s. The first has blown what looks like multiple FETs and no longer works. The second still works only when the output voltage exceeds the input voltage eg) 4S or more when using a 12v supply, or 8s or more when using a 24v supply. The third one is still working fine apart from it no longer being detected by the eos data suite.

Since these are no longer sold, the warranty I was offered was credit to spend on another Hyperion charger. Even with 2 of the 730 models it will be a hassle to charge my 6+6 12s lipo pack but even more of a pain to charge my 4+4+4 12s pack. I'm starting to think that repairing might be a better option than the warranty in this case?

I have pulled apart Charger 1 and have already found what appear to be two cooked FETs. So I guess replace them and see if it works, or should I be checking all of the FETs and making sure gate resistors are OK first?

Here are some pics for everyone's enjoyment.
rps20140512_213405.jpg
The eight FETS under the heatsink
rps20140512_213405.jpg (175.75 KiB) Viewed 1452 times
rps20140512_213725.jpg
The cooked ones
rps20140512_213725.jpg (84.4 KiB) Viewed 1595 times

dnmun   100 GW

100 GW
Posts: 16190
Joined: Jun 09 2008 1:32pm
Location: portland, or and loveland, co

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by dnmun » May 12 2014 9:14am

you can use the diode tester in your voltmeter to test the other mosfets and the schottky diodes there. do u know which mosfet is the irfb49..

maca55   10 mW

10 mW
Posts: 21
Joined: May 01 2013 6:54am
Location: Chadstone, Australia

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by maca55 » May 13 2014 8:02am

dnmun wrote:you can use the diode tester in your voltmeter to test the other mosfets and the schottky diodes there. do u know which mosfet is the irfb49..
I'll remove them all from the board to test them and report back. I believe the broken MOSFET is a IRF 4905.

Post Reply