Broken EMC-1000 charger

Get all your technical information about electric bikes here.
Post Reply
samush
1 mW
1 mW
Posts: 11
Joined: Dec 23, 2014 4:56 am
Location: Victoria, BC

Broken EMC-1000 charger

Post by samush » May 19, 2017 10:47 pm

The charger that I'm using broke after charging my 20ah pack 17 times, and most of those were partial charges! :cry:
When I plug it in the lights don't come on. Does anyone know how you can fix these chargers?

User avatar
fechter
100 GW
100 GW
Posts: 12419
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Broken EMC-1000 charger

Post by fechter » May 19, 2017 11:49 pm

If no lights, noise or sign of life, you need to open it and see if there is a blown fuse or other obvious sign of smoke release.

If it's new, it may still be under warranty.
"One test is worth a thousand opinions"

samush
1 mW
1 mW
Posts: 11
Joined: Dec 23, 2014 4:56 am
Location: Victoria, BC

Re: Broken EMC-1000 charger

Post by samush » May 21, 2017 7:10 pm

I took it apart and it looks okay, I cant find any fuses or anything burnt. I bought it 2 years ago and only started using it this year.

User avatar
fechter
100 GW
100 GW
Posts: 12419
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Broken EMC-1000 charger

Post by fechter » May 23, 2017 8:57 am

Can you post a picture of the board? I'm not familiar with that model, but from a picture I might be able to pick out parts to check.
"One test is worth a thousand opinions"

samush
1 mW
1 mW
Posts: 11
Joined: Dec 23, 2014 4:56 am
Location: Victoria, BC

Re: Broken EMC-1000 charger

Post by samush » May 23, 2017 10:16 pm

Too bad it's all glued down
Attachments
DSC_0039-min.JPG
DSC_0041-min.JPG

User avatar
fechter
100 GW
100 GW
Posts: 12419
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Broken EMC-1000 charger

Post by fechter » May 24, 2017 2:41 pm

Charger board 1.jpg
Charger board 1.jpg (85.61 KiB) Viewed 425 times
The item circled in red is likely to be the "fuse". These are power resistors with an integrated thermal fuse that will blow if it gets too hot.
Look at the markings on the part and try measuring the resistance of it.
"One test is worth a thousand opinions"

samush
1 mW
1 mW
Posts: 11
Joined: Dec 23, 2014 4:56 am
Location: Victoria, BC

Re: Broken EMC-1000 charger

Post by samush » May 25, 2017 4:20 pm

I found a broken fuse! I'm going to give this a try first
Attachments
DSC_0044-min.JPG

User avatar
fechter
100 GW
100 GW
Posts: 12419
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Broken EMC-1000 charger

Post by fechter » May 26, 2017 8:22 am

OK, glad you found the fuse. If the new fuse blow immediately, you have a bigger problem.
"One test is worth a thousand opinions"

Moto996
1 µW
1 µW
Posts: 1
Joined: Feb 05, 2018 5:06 am

Re: Broken EMC-1000 charger

Post by Moto996 » Feb 05, 2018 5:31 am

Hi Guys

Just found this forum as im looking for ways to fix my EMC-1000 charger.
I've had this unit for years charging my 72v road going scooter.

in any case, my charger stopper working all of a sudden. I have checked the fuse and it works just fine, i have also checked the input cable to make sure there is input voltage and that checks out as well.

so i saw this post about the power resistor and i was wondering if that could be my issue. so i was wondering if anyone has has experience with this repair since the board is all glued in place??

User avatar
fechter
100 GW
100 GW
Posts: 12419
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: Broken EMC-1000 charger

Post by fechter » Feb 05, 2018 4:27 pm

Since the OP found a real fuse, the resistor thing might just be a resistor. You could try to see if there are any markings on it. If the board is all glued down with potting, it may be difficult to replace.

Does the charger light up at all?
"One test is worth a thousand opinions"

Post Reply