Programming APT AE96600 controller

Get all your technical information about electric bikes here.
SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 16 2019 10:47am

But the first two parameters are not adjustable and are set by default.

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 16 2019 12:07pm

larsb wrote:
May 15 2019 2:59pm
Increase them or the time limit for protection above. If you have iac set at max 200A and the motor can take 100A for max 5 minutes then heavy load time would be 300 seconds and heavy load Iac 50%

Same logic for motor lock protection but with lower values.
Here is on this a time we are discussing controller there there is my figure with investment, not can whether we try to communicate on this a time?
https://electrotransport.ru/ussr/index. ... c=57126.18

larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 16 2019 12:40pm

Just try to set both motor lock and heavy load at 99%. If it works then you can find the best setting afterwards.

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 16 2019 2:23pm

larsb, what do You have with the weakening of the field did well? Or there are difficulties?

larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 16 2019 2:28pm

I never got field weakening to work on my controller, i thought about trying another version of the program later on.

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 16 2019 2:31pm

Tomorrow I'm working, so I'll check the controller settings only in one day, then I'll write. It is a pity that I can not add photos and videos to the forum.

larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 16 2019 3:25pm

Did you read this:
https://endless-sphere.com/forums/viewt ... =1&t=14748

Could be your file is larger than 512kb.

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 3:10am

https://electrotransport.ru/ussr/images ... thumb.jpeg
Here is a link to the picture of my mistake.Now

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 3:23am

https://electrotransport.ru/ussr/images/4/vqjcca.jpeg
parameters circled in green, are by default, and which are circled in red I tried to adjust, but the problem was not solved

larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 18 2019 5:40am

This will be difficult/impossible without more info. Can you post a pic on your battery and cables to controller?
What is your phase current setting?
What is your battery current setting?
Please also give a link to the motor you have.

Does motor get hot quickly when you're driving?

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 6:40am

The motor is almost cold. The controller shows the temperature 38-42.
If I'm using links to send images you'll see them?

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 7:02am

The battery voltage is 108 volts. Battery assembled from the elements of NMC with a capacity of 60 ampere hours. 26S. The engine Yuma Electric 17, 500 TT, when sold in China was positioned as 5000 watts for a long time.

larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 18 2019 7:11am

Ok, only some answers so i'd repeat:
Can you post a pic on your battery and cables to controller?
What is your phase current setting?
What is your battery current setting?

Is your motor similar to this? http://en.wxymmotor.com/ProductInfoA.aspx?Id=22
Capture.JPG
Capture.JPG (99.47 KiB) Viewed 78 times
Have you tried both hall sensor sets (if you have two..) Is the problem the same for both?
I see the pictures throught the links.

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 8:27am

колесо другое, ширина покрышки 200 мм. соответственно обод и внутренности другие.

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 9:38am

Controller Over iac error: means: The controller is over current.
But that's the problem and how to treat? What overload can occur, and most importantly from what?

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 11:49am

Вот мои текущие настройки :D
Attachments
basic setting-.jpg
Control-.jpg
Derate setting-.jpg
FluxWeaken Referans-.jpg
Idc calibration-.jpg
Mode set-.jpg
Motor parameter-.jpg
Other-.jpg
Protection-.jpg
Reference-.jpg
Torque PID.jpg

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 11:50am

I currently have these settings installed

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 18 2019 11:58am

Well, this is a mistake
Attachments
InkedОбрезка гл страницы — копия_LI.jpg

larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 18 2019 4:04pm

SergeyNikulochkin wrote:
May 18 2019 9:38am
Controller Over iac error: means: The controller is over current.
But that's the problem and how to treat? What overload can occur, and most importantly from what?
It means (normally) that the actual current value has increased above the protection value (the controller has lost control)
This triggers a protection fault and everything is shut down.

When does it happen? at rapid throttle/ full throttle or just randomly?

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 19 2019 1:40am

I go about 5-10 minutes normally, then there is a shutdown. And the shutdown begins to occur frequently and chaotically. And also at different throttle positions. And at different speed modes. Eco-D, Boost. The controller is warm, and I thought it was overheating, but the computer shows a maximum of 44 degrees of controller temperature.


larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 19 2019 7:44am

Did it work 100% OK before and now you're starting to get issues?

or has it never worked correctly?

Did you try both hall sensor sets? (Could be that there is bad connection after wear and tear)

Also check all connector for battery and motor phases, if there is intermittent broken connection then this can cause overcurrent spikes

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 19 2019 7:47am

It never worked right. The phase wires are screwed tight, I checked. I haven't tried the hall sensors. Need to disassemble the bike

larsb   10 kW

10 kW
Posts: 902
Joined: Dec 10 2014 5:12am
Location: Gothenburg, Sweden

Re: Programming APT AE96600 controller

Post by larsb » May 19 2019 12:32pm

I mean that motor seems to have two hall sensor sets. You could try them both and see if error is the same.

Did you do a hall mapping in the program?
Was it OK or did you have issues?

I think you could try to set hall shift at 60degrees (not -60). Please be careful, lower current to something like 30A before you do this (I've read that FETs can blow if phase angle is totally wrong) and try how it runs with wheel in the air.

Good luck.

SergeyNikulochkin   10 mW

10 mW
Posts: 30
Joined: May 06 2019 4:35am

Re: Programming APT AE96600 controller

Post by SergeyNikulochkin » May 19 2019 1:28pm

I tried to set the settings for the QS engine, it seemed to me that the work became smoother, but the controller is still off.

Post Reply