Page 1 of 1

What are your AGain and WGain settings?

Posted: Sep 22 2022 10:20am
by E-HP
For folks that have a Cycle Analyst V3.2, I'd like to see what your AGain, WGain, and PLim settings are, including those setting and what the controller rating is and motor used.

It's surprising how little information there is regarding these settings, even on the main CA thread. The parameters have a huge effect on how the bike performs/accelerates and a huge negative effect if not set correctly. After recently swapping out my controller, I decided to adjust my settings by starting at the default values and moving from there. The default made my bike like a bucking bronco, jerking and hopping the front tire up and down; pretty terrifying. I spent about a half hour and got things to settle down and run somewhat smoothly. There's still a little surging in certain circumstances, but all in all, it feels like I tapped into some additional power that I wasn't taking advantage of. I had to drop my throttle ramp rate down even further because of it. Still needs tweaking, but at least it's rideable.

Anyway, hoping folks can share their settings and controller and motor info, and that may be of use to others that have a similar setup. It's one of those things that it hard to determine a good starting point for, and the documentation, to the layman, is a bit vague. Thanks ahead of time for anyone willing to contribute. I'm going to spend a little more time tuning mine and will post the settings that seem to work best.

Re: What are your AGain and WGain settings?

Posted: Sep 22 2022 11:16pm
by amberwolf
I don't think I messed with mine much (long time since I tuned it), but here is my settings file from the last time I backed up the SB Cruiser's CA about three years (and a few thousand miles) ago: The Again is 5
and so is Wgain
PLim is the max it would accept, 60000, since I don't use any power limiting.
All ramp rates are effectively no ramping, set to fastest possible ramp rate for as close to instant response as possible.

System is, with some "rough numbers" that I don't recall the exact specifics for:
14s2p EIG NMC C020 20Ah cells, for 52v 40Ah
Right rear wheel is generic "30A" controller driving Ultramotor (presently one off an A2B Metro, previously one off a Stromer), in a 20" wheel (effectively really about 22-23" with the tire).
Left rear wheel is Grinfineon "30A" controller driving MXUS 450x (3 or 4, can't recall which as I have used both) in same wheel/tire.

I see around 80A total during the few seconds of accleration from a stop to 20MPH, don't know which controller has how much share of that at any moment.

(Motors and controllers are different because that's what I happen to have, until someday I get back to my Lebowski/Honda-IMA project to put those on each one and work out a pair of matched motors one way or another.)

Throttle for both comes from CA.

CA uses cadence sensor only out of a TDCM BB to control throttle amount sent to the controllers (because until the most recent FW version the torque control didnt' work the way I need it to so cadence-only worked "better", at some point I'll mess with trying out the new FW's torque stuff).

There's also a throttle (cable-operated hall type via ATV thumb throttle) for when I can't start from pedalling or times I just can't pedal due to pain, injury, mechanical or system failure, etc.

Then there's a second COT via left ebrake lever that controls variable regen on the Grinfineon via the CA by a relay setup that switches between throttles for this purpose during braking. (mechanical brake is not connected to that lever, only ebrake/regen).