Greentime runs, but backward!

Get all your technical information about electric bikes here.
Post Reply
OCD   100 W

100 W
Posts: 143
Joined: Jan 09 2011 12:25pm
Location: Nanaimo BC Canada

Greentime runs, but backward!

Post by OCD » Mar 23 2014 8:37pm

I bought a Greentime controller which seems to come with no after sales support... at all. Does anyone know the connections shown in the picture? The controller has regen braking and a 3 speed switch. There are only two connectors with three wires, I assume one's the throttle and the second one seems to have the same colours as the supplied switch, although 2 of the wires are interchanged in the plug.

Thanks for any help you can provide

Image
Last edited by OCD on Apr 04 2014 11:39pm, edited 1 time in total.

Skedgy Sky   100 W

100 W
Posts: 237
Joined: Nov 18 2012 12:40am
Location: New Britain, CT, USA

Re: Greentime connection help?

Post by Skedgy Sky » Mar 23 2014 10:05pm

Well it looks like you have the throttle figured out.
I'll assume blue/black/orange one is the 3 speed switch.

I suggest opening the controller up and seeing where the wires go to. If you need help from there, post some more pictures up and I think we can help.

User avatar
Samd   1.21 GW

1.21 GW
Posts: 3750
Joined: Jun 28 2011 11:08pm
Location: Ballarat, AU
Contact:

Re: Greentime connection help?

Post by Samd » Mar 23 2014 11:36pm

Did it come with a printed page? I just got a 72v one from them with some info, will check it tonight at home...
http://ballaratebikes.com/

ImageImageImage
"Knowledge is knowing that a tomato is a fruit. Wisdom is knowing that a 165mm rear shock can't deliver 220mm of rear swingarm travel." - Oprah Winfrey.

User avatar
newb   100 W

100 W
Posts: 263
Joined: May 31 2010 6:05am
Location: SoCal

Re: Greentime connection help?

Post by newb » Mar 23 2014 11:53pm

I got this from them with the last controller I bought, maybe it will help.

OCD   100 W

100 W
Posts: 143
Joined: Jan 09 2011 12:25pm
Location: Nanaimo BC Canada

Re: Greentime connection help?

Post by OCD » Mar 24 2014 8:39am

Thanks for the help. I have the 72 volt 1500 watt version with 3 speed switch. Not only did it not come with a diagram, I have had no luck getting any reply from Leo via email. The 3 speed switch they supplied I plugged into the throttle connection as it has the same wire colours but now appears wrong and must go to the other 3 wire connector.

User avatar
Samd   1.21 GW

1.21 GW
Posts: 3750
Joined: Jun 28 2011 11:08pm
Location: Ballarat, AU
Contact:

Re: Greentime connection help?

Post by Samd » Mar 25 2014 10:16pm

Hopefully this helps. I recently got a 72V 45A one, so hopefully similar.

I actually got a follow up email from him to make sure all was ok. Sorry you didnt!

Hopefully I can work out how to wire regen on this one!
20140324_211930.jpg
20140324_211935.jpg
20140324_211938.jpg
http://ballaratebikes.com/

ImageImageImage
"Knowledge is knowing that a tomato is a fruit. Wisdom is knowing that a 165mm rear shock can't deliver 220mm of rear swingarm travel." - Oprah Winfrey.

OCD   100 W

100 W
Posts: 143
Joined: Jan 09 2011 12:25pm
Location: Nanaimo BC Canada

Re: Greentime connection help?

Post by OCD » Apr 04 2014 8:45pm

Thanks for the info and pics. I've got it working now, except it goes in reverse. The info states brown and black as the forward/reverse wires and recommends a switch. The connections are labeled gnd and zf. What do they connect to? If I short them together it goes the correct direction but has little speed/power compared to reverse.

Thanks

User avatar
wesnewell   100 GW

100 GW
Posts: 7171
Joined: Jan 31 2011 6:25pm
Location: Wylie, TX, USA

Re: Greentime runs, but backward!

Post by wesnewell » Apr 05 2014 12:39am

read step 2 above.
Need Advice? https://endless-sphere.com/forums/viewt ... =3&t=66302
Mongoose 26" Ledge 2.1 mtb bike $99, yescomusa.com 48V 1000W rear hub kit $200, Hua Tong 72V 40A controller $35, 10ah 24s lipo $217=~43mph, range=45 miles @ 20mph. 25K miles and still going strong.
Huffy Fortress 3.0 with MXUS 3000 4T motor, 24s lipo, 96V 60A controller. Total cost with extras <$700. Top speed ~50mph
My videos https://www.youtube.com/channel/UC0KW4U ... _G2wQhptMg

OCD   100 W

100 W
Posts: 143
Joined: Jan 09 2011 12:25pm
Location: Nanaimo BC Canada

Re: Greentime runs, but backward!

Post by OCD » Apr 05 2014 8:08am

Thanks, I tried step 2 and the motor did nothing at all, switch it back and it runs backward. I tried this 2 or three times with the same result, either no rotation or backwards. I have added Anderson connectors to the phase lines so I assume there is a good connection when I switch the wires.

User avatar
Ykick   100 GW

100 GW
Posts: 5558
Joined: Nov 26 2009 6:10pm
Location: San Diego, California

Re: Greentime runs, but backward!

Post by Ykick » Apr 05 2014 8:37am

Talent must not be wasted.... Those who have talent must hug it, embrace it, nurture it and share it lest it be taken away from you as fast as it was loaned to you.

- Frank Sinatra

OCD   100 W

100 W
Posts: 143
Joined: Jan 09 2011 12:25pm
Location: Nanaimo BC Canada

Re: Greentime runs, but backward no longer

Post by OCD » Apr 05 2014 9:28pm

Thanks to the assistance and support of the other forum members, the bike is now operational. Must be something wrong in the way I crimped the Anderson connectors as they wouldn't connect in the "switch any pair" position for some reason and connected fine for reverse when switched back. After work today, I pulled the Anderson's apart and connected everything without the plastic housing and away it went in the correct direction. Had a couple of trips around the block to be sure, but have numerous other details to attend to before putting the bike into regular service.

Alan

Post Reply