Adaptto Mini-E/Max-E Owner's Thread

Get all your technical information about electric bikes here.
Buk___   10 kW

10 kW
Posts: 750
Joined: Jul 28 2017 5:59pm

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Buk___ » Dec 02 2017 8:10am

nio88 wrote:
Dec 02 2017 7:44am
my problem is, my battery pack is a welded pack :(, it´s not easy remove that group and charge it, and not sure how I can insolate that group and charge it without disassesemble part of the battery...

If some cells are wrong in that group it´s going to be a pain in the ass :?
I had a similar problem, but found out that if you connect via (or at the attachment points for) the balance leads, you can test and charge each group in isolation. Be sure to respect the polarity when charging.

litespeed   100 kW

100 kW
Posts: 1273
Joined: Aug 11 2010 4:42pm
Location: St. Peters, Missouri

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by litespeed » Dec 02 2017 9:51am

What Buk___ said is exactly right. You can charge or discharge a "P" row and cycle to find out what's going on. You have to pull the connections to find out which cell is bad in the "P" row though.

Good luck.

Tom
I'm married so you know I'm no stranger to pain!

nio88   10 mW

10 mW
Posts: 31
Joined: Sep 15 2014 4:00pm

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by nio88 » Dec 02 2017 3:43pm

Ok, I´m going to try it :)
just to confirm, so basically connecting a rc charger to 1s, on negative (13) positive (14) (that should be the correct polarity, isn´t it?) until that group is at same level, is that correct?

Thank you so much for the tips guys...
Attachments
Capture.PNG
Capture.PNG (39.63 KiB) Viewed 1943 times

User avatar
Merlin   100 kW

100 kW
Posts: 1474
Joined: Jan 29 2013 10:00am
Location: europe

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Merlin » Dec 03 2017 10:10pm

be honest dude....who build this battery :D

ask the dude to help you charging this "P".

if this was really your work, get your multimeter and measure the voltage.
0,1v difference are "visible" on your multimeter :P

if you found the 0,1 difference you have the right "-" and "+" where you connect your RC charger.
if you charging: disconnect all other wires. from the Battery. ALL(!)

just plug in the two tiny bms wires and charge with very low current.

but i think theres something wrong. a bad cell or a bad(not) contact on one cell.
because if you only have 1-2 discharges and it differs so much its simple less capacity on this "P"

csc   100 W

100 W
Posts: 146
Joined: Dec 13 2016 7:40am

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by csc » Dec 04 2017 3:32pm

I found a trick to push the slave speed limit in 2wd mode ! More details here https://endless-sphere.com/forums/viewt ... 8#p1338398

nio88   10 mW

10 mW
Posts: 31
Joined: Sep 15 2014 4:00pm

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by nio88 » Dec 04 2017 4:44pm

Merlin wrote:
Dec 03 2017 10:10pm
be honest dude....who build this battery :D

ask the dude to help you charging this "P".

if this was really your work, get your multimeter and measure the voltage.
0,1v difference are "visible" on your multimeter :P

if you found the 0,1 difference you have the right "-" and "+" where you connect your RC charger.
if you charging: disconnect all other wires. from the Battery. ALL(!)

just plug in the two tiny bms wires and charge with very low current.

but i think theres something wrong. a bad cell or a bad(not) contact on one cell.
because if you only have 1-2 discharges and it differs so much its simple less capacity on this "P"
haha Merlin, just i know it was a noob question, I already leveled that group thanks for your first explanation through the balance cable, and of course for the second one :p, but I only wanted to confirm the theory hahah, a double check is always welcome :), and yes, the multimeter did the trick :)

Now we will see how fast the group goes down (I hope they don´t), and if they go down very fast, I will check all the connections in that group.

Thanks again Merlin.

User avatar
Merlin   100 kW

100 kW
Posts: 1474
Joined: Jan 29 2013 10:00am
Location: europe

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Merlin » Dec 04 2017 6:30pm

if you want to thank "us"....come back IF things come worse + if things goes well.
the best thank you is always report back whatever happend...this helps other guys if they in a same situation.

User avatar
Cricket_Swe   100 W

100 W
Posts: 155
Joined: May 22 2016 4:01am
Location: Sweden

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Cricket_Swe » Dec 11 2017 4:31am

Adaptto E-Drives Lab wrote:
Mar 04 2015 9:23am
Dear Friends,

We've received many questions recently regarding the external on/off button (or a key switch) implementation for our controller.
Firstly, for those ordering the controllers now - we can include this option upon request.
Secondly, if you already got the controller - you could always send it to us and we will install the cable for button integration at reasonable price (no more than 20 USD). Return shipping is always on us.

Thirdly, if you got the controller and are not ready to wait for the shipping period we have worked out the following simple guide on how to do it yourself.

PLEASE NOTE: use the guide ONLY if you've got enough experience in soldering because opening up the controller automatically stops the warranty coverage. Thus Adaptto E-Drive Lab Ltd. will not be liable for any problems caused by your actions starting from the controller opening.

Let's start:

1) To open up the controller - GENTLY undo the following screws Image


2) Withdraw the inner part of the controller and unscrew these studs thus releasing the processor board: Image


3) On processor board you need to concentrate on the line shown: Image

4) ACCURATELY cut the line in the middle (with the knife for example) Image
Result: Image

5) Clear the rest of the line up until the copper: Image

6) Tin-plate: Image

7) Solder the wire for the button (DON'T forget to apply the thermal setting) : Image

8 ) That's it. Now just drill out the new bore for the cable soldered. Here is the perfect place for it: Image


Hope this helps,
All the best!
Thanks! This is what I'll be doing this weekend.

User avatar
Cowardlyduck   10 MW

10 MW
Posts: 2432
Joined: Jun 26 2011 8:41pm
Location: Canberra, ACT, Australia

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Cowardlyduck » Dec 18 2017 5:24am

Finally cracked open my screen over the weekend to fix the USB cable and update the firmware to unlocked.
Glad to say I succeeded in both, and am now enjoying 6.5KW in Boost mode with 90A @72V.
Image

I will be switching to a 14S, ~54V 18650 pack in the new year and might up the amps to 100 when I do in order to keep things in the 5.4KW range, but don't want to go too high as it was at around 120A (7.8KW) I blew my last Mini-E from memory.

Cheers
High Power LiPo wiring harnesses - 4P - XT90, HXT4mm, 5.5mm. 200Amp+ capable. Global shipping.

Modified Stealth Fighter - Force air cooled motor @ 6KW, Heat-sinked Adaptto Mini-E. 49AH, 52V 18650 - 2.5Kwhr
Cowardlyducks - Stealth Fighter Videos

BikeE recumbent commuter - 9C, 6Fet Grinfineon, internal 17AH, 52V, + on-board solar.

The stuff I make and modify.

csc   100 W

100 W
Posts: 146
Joined: Dec 13 2016 7:40am

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by csc » Dec 22 2017 4:26am

Hi there

I received Cowardlyducks' blown mini (very enthusiastic level of meltdown, congrats !) for parts, and begin a reparation session of all the blown minis that I have myself.

Concerning one of them I don't understand how to repair.

It won't switch the screen on, seems like there's no 12v. Does anybody know where the 12v circuit is and what the buck converter looks like ?

Thanks in advance !

User avatar
ridethelightning   1 MW

1 MW
Posts: 1778
Joined: Jul 21 2013 9:48pm

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by ridethelightning » Jan 14 2018 3:03am

nio88 wrote:
Dec 02 2017 3:43pm
Ok, I´m going to try it :)
just to confirm, so basically connecting a rc charger to 1s, on negative (13) positive (14) (that should be the correct polarity, isn´t it?) until that group is at same level, is that correct?

Thank you so much for the tips guys...
a cell group that seems to drop out is not always a due to a bad cell, when using adaptto bms.

i have had similar problems, and naturally thought the worst, but after changing the max cell charge V/balance regime, it sorted itself out(surprisingly)

after a discharge, try to set max cell V to 3.89 volts and ballance to 3.88v. for example, and slow charge at 3 Amps or something.
somehow, it seems the high cells can get "out of range" of the balancing function. maybe its just a adaptto glitch, wouldnt surprise me.

the lg pack i had issue with was showing similar behaviour to yours, but when i changed the settings it stayed ballanced for ~1year afterwards from memory.

another thing it might be worth checking the real group voltages with a good meter and calibrating the bms voltages accordingly.

csc   100 W

100 W
Posts: 146
Joined: Dec 13 2016 7:40am

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by csc » Jan 18 2018 4:00am

Ladies and gentlemen, UP !

Would anybody know how the 12v circuit in the controller, feeding the screen, looks like ?

User avatar
Cowardlyduck   10 MW

10 MW
Posts: 2432
Joined: Jun 26 2011 8:41pm
Location: Canberra, ACT, Australia

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Cowardlyduck » Jan 20 2018 12:28am

Getting my Midi-E ready to roll with my Alpha build. Heat-sinks allround + thermal padding to the frame, just like the Mini-E on my Fighter. :mrgreen:

Image
Image
Image

Still gotta drill the holes in my frame to mount it....that's the part I hate. :|

Cheers
High Power LiPo wiring harnesses - 4P - XT90, HXT4mm, 5.5mm. 200Amp+ capable. Global shipping.

Modified Stealth Fighter - Force air cooled motor @ 6KW, Heat-sinked Adaptto Mini-E. 49AH, 52V 18650 - 2.5Kwhr
Cowardlyducks - Stealth Fighter Videos

BikeE recumbent commuter - 9C, 6Fet Grinfineon, internal 17AH, 52V, + on-board solar.

The stuff I make and modify.

User avatar
Willow   10 kW

10 kW
Posts: 800
Joined: Sep 06 2011 7:42pm
Location: Tasmania

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Willow » Jan 20 2018 8:25pm

csc wrote:
Jan 18 2018 4:00am
Ladies and gentlemen, UP !

Would anybody know how the 12v circuit in the controller, feeding the screen, looks like ?
5V not 12V.... the 5V is the red wire going to the screen.

csc   100 W

100 W
Posts: 146
Joined: Dec 13 2016 7:40am

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by csc » Jan 22 2018 12:55pm

Thanks Willow

Any explanation for the circuit not working ? Is there a specific resistor -or a buck converter or whatever - to check ?

I found this in the previous pages (https://endless-sphere.com/forums/viewt ... 13#p948501) :

Image
Image
Image

If somebody can complete...

nio88   10 mW

10 mW
Posts: 31
Joined: Sep 15 2014 4:00pm

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by nio88 » Jan 28 2018 7:02am

Merlin wrote:
Dec 04 2017 6:30pm
if you want to thank "us"....come back IF things come worse + if things goes well.
the best thank you is always report back whatever happend...this helps other guys if they in a same situation.
I can confirm I´ve an issue in a cell on that group (it is always 0.15v below the rest) , so at some moment I would have to disassembly that group and change that cell :?

User avatar
Merlin   100 kW

100 kW
Posts: 1474
Joined: Jan 29 2013 10:00am
Location: europe

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Merlin » Jan 28 2018 7:28am

Good luck... Did that yesterday also... One cell 1.65v only... God... That sux so hard ;(
What should someone pay for this work?
Not sure if I offer repairing batteries in the future....

litespeed   100 kW

100 kW
Posts: 1273
Joined: Aug 11 2010 4:42pm
Location: St. Peters, Missouri

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by litespeed » Jan 28 2018 10:39am

Repairing a bad cell in a glue pack is worse than sticking your hand in a garabage disposal. Sucks big time. I've done it a few times and it never gets easier. My next pack I will only glue the p's together and the whole thing will be held together with tape and shrink wrap just in case!

Tom
I'm married so you know I'm no stranger to pain!

nio88   10 mW

10 mW
Posts: 31
Joined: Sep 15 2014 4:00pm

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by nio88 » Jan 28 2018 2:20pm

the problem is where the wrong cell is... if it´s in the top is a pain in the ass, since you have to remove all group, and then it´s better change all the cells in that group, since when you remove the strips, at least for my experience (this was my first pack), it´s not a flat surface, and the next time you try to weld those cells if you don´t get a good flat contact, you´ll get nice hole around the strip hahaha.

I will do it someday, when I see it´s going worst, for now I´m leveling that group manually, before charging the full pack.

User avatar
Willow   10 kW

10 kW
Posts: 800
Joined: Sep 06 2011 7:42pm
Location: Tasmania

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Willow » Jan 28 2018 11:22pm

The biggest problem comes after the cells are replaced. If you are replacing a cell thats been used 100 times with one thats brand new, they are going to behave differently (charge and discharge), and you will struggle to (if ever) be able to balance the pack. Ideally the cells would be replaced with exactly the same type, with the same number of cycles.

nio88   10 mW

10 mW
Posts: 31
Joined: Sep 15 2014 4:00pm

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by nio88 » Jan 29 2018 3:18pm

Ok, so when I replace it, I will replace the whole group, is that better??,

User avatar
Willow   10 kW

10 kW
Posts: 800
Joined: Sep 06 2011 7:42pm
Location: Tasmania

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by Willow » Jan 30 2018 3:51am

actually better to replace less than more. But still best to match the usage cycles.

honya96   1 kW

1 kW
Posts: 328
Joined: Mar 05 2015 9:38am
Location: Czech Republic

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by honya96 » Feb 01 2018 3:08pm

csc wrote:
Jan 22 2018 12:55pm
Thanks Willow

Any explanation for the circuit not working ? Is there a specific resistor -or a buck converter or whatever - to check ?

I found this in the previous pages (https://endless-sphere.com/forums/viewt ... 13#p948501) :

Image
Image
Image

If somebody can complete...
Glad I found this, seems that I have the same problem as you, 12v to display not working. + accidentaly scraped off R32. Anyone knows value?

Have you solved that problem or found some info how to do it atleast? I have asked adaptto but its really hard to communicate with them, after few dumb answers they just cut the communication. :?
Attachments
20180201_205145-432x768.png

bowers   10 mW

10 mW
Posts: 28
Joined: Jul 02 2016 7:51am
Location: Norway

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by bowers » Feb 14 2018 7:04am

Has anyone successfully repaired an Adaptto display?

I have one that's waterdamaged (down and right key not working) and after reading others experience with sending the display to Russia for repair I want to avoid that if possible ;)

honya96   1 kW

1 kW
Posts: 328
Joined: Mar 05 2015 9:38am
Location: Czech Republic

Re: Adaptto Mini-E/Max-E Owner's Thread

Post by honya96 » Feb 15 2018 6:09am

bowers wrote:
Feb 14 2018 7:04am
Has anyone successfully repaired an Adaptto display?

I have one that's waterdamaged (down and right key not working) and after reading others experience with sending the display to Russia for repair I want to avoid that if possible ;)
I have removed the usb from display and replaced with cable to external buttons.

Just look at some videos about soldering to those small pads..

You can use something like this as buttons
http://s.aliexpress.com/nuAJnqAB?fromSns=Copy

Post Reply