Magic Pie 5 Bluetooth issues

Get all your technical information about electric bikes here.
Post Reply
andyjk
1 W
1 W
Posts: 56
Joined: Feb 19, 2016 5:09 pm
Location: Essex - UK

Magic Pie 5 Bluetooth issues

Post by andyjk » Mar 11, 2016 4:58 pm

I've searched around for an answer to this issue, just wondered if anyone had similar issues to me programming the magic pie 5 via Bluetooth using the golden motor android app.

The MP is discovered and connects fine to my phone using the Golden Motor app, I can see the motor dashboard (speed, volts, amps, etc) and it also reads the speed controller parameters fine but when I attempt to change the low voltage cutoff and save the settings to the controller it doesn't seem to write the changes because when I re-read the program data back from the controller it just fills in the old settings (42V cutoff)

I've tried lots of times including turning off controller before reading the data, I just wondered if anyone has had this issue before?

Cheers

Andy

dorbot
1 µW
1 µW
Posts: 1
Joined: Dec 10, 2016 10:15 am

Re: Magic Pie 5 Bluetooth issues

Post by dorbot » Dec 10, 2016 10:25 am

Yes its the same for me. The last confirmation "write parameters successfully" never shows up after pressing the second button from the left.
Phone is Nexus 5 running android 6.0.1 does not save parameters.
I could try another phone but I suppose Ill have to revert to the usb cable and a laptop. Bit of a pain in the arse though. Or I could flash marshmallow 6.0.0 again I suppose.


In any case it will be a few years till GM get round to writing software that actually works as intended, if ever.

djbeede
1 µW
1 µW
Posts: 3
Joined: Jan 11, 2016 10:15 am

Re: Magic Pie 5 Bluetooth issues

Post by djbeede » Jan 30, 2018 11:22 am

It sure would be nice to have a data base of what phones the GM bluetooth app works with.
I have a Moto E4 Plus running Android 7.1.1 and it can't find or connect with my Magic Pie 5 Vector or my Magic Pie Edge.
The app is version 1.6

It's a great idea, but from browsing the various forums it appears it often either doesn't work at all or is glitchy and partially functional. It played a part in my decision making, but it seems undoable now.

Now I'm looking at Cycle Analyst for about $150 plus the install time. I'd much rather clip my phone in the holder and ride, like I saw in the PR video.

I have an old iPhone but it looks like the ios version is still unavailable.
I do have a support ticket in, so if I get it worked out I'll update.

djbeede
1 µW
1 µW
Posts: 3
Joined: Jan 11, 2016 10:15 am

Re: Magic Pie 5 Bluetooth issues

Post by djbeede » Feb 12, 2018 10:27 pm

Update : Reversing my previous post. The GM App does work for me after all. The US site for Golden Motor didn't offer an option for the Bluetooth dongle. For that reason I was under the impression that the newest version of the Magic Pie controller included Bluetooth. After going to the same page on the Canada site I saw that they DID offer the Bluetooth dongle. So I contacted Gary and found out I did indeed need to order it. He was kind enough to send it with free postage. He has been helpful all along. So the upshot is that the App DOES WORK with my phone and Android version. As I said above, it is a Moto E4 Plus running 7.1.1 Android OS. It just arrived and I did use it to update the Regen braking and RPM settings. I'm assuming it will now work as a monitor of riding sessions. If not, I'll keep you posted. I'm a happy E-biker!

Post Reply