Setup of CA temp sensor

Get all your technical information about electric bikes here.
Post Reply
User avatar
ABritInNY   100 W

100 W
Posts: 116
Joined: Jul 12 2015 1:55pm

Setup of CA temp sensor

Post by ABritInNY » Sep 18 2016 11:38pm

Hi guys,
Well I'm having an issue with seeing a negative temp reading on my CA temperature monitoring. It currently reads as -18c?
I had to change my rotor winding after a broken axle on my leafmotor, and on this new one I'm not understanding the reason for the issue.
The previous sensor was an NTC and setup fine under the 10k setting, I thought perhaps it was a linear type after reading a few posts but have since been confirmed by Leafmotor that it's the SAME sensor as I had? MF5A-4- 60MM NTC sensor, is what it says on the id tag he sent me by email?
So any ideas how to fix the negative degree reading? Is it a polarity issue perhaps?
EEB frame set, 1500w Leafmotor 4t winding, Powervelocity 18fet/Lyen 18 fet 4110 ESC, 24s 30ah prismatic cell Lifepo4 batt w/60a-120a BMS, CA V3, Dropper Seat post.
Fusion 48v AGM (4x 12v 15ah) 1000w nom DD rear hub, 50a max ESC, 21sp FS Genesis overkill 650b conversion
Kayman Flash+ 350w Mxus geared hub, dual 36v 5.2ah batts 10.4ah 13a-15a ESC
Freway Vr01, 27sp Pedelec 250w Bafang geared hub, (2x) 36v 5.2ah batt, FVS ESC limited to 10a!! (yup sloow on roads but great on trails ;)

User avatar
teklektik   10 GW

10 GW
Posts: 4020
Joined: Mar 26 2011 1:15pm
Location: CT, USA

Leaf Motor CA Temp Sensor MF5A-4

Post by teklektik » Sep 19 2016 5:14am

Non-polarized.
The problem is that there is more to the part number than Leaf indicated. The basic part is available with various specifications.
mf5a-4_66mm_CA3compatibleParts.png
yellow hilite = in spec for CA3
mf5a-4_66mm_CA3compatibleParts.png (140.78 KiB) Viewed 593 times
You likely have the wrong type. This post in the Leaf Thread shows they are supplying this as a 100K part - the CA needs a 10K part with a beta of 3900. The poor specification that they sent might indicate that they are unaware of the fine points and may be mixing 10K and 100K parts as available (?).

Ideally they should be using an MF5A-4-390-103 (model = MF5A-4, beta=390 (3900), R25=103 (10K))

Unplug the hall/temp connector and measure the resistance between the temp wire and hall ground at room temperature.
Should be about 10K.
If not, snip the leads on the installed part leaving it glued in place, solder up a replacement part (eBay, etc), then goop the new part to the winding with JB Weld (500degC).
Visit Grin Technologies at www.ebikes.ca
Build Thread: 2WD Yuba Mundo V4

User avatar
ABritInNY   100 W

100 W
Posts: 116
Joined: Jul 12 2015 1:55pm

Re: Setup of CA temp sensor

Post by ABritInNY » Sep 20 2016 12:59am

Yes I checked the tag he sent and indeed the R25=100k not 10k :( so it seems they used a different sensor last year to this. I emailed Leaf about it but I don't expect much joy. I'm not interested in trying to ruin it by attempting to affix one and I certainly am not paying more! I expect I'll just have to keep harassing leaf multiple times a day until they send me a working replacement just as my last one was and I paid them for. It's not my fault they're typically inept chinese!
I'm also having other CA issues too, since updating it that never occured before, (fml) my PAS (that I bought from lyen with my 1st ESC) is hooked up to the CA and is working both backward and forward pedaling? which is imo a lil dangerous, and it still does whether i change 5v = forward or reverse, or just won't work at all.
Aside from that the aux input setting, to switch PAS power modes, is nearly always displaying, not the normal screen for some reason, its one second normal and 10 seconds on the PAS??? what the heck is up all of a sudden?
EEB frame set, 1500w Leafmotor 4t winding, Powervelocity 18fet/Lyen 18 fet 4110 ESC, 24s 30ah prismatic cell Lifepo4 batt w/60a-120a BMS, CA V3, Dropper Seat post.
Fusion 48v AGM (4x 12v 15ah) 1000w nom DD rear hub, 50a max ESC, 21sp FS Genesis overkill 650b conversion
Kayman Flash+ 350w Mxus geared hub, dual 36v 5.2ah batts 10.4ah 13a-15a ESC
Freway Vr01, 27sp Pedelec 250w Bafang geared hub, (2x) 36v 5.2ah batt, FVS ESC limited to 10a!! (yup sloow on roads but great on trails ;)

User avatar
ABritInNY   100 W

100 W
Posts: 116
Joined: Jul 12 2015 1:55pm

Re: Setup of CA temp sensor

Post by ABritInNY » Sep 20 2016 1:59am

Wow, so Peter the main guy from Leafmotor just emailed me back less than 15 min after sending him an email. He claims the tag with the 100k is WRONG! and that ALL the therms he installs at Leaf ARE 10K and have never changed?? I'm not able to argue with a blanket denial without any king of data to back me up so I guess I'm doing the room temp resistance test tomorrow and document it. Time to crack out the multi :wink:
EEB frame set, 1500w Leafmotor 4t winding, Powervelocity 18fet/Lyen 18 fet 4110 ESC, 24s 30ah prismatic cell Lifepo4 batt w/60a-120a BMS, CA V3, Dropper Seat post.
Fusion 48v AGM (4x 12v 15ah) 1000w nom DD rear hub, 50a max ESC, 21sp FS Genesis overkill 650b conversion
Kayman Flash+ 350w Mxus geared hub, dual 36v 5.2ah batts 10.4ah 13a-15a ESC
Freway Vr01, 27sp Pedelec 250w Bafang geared hub, (2x) 36v 5.2ah batt, FVS ESC limited to 10a!! (yup sloow on roads but great on trails ;)

User avatar
izeman   10 GW

10 GW
Posts: 4919
Joined: Jun 21 2011 8:25am
Location: vienna, austria
Contact:

Re: Setup of CA temp sensor

Post by izeman » Sep 20 2016 6:38am

just check resistance with a digital multimeter. this will give you certainty. is it 10k or 100k?

User avatar
ABritInNY   100 W

100 W
Posts: 116
Joined: Jul 12 2015 1:55pm

Re: Setup of CA temp sensor

Post by ABritInNY » Sep 20 2016 4:37pm

izeman wrote:just check resistance with a digital multimeter. this will give you certainty. is it 10k or 100k?
I do not know just yet... I was out riding it first to test whether it actually works to gauge rising temps and is the wrong spec or is just plain faulty.
Well, it seems it's working all right because I took the temp reading from the setup screen and a pic of the changes after 3 hard runs of 5000+w for a few minutes, in an effort to heat her up fast (In the past under my 18fet lyen that would only take a few mins at 5kw constant so I thought it would be an OK test condition.
My 4 results were... (we should be able to upload bigger jpg's imo so I could upload them without shrinking 1st.) It was only moderately warm when it should've been burning hot but now I run a more efficient sine wave esc and I also just Ferro fluided it before I sealed it up so it didn't burn up as expected, but it did get hot enough to show a few temp changes.
1) Room temp b4 riding (ambient was 74f) 4.73v = -18c
2) 4.2v = 4.1c
3) 3.86v =13.1c
4) 3.82 = 14.1c
my question is would there be any way to extrapolate the ratio of the figures to calculate a corresponding voltage to be used with the CA's limiting feature and rollback (e.g 35c at like 2.2v? is really 130c?) or is that impossible?
I actually tried to practice taking the resistance measurement on my old rotors ntc therm sensor, which worked fine, with 2 diff multis (because I'm a multi newbie and want to know what a good sensor should look like,) but checking as described with 1 probe on the white therms pin and 1 on the hall plugs black ground wire gave me just the 1 an no change and no 10k?
what am I doing wrong, It shouldnt need power 4 a resistance check should it?
EEB frame set, 1500w Leafmotor 4t winding, Powervelocity 18fet/Lyen 18 fet 4110 ESC, 24s 30ah prismatic cell Lifepo4 batt w/60a-120a BMS, CA V3, Dropper Seat post.
Fusion 48v AGM (4x 12v 15ah) 1000w nom DD rear hub, 50a max ESC, 21sp FS Genesis overkill 650b conversion
Kayman Flash+ 350w Mxus geared hub, dual 36v 5.2ah batts 10.4ah 13a-15a ESC
Freway Vr01, 27sp Pedelec 250w Bafang geared hub, (2x) 36v 5.2ah batt, FVS ESC limited to 10a!! (yup sloow on roads but great on trails ;)

User avatar
ABritInNY   100 W

100 W
Posts: 116
Joined: Jul 12 2015 1:55pm

Re: Setup of CA temp sensor

Post by ABritInNY » Sep 20 2016 10:00pm

I've been trying to extrapolate a working data set using the current installed sensor, by finding this thermistor calc online, I wanted to know the voltage it would be at a particular temp if it was a 100k therm and contrast it with what I have. That way I'd still know when it was getting too hot even if the readings were wrong. It really makes sense to me that it should be possible, but I cannot figure it out? guess I've alot more reading still to do :?
http://www.electro-tech-online.com/tool ... ulator.php
EEB frame set, 1500w Leafmotor 4t winding, Powervelocity 18fet/Lyen 18 fet 4110 ESC, 24s 30ah prismatic cell Lifepo4 batt w/60a-120a BMS, CA V3, Dropper Seat post.
Fusion 48v AGM (4x 12v 15ah) 1000w nom DD rear hub, 50a max ESC, 21sp FS Genesis overkill 650b conversion
Kayman Flash+ 350w Mxus geared hub, dual 36v 5.2ah batts 10.4ah 13a-15a ESC
Freway Vr01, 27sp Pedelec 250w Bafang geared hub, (2x) 36v 5.2ah batt, FVS ESC limited to 10a!! (yup sloow on roads but great on trails ;)

Post Reply