Yamaha Power Assist Bicycles - how to enable the motor to run?

Get all your technical information about electric bikes here.
Post Reply
ivelegacy   1 µW

1 µW
Posts: 1
Joined: Sep 07 2018 5:12am

Yamaha Power Assist Bicycles - how to enable the motor to run?

Post by ivelegacy » Sep 07 2018 5:34am

Image
Yamaha Power Assist Bicycle

Image
the cables to the motor

Image
the connector from the motor to the battery: only the red, black, and yellow wires are used

Image
digital controller

Image
a pic of the motor

so, I have recently found the above bicycle for sale at a super low price, but there is a reason for that: it misses the battery pack, and the connector is not very good. It sounds like the previous owner just wanted to shift it out of the door.

Anyway, paid 100 Euro for the bicycle, and now I have to understand how to make it work.

First of all, the battery pack connector says 25.2V with 4A as the maximal current, and there are three wires from the package to the motor engine: red, black, and yellow. The blue and white wires are only used by the battery charger.

I don't know what the yellow wire is for, it looks like a sort of "power good" signal or "battery good" signal, and without that wire connected, the controller on the bicycle handlebar says the battery is no good, and it doesn't enable the motor to run, even if it takes the energy from the external PSU rather than a battery pack.

Since I don't have an original battery package I can't try to investigate or reverse engineering signals.

Do you happen by any chance happen to know what is the yellow wire for? And which kind of signal (e.g. 5V DC, higher?) does the motor-box need to receive in order to be enabled?


Thanks in advance :D

Post Reply