tongsheng tsdz2 speed sensor not working

Discussions related to motors other than hub motors.
This includes R/C motors, botttom bracket, roller and geared drives.
Post Reply
gator90065   1 µW

1 µW
Posts: 1
Joined: Mar 26 2020 7:41pm

tongsheng tsdz2 speed sensor not working

Post by gator90065 » Mar 26 2020 7:45pm

Just installed a TSDZ2 48v 500w motor and the display is not showing the speed. I am guessing the speed sensor is faulty. Anyone had this issue before. Also, does the speed sensor have anything to do with the power output of the torque sensor. The reason I ask is because I have a Bafang 48v 750w motor on another bike of mine and the Bafang has much more power assist that than the TSDZ2.

User avatar
xtinctionRebeller   10 mW

10 mW
Posts: 25
Joined: Mar 17 2020 1:10pm

Re: tongsheng tsdz2 speed sensor not working

Post by xtinctionRebeller » Mar 28 2020 2:40pm

I probably can't help you, but I like to know if you're talking about the external speed sensor or internal one. This page claims the tsdz2 includes a built-in speed sensor (although I'm struggling to believe it, since it seems unlikely that so many users would be installing external ones to improve accuracy).

Elinx   100 W

100 W
Posts: 187
Joined: Aug 09 2019 6:58am

Re: tongsheng tsdz2 speed sensor not working

Post by Elinx » Mar 28 2020 4:49pm

xtinctionRebeller wrote:
Mar 28 2020 2:40pm
.... This page claims the tsdz2 includes a built-in speed sensor ,,,,,,
That commercial page is problably a bad translation, They mean problably internal torque and cadence sensor. The speed sensor is external.

The speedsensor is a reed contact, and very sensitive for right mounting of the magnet. Be sure that the magnet is on front of the arrow on the sensor and about 3mm distance. Too close or too far could give problems

Post Reply