Error code 12 - Bafang BBS2 500W with C961 display

Discussions related to motors other than hub motors.
This includes R/C motors, botttom bracket, roller and geared drives.
Post Reply
KnNashua   1 mW

1 mW
Posts: 15
Joined: Jun 22 2014 1:28am
Location: Nashua, New Hampshire, United States of America

Error code 12 - Bafang BBS2 500W with C961 display

Post by KnNashua » Apr 29 2015 11:06am

Upon startup this week 80% of time over 20 rides, I get error code 12 and bafang non-functioning. Shutting off and restarting consistently clears code and then runs smooth for miles.

From C961 Manual error code 12 is "current sensor abnormality", which I believe is correct for code (old BBS manual I have says code 12 is "Temperature inside of battery is
un-normal") (Random red herring or possible important detail, at 600 miles it started randomly adding resistance when not assisting, no code shown, shutting off and restarting behaved normally, then this stopped for 50 miles and happened twice this week.)

Two questions:

What should/can I test and how. (ie voltage or current and when)

Also other than the hassle, should I be concerned about fixing instead of using to avoid damage?

User avatar
speedmd   100 MW

100 MW
Posts: 2987
Joined: Nov 14 2012 12:16pm
Location: new england

Re: Error code 12 - Bafang BBS2 500W with C961 display

Post by speedmd » Apr 29 2015 12:03pm

You may want to post it on the BBS02 fault thread. http://endless-sphere.com/forums/viewto ... 28&t=58898

I don' understand your statement "it started randomly adding resistance when not assisting". Something dragging down your motor speed? If so this may suggest you may have a mechanical failure developing somewhere.

KnNashua   1 mW

1 mW
Posts: 15
Joined: Jun 22 2014 1:28am
Location: Nashua, New Hampshire, United States of America

Re: Error code 12 - Bafang BBS2 500W with C961 display

Post by KnNashua » Apr 30 2015 3:41pm

I posted there on that main thread, thanks.

KnNashua   1 mW

1 mW
Posts: 15
Joined: Jun 22 2014 1:28am
Location: Nashua, New Hampshire, United States of America

Re: Error code 12 - Bafang BBS2 500W with C961 display

Post by KnNashua » Jun 09 2015 8:16am

Update, a week after I posted this I noticed that one of the leads from the brakes was disconnected. Didn't notice as don't really need the cutoff as stop pedaling before braking usually . Connected and never got error again.

Post Reply