BBSHD not working, chainring moves 1cm, no error, display works

Discussions related to motors other than hub motors.
This includes R/C motors, botttom bracket, roller and geared drives.
Post Reply
sleepless
100 µW
100 µW
Posts: 9
Joined: Nov 27, 2017 3:39 pm

BBSHD not working, chainring moves 1cm, no error, display works

Post by sleepless » Jan 26, 2018 6:28 am

Hi,

I have a strange problem. I came home yesterday with my ebike and everything worked fine. Plugged the charger in and went to sleep. Today the BBSHD isn't working anymore. The display turns on, battery is at 58.6V almost full. When I start to pedal the BBSHD won't assist. The throttle on the other hand will move the chainring about 0.1-1cm and then suddenly instantly stops. It's like there is something blocking it and the motor / controller tries to protects itself by shutting down - like if I'd use the throttle while braking.

Normally there is no error. But after switching it on and off multiple times I've spotted error 12H. But it's rare.

What can I do? Do I have to take it apart? Can the controller be defective even if the display works and no error is shown?

PS: There is and was no brake sensor connected. Also no speed sensor.

User avatar
fechter
100 GW
100 GW
Posts: 12145
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: BBSHD not working, chainring moves 1cm, no error, display works

Post by fechter » Jan 26, 2018 1:56 pm

I think that error is for the current sensor, but if it doesn't stay on all the time, it's hard to say.

One test is to roll the bike backward (with no power) and see if the motor turns smoothly. You should be able to feel the motor cogging, but otherwise it should roll smoothly. This would test the gears, clutches, etc.

Normally you need the speed sensor attached for the thing to run more than a few seconds.
"One test is worth a thousand opinions"

sleepless
100 µW
100 µW
Posts: 9
Joined: Nov 27, 2017 3:39 pm

Re: BBSHD not working, chainring moves 1cm, no error, display works

Post by sleepless » Jan 26, 2018 2:36 pm

Hi fechter,

thanks for your reply!

It indeed runs smoothly and I feel the motor cogging. The speed sensor isn't needed because I lost it the first day I installed my BBSHD and rode many hours since then without issues.

Any other idea what I can check? It can't be the battery, right? If it'd be the battery (like the BMS cutting the power) I think the whole display would shut down if I use the throttle and the motor stops moving instantly, right?

Edit:

Okay guys, forget it. I cleaned the whole bike under the shower and no it works. I think it really simply was some dirt blocking the system :oops:. Wow, I'm so happy!! :lol:

sleepless
100 µW
100 µW
Posts: 9
Joined: Nov 27, 2017 3:39 pm

Re: BBSHD not working, chainring moves 1cm, no error, display works

Post by sleepless » Jan 27, 2018 4:10 pm

Sadly it worked just for about 10km. Now it shows error 12H almost instantly and doesn't move :cry: it just makes a silent noise when pushing the throttle. My chinese seller said error 12 means controller error and I should send it back for repair. But that would take very long I think.

Does anybody know a good seller in the UK that offers replacement controllers? I'd buy one and send this one back to china. That way I would have two so if something goes wrong again I'd be prepared..

User avatar
fechter
100 GW
100 GW
Posts: 12145
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: BBSHD not working, chainring moves 1cm, no error, display works

Post by fechter » Jan 27, 2018 8:11 pm

One other thing you might try. Open up the controller side and disconnect, inspect and reconnect all the plugs. Also inspect the phase wires for damaged insulation. This is pretty easy. It seems like your problem is intermittent, which is usually a bad connection somewhere.
"One test is worth a thousand opinions"

sleepless
100 µW
100 µW
Posts: 9
Joined: Nov 27, 2017 3:39 pm

Re: BBSHD not working, chainring moves 1cm, no error, display works

Post by sleepless » Jan 28, 2018 8:45 am

Thanks for your reply.

Well, overnight it stopped working completely. It doesn't turn on anymore. I tried to disconnect and reconnect the controller but still nothing. The wires look good so there shouldn't be a problem. Am I right that it has to be the controller if the battery works well? I have to send it back to china so I have to be very sure about this.

User avatar
fechter
100 GW
100 GW
Posts: 12145
Joined: Dec 31, 2006 3:23 pm
Location: California Bay Area, USA

Re: BBSHD not working, chainring moves 1cm, no error, display works

Post by fechter » Jan 28, 2018 9:35 pm

There is small chance it is the display unit but most likely the controller.
"One test is worth a thousand opinions"

tommie
10 W
10 W
Posts: 78
Joined: Jun 21, 2015 10:54 am
Location: N. Ireland

Re: BBSHD not working, chainring moves 1cm, no error, display works

Post by tommie » Feb 04, 2018 10:51 am

I hope you weren`t being serious here -->

Edit:
Okay guys, forget it. I cleaned the whole bike under the shower and no it works.


water and motors/cabling etc do not mix!

you`ll get a controller in the UK ok

go to pedelecs.co.uk and someone in there will help.

Post Reply