TSDZ2 with VLCD5 shutting off

Discussions related to motors other than hub motors.
This includes R/C motors, botttom bracket, roller and geared drives.
Post Reply
sjuft   10 µW

10 µW
Posts: 6
Joined: Mar 07 2019 3:29pm

TSDZ2 with VLCD5 shutting off

Post by sjuft » Mar 25 2019 6:44am

I just installed med TSDZ2 but something is wrong.
After riding for 5-10 minutes the motor and display shuts off. Right before it shuts off, the battery indicator goes form full to 1 bar.
And then afterwards i cant turn it off. If i wait a few minutes, i can turn it back on but then only ride for 2-3 minutes.
It appears that i can continue riding with the display on but with motor assist off. So i assume the problem is related to drawing the amps, or maybe the ESC, even though the motor shell doesnt feel hot at all.
My battery is fully charged and shows 53v.

Any tips on what it could be or how to diagnose for the error?

Mike-P   100 mW

100 mW
Posts: 37
Joined: Mar 03 2019 3:16pm
Location: North Yorkshire

Re: TSDZ2 with VLCD5 shutting off

Post by Mike-P » Mar 25 2019 2:03pm

Check the connections in the cable twix motor and battery; if soldered it could be a dry joint, if by connectors are they firmly fitted together and the wires well secure.

sjuft   10 µW

10 µW
Posts: 6
Joined: Mar 07 2019 3:29pm

Re: TSDZ2 with VLCD5 shutting off

Post by sjuft » Mar 26 2019 7:20am

Mike-P wrote:
Mar 25 2019 2:03pm
Check the connections in the cable twix motor and battery; if soldered it could be a dry joint, if by connectors are they firmly fitted together and the wires well secure.
Cables appear fine. I unplugged all cables and reconnected carefully. Some further testing revealed that the problem is somehow related to high amps. When i ride with little to no assistance i can go for more than ten minutes. If i go to "turbo" drawing max assistance, it shuts off after 1-2 minutes.

I measured all the cell groups today after the short ride. They all appear at 3.8v except for one which is at 3.2v. Can that small difference make the BMS cut the power?

Jez   1 mW

1 mW
Posts: 17
Joined: Apr 10 2019 1:25pm

Re: TSDZ2 with VLCD5 shutting off

Post by Jez » Apr 17 2019 7:35pm

Hi. Have a few issues of my own with this setup but thought I would share stuff I've discovered. In short, no, that small a difference in cell voltages shouldn't make a difference. in diagnosing my own issues I have routinely seen bigger voltage differences than this and all still works. HTH

Post Reply