I need help, as i dont have anywhere to ask, and no one to help me

General Discussion about electric bicycles.
User avatar
MadRhino   100 GW

100 GW
Posts: 6802
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 20 2020 2:01pm

Davidcroatia wrote:
Jul 20 2020 11:05am
I lost all day diagnosing (Learning) , it was bad chinese throttle
:D
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 20 2020 4:51pm

Oh yes after all this i have learnt alot , but now i have few problems to solve. 1. I have put carbon non suspension fork in front, and all day i tighten headset and all day its floppy. 2. I dont have washers so i removed disk rear, and casette is tightened by the frame so it doesnt go to reverse bike...

Balmorhea   10 kW

10 kW
Posts: 883
Joined: Oct 01 2019 8:30pm
Location: Austin

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Balmorhea » Jul 20 2020 5:00pm

Davidcroatia wrote:
Jul 20 2020 4:51pm
Oh yes after all this i have learnt alot , but now i have few problems to solve. 1. I have put carbon non suspension fork in front, and all day i tighten headset and all day its floppy. 2. I dont have washers so i removed disk rear, and casette is tightened by the frame so it doesnt go to reverse bike...
Apparently, you have not learned enough.

It sounds like you don’t have enough headset spacers. You want about 3mm of stem (or spacer) showing up above the top of the steer tube when you remove the top cap. if you can’t snug up the headset, don’t ride the bike. You may already have damaged your fork beyond repair.

As far as the other problem goes, that’s wrong, and under no circumstances should you ride your bike that way.

We should not have to tell you not to operate your bike when it’s missing necessary parts.

markz   100 GW

100 GW
Posts: 10150
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 20 2020 8:46pm

Yeah thats pretty basic stuff. Follow along on youtube like the Park Tool youtube channel is pretty good. Bikeman4u is alright also, I wonder if he still has his mohawk and pony tail, you know a bike mechanic at a shop is cool when they got a mohawk and ponytail. You know whats even better, when your bicycle mechanic is wearing a beaver hat.

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 21 2020 3:39am

This headset is original to this frame, i am fixing bikes 15 years already, headset is all good fot ten minutes, then after it just bounces, im running carbon 26 27 29 for with 1 1/8 steerer, the rest probllems i cant correct as i dont have spacers for the axle

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 21 2020 3:41am

Btw i have enough fork spacers

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 21 2020 9:29am

I fixed a headset now its all good, what about spacers for rear wheel? How do you solve that ?

User avatar
E-HP   100 kW

100 kW
Posts: 1307
Joined: Nov 01 2018 9:20pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by E-HP » Jul 21 2020 9:48am

Davidcroatia wrote:
Jul 21 2020 9:29am
I fixed a headset now its all good.
How did you fix it?

User avatar
MadRhino   100 GW

100 GW
Posts: 6802
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 21 2020 10:01am

Davidcroatia wrote:
Jul 21 2020 9:29am
...what about spacers for rear wheel? How do you solve that ?
Filing big washers to match axle flats can do, to get axle shoulder further from the dropout. Yet I am used to make custom dropouts to perfect fit.

Spacing the disc away from the motor can be done many ways: small washers for each of the 6 rotor screws, cutting the flange off old discs to make full ring spacers, or buying one since they are available on the market. Yet, when a motor doesn’t clear the caliper, I have two quick solutions: Use one of my Magura Gustav calipers, or use a larger 225mm rotor, or both.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 21 2020 10:18am

E-HP wrote:
Jul 21 2020 9:48am
Davidcroatia wrote:
Jul 21 2020 9:29am
I fixed a headset now its all good.
How did you fix it?
I have played with rings from headset, i put 1 mm smaller, and used glue for it. For now its all good

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 21 2020 10:20am

MadRhino wrote:
Jul 21 2020 10:01am
Davidcroatia wrote:
Jul 21 2020 9:29am
...what about spacers for rear wheel? How do you solve that ?
Filing big washers to match axle flats can do, to get axle shoulder further from the dropout. Yet I am used to make custom dropouts to perfect fit.

Spacing the disc away from the motor can be done many ways: small washers for each of the 6 rotor screws, cutting the flange off old discs to make full ring spacers, or buying one since they are available on the market. Yet, when a motor doesn’t clear the caliper, I have two quick solutions: Use one of my Magura Gustav calipers, or use a larger 225mm rotor, or both.
Sorry english is not my native, what is a flange? I mean do you have a picture what that is? Thank you

User avatar
MadRhino   100 GW

100 GW
Posts: 6802
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 21 2020 10:32am

The flange in this case, is the center part of the disc where the 6 mounting holes are. We can cut it off an old disc to make a ring spacer.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

User avatar
E-HP   100 kW

100 kW
Posts: 1307
Joined: Nov 01 2018 9:20pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by E-HP » Jul 21 2020 11:27am

Davidcroatia wrote:
Jul 21 2020 9:29am
what about spacers for rear wheel? How do you solve that ?
Hub motors almost always come with spacers. If they weren't included, you should probably ask the seller.

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 21 2020 2:30pm

This one doesnt come with spacers


markz   100 GW

100 GW
Posts: 10150
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 21 2020 8:15pm

Davidcroatia wrote:
Jul 21 2020 2:30pm
This one doesnt come with spacers
Spacers for the freewheel are needed but they need to be the right size, to fit inside the freewheel indent and keep the frame off the freewheel spinning (The outter edges of the indent). I've run into that problem once or twice on my Townie Electra 21D and 7D and I just got some washers from the big box hardware store and took a rotary tool to the outside of the washer to fit inside the indent. I guess it would be good to have a handful as specific spares so you dont have to do any work to the washers. Just throw them in. I seem to always lose or misplace the lips, washers, nuts. But I change my ebike setup frequently, different motors, battery configs, bike frames.

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 22 2020 6:27pm

Im sorry, its me again and im very pissed off already... The qs motor 1000w has a cable running along the axle, not in the axle, so i already rubbed the cable a little bit on the sharp edges of its rear axle (very retarded product) , so i put a little bit of glue and put a thermal that thing that goes around the wire, but stupid 6bolt bolts managed to destroy even that, so what i can do ? Ps i bought washers today 2 on every side so now is okay for the frame distance


markz   100 GW

100 GW
Posts: 10150
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 22 2020 7:07pm

Bro, you need to have a bit of slack, a bit of a loop when that cable exits the axle, then either have the cable come back to the seat stay or chain stay and use some electrical tape or a zip tie to keep it in place. Dont have too much of a loop, have it tight. Also I like to be sure my axle is mounted a certain way, a way in which the cable exiting the axle is on the back of the bike. Others may do it differently.

I know what your talking about, I think. The cable coming out of the axle and the disc mount bolts can interfere. On the Leaf 1500W there is a spring to help protect the cable. You can do the same thing, we talked about the same thing here at ES in some thread. Do a search for it, there are other ways to protect the wires. I have personally replaced the phase wires with PTFE Teflon wire which has very protective insulation. But the spring you can buy at Home Depot, its a basic spring, already compressed, that you hold on either end and pull away and it stretches, as opposed to the other kind of spring.

https://www.homedepot.com/s/spring?NCNI-5
Compression spring
Extension spring is what you want. https://www.homedepot.com/p/Everbilt-1- ... /202045469
probably a better fit for the cable to run through - https://www.homedepot.com/p/Everbilt-7- ... /202045466

User avatar
MadRhino   100 GW

100 GW
Posts: 6802
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 22 2020 7:21pm

That is a common beginner’s mistake. A build must not be going on the street before everything is tested and double checked. Beginners are on a hurry to try the bike. You must calm down and finish the build before riding.

The wiring of QS motors is big, but not so hard to bend and tie out of any risk of rubbing. When I make the steel dropouts or torque plates, I manage a place to run and tie the wiring before and after the drip loop. Then I run the wiring together with the brake hose and tie it on the hose guides. I use tie wraps, not too tight.

If the wiring sheath and/or insulation is damaged, repair with silicon tape. If some wires are cut, you might have to open the motor to make the splice inside.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

markz   100 GW

100 GW
Posts: 10150
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 22 2020 7:26pm

Also

Double, Also

Do not forget Torque Arms

Tripley Also

User avatar
MadRhino   100 GW

100 GW
Posts: 6802
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 22 2020 7:27pm

Ps. No pics on the link that you posted.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

Davidcroatia   10 W

10 W
Posts: 67
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 22 2020 7:43pm

This is a big frustration. Im gonna tell now the whole story. I have an apnea, so im tired all day always,when i drive i get tired very fast, i drive wolt on a bike. Considering ebikes i borrowed money to buy all parts, because of corona aliexpress couldnt deliver, so i asked locally, i have found a guy who has sold me those things waiting it for about 2 weeks lets say, 10 days for refund from aliexpress and 10 days for parts locally, i put quite a lot of money in this , all will be in croatian kuna, 1$ is 7 kuna lets say , so motor 1200 kuna, controller 1200 kuna, 26 inch rim 150 kuna, spokes 200 kuna, wheel lacing job 240 kuna, gas sensor that turned up to be broken 100 kuna, bike for putzing this set 1500 kuna, battery upp factory 3200 kuna, anti spark connector 50 kuna, mounting battery holes in frame 400 kuna , seller telling me phase wires and small wires how they go 400 kuna, the most important thing i lost time having to work on a bike, now im very frustrated in this whole thing, i already ripped a little bit of insulation, i even asked some qs motor seller to help me with washers or even help me how to connect , he says THEY DONT PRODUCE WASHERS FOR DROPOUTS LOL LOL , like selling a car with no engine, and his reposnse was you didnt buy it from me, if there is no good people on this forum, i wouldnt even come this far, all people around me just look for money mone money money more money, bring it here i will fix it , and they could just say look connect these wires like this and its done, now im in debt because i borrowed money because i had 2 very bad situations in my life with bad consequences , today i bought washers to put on a bike, they are round so thats why they stick the wire out, but atleast now i put a rear brake, but news flash rear disc is very warped so im in always in some problem, and some frustration i cant tell you how much im let down with all of this, and icing on a cake is i come to a bike store for a washer that goes behind kranz because it doesnt rub on a motor and they start laughing and say that thing doesnt exist , and they say bad creation of chinese qs motor development team that didnt consider mounting kranz would be a viable 2mm more space on a motor, btw i dont have a chain also on my bike, you ask why ? Because torque arm supplied , and a big axle ring cant even put rear derailleur on a frame because torque arm and a nut for axle is too big so i drive chainless on a bike, and had like 11 hits on my leg lower than my knee area and ripped my skin so there , i would curse but that would be of much help, so there some of my frustrations, and a fear of ripping my cable tommorow when i start to drive wolt again


markz   100 GW

100 GW
Posts: 10150
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 22 2020 11:10pm

Well we told you how to fix the cables rubbing on the brake bolts, and its probably best to take the caliper disc bolts off.

Second, a wall of text is a big turn off. I stopped reading 4 lines in. But I did read your CAPITALIZED text.
Here you go
https://www.ebikes.ca/shop/electric-bic ... ?limit=all
washers that will fit the axle, so you can space out your rear dropout so it dont rub on the freewheel. Also bolts, and normal washers, Anti-Rotation Washer aka Lips. But remember dont count on that, USE TORQUE ARMS. Whether you cut a slot out of 1/4" steel and use hose clamps or buy from Grintech, https://www.ebikes.ca/shop/electric-bic ... -arms.html

While your at it, might as well buy a spare throttle, always always have two throttles that work.


OK I will try reading that wall of text again but I dont give it much hope, probably 4 more lines. You see how I break my post up into seperate ramblings and ideas and thoughts.

Well there are good people on the forum, there are good sellers online. Its just when we cheap out, yes I am cheap too, it ends up costing us more money in the end.

I buy from trusted vendors, like Greentime EVFitting on Aliexpress, EM3EV.com, www.ebikes.ca, Luna Cycle, my local ebike store, manufacturers like Leafbike and Leafmotor and MXUS and QS.

Not sure what else to say, a good rant ramblings always good. A better thought out post would have been better but its understandable you are upset.

What are your current issues right now?
- We know your wires coming out of the axle are damaged due to the disc mount bolts. Assuming you have rim brakes, take off them bolts and SAVE THEM.

- Your other problem was solved with a throttle.

What are your current problems, your motor does not run because the wires are damaged. You need to fix the wires. This is what you do, you take off the cover plate on that wire side. You take off the cover plate, that can be tricky, but can be easy too. Sometimes I will gently tap the axle on the other side to help pop the cover plate off. Now, dont go shoving a flat head screwdriver in there, you will damage the laminations. You either go all the way with forcing the cover plate off by taping on the ground the other side of the axle, or you can get a 3 jaw puller. Be careful with the wires, the all important wires, BE CAREFUL. It dont matter now since they are damaged but you can end up scraping insulation off the wires.




Post Reply