Thoughts on this controller for this motor?

General Discussion about electric bicycles.
Post Reply
ebike11   10 kW

10 kW
Posts: 951
Joined: Nov 16 2013 8:01pm
Location: Korea

Thoughts on this controller for this motor?

Post by ebike11 » Jan 01 2018 9:29am

Hi guys
I recently got the MXUS v3 turbo rear motor with 3T option.
No controller came with it. I then ordered this one below. Its a sinowave type
I was surprised at how quiet it is on the first ride around the yard.
The motor is basically silent..and with 50A has lots of take off power.
I have a 72V battery pack.
The other day though i decided to to and test it on long flats..but notice a lot of motor sputtering. The sputtering seems to come and go, and sometimes im able to go full throttle after it seems to clear the cobwebs but other times not.
Im wondering do you guys think its a controller issue?
Thanks in advance!

https://www.aliexpress.com/item/72V-200 ... 0.0.5zONxO

https://www.aliexpress.com/item/Standar ... 0.0.5zONxO

User avatar
wesnewell   100 GW

100 GW
Posts: 7166
Joined: Jan 31 2011 6:25pm
Location: Wylie, TX, USA

Re: Thoughts on this controller for this motor?

Post by wesnewell » Jan 01 2018 12:36pm

Sounds like a bad connection. Check phase and hall wire connections.
Need Advice? https://endless-sphere.com/forums/viewt ... =3&t=66302
Mongoose 26" Ledge 2.1 mtb bike $99, yescomusa.com 48V 1000W rear hub kit $200, Hua Tong 72V 40A controller $35, 10ah 24s lipo $217=~43mph, range=45 miles @ 20mph. 25K miles and still going strong.
Huffy Fortress 3.0 with MXUS 3000 4T motor, 24s lipo, 96V 60A controller. Total cost with extras <$700. Top speed ~50mph
My videos https://www.youtube.com/channel/UC0KW4U ... _G2wQhptMg

ebike11   10 kW

10 kW
Posts: 951
Joined: Nov 16 2013 8:01pm
Location: Korea

Re: Thoughts on this controller for this motor?

Post by ebike11 » Jan 01 2018 9:18pm

wesnewell wrote:
Jan 01 2018 12:36pm
Sounds like a bad connection. Check phase and hall wire connections.
Hi there
I double checked the connections. They all seem fine. Nothing loose or disconnected.

Do you think that since the controller wattage is rated lower than the motor wattage that it might cause sputtering?

User avatar
wesnewell   100 GW

100 GW
Posts: 7166
Joined: Jan 31 2011 6:25pm
Location: Wylie, TX, USA

Re: Thoughts on this controller for this motor?

Post by wesnewell » Jan 02 2018 1:52am

ebike11 wrote:
Jan 01 2018 9:18pm
I double checked the connections. They all seem fine. Nothing loose or disconnected.

Do you think that since the controller wattage is rated lower than the motor wattage that it might cause sputtering?
Nope, the rating has nothing to do with it. I have a 1000W rated controller on my mxus 3000 and I push 6000W though it (100Vx60A), but so long that I blow the controller. I could be a bad connection inside the controller, or just a flaky controller though. Could also be bad halls, or bad connection in the motor. But for on again off again problems like you describe, it's usually a bad connection somewhere. If you are using the ring terminals on the phase wires that cam with the controller, I'd replace them with some good connectors, like gold plated bullets. Those ring terminals are crap.
Need Advice? https://endless-sphere.com/forums/viewt ... =3&t=66302
Mongoose 26" Ledge 2.1 mtb bike $99, yescomusa.com 48V 1000W rear hub kit $200, Hua Tong 72V 40A controller $35, 10ah 24s lipo $217=~43mph, range=45 miles @ 20mph. 25K miles and still going strong.
Huffy Fortress 3.0 with MXUS 3000 4T motor, 24s lipo, 96V 60A controller. Total cost with extras <$700. Top speed ~50mph
My videos https://www.youtube.com/channel/UC0KW4U ... _G2wQhptMg

ebike11   10 kW

10 kW
Posts: 951
Joined: Nov 16 2013 8:01pm
Location: Korea

Re: Thoughts on this controller for this motor?

Post by ebike11 » Jan 02 2018 2:48am

wesnewell wrote:
Jan 02 2018 1:52am
ebike11 wrote:
Jan 01 2018 9:18pm
I double checked the connections. They all seem fine. Nothing loose or disconnected.

Do you think that since the controller wattage is rated lower than the motor wattage that it might cause sputtering?
Nope, the rating has nothing to do with it. I have a 1000W rated controller on my mxus 3000 and I push 6000W though it (100Vx60A), but so long that I blow the controller. I could be a bad connection inside the controller, or just a flaky controller though. Could also be bad halls, or bad connection in the motor. But for on again off again problems like you describe, it's usually a bad connection somewhere. If you are using the ring terminals on the phase wires that cam with the controller, I'd replace them with some good connectors, like gold plated bullets. Those ring terminals are crap.
Ok thx
Actually i soldered xt60s for the phase connectors.
I notice you also have a 3000 mxus. Regarding the wire coloring..did your controller phase and hall wires match up exactly with the motors phase and halls?
Also the controller is a sinuwave type. I love how quiet it is...but not sure if that type of controller has anything to do with my problem

User avatar
dogman dan   100 GW

100 GW
Posts: 34367
Joined: May 17 2008 12:53pm
Location: Las Cruces New Mexico USA

Re: Thoughts on this controller for this motor?

Post by dogman dan » Jan 02 2018 9:36am

I'm also betting on it being a bad contact someplace on a wire, most likely the halls connections.

But its still possible the controller itself has some kind of problem, and loses synch when at high rpms. Much rarer, but defects are always still a possibility.

ebike11   10 kW

10 kW
Posts: 951
Joined: Nov 16 2013 8:01pm
Location: Korea

Re: Thoughts on this controller for this motor?

Post by ebike11 » Jan 02 2018 10:50am

dogman dan wrote:
Jan 02 2018 9:36am
I'm also betting on it being a bad contact someplace on a wire, most likely the halls connections.

But its still possible the controller itself has some kind of problem, and loses synch when at high rpms. Much rarer, but defects are always still a possibility.
Ok ill check my connections this weekend.
I might try swapping the hall wire combination around but i cant see that being a problem since the bike runs fairly well except for the sputtering. No weird noises

User avatar
wesnewell   100 GW

100 GW
Posts: 7166
Joined: Jan 31 2011 6:25pm
Location: Wylie, TX, USA

Re: Thoughts on this controller for this motor?

Post by wesnewell » Jan 02 2018 4:19pm

ebike11 wrote:
Jan 02 2018 2:48am
notice you also have a 3000 mxus. Regarding the wire coloring..did your controller phase and hall wires match up exactly with the motors phase and halls?
Running sensorless, so not using the halls. With learning feature of controller, you can hook the phase wires any way you want. On my other bike I had to wire them correctly, and they aren't a straight match. If your controller doesn't have a learning feature then it's possible you don't have it wired correctly. And a motor can run, sometimes fairly decently, with the wrong wiring combo. A 3t motor should get you close to 50 mph with a 72v battery and everything wired right.
Need Advice? https://endless-sphere.com/forums/viewt ... =3&t=66302
Mongoose 26" Ledge 2.1 mtb bike $99, yescomusa.com 48V 1000W rear hub kit $200, Hua Tong 72V 40A controller $35, 10ah 24s lipo $217=~43mph, range=45 miles @ 20mph. 25K miles and still going strong.
Huffy Fortress 3.0 with MXUS 3000 4T motor, 24s lipo, 96V 60A controller. Total cost with extras <$700. Top speed ~50mph
My videos https://www.youtube.com/channel/UC0KW4U ... _G2wQhptMg

Post Reply