Page 1 of 1

Vehicle Setup and Configuration SEVCON

Posted: Apr 24, 2018 1:32 pm
by bernext
Hi ,

I'm following the instructions from the “Vehicle Setup and Configuration” application note from Sevcon.
I'm trying to use the DVT to control the torque demand being fed to the motor control directly, overriding demands fed in from the Traction Application.
I've reached the part of writing Torque demands to 0x6071, but I cannot get the motor to turn.

Because of this, I've checked the following:

-The controller is in the operational state, and powered up with the line contactor closed and there are no faults at all.
-The statusword of the motor control read from 0x6041 DOES NOT have the following bits set: 0x0027, IT HAS the value of 0x0421 instead.
Do you know the reason for this ?
-The actual torque output read from object 0x6077 is 0x0000, and is different from the value previously set to 0x6071,( i.e., sdo_wnx 1 0x6071 0 15 2 ).
According to the application note, If these two are different between each other, then it is being limited by either the power limit map, low battery or over temperature.

Battery is at 100%, 79V-80V.
Temperature is at 26 °C.
The power limit map, shows a maximum torque of 100NM at 0 rpm, for a motor which is rated to have 133NM tops.

What do you think it's going on ?

The voltage read between B- and any motor phase is 11.36VDC. It never reaches approximately half battery voltage between B- and each terminal, after enabling the bridge in the controller and activating the
motor control.

Regards.

PS.

Drive data:
Type: Gen4 72/80V 550A
Mod# PMAC-DLC Traction, Rotation CW

Motor data:
Motenergy ME1302 Water-Cooled Brushless
PART #DLC28