Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Electric Motors and Controllers
Post Reply
Speedproject   1 µW

1 µW
Posts: 3
Joined: Jun 22 2018 12:13am

Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by Speedproject » Jun 23 2018 2:54am

Hi,
does anyone know why my mxus3000 stopps so hard on kls 7218s if i close and reopen the throttle, i try to change some parameters already but it didn't help.
And how can the axle be changed on the motor.
Thx :wink:
BULLS Copperhead: Mxus3000 3t 17in , kelly kls 7218s 200A (65a battery set) Magura throttle + 12x Multistar 6s 5200 (12s) :mrgreen:

User avatar
eee291   10 kW

10 kW
Posts: 662
Joined: Nov 05 2015 4:35pm
Location: Austria, Burgenland: Güssing

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by eee291 » Jun 24 2018 1:23pm

Hast du schon den Auto Identify gemacht?
Ich hab dich schon mal gefragt, aber du hast nichts darüber gesagt.

In den feld Auto Identify musst du 170 eingeben, dann auf Write drücken und noch einen neustart machen und 20 sekunden warten.

Lg

2WheelsMovesTheSoul   100 W

100 W
Posts: 111
Joined: Oct 17 2017 12:59pm

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by 2WheelsMovesTheSoul » Jun 25 2018 9:57am

viewtopic.php?f=2&t=94355&p=1381823#p1381823

Given you've properly ID'd the motor with no load...

Look at page 22 & 23 of the KLS-S manual. http://kellycontroller.com/mot/download ... V1.10.pdf
Go to 4.3 (Step 3)

(1) RLS_TPS Brk %: Set to 0

Write the new setting, cycle main power off and on again. Check the setting again to make sure it wrote.

This setting mimics the inherent engine braking characteristics of a petrol motor that is in gear and rolling with no throttle. A small amount of drag is added while rolling with zero throttle to give the same predictable behavior. I've also noticed this effect is even more exaggerated when active while using the 3 speed switch in the low setting.

If problem persists, leave at 0 and try to re-calibrate your throttle input values to be more accurate and then controller won't see 0% thru 5% or 10% throttle as the same.

Page 17 & 18 (4.1 Steps 6 thru 10)
Very important that you measure and convert the voltages to Kelly's 0-255 scale (on "AC monitor" screen w/Bluetooth app) for your specific throttle high, low, and establish accurate deadzones for both.

It is possible to just plug the throttle in, not make any adjustments and everything seem fine from the start. But if you want the best performance, take the time and set it up right.

DaDo.Bzz   100 W

100 W
Posts: 128
Joined: Feb 12 2015 3:29pm

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by DaDo.Bzz » Jun 30 2018 7:02pm

Had same issue with KLS and LMX motor. Setting rls braking didnt helped. It is some problem with halls and sync with phases. Also had high amp consumption with no load.

My motor rotor is not designed for sine controller (not sure if this is true, got this info from chinese manufacturer) so I changed for KBS and now it works fine.
LMX 81, 16S6P 60A
BBS02 on Cannondale Rz 120
BBSHD on CTM Scroll, XTR Di2, 700Wh 52V
Slovakia, Bratislava

User avatar
skeetab5780   10 MW

10 MW
Posts: 2125
Joined: Jun 15 2009 10:58pm
Location: MA
Contact:

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by skeetab5780 » Jun 30 2018 7:49pm

Yep i had this issue before also the Kls series wouldnt work with my lrhdd motor...tried every setting. Got a Kbs series and now it works perfect.

I tried 12v to halls adding diodes in series nothing helped Kls hall signal distortion

You can easily see the hall errors in the test portion of the kelly setup program when spinning motor under no load while using Kls

Altair   100 W

100 W
Posts: 267
Joined: May 03 2014 10:35am
Location: Quebec, Canada

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by Altair » Jul 01 2018 8:30pm

This is probably the same problem I have with my Adaptto; I have been driving a BHT mid-drive with it for almost 3 years now, but recently I removed the freewheel from my rear wheel because of constant breakage of pawls inside it. I then machined a piece that allows me to lock the rear sprocket to the wheel, so no more freewheeling, the motor always turns with the wheel.
But now when I close the throttle while the bike is still moving fast, the motor will almost lock the wheel if I reopen the throttle before the bike has slowed down enough. This is a PITA.

The worst thing is that I bought a Kelly KLS to replace the Adaptto. I guess now it's futile to do the replacement, the KLS will do the same thing?
Damn... :evil:

User avatar
madin88   100 MW

100 MW
Posts: 2757
Joined: May 27 2013 2:02am
Location: Austria

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by madin88 » Jul 02 2018 3:39am

Altair wrote:
Jul 01 2018 8:30pm
This is probably the same problem I have with my Adaptto; I have been driving a BHT mid-drive with it for almost 3 years now, but recently I removed the freewheel from my rear wheel because of constant breakage of pawls inside it. I then machined a piece that allows me to lock the rear sprocket to the wheel, so no more freewheeling, the motor always turns with the wheel.
But now when I close the throttle while the bike is still moving fast, the motor will almost lock the wheel if I reopen the throttle before the bike has slowed down enough. This is a PITA.

The worst thing is that I bought a Kelly KLS to replace the Adaptto. I guess now it's futile to do the replacement, the KLS will do the same thing?
Damn... :evil:
Do you have access to an oscilloscope to check if the signals from the Halls switch exactly at the moment when the phase- to phase voltage crosses the the middle line (imagine a sine-wave curve and the zero line is the x-axis)?

Because i am also running a mid-motor with adaptto and i never had your issues. The motor has 16 magnets (8 pole pairs) and it's spinning at 6000rpm unloaded which is already very close to the ERPM limit of the adaptto. There is no freewheel as well and regen works as smooth as it does with a hubdrive.
BUT the hall signals are perfect :wink:
here is a pic how the signals should look like:
viewtopic.php?f=30&t=91144&start=25#p1362255
- 10kW belt drive with Neumotor 8057: viewtopic.php?f=30&t=91144&start=50#p1377787
- Fully road legal (L1E approval) e-bike based on Votec V-FR frame
/ MXUS 3T / 17" Mitas MC11 / Adaptto Max-E / 20s12p 25R
- KTM Hardtail Pedelec / eZee V2 6T / 27,5" / Kelly KBSX @ 1,5kW / Torque PAS / CA-V3 / 13s4p Sanyo GA in Shark case

Altair   100 W

100 W
Posts: 267
Joined: May 03 2014 10:35am
Location: Quebec, Canada

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by Altair » Jul 02 2018 7:53am

Yes madin, I have a 'scope.
I will surely check that out, it might be the problem. But in that case, so would be the problem of others with the KLS controllers...?

As the BHT is a "cheap" motor, I wouldn't be surprised that the timing is wrong. But it still served well for 3 years with a freewheel.

I've recently seen something here on ES about someone mentioning that a problem was caused by uncontrolled rectification via the body diodes of the MOSFETS, but I can't remember in what thread it was. Probably a controller thread...
The Adaptto has only one current sensor if I remember well, as opposed to one sensor for each phase. If the KLS also has only one, that could also cause problems.

BTW madin, I've been following your thread on the Neumotor. NICE!

DaDo.Bzz   100 W

100 W
Posts: 128
Joined: Feb 12 2015 3:29pm

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by DaDo.Bzz » Jul 03 2018 8:07pm

I did also measure hall sensors with osciloscope. Just couldnt do anything with it. So sold kls and bough kbs.

Check if you have sine motor. Rotor magnets are little different positioned there.

But I think kls controller has faulty firmware.
LMX 81, 16S6P 60A
BBS02 on Cannondale Rz 120
BBSHD on CTM Scroll, XTR Di2, 700Wh 52V
Slovakia, Bratislava

User avatar
madin88   100 MW

100 MW
Posts: 2757
Joined: May 27 2013 2:02am
Location: Austria

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by madin88 » Jul 04 2018 5:43am

DaDo.Bzz wrote:
Jul 03 2018 8:07pm
I did also measure hall sensors with osciloscope. Just couldnt do anything with it. So sold kls and bough kbs.
I don't know if you have connected the osci the right way to the motor, but just as info how i did:

- disconnect all wires from the controller, aside of + (plus) and - (minus) from the halls. or disconect all wires and use any other 5V supply to power the halls.
- connect one of the phase wires to - (minus) of the halls
- connect GND from the osci to - (minus) of the halls
- channel 1 needs to be connected to one hall signal (yellow, green or blue)
- channel 2 needs to be connected to one of the remaining two phase wires

ONE of the three hall signals should exactly match with the connected phase (match = same crossing of the middle line -> check my pic)
If non of the three hall signals match with the phase curve, than the motor does not have a neutral timing.
I was using a cordless drill to spin the motor :wink:
- 10kW belt drive with Neumotor 8057: viewtopic.php?f=30&t=91144&start=50#p1377787
- Fully road legal (L1E approval) e-bike based on Votec V-FR frame
/ MXUS 3T / 17" Mitas MC11 / Adaptto Max-E / 20s12p 25R
- KTM Hardtail Pedelec / eZee V2 6T / 27,5" / Kelly KBSX @ 1,5kW / Torque PAS / CA-V3 / 13s4p Sanyo GA in Shark case

Altair   100 W

100 W
Posts: 267
Joined: May 03 2014 10:35am
Location: Quebec, Canada

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by Altair » Jul 04 2018 7:21am

Personally, I haven't checked my motor yet, as I would have to make an adapter to match the large output shaft. And as I'm pretty sure that the timing WILL be wrong, I will want to fabricate a new timing assembly (probably optical) that will attach to the rotor and left casing. I already have so many unfinished projects... :roll:
Wondering if it wouldn't be better to just put the freewheel back in! :lol:

User avatar
skeetab5780   10 MW

10 MW
Posts: 2125
Joined: Jun 15 2009 10:58pm
Location: MA
Contact:

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by skeetab5780 » Jul 04 2018 7:49am

I ran my setup with it running like this for a couple of rides before i figured out what was going on, the controller would keep blinking a 3-2 error code when i beat on it, and the problem never stopped. The bike did work somewhat and had plenty of power but was hard to control

Freewheel will just delay the problem and cause another weak link in the system

Altair   100 W

100 W
Posts: 267
Joined: May 03 2014 10:35am
Location: Quebec, Canada

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by Altair » Jul 04 2018 9:45am

I've never had an error during the 3 years that I ran with the freewheel.
Still had no errors pop up with the freewheel eliminated, but then had the huge motor braking effect.

DaDo.Bzz   100 W

100 W
Posts: 128
Joined: Feb 12 2015 3:29pm

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by DaDo.Bzz » Jul 04 2018 11:11am

madin88 wrote:
Jul 04 2018 5:43am
DaDo.Bzz wrote:
Jul 03 2018 8:07pm
I did also measure hall sensors with osciloscope. Just couldnt do anything with it. So sold kls and bough kbs.
I don't know if you have connected the osci the right way to the motor, but just as info how i did:

- disconnect all wires from the controller, aside of + (plus) and - (minus) from the halls. or disconect all wires and use any other 5V supply to power the halls.
- connect one of the phase wires to - (minus) of the halls
- connect GND from the osci to - (minus) of the halls
- channel 1 needs to be connected to one hall signal (yellow, green or blue)
- channel 2 needs to be connected to one of the remaining two phase wires

ONE of the three hall signals should exactly match with the connected phase (match = same crossing of the middle line -> check my pic)
If non of the three hall signals match with the phase curve, than the motor does not have a neutral timing.
I was using a cordless drill to spin the motor :wink:
I have unplug motor. Did a floating groung with three resistors (star) from phases. Measured ground to one phase on first channel.
5V to halls and second channel to one hall. And turned motor by hand or you can constantly rotate motor with another motor. And measured all phases with all halls.

Not sure if you can connect one phase to hall ground.
LMX 81, 16S6P 60A
BBS02 on Cannondale Rz 120
BBSHD on CTM Scroll, XTR Di2, 700Wh 52V
Slovakia, Bratislava

User avatar
madin88   100 MW

100 MW
Posts: 2757
Joined: May 27 2013 2:02am
Location: Austria

Re: Kelly kls 7218s stopping hard when throttle is closed and reopened a bit

Post by madin88 » Jul 04 2018 2:36pm

DaDo.Bzz wrote:
Jul 04 2018 11:11am
Not sure if you can connect one phase to hall ground.
Yes you can connect one phase to hall GND because the windings are insulated.
As you must measure the phase- to phase voltage, one phase MUST be connected to GND of the osci. The thing with the floating ground resistors isn't necessary.
Channel 2 from to osci than connect to any of the other two remaining phase wires.
- 10kW belt drive with Neumotor 8057: viewtopic.php?f=30&t=91144&start=50#p1377787
- Fully road legal (L1E approval) e-bike based on Votec V-FR frame
/ MXUS 3T / 17" Mitas MC11 / Adaptto Max-E / 20s12p 25R
- KTM Hardtail Pedelec / eZee V2 6T / 27,5" / Kelly KBSX @ 1,5kW / Torque PAS / CA-V3 / 13s4p Sanyo GA in Shark case

Post Reply