24F Silent Controller 20kw 100-150v iOS/Android- $299>

Place for dealers to post items for sale.
User avatar
TorgueRPM   10 mW

10 mW
Posts: 26
Joined: Jan 09 2019 3:27pm
Location: Milwaukee, Wisconsin, USA

Re: 24F Silent Controller 20kw 100-150v iOS/Android- $299>

Post by TorgueRPM » May 22 2019 7:40pm

Ok, so I was going over some small bumps in the pavement and all of a sudden the motor cogs really hard and the throttle does nothing. The motors spun freely when not connected to the controller, so I checked to see if the controller connections had any shorts between them and I found one between the green phase connection and the positive battery wire.
20190522_192008_LI.jpg
When I opened up the controller I didn't find any obvious signs anything had gone wrong, but I did notice that one of the tiny capacitors had been pushed aside by the battery wire. Maybe the bumps caused the wire to break the capacitor and short it?
20190522_184500_LI.jpg

User avatar
TorgueRPM   10 mW

10 mW
Posts: 26
Joined: Jan 09 2019 3:27pm
Location: Milwaukee, Wisconsin, USA

Re: 24F Silent Controller 20kw 100-150v iOS/Android- $299>

Post by TorgueRPM » May 22 2019 8:13pm

The capacitor isn't shorted so I have no idea what the problem is


User avatar
TorgueRPM   10 mW

10 mW
Posts: 26
Joined: Jan 09 2019 3:27pm
Location: Milwaukee, Wisconsin, USA

Re: 24F Silent Controller 20kw 100-150v iOS/Android- $299>

Post by TorgueRPM » May 23 2019 12:38pm

Powervelocity.com wrote:
May 23 2019 11:09am
That looks like shorted mosfets on the green phase. Replacing those should bring it back to life.

TorgueRPM wrote:
May 22 2019 8:13pm
The capacitor isn't shorted so I have no idea what the problem is
I haven't been able to find any info on the magnachip mosfets in the controller. What could I use to replace them?

Powervelocity.com   10 kW

10 kW
Posts: 896
Joined: Mar 27 2015 2:15pm
Location: California
Contact:

Re: 24F Silent Controller 20kw 100-150v iOS/Android- $299>

Post by Powervelocity.com » May 24 2019 11:36am

They are not available in the US.
I can send you a few if you are comfortable replacing them.
PM me your address.
TorgueRPM wrote:
May 23 2019 12:38pm
Powervelocity.com wrote:
May 23 2019 11:09am
That looks like shorted mosfets on the green phase. Replacing those should bring it back to life.

TorgueRPM wrote:
May 22 2019 8:13pm
The capacitor isn't shorted so I have no idea what the problem is
I haven't been able to find any info on the magnachip mosfets in the controller. What could I use to replace them?

Ebuilt   1 W

1 W
Posts: 61
Joined: Jun 19 2018 11:27pm
Location: West coast usa

Re: 24F Silent Controller 20kw 100-150v iOS/Android- $299>

Post by Ebuilt » Jul 03 2019 11:48pm

Edit: PM incoming. Sorry for taking up space here.
:bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt: :bolt:

Trailblazer   10 W

10 W
Posts: 73
Joined: Oct 13 2012 11:26am
Location: Meridian, ID

Re: 24F Silent Controller 20kw 100-150v iOS/Android- $299>

Post by Trailblazer » Jul 12 2019 10:45am

Hello PV person.
I tried to converse with you through email, but that doesn't seem to be going well, so I'll try this.

I bought one of the 18Fet controllers almost exactly 2 years ago. The BT module is internal. I am on Android.

It seems with each software update that it has become harder to program the controller. I barely got it programmed with my new battery voltage a few days ago (took many attempts). Then I saw that there was an update for the BT Module firmware, I assume. So I applied it. It appeared to apply properly, but every time I go into settings, it wants to apply the firmware update again.
Now I can't program or communicate with the controller at all. I see that PowerVelocity-I is there, but it won't program successfully.
My wife's iPhone doesn't see any bluetooth device so no help there.

Looks like I'm having the same problem as TorgueRPM
TorgueRPM wrote:
Mar 28 2019 9:26am
I think there might be an issue with my bluetooth module. It won't connect from the app unless I connect through my phone settings first (I only tried that because it wasn't connecting). Half the time the app doesn't even see the module, but when it does and I try to connect, it turns yellow and slides down the screen before reappearing.
I am very much so willing to pay a reduced price (for previous buyers) for one of those new BT 2.0 modules that you mention here:
http://powervelocity.com/forum/viewtopic.php?f=8&t=25

Can I please get one of those ASAP? I'm down right now and having to use a car to commute is painful. Thanks!

PS The controller works fine otherwise. I have to reprogram it because I have changed battery voltage and it keeps cutting out at the LVD that I set. I can't reset that because I can't program the controller.

Powervelocity.com   10 kW

10 kW
Posts: 896
Joined: Mar 27 2015 2:15pm
Location: California
Contact:

Re: 24F Silent Controller 20kw 100-150v iOS/Android- $299>

Post by Powervelocity.com » Aug 02 2019 1:34pm

Please PM or email if you haven't done so. We should have a new module for you.
Trailblazer wrote:
Jul 12 2019 10:45am
Hello PV person.
I tried to converse with you through email, but that doesn't seem to be going well, so I'll try this.

I bought one of the 18Fet controllers almost exactly 2 years ago. The BT module is internal. I am on Android.

It seems with each software update that it has become harder to program the controller. I barely got it programmed with my new battery voltage a few days ago (took many attempts). Then I saw that there was an update for the BT Module firmware, I assume. So I applied it. It appeared to apply properly, but every time I go into settings, it wants to apply the firmware update again.
Now I can't program or communicate with the controller at all. I see that PowerVelocity-I is there, but it won't program successfully.
My wife's iPhone doesn't see any bluetooth device so no help there.

Looks like I'm having the same problem as TorgueRPM
TorgueRPM wrote:
Mar 28 2019 9:26am
I think there might be an issue with my bluetooth module. It won't connect from the app unless I connect through my phone settings first (I only tried that because it wasn't connecting). Half the time the app doesn't even see the module, but when it does and I try to connect, it turns yellow and slides down the screen before reappearing.
I am very much so willing to pay a reduced price (for previous buyers) for one of those new BT 2.0 modules that you mention here:
http://powervelocity.com/forum/viewtopic.php?f=8&t=25

Can I please get one of those ASAP? I'm down right now and having to use a car to commute is painful. Thanks!

PS The controller works fine otherwise. I have to reprogram it because I have changed battery voltage and it keeps cutting out at the LVD that I set. I can't reset that because I can't program the controller.

Post Reply