Electric kart

Electric cars, trucks, ATVs, NEVs - things bigger than a motorcycle.
User avatar
Doctorbass   100 GW

100 GW
Posts: 7425
Joined: Apr 08 2007 2:24am
Location: Quebec, Canada East
Contact:

Re: Electric kart

Post by Doctorbass » Jun 19 2017 10:06am

Here are some description of the errors of Sevcon:

http://acgcars.us/support/SEVCON_Faults_Table.pdf

Doc
CURRENT PROJECT: 2WD duo MXUS/Max-E ebike 32kW
http://endless-sphere.com/forums/viewto ... =3&t=65764
-Fastest speed record 117 km/h on flat
-Fastest 1/4 mile@ 114km/h on flat and 16.316 sec
-Succeded to haul a 19200 pounds schoolbus!
113kmh Gianthttp://www.evalbum.com/3406
Mongoosehttp://www.evalbum.com/1947
YOUTUBE---https://m.youtube.com/user/Doctorbasss
http://twitter.com/DocbassMelancon
I speak FRENCH and english

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Jul 06 2017 3:15am

Finally solved my DSP error problem and it was a very easy fix.
Just I did not saw that before that in motor signal wire socket one of the female pins were bad.
And then male pin inside female pin was moving and there was contact and not contact depending of the movement.
But to get to the cause I resoldered just in case male part of that socket and event opened motor encoder area to see are there everything ok.
And I tested with tester wires between motor and socket and between sevcon and socket and these were good. And only then I bothered to look at the socket itself :wink:

replaced this bad pin and now everything works like new.
Here is picture of that bad pin :twisted:
MotorSocket.jpg
MotorSocket.jpg (162.5 KiB) Viewed 2996 times

Badkad   100 µW

100 µW
Posts: 7
Joined: Jun 04 2016 11:07am

Re: Electric kart

Post by Badkad » Jul 10 2017 2:13pm

Where can I get that Z-force motor from?

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Jul 11 2017 9:04am

Badkad wrote:Where can I get that Z-force motor from?
I got my motor from this thread, but that was a year ago :)
https://endless-sphere.com/forums/viewt ... 30&t=81009

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Aug 13 2017 7:52am

Tested Zero air-through cooling this weekend in a race that was very acceleration and braking intensive and motor was not able to cool itself enough by pumping air through by itself.
Theoretically inner rotor should act as tesla turbine and I actually felt the air through motor very well when wheels in air and rotating in 5000rpm.
So it seems I need to install active air cooling, two powerful centrifugal vents to pump air trough at faster speed that motor itself can do :)
Video of first race when I hit the wall, because I lost rear brakes also due overheating :(
https://www.youtube.com/watch?v=uEmZBzaQNuo
Attachments
Motor1.jpg
Motor2.jpg
Motor2.jpg (221.87 KiB) Viewed 2846 times

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Sep 05 2017 2:09pm

Installed forced air cooling to the motor and tested acceleration.
This should be not official word record with electric kart acceleration.
https://www.youtube.com/watch?v=2Xp41u1y9KI
2,640 seconds to 100km/h and 0-60mph is even faster in 2.577 seconds as 60mph=96,5km/h

This should be current official record I think to 60mph
https://www.youtube.com/watch?v=r0b6UoxqrPE

But in that track forced cooling is not enough for 10 laps. I can do sprint like 7 or 8 laps only.
Attachments
Cooling1.jpg
Cooling1.jpg (109.05 KiB) Viewed 2762 times
Cooling2.jpg
Cooling2.jpg (139.58 KiB) Viewed 2762 times
Cooling3.jpg
Cooling3.jpg (116.17 KiB) Viewed 2762 times
Cooling4.jpg
Cooling4.jpg (119.17 KiB) Viewed 2762 times

User avatar
amberwolf   100 GW

100 GW
Posts: 25145
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Electric kart

Post by amberwolf » Sep 05 2017 2:28pm

As an experiment you might try flipping the fans and expanding the duct so that they suck the air thru the motor instead of trying to force it in.

When I did computer cooling I found that worked better (less noise, which means less turbulence, less wasted power, more cooling airflow).


Or use a single larger fan shaped just like those but with it's intake the size of the outlet ring on the motor, and place it directly against that outlet ring (or spaced a short distance away with a ring between them).

Hillhater   100 GW

100 GW
Posts: 9266
Joined: Aug 03 2010 10:33pm
Location: Sydney ..(Hilly part !) .. Australia/ Down under !

Re: Electric kart

Post by Hillhater » Sep 05 2017 6:37pm

Very impressive 0-100 run.....mainly because i dont figure how you got enough grip.
Every kart i have used (regular 2t race karts) have always had more power than grip..even with good warm tyres.?
Also , depending on your definition od a "kart" , im sure you are aware of the 1.51 sec time from this...
https://youtu.be/n2XiCYA3C9s
This forum owes its existence to Justin of ebikes.ca

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Sep 06 2017 3:38am

amberwolf wrote:As an experiment you might try flipping the fans and expanding the duct so that they suck the air thru the motor instead of trying to force it in.
Or use a single larger fan shaped just like those but with it's intake the size of the outlet ring on the motor, and place it directly against that outlet ring (or spaced a short distance away with a ring between them).
Can't do that because motor has opening around encoder in one side and opening in the edges in sprocket side. So rotor itself using tsentrifugal force will push air from encoder side to sprocket side.
And I can't install blower in sprocket side for sucking air.
I will try to install two more blowers if I have time.
But in the end it is very hard to remove 4kw to 9kw of heat so rapidly like I need in the racetrack.
If I stop then it cools very fast.

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Sep 06 2017 5:20am

Hillhater wrote:Very impressive 0-100 run.....mainly because i dont figure how you got enough grip.
Every kart i have used (regular 2t race karts) have always had more power than grip..even with good warm tyres.?
When I did acceleration test last year I had old hard tires and outside was 11 degrees.
This time we had soft White VEGA tires that we had run like 20 laps. So grip was very good.
We also started in the corner where there was rubber in asphalt but even then he succeeded to spin tires couple of times :)
Hillhater wrote:Also , depending on your definition od a "kart" , im sure you are aware of the 1.51 sec time from this...
https://youtu.be/n2XiCYA3C9s
Yeah, I know this, but this is 4WD and not comparable to kart. They also have suspensions and bigger tires (wider and bigger in diameter)
But how did they measured the time? Formula student actually have in competition acceleration test, but this is 0 to 75 meters test.
And I would like to officially measure my time, but I do not now what equipment I should use that will make it official?

PS! I also analyzed again and used data from cycle analyst started the clock when speed went to 1km/h.
And with that it's 2,507 to 100kmh. It took 40 meters to reach it.
https://youtu.be/eb4UeH0XcJU

User avatar
craigcalfee   10 µW

10 µW
Posts: 5
Joined: Jun 20 2016 8:09pm
Location: La Selva Beach, California, near Santa Cruz
Contact:

Re: Electric kart

Post by craigcalfee » Sep 06 2017 11:20am

Your fan size seems too small. When we bench tested that motor, a lot of air pressure is generated. That fan doesn't look like it would add much velocity to it. And the ducting is not so good for laminar flow. But good progress! Looking forward to the next improvement!
Craig Calfee

Calfee Design
Bicycles, E Bikes, E Motorcycles, Gyrocycles, Prototyping and Consulting
calfeedesign.com

Hillhater   100 GW

100 GW
Posts: 9266
Joined: Aug 03 2010 10:33pm
Location: Sydney ..(Hilly part !) .. Australia/ Down under !

Re: Electric kart

Post by Hillhater » Sep 06 2017 5:55pm

nuxland wrote:[
Hillhater wrote:Also , depending on your definition od a "kart" , im sure you are aware of the 1.51 sec time from this...
https://youtu.be/n2XiCYA3C9s
Yeah, I know this, but this is 4WD and not comparable to kart. ......
Thats the issue...Once you diverge from the common FIM/CIK specification a "Kart" , (motors, chassis, wheels , tyres etc) then you are in an "unregulated" area and as such there is no restrictions on what you use or what you call it.
there are karts in the USA that run 6", 8", and 10" dia x 10" wide tyres, karts with 4 wheel drive, fully enclosed bodywork, and a whole range of odball drive systems.
But i basicly agree, a "Kart" should have as a base, a solid rear drive axle, no suspension .and a ? Limit on wheel size.
This forum owes its existence to Justin of ebikes.ca

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Sep 07 2017 3:34am

craigcalfee wrote:Your fan size seems too small. When we bench tested that motor, a lot of air pressure is generated. That fan doesn't look like it would add much velocity to it. And the ducting is not so good for laminar flow. But good progress! Looking forward to the next improvement!
I'm using two of these fans 09533GA-12Q-AA-00 and according to specs they provide good airflow against pressure.
I'm considering to add two more or upgrade to bigger one, but I have little room there so need to think of something.
Attachments
Blower.png
Blower.png (158.1 KiB) Viewed 2693 times

User avatar
fechter   100 GW

100 GW
Posts: 12929
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: Electric kart

Post by fechter » Sep 08 2017 8:21am

You could bump the fan voltage up to 15-16v. :wink:
It looks like the air passages through the motor are fairly small, so you need those centrifugal blowers. I can't tell from the pics what kind of cross sectional area the air passages have inside.
You could also blow air over the fins on the outside of the motor but it won't be as effective as blowing through the windings.
"One test is worth a thousand opinions"

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Oct 20 2017 6:21am

They built a brand new kart track near Tartu, Lange. It's not finished yet and will open spring 2018 but they let me try out that track.
In in the same day there were also one guy with Estonian formula student car from the year 2008. So we both tested that track.
I recorded a video also. But as this was our first run on that track we were easy and track was also moist a little bit.
https://www.youtube.com/watch?v=6R7st79kbps
I think this was my last driving this year as it's already minus degrees in night time.
I hope I can finish installing second controller + motor + battery to kart and try 1/4 mile next spring with 110kw and 210kg kart :)

SlowCo   10 kW

10 kW
Posts: 918
Joined: Jan 05 2015 5:43pm
Location: The Netherlands

Re: Electric kart

Post by SlowCo » Oct 20 2017 10:36am

Great video!
Love to see your progress on installing the second controller, motor and battery. Curious what your 1/4 mile time will be :shock:

LuigiDesign   1 µW

1 µW
Posts: 3
Joined: Jan 11 2017 1:46pm

Re: Electric kart

Post by LuigiDesign » Dec 03 2017 5:59pm

Hi Nuxland again! Very busy last months... :roll:

There are few things that I can comment, first one, you are getting better and better!

-When you are on field weakening state, it is caused by the motor is above max modulation, meaning, back emf is equal to max volts delivered to the motor due to higher rpms than nominal. Then, needs to compensate angle of shot with -id to still giving you torque at higher rpms, but have 2 issues, as soon you change the angle of shot you lose efficiency rapidly, you must to consider then change the final ratio to be on max torque curve. And the fatal and second one, if you abuse of this and lets the motor heat up enough, you can demagnetise permanently the magnets......

In the other hand, I suggest to check if,
-Encoder is at its best ofset.
-If field weakening gains operation is modulating properly, enough -iq amps?.
-Ls is tracking?

If you send me screenshots of dvt motor data config and logs of vehicle interface during a run I'll try to help you if you need it.

Regards!
Luigi

User avatar
Quinc   10 W

10 W
Posts: 93
Joined: Apr 18 2016 11:21am

Re: Electric kart

Post by Quinc » Dec 06 2017 4:22pm

Image

User avatar
h0tr0d   1 kW

1 kW
Posts: 460
Joined: Apr 28 2012 5:17pm

Re: Electric kart

Post by h0tr0d » Jan 06 2018 8:41pm

Awesome results and evolution!!!
Thank you Justin! Life is so much sweeter with this forum... ;)

User avatar
macribs   1 GW

1 GW
Posts: 3481
Joined: Jul 22 2014 5:59pm

Re: Electric kart

Post by macribs » Jan 14 2018 4:59pm

Yeah this have been an epic thread. Look forward to see what is possible with dual controllers.

GeriatricGeoffrey   1 mW

1 mW
Posts: 19
Joined: Jan 10 2018 6:04pm

Re: Electric kart

Post by GeriatricGeoffrey » Jan 17 2018 12:10am

looks fun. estimated cost so far?

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Feb 10 2018 2:17pm

Was having I little setback with battery. Forgot motor cooling fan dc/dc connected to battery for 2 months. And battery was only 10Ah from 40Ah. Result was devastating 0V the whole battery. From 68 cells or 34 cellpairs 11 pairs or 22 cells broke (did not hold voltage anymore).
This was the first image I made when using laboratory power supply to get inital voltage back to the battery.
EmptyFirstCharge.JPEG
EmptyFirstCharge.JPEG (217.31 KiB) Viewed 1533 times
Here I have charged cells and disconnected problematic pairs and concluded the pairs I have to replace.
EmptyChangeCells.JPEG
Then I charged them to full and it seems 3 more pairs are not completly ok and their voltage dropped event other did not.
EmptyThreeMore.JPG
EmptyThreeMore.JPG (193.38 KiB) Viewed 1533 times
So I'm now in the middle of replacing these cells also. And it had taken me more than two months, so my plan to install two controllers has now postponed until I get this battery working again.
Usually I checked my battery once or twice a month, but this time forgot. Never again will this happen again :twisted:

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Feb 13 2018 3:42pm

Got the battery back together today to test it with bigger current. So installed it on kart and simulated load with brake (you can do it only like 5s and then you have to cool brakedisk back down :). But I'm impressed with these cells. They were at 0V for some time and can still give out 350A and drop only to 2,9V :) Have to wait until snow is gone, to test with more current (it can be done only outside)
Load.png
Load.png (53.07 KiB) Viewed 1495 times
But sad part is that 24 cells from total of 68 got hurt with it and had to be replaced. Some of them can hold some charge and I think there is at least 4 that can hold 3.2v. So I can make 12V battery with these to my honda GX200 with turbo and fuel injection if I will ever finish it :)

hallkbrdz   1 µW

1 µW
Posts: 1
Joined: Mar 24 2018 1:47pm
Contact:

Re: Electric kart

Post by hallkbrdz » Mar 24 2018 1:59pm

Hey - found your thread! :D

That weight is quite good. My 80cc shifter with me and fuel is about 208 Kg. Of course it doesn't help much that I'm about 95 Kg's of that weight. I'd really like to pursue a setup like this instead of upgrading to a 125 KTM setup with the Mechatron paddle shifter.
Simplicity is Perfection - Add lightness

User avatar
nuxland   100 W

100 W
Posts: 138
Joined: Apr 04 2015 2:18pm
Location: Tallinn

Re: Electric kart

Post by nuxland » Apr 02 2018 1:40pm

Got myself a iCharger 4010Duo to balance my repaired pack (even made two sets of charge and balance wires with crocodile endings).
wires.jpg
And as always did not read the manual at first :( (RTFM is a must next time) So connected both sideof the charger to same pack and caboom one side (right one) of charger was dead. Anyhow I then balanced the pack with one side. And a good thing is that iCharger also calculated IR-s.
IR.jpg
IR.jpg (233.4 KiB) Viewed 891 times
PS! repaired also the charger afterwards, only 4x 15A fuses and one diod where burned away :)
diod.jpg
diod.jpg (222.8 KiB) Viewed 1110 times
fuses.jpg
Last edited by nuxland on Apr 02 2018 2:22pm, edited 1 time in total.

Post Reply