10S custom skate ESC: testers wanted!

Lightweight / Folding / Portable EVs - seats optional
User avatar
whitepony   10 kW

10 kW
Posts: 663
Joined: Feb 19 2015 12:37pm

Re: 10S custom skate ESC: testers wanted!

Post by whitepony » Jan 02 2016 11:55am

I got one of the latest enertion vesc 4.10 batches and tried it today - flashed 1.14 to the 2.7 FOC release. autodetection worked flawlessly, motor spinup was smooth, probably needs a slighty increased startup boost, otherwise Im really exited about the unit and the little noise it makes. :)

really really great job - basically I had no idea about VESC useage and it took me 20min to set everything up. doesnt get any more user friendly! :D


User avatar
chaka   1 kW

1 kW
Posts: 303
Joined: Jul 02 2015 2:42pm
Location: New Mexico

Re: 10S custom skate ESC: testers wanted!

Post by chaka » Jan 02 2016 4:01pm

scoobiext wrote:That looks awesome Chaka, how do you have the CAN bus wired? Are all 4 controllers on the one bus? What are the plans for the board/s?

The heat shinks are the icing on the cake, nice work.
I set this up wired for ppm input split off one receiver and also made a CANBUS splitter in case the customer wanted to implement that at a later date.

eiprol   1 mW

1 mW
Posts: 18
Joined: Oct 07 2015 6:23pm

Re: 10S custom skate ESC: testers wanted!

Post by eiprol » Jan 02 2016 9:36pm

Hi guys!

I just fot my VESC 4.10 a few days ago, and I'm still finishing my first eBoard!
It's my first time with BLDC and VESC too, so I'm still confuse about many things... But it works!

However, I was giving a try to this new FOC feature, and when I try to read the parameters (R, etc) from my r-spec motor, it fails and kind of blocks the motor, starting an annoying sound after failing, and blinking the red light on the VESC...
:( :shock: any idea?

User avatar
chaka   1 kW

1 kW
Posts: 303
Joined: Jul 02 2015 2:42pm
Location: New Mexico

Re: 10S custom skate ESC: testers wanted!

Post by chaka » Jan 02 2016 10:59pm

Are you sure it is failing? Have you checked for faults? Does it still work running under BLDC configuration?

eiprol   1 mW

1 mW
Posts: 18
Joined: Oct 07 2015 6:23pm

Re: 10S custom skate ESC: testers wanted!

Post by eiprol » Jan 03 2016 6:06am

chaka wrote:Are you sure it is failing? Have you checked for faults? Does it still work running under BLDC configuration?
You were right, I was being dumb. When I hit "measure R and L", after a first quiet noise, it started doing a really loud noise for more than two seconds, and I thought that something was going wrong, and concerned about the life of the motor, I switched off the power of the VESC everytime to prevent any kind of motor damage :roll: ... But yes, now it's working fine, thank you!

The only thing now, is that I really don't appreciate any difference between BLDC and FOC... I'm sure it has to be different, so, what should I be looking for :lol: ? The only thing is that in BLDC my motor reaches 44000rpm, and in FOC it only goes to 41000rpm...

And, another thing related to this; how many rpm should I be getting with a rspec190KV, 9S Zippy Lipo 5000maH? I'm getting inconsistent lectures and speeds within the same charge (yesterday only 30.000rpm, and a few minutes before, way more than 50000rpm)

To sum up, is there any guide (or a XML file) to really set up my VESC to fully work with my rspec motor :P ?

User avatar
chaka   1 kW

1 kW
Posts: 303
Joined: Jul 02 2015 2:42pm
Location: New Mexico

Re: 10S custom skate ESC: testers wanted!

Post by chaka » Jan 03 2016 11:47am

FOC is almost silent while under load and a bit more efficient than using BLDC. As you have noticed FOC will shave a little off the top end compared to BLDC.

You are running with a very low capacity pack. Double or triple the capacity you currently have and it will have a much happier life and smooth out the voltage fluctuations under load. This is my best guess to the fluctuation you are seeing on your max erpm.

Pedrodemio   10 W

10 W
Posts: 82
Joined: Jun 30 2015 8:38pm
Location: Brazil

Re: 10S custom skate ESC: testers wanted!

Post by Pedrodemio » Jan 03 2016 1:18pm

Hello guys

Anyone know how can i measure the motor temperature in BLDC Tool? i connected my motor temperature sensor to VESC but there is no way to tell if it's working, and in the terminal help there is no command for temperature

Hummina Shadeeba   1 MW

1 MW
Posts: 1728
Joined: Apr 25 2014 10:26pm

Re: 10S custom skate ESC: testers wanted!

Post by Hummina Shadeeba » Jan 03 2016 1:48pm

it'd be great if someone who at least had a half-decent grasp of setting it up could do a video for dummies. Maybe I'm missing some of the videos out there. I've seen vedder's and (I forget his name now but the European guy who sells them) but they don't go through all the features. If I hadn't had a friend come over and set it up with me I likely wouldn't have gotten even the bldc program downloaded and going. I'd like to set up the foc but don't know where to search for info. I find the vesc is not complicated to set up but until you know what you're doing it is. I never do anything on a computer but watch my shows, shop, play chess, and get on ES so the set-up was foreign. If there was a resource that answered all the questions then we wouldn't constantly be asking questions.

jacobbloy   100 W

100 W
Posts: 237
Joined: Feb 12 2013 4:45pm

Re: 10S custom skate ESC: testers wanted!

Post by jacobbloy » Jan 04 2016 10:05am

updated BLDC TOOL for the vesc to FW2.8 with FOC to day for windows and OS X.

hope every body enjoys.

windows
https://drive.google.com/file/d/0Bym9Xr ... sp=sharing

OS X
https://drive.google.com/file/d/0Bym9Xr ... sp=sharing

User avatar
whitepony   10 kW

10 kW
Posts: 663
Joined: Feb 19 2015 12:37pm

Re: 10S custom skate ESC: testers wanted!

Post by whitepony » Jan 04 2016 12:59pm

thank you for your effort - your google drive has been a major contribution to make my first vesc contact a successful one :D

User avatar
Nordle   100 W

100 W
Posts: 182
Joined: Jul 20 2015 1:42pm
Location: The Alps

Re: 10S custom skate ESC: testers wanted!

Post by Nordle » Jan 04 2016 2:12pm

jacobbloy wrote:updated BLDC TOOL for the vesc to FW2.8 with FOC to day for windows and OS X.

hope every body enjoys.

windows
https://drive.google.com/file/d/0Bym9Xr ... sp=sharing

OS X
https://drive.google.com/file/d/0Bym9Xr ... sp=sharing
That's great!

Can someone tell me why I always get ''unknown error''? I have Version 1.1, HW 4.7. Tried on both BLDC tools (yours and for FW 1.1). After the Error I have to repower my VESC otherwise it does anything and can't be detectef from BLDC tool.
4:20 Noob Hubz! BLAZE it
..sry for dat poor english..

elkick   100 W

100 W
Posts: 127
Joined: Nov 13 2014 3:45am
Location: Hamburg

Re: 10S custom skate ESC: testers wanted!

Post by elkick » Jan 04 2016 2:24pm

You might try the following on BLDC-Tool v2.8:

- start BLDC tool 2.8 and connect USB cable to VESC
- connect
- Firmware Tab: choose Firmware 2.8 (in folder hw_460_470!)
- hit upload (now you will be stuck, but no worries)
- leave everything like it is (BLDC must stay where it is)
- power VESC off and on again (don't disconnect USB cable!)
- hit connect again
- acknowledge "outdated Firmware"-message
- hit upload again and it should now upload the FW

If this doesn't work you might have to reinstall the bootloader with a STlinkv2 again. Were you ever able to update your FW before?
http://www.esk8.de/vesc VESC V4.12 - made in Germany
http://www.esk8.de/shop General eSkateboard parts

User avatar
Nordle   100 W

100 W
Posts: 182
Joined: Jul 20 2015 1:42pm
Location: The Alps

Re: 10S custom skate ESC: testers wanted!

Post by Nordle » Jan 04 2016 2:40pm

thx, very fast reply
elkick wrote:You might try the following on BLDC-Tool v2.8:

- start BLDC tool 2.8 and connect USB cable to VESC
- connect
- Firmware Tab: choose Firmware 2.8 (in folder hw_460_470!)
- hit upload (now you will be stuck, but no worries)
- leave everything like it is (BLDC must stay where it is)
- power VESC off and on again (don't disconnect USB cable!)
after that point it's like i did anything, uploading firmware seems to just disconnect and freeze my VESC till i restart it.
elkick wrote: If this doesn't work you might have to reinstall the bootloader with a STlinkv2 again. Were you ever able to update your FW before?
What is that? Didn't try before.
4:20 Noob Hubz! BLAZE it
..sry for dat poor english..

elkick   100 W

100 W
Posts: 127
Joined: Nov 13 2014 3:45am
Location: Hamburg

Re: 10S custom skate ESC: testers wanted!

Post by elkick » Jan 04 2016 3:14pm

If you have not yet tried to upload a new firmware until now it could be that your VESC is not containing a bootloader which is required to upload a new firmware to your VESC.

I know that there were some VESCs without bootloader (or not functioning ones) in the past. I was having four of those from different sources. The only way solving this is by uploading the bootloader manually with a STlinkv2 connection under Ubuntu. If you're in Europe I could do that for you (for free of course, that only takes a few minutes).
http://www.esk8.de/vesc VESC V4.12 - made in Germany
http://www.esk8.de/shop General eSkateboard parts

User avatar
okp   100 kW

100 kW
Posts: 1153
Joined: Oct 26 2014 3:27pm
Location: Paris
Contact:

Re: 10S custom skate ESC: testers wanted!

Post by okp » Jan 04 2016 3:14pm

hope it helps guys.

Last edited by okp on Jan 04 2016 6:13pm, edited 1 time in total.

jacobbloy   100 W

100 W
Posts: 237
Joined: Feb 12 2013 4:45pm

Re: 10S custom skate ESC: testers wanted!

Post by jacobbloy » Jan 04 2016 3:16pm

Because you probs don't have a bootloader

User avatar
whitepony   10 kW

10 kW
Posts: 663
Joined: Feb 19 2015 12:37pm

Re: 10S custom skate ESC: testers wanted!

Post by whitepony » Jan 04 2016 5:07pm

okp wrote:hope it helps guys.
great effort, just one little details: you measure lambda before you measure R (resistance). in the lambda measurement, it explicitly says "req. R", so if you just follow the GUI, you should measure R and L (inductance) before measuring lambda?

User avatar
okp   100 kW

100 kW
Posts: 1153
Joined: Oct 26 2014 3:27pm
Location: Paris
Contact:

Re: 10S custom skate ESC: testers wanted!

Post by okp » Jan 04 2016 5:14pm

Yes, I think I read that somewhere; I will ask Benjamin and modify this if necessary.
vedder wrote:R and L can be autodetected without starting the motor, and lambda (flux linkage) can be detected by spinning up the motor in bldc delay commutation mode. These are the important parameters to get the sensorless observer running. There is also automatic PI current control parameter calculation as described here (the time constant has to be chosen, but this is not critical for eboards):
https://e2e.ti.com/blogs_/b/motordrivec ... ve-part-ii.

jacobbloy   100 W

100 W
Posts: 237
Joined: Feb 12 2013 4:45pm

Re: 10S custom skate ESC: testers wanted!

Post by jacobbloy » Jan 04 2016 5:21pm

okp wrote:hope it helps guys.

hey, tour vid is great, just wanted to add that there is an apply button in v2.8 for motor detection that will copy the limits in automatically saves 1 sec lol

User avatar
okp   100 kW

100 kW
Posts: 1153
Joined: Oct 26 2014 3:27pm
Location: Paris
Contact:

Re: 10S custom skate ESC: testers wanted!

Post by okp » Jan 04 2016 5:29pm

thanks !

by the way, should we measure lambda before R and L or is Lambda a prerequisite for R & L measurement ?

Pedrodemio   10 W

10 W
Posts: 82
Joined: Jun 30 2015 8:38pm
Location: Brazil

Re: 10S custom skate ESC: testers wanted!

Post by Pedrodemio » Jan 06 2016 6:33am

Guys, caution with firmware 2.8, i don't know if is fault but it is the only thing i changed

Is was ridding a few minutes ago and in max speed the VESC suddenly applied full brake, hands and one of the knees aching pretty bad, but is superficial

From now on i will only ride with full protection

What i found strange is the full brake way beyond the max brake current, so probably has nothing to do with the radio, when i tried to plug it in the BLDC tool as soon i touched the usb connector the motor started spinning to both sides at random, weird again, since reverse is disabled, and for last there were no faults logged

Ride safe

jacobbloy   100 W

100 W
Posts: 237
Joined: Feb 12 2013 4:45pm

Re: 10S custom skate ESC: testers wanted!

Post by jacobbloy » Jan 06 2016 6:46am

i would start with refreshing the firmware, then re doing motor detection while also checking all of your wiring, then make sure that where your are located there isn't crazy amounts of rf, it can interfere but very unlikely, there is a study done buy 2 guys who hacked and controlled a boosted board e-go ad evolve just but filling the 2.4 spectrum with noise they did this because the same thing happen to one of them on his boosted board.

User avatar
okp   100 kW

100 kW
Posts: 1153
Joined: Oct 26 2014 3:27pm
Location: Paris
Contact:

Re: 10S custom skate ESC: testers wanted!

Post by okp » Jan 06 2016 6:50am

hey pedro, sorry for that... which transmitter were you using?

Pedrodemio   10 W

10 W
Posts: 82
Joined: Jun 30 2015 8:38pm
Location: Brazil

Re: 10S custom skate ESC: testers wanted!

Post by Pedrodemio » Jan 06 2016 7:16am

jacobbloy wrote:i would start with refreshing the firmware, then re doing motor detection while also checking all of your wiring, then make sure that where your are located there isn't crazy amounts of rf, it can interfere but very unlikely, there is a study done buy 2 guys who hacked and controlled a boosted board e-go ad evolve just but filling the 2.4 spectrum with noise they did this because the same thing happen to one of them on his boosted board.
I just downgraded to 2.7 and re-configuring it, but probably wont ride in the next few days, i live in a few kilometers away from town, and i was ridding in the road that connect it to the city, so not much there except from a low voltage power line that was more than 10m away, and i rode this exactly place lots of times

But in this case you mentioned they did that by confusing the raio input, since in my case i were full brake for the motor, a lot more than i can get giving full brake in the remote via current control i suspect something happened in VESC itsel. I re-checked all configuration and there was nothing that would cause full brake in case of signal loss
okp wrote:hey pedro, sorry for that... which transmitter were you using?
I am using the NRF modules with arduino and connected to vesc via PPM, as i said above, due the nature of the brake force i don't think is was related to radio communication, in the arduino code i have a fail safe to reset everything to neutral in case i get radio drop or problems with communication

Did you update to 2.8 yet?

EDIT:

Hum, apparently my NRF module was a little loose on the connector, i was delaying to weld everything because i was ridding a lot lately , but even if it came loose it does not explain the full brake

EDIT2:

And again, apparently my fail safe is not so safe in fails, it works good with a signal loss, or if the remote shut down, but if remove the module the PPM output goes crazy and start to oscillate between 0 and 100% at random several times per second

Maybe this could cause some trouble on VESC? even after i could get up again the motor remained full on full brake

And a tip for everyone duct tape is not a good measure to prevent vibrations from disconnecting connectors :|

User avatar
okp   100 kW

100 kW
Posts: 1153
Joined: Oct 26 2014 3:27pm
Location: Paris
Contact:

Re: 10S custom skate ESC: testers wanted!

Post by okp » Jan 06 2016 2:13pm

yes I did upgrade to 2.8 and ride a lot and no problem whatsoever, you should go with GT2B to remove the NRF variable

Post Reply