FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Lightweight / Folding / Portable EVs - seats optional
Post Reply
xlzeo   10 W

10 W
Posts: 99
Joined: Aug 09 2012 1:03am
Location: israel

FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by xlzeo » Sep 29 2016 12:51am

hi guys,i just want to share with all of you a really important bad expiriance i am having with dexter from diyelectric skateboard.
i have made couple of orders over the time , with total amount of over then 800$USD.
i have purchase the welded motor mount kit becuase he advised to do so and used it for 2 month's.
just to make it clear- im riding very come and very slow i dont do anything extremy.
after so little time the motor mount just broke, it had big nasty crack in it.
besides the fact this kit is unsafe and it could seriously injured me.
dexter service is just thw worst i had, he just ingore my massages and never offered alternative or solution.
be aware , i wont buy from him again.
picture: https://s21.postimg.org/59nd0xhaf/crack.jpg

fuelre   10 mW

10 mW
Posts: 31
Joined: Mar 11 2015 10:54am

Re: FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by fuelre » Sep 29 2016 2:02pm

give him some time, he is realy busy.
But he tries always to make the customer happy, if you give him the chance.
I broke a part from my BoltOn Mount. I wrote him a simple email with 2 pictures. He answered me around 2 Weeks later with the question, if we could share the shipping costs (International shipping - 40$)
It was fine for me , and I got my replacement without further cost.

But I think its a bit harder to change the whole truck with the mount welded on it.
Maybe he gives you a discount for a Bolton Motor Mount.

hopefully you understand what I mean - thats not my native language.

MagiicHat   10 mW

10 mW
Posts: 28
Joined: Aug 31 2016 12:06pm

Re: FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by MagiicHat » Sep 29 2016 2:07pm

Looks like you smacked the crap out of that mount. Big gouge and bent sideways? Are you sure you didn't take this thing off a curb or something?

User avatar
okp   100 kW

100 kW
Posts: 1153
Joined: Oct 26 2014 3:27pm
Location: Paris
Contact:

Re: FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by okp » Sep 29 2016 2:12pm

relax, this happens. Dexter is a really good guy.

BTW, if you want a really dope mount... get a UNIK one. I designed them.... and you don't need epoxy or whatsoever to make them get out of alignement.

User avatar
sl33py   10 kW

10 kW
Posts: 686
Joined: Apr 24 2015 5:21pm
Location: Seattle, WA

Re: FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by sl33py » Sep 29 2016 6:40pm

unfortunately i think you've been quick to actively bash his company on here and esk8 B...

You may have it as well, but we have a saying (idiom) - "you get more flies with honey than vinegar."

So instead of asking him for help, and waiting patiently for his review/decision - you are actively bashing his company. This makes it less likely he is going to bend over backwards, or go the extra mile, to help you out.

The mount looks like it hit something - hard enough to leave a pretty good gouge/scrape. Chalk it up to user error and time to buy another mount would be my expectation.

if you have everything else you need, except a mount, i'd get a bolt-on one from any vendor of your choice (APS, Enertion, etc.). Quite a few folks have made their own and sell an extra set or two for a great price. Still will need at least a new Paris hanger. Might be easier to get a set of Caliber trucks as more mounts are made for them (they aren't round so easier ot keep mount secure from rotating).

Good luck!

xlzeo   10 W

10 W
Posts: 99
Joined: Aug 09 2012 1:03am
Location: israel

Re: FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by xlzeo » Sep 30 2016 12:26am

sl33py wrote:unfortunately i think you've been quick to actively bash his company on here and esk8 B...

You may have it as well, but we have a saying (idiom) - "you get more flies with honey than vinegar."

So instead of asking him for help, and waiting patiently for his review/decision - you are actively bashing his company. This makes it less likely he is going to bend over backwards, or go the extra mile, to help you out.

The mount looks like it hit something - hard enough to leave a pretty good gouge/scrape. Chalk it up to user error and time to buy another mount would be my expectation.

if you have everything else you need, except a mount, i'd get a bolt-on one from any vendor of your choice (APS, Enertion, etc.). Quite a few folks have made their own and sell an extra set or two for a great price. Still will need at least a new Paris hanger. Might be easier to get a set of Caliber trucks as more mounts are made for them (they aren't round so easier ot keep mount secure from rotating).

Good luck!
thats not the case- , those forums are here to share everything, the good and the bad - i didn't wrote those threads to hurt him or anybody. i have spent so much money on hes store, and honestly i had bad expriance in the whole porcess, he gave me hard time on the purchase, on shipment and later on when i needed hes help, im not the person which will spam hes email/ chat .
on the 21th i have wrote to him on chat and explained the issue im having, then he ask me about my order ID, (thats was hes last and only respond) i immidately respond and from this moment on.. he didnt respond to my msaasges and my emails.
may be i delirious , but thats how you ignore some one.

i gave him 8 days to respond , i think its more then enough.
he dont feel responsible for the lack in hes service/ products - he is sure hes doing everything like a charm.
we spoke today again and suddenly he was responding, and blaming me for sharing my expiriance on the net , in our conversation - its my fualt the mount snaped, its my fualt he didnt respond, and its surly my resposibily, to short it out.
i can see whey its harm when some one leaves you bad feedback, im runing a business also, it does piss, but when ever i have issues with costumer , i make sure to respond in 2 days max.
and even if got a bad feedback its still my responsibilty as a seller to solve the problem.
i honestly got the feeling hes ignoreing me and trying to avoid to offer a solution - its simple as that.

User avatar
okp   100 kW

100 kW
Posts: 1153
Joined: Oct 26 2014 3:27pm
Location: Paris
Contact:

Re: FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by okp » Sep 30 2016 1:19am

yeah, I can understand. We have all been through this kind of situation which is frustrating; I would say that keep in mind that even if it is business... that most if not all the DIY industry is run by hobbyists with ... hobbyist processes even if they sometimes fails, can also be really great and flexible. That's not an excuse, but much more something that must be taken into consideration.

Today, I have basically destroyed ALL the mounts in the DIY industry (but I had a great fun with them). Most of them had design issues or were too complex, too many screws,too difficult to get in alignement and keep it aligned, maybe also a low testing as I am not sure that all DIY hobbyist sellers are riding hard. I have been skateboarding for now like 20 years and I ride a lot. I am actually one, if not the first to pull a jump on an electric skateboard with hooks, or go to some mad wheelings. Having products is good, but getting them on the dirty side of things (even if you will not cover 100%) is mandatory.

That being said, Dexter is a really nice guy and this can happen. You can search all the forums, you will see a lot of people complaining for some good or bad reasons on each and everyone of the DIY sellers.... but unfortunately, your message will be like every other one... legacy.

Happy riding !

stealth71   10 W

10 W
Posts: 75
Joined: Oct 23 2015 3:11pm

Re: FAULTY ITEMS AND BAD SERVICE FROM DIYELECTRICSKATEBOARDS

Post by stealth71 » Oct 04 2016 8:52am

I can see what happened to make it break. I had a similar problem with his drive pulley. The wheel drive pulley gets sucked in to close to the wheel and the belt drags on the edge of the wheel. This creates a lateral force on the mount and it snapped. His drive pulleys sit too close to the face of the wheel and causes this to happen. At least I think that is why my last mount broke (not diyelectricskateboard mount) as well as lack of material on the mount in critical places.

Try getting in touch again and see what you can work out. I had decent customer service from them, but also had some emails not returned.

Post Reply