Evolve Carbon Gen 2 - need bms

Lightweight / Folding / Portable EVs - seats optional
Post Reply
one4torque   1 kW

1 kW
Posts: 336
Joined: Dec 28 2015 8:29pm
Location: Texas, fighting entropy one build at a time...

Evolve Carbon Gen 2 - need bms

Post by one4torque » Dec 23 2017 5:39pm

Hello ES folks... I've recently become addicted to eboards...... I picked up a used evolve gen 2 carbon board, and after 2 rides the BMS burned up. I checked the battery has 42 volts...... but the bms is fried.

Can I source a suitable replacement somewhere that I can just solder in, or is my best bet sourcing through Evolve people?

Best Regards - Jeff Houston
sucka free since 1968

uglyduck   1 µW

1 µW
Posts: 2
Joined: Mar 10 2018 11:57pm

Re: Evolve Carbon Gen 2 - need bms

Post by uglyduck » Mar 11 2018 12:07am

DO NOT BUY EVOLVE SKATEBOARDS

THEY ARE JUNK,, READ FOLLOWING CONSUMER AFFAIRS COMPLAINT BEFORE YOU PURCHASE!!!
****************************************************************************************************************

Case Assessment and Response Unit
Office of Fair Trading
GPO Box 3111
BRISBANE, QLD, 4001
Re: Consumer complaint against Evolve Skateboards
Dear Sir/Madam,
I wish to lodge a complaint against electric-skateboard manufacturer Evolve Skateboards based at Varsity Lakes on the Gold Coast. I have had the worst consumer experience I could have ever imagined possible with Evolve Skateboards, and the matter remains unresolved.
I purchased Evolve’s latest model carbon-fibre electric-skateboard back in early June 2016 at a cost of $2,159. For that price, I never expected the nightmare that followed. There was a six-week waiting period for delivery at the time as these were Evolve’s latest and greatest design of electric-skateboard, and therefore I didn’t receive the board until the last week of July.
It was only a little over a month at the end of August, I was making the first complaint of electrical issues to Evolve, raising some serious safety concerns. The board would either turn off unexpectedly mid-ride, resulting in the board having no brakes to slow-down or stop; or switch to its slowest speed without warning leaving you with less power than expected upon going to cross an intersection leaving you vulnerable to collisions.
To solve the issue, on the 5th September Evolve sent me a replacement “motor-controller” which is the main processing circuit-board between the battery, hand-remote and the power to the motors. This did appear to resolve the issues for a short while, but it wasn’t before long I was experiencing the same issues. In fact, I was making my second complaint to Evolve by mid-January. I was starting to feel frustrated with the board by this time as it was proving itself to be more trouble than it was worth.
Evolve requested I send the board to them as this was the second instance of electrical issues; so I did (at my cost). The motor-controller was then replaced for the second time. I didn’t receive the board back until late February, as Evolve returned it to the address where I lived at the time I initially purchased the board, even though I had explicitly notified them of my new address to avoid such occurring. They were then asking me to pay for the additional return postage costs, even though it was their mistake.
Despite the frustrations with the postage, I was pleased upon receiving the board back as I was hopeful that after it had made the trip to Evolve, that it would be finally repaired and I could start enjoying the thing finally. Unfortunately, this was not the case and it was soon the same old story. The board seemingly had a will of its own; some days it would turn on; others it wouldn’t; or quite often it would wait until you were a few kilometres from home before it completely died; leaving you with no choice but to lug it back home.
I was seriously upset by this stage; the board was still not repaired and it was so unreliable I didn't even feel comfortable riding it further than 500m due to the fear of being stranded. I was tired with speaking to various people within Evolve about it, and wanted someone to take ownership of the problem and make this whole situation right for me. I knew the owner Jeff, was actively involved in the daily operations of the business, so I called and requested to speak to him, only to get the response; “Jeff doesn’t concern himself with customer complaints”. I raised my concern to the person I was speaking too, of the costs involved with continually shipping it interstate for repairs, only to get told that sending it back at my cost was their policy and the only way forward in getting the board repaired was to do just that.
So I did – again. Before I posted it back however, I took great time and effort in monitoring and documenting via video the problems I was experiencing. I was hoping this would assist Evolve as I understood the problems were intermittent; they were not always present making it not the easiest to diagnose.
The collated video, along with an email detailing the issues were sent to Evolve in Queensland, and so was the board a short time later. I specifically told Evolve that the 'symptoms' of malfunction often don't begin appearing after 5 to 15min of riding, and I requested they keep the board for however long it was needed for it to be repaired. Well it wasn’t more than a week later I received a notification the board was on its way back after having its motor-controller replaced (again). Although once again, Evolve had actually sent the board back to my old address in Sydney and I had to wait for it to be returned to Evolve and re-dispatched.
Before I had even physically received the board back, I expressed my concerns to Evolve at having heard that just the motor-controller had been replaced again. As this had been done 3 times now and the problems had just kept arising after a short while. I expressed my concern that it may be a battery or motor irregularity causing the motor-controller to malfunction, hence it needing to be replaced continually.
After pulling it out of the box upon receiving it back, I only got roughly 500 meters down the road before the board started turning itself off again mid-ride. I turned it on again only to get another 10 meters and it was off again. Well I was furious – absolutely livid. I was ready to throw the stupid thing off the rail bridge I was on I was so angry. How could it possibly be returned in this state? Do they really now expect me to ship it straight back to them at my cost? I was even more pissed-off when Evolve told me that they hadn’t bothered viewing the videos I made for them to assist diagnosing, as the file was “too large” (2gb) for them to download.
I knew too well by this time what needed to happen. The issues were well documented to have commenced a little over a month after I first received the board and Evolve had since attempted to repair it on 3 occasions without success. The board had failed to meet any basic and reasonable expectations in quality, reliability, safety and value. It's for these reasons I have never questioned whether I would be eligible for a refund if I deemed it necessary.
Before any demand was made however, the slim possibility had to be ruled out that it wasn't the hand-remote causing any of the issues. Each time the board had been returned to Evolve, they must have had to use their own hand-controller, as the one that came with the board had stayed with me. To prove it was indeed the board that had the malfunction, I purchased from Evolve a brand new hand-remote at a cost of $120. Well after receiving the new hand-remote and experiencing exactly the same issues, it was confirmed that after 3 attempts, Evolve had indeed failed to repair the board to a usable, reliable state, and I simply needed to demand my money back.
I sent the board back with a demand letter requesting to be refunded for the initial cost of the board, and took the opportunity to express my dissatisfaction. I also explicitly told them not to send the board back to me.
The only emails I received back thereafter, were emails that were attempting to suggest the board had been ill-treated in someway. For instance, I had replaced the brand new belts I had recently paid extra for with worn ones before returning, which they were ever so quick to criticise. That there was dust or dirt they thought had got in somewhere that shouldn't. The thing that infuriated me the most however, is their claim the boards carbon-fibre deck itself has been damaged at the rear somehow and it needs replacing at a cost of $550! I was given notice of this in an email several weeks after it had been in their possession and after several emails that made no mention of it; which makes me think if there is such damage, it's of their doing. I can swear on my own life there was no such damage when the board left my end last and I refuse to accept any different. Weirdly enough though, it didn't stop Evolve trying to return the board to me. Yes that's correct; after explicitly instructing them not to send it back; and demanding to be compensated; and after their email saying the carbon-fibre board had itself been damaged and needs replacing; they attempt to send it back! They sent me an email stating that some electrical component had been replaced again and further testing had been done (someone riding my apparently broken board around) with no further reports of any issues. Well I'm sure I can be understood for not being so gracious. I refused to sign the postal consignment and I assume the board has now been returned to Evolve.
It's evident Evolve are deliberately trying any tactic to weasel their way out of compensating me by trying to pin whatever issues the board has on me, framing it in a way that I had somehow misused the board in some way. This is complete nonsense. Submitted with this complaint is the collated email correspondence between myself and Evolve from the first instance of malfunction to the present. This clearly documents this being an ongoing saga of electrical issues from little more than a month after I first received the board. The electrical issues being experienced rendered the board unsafe, unreliable and generally unusable as an electric-skateboard is inherently useless without working electrics. It's astonishing to learn that after the woeful experience I have had with Evolve and their product; after 3 failed attempts to fix the issues; Evolve somehow think they are not responsible or obliged to give my money back. I never imagined I would experience the misery I have had from a product that was intended to be fun and cost over 2 thousand dollars. I experienced nothing but continual electrical issues that made the board unreliable, unsafe and generally unusable from almost the time I first received the board.
I believe I have a strong case and wish to take it as far as it needs to go to receive a refund for the initial cost of the board. I request the services of Consumer Affairs (CA) to assist in this process. I will attach the original invoice along with this letter. The 2GB of video showing the issues as they were experienced is also available upon request but is is too large to attach along with this letter.
I regrettably was unable to attend to this matter sooner due to a hectic end to the year myself, and therefore fully expect this won't be a matter that CA will assess until the new year. I would appreciate to hear back from someone around then. Please don't hesitate to contact me via the details provided if you may have any further questions that may assist in the matter.
Yours sincerely,

Rube   100 W

100 W
Posts: 241
Joined: Jun 25 2016 10:18pm
Location: Brisbane, Australia

Re: Evolve Carbon Gen 2 - need bms

Post by Rube » Mar 11 2018 1:21am

Crikey, $2k and epic cluster of rework and repair. Hope you get your money back.

Post Reply