Sevcon Gen 4 Errors and Solutions thread

Things that fly
ewa1001   10 µW

10 µW
Posts: 5
Joined: Dec 15 2019 2:36am

Re: Sevcon Gen 4 Errors and Solutions thread

Post by ewa1001 » Feb 10 2020 9:28am

Any one encountered with
0x4F54 AUTOZERO RANGE ERROR
Is it a hardware malfunction ?

kiwifiat   100 W

100 W
Posts: 253
Joined: Mar 16 2013 5:49pm
Location: Vancouver, Canada

Re: Sevcon Gen 4 Errors and Solutions thread

Post by kiwifiat » Feb 10 2020 6:30pm

ewa1001 wrote:
Feb 10 2020 9:28am
Any one encountered with
0x4F54 AUTOZERO RANGE ERROR
Is it a hardware malfunction ?
Yes it is a hardware fault relating to the current sensors.
“You never know if quotes on the internet are genuine.” - Abraham Lincoln

buddhafragt   1 mW

1 mW
Posts: 17
Joined: Oct 15 2014 3:33am

Re: Sevcon Gen 4 Errors and Solutions thread

Post by buddhafragt » Dec 19 2020 11:18am

darseygodwin wrote:
Sep 28 2019 11:08am

2. Since I kept B- isolated from frame ground, I used bypass caps on both my encoder +/- and pack B+ to B-. This smoothed out that ground bounce so much I was able to open up the throttle to 500A for the first time since building this bike. I didn't have resistors to run parallel and properly filter the signal, but that's next. Plus I'll have to clean up the wiring a bit before going riding.

Finally, once that filter is properly set up I'll see if the contactor coils still cause significant noise, and if a similar filter will work on that coil if needed, I'll do the same there too.
Hello Darsey,
very interesting, one question:
You don't ground b- at the controller, but it is grounded at the battery pack, right?
You use a cap between b- and b+, which size you use?

Greetings, Michael

User avatar
darseygodwin   10 mW

10 mW
Posts: 29
Joined: Jul 31 2016 5:51pm

Re: Sevcon Gen 4 Errors and Solutions thread

Post by darseygodwin » Dec 19 2020 7:43pm

Hey @buddhafragt.
B- is not grounded to frame at any point for safety redundancy but is the base point for all of the high voltage stuff run off the controller. (Though lots of systems do have a frame grounded b-) It's a bit misleading when I called it "ground bounce". In the end, I was able to pull those caps off the system from both the pack and the encoder as I continued to shield more of the seemingly unrelated b- wires that were picking up all that noise I was trying to smooth with the caps. It was also pretty damn unsafe imo to have caps on my b+/b-, so I really didn't like that solution at the time. I used a supercap on the encoder and four x 250v, 1mF caps each for the pack.

Darsey

Sent from my SM-N770F using Tapatalk


buddhafragt   1 mW

1 mW
Posts: 17
Joined: Oct 15 2014 3:33am

Re: Sevcon Gen 4 Errors and Solutions thread

Post by buddhafragt » Dec 20 2020 6:10am

Hello Darsey,
if I understand you correctly, you have shielded the B-lines? How so?

If you do not put B- on the chassis, I would guess you have more noise on the frame!?
What safety advantage do you have by not connecting the frame to B-? (I guess you don't have a very high traction battery voltage).
greetings, Michael

User avatar
darseygodwin   10 mW

10 mW
Posts: 29
Joined: Jul 31 2016 5:51pm

Re: Sevcon Gen 4 Errors and Solutions thread

Post by darseygodwin » Dec 20 2020 11:31am

buddhafragt wrote:Hello Darsey,
if I understand you correctly, you have shielded the B-lines? How so?

If you do not put B- on the chassis, I would guess you have more noise on the frame!?
What safety advantage do you have by not connecting the frame to B-? (I guess you don't have a very high traction battery voltage).
greetings, Michael
Yes, all of my b- wires needed to be shielded. The noise comes from the three motor phase leads, even though they too are shielded. I'm using Champlain EXRAD cables, so they're well shielded too. My performance was better leaving the shielding ungrounded. as in, forget the notion of "give the noise a return path" but instead it's keeping the motor phase frequency off your traction pack voltage system because it affects the sin cos encoder directly via noise on the b- line.

Voltage level, I'm running a 32s pack, peak voltage limited to about 112v. Safety is because to get a shock, you need to contact two locations, not just one. If either b- or b+ shorts to frame, I get nothing more than a warning alarm on my display.

Honestly, I feel like it would've been much smarter if I used a different encoder from the start, and forget this hyper sensitive sin-cos business.

Darsey

Sent from my SM-N770F using Tapatalk


buddhafragt   1 mW

1 mW
Posts: 17
Joined: Oct 15 2014 3:33am

Re: Sevcon Gen 4 Errors and Solutions thread

Post by buddhafragt » Dec 20 2020 1:37pm

Thanks for your answer,
but I dont understand: How a shield should work, if it is not grounded?

What kind of shorts detection circuit you use?

Michael

mirai   1 µW

1 µW
Posts: 1
Joined: Dec 23 2020 9:47am

Re: Sevcon Gen 4 Errors and Solutions thread

Post by mirai » Dec 23 2020 10:11am

Any one encountered with 0x45ce VCAP VKEY DIFF? Is it a capacitor malfunction?

I can ride a motorcycle without problems, but the green LED lamp on SEVCON lights up 7 times. Any possible causes and the countermeasures?

AMP ADRENALINE   10 µW

10 µW
Posts: 5
Joined: Jul 28 2019 1:21pm

Re: Sevcon Gen 4 Errors and Solutions thread

Post by AMP ADRENALINE » Feb 10 2021 6:01pm

Darseygodwin, How is it going. Are you still around and working on your Sevcon Bike Project?
Are you still working on it or did you finish it?
I am almost finished with my Bike after a couple years of engineering. Still not
perfect, but moving along. Designed for a 10 sec Battery swap, and all stock Yamaha
parts like Plastics, Seat and Seat Covers, Sprockets.. ect..
XEMX 9-25-2015 (7).jpg
XEMX 9-25-2015 (7).jpg (5.33 MiB) Viewed 230 times
Sevcon has been a pain and expensive as I have had to pay an Engineer to help
fine tune it continuously.
I have recently converted to Curtis and Had some Custom controllers made to get
more amps out of it. I am still working on intergrading them with my project, but as a
rep. for them I will soon be selling and supporting them, if all goes well.
Here is a You Tube link to short test clip.

https://www.youtube.com/watch?v=Twku6BUzc6k


Mark

User avatar
darseygodwin   10 mW

10 mW
Posts: 29
Joined: Jul 31 2016 5:51pm

Re: Sevcon Gen 4 Errors and Solutions thread

Post by darseygodwin » Feb 17 2021 12:12pm

You bet!

DM sent.

buddhafragt   1 mW

1 mW
Posts: 17
Joined: Oct 15 2014 3:33am

Sevcon Gen 4 Motenergy ME1114

Post by buddhafragt » Apr 06 2021 4:39pm

Hello,
I try to get the ME1114 running with the GEN4, but I dont have the Firmware for PMAC motors.... can someone send me the fitting Firmware for the 80V/350A controller? :oops:

greetings, Michael

Post Reply