Terrible Experience from E-BikeKit.com !!!

Get real world experience and user feedback on the electric bicycle products.
Pharther Phurther   1 mW

1 mW
Posts: 16
Joined: Aug 23 2011 12:53am

Terrible Experience from E-BikeKit.com !!!

Post by Pharther Phurther » Aug 23 2011 1:38am

This thread has nothing to do with the new e-bike kits .. which I am sure are excellent. I like the new designed plugs .. and the kits are probably the best and easiest kit to install .. as well as priced fairly.

I would still recommend these kits to anyone interested in good equiptment.


Note: This post is over a petty $20 throttle assembly that the owner of the company would not replace. It was his attitude that made me write it.

Tried to replace a older controller with a new one.

I contacted e-bikekit.com prior to wiring it if the color codes were the same. ( green - black - red )

I asked both employee Pat and president Jason Kraft to advise me about the color codes for the new controllers.

Jason replied: " The colors underneath I believe are the same too. You should be able to figure it out. " August 16.

They were not the same, and caused a situation that fried both the new motor controller and several throttle assemblies before I called e-bikekit.com and received a call from David in tech support .. who said that they are not the same and the black wire is not to be used, but it was too late.

After having to argue my case with owner Jason who email me the above statement ... he said he would only provide a refund for the motor controller and not send me a replacement throttle .. which technically was part of the same system that fried because of his lack of product knowledge.

Also .. Jason continued to defend his actions .. stating that he said .. "I believe" .. with emphasis on the fact that he wasn't sure.

During our conversation .. he mentioned that the refund is purely at his own discretion.

I asked for a new throttle so I can get the bike running with the old controller ... Jason said to go buy one on the web site.

I was also accused of voiding my warrantee by opening the controller while looking at the wires with David from tech support on the phone after the fact that it was wired up per Jason's advice and tested and fried. David also told me that he has been working on the issue for two weeks and has determined inconsistencies in the color codes. David also said that the black wire was not to be used. I thought I was partially at fault ... and David send me a coupon code for 20% off a new one. I thought that was OK until I reviewed the previous email stating that "The colors underneath I believe are the same too. You should be able to figure it out. " from e-bikekit.com owner Jason Kraft. I sent a email pointing this out in hoes that Jason would reply with a replacement solution for his fault. I waited till today and received nothing .. so I emailed:

"After reviewing the previous emails .. it seems unfair that I have to purchase and replace $100 worth of equipment because you didn't know the new motor controllers have different wiring color codes."

Jason emailed me : " Dave just told me your were 100% told that opening the controller would void your warranty. Is this correct?"

I cannot believe the operator of a company would continue to cause distress to a customer that purchased kits .. and I advise others to never purchase from E Bike Kits.com.

I just asked for a working replacement throttle so I could get up and running with my older controller.

I wish I could have recorded the conversation. I have never dealt with more of a unknowledgeable and irresponsible to their own products, as well as the worse customer support via the company's president / owner Jason Kraft I have ever experienced.

I would like to note that both Pat and David of e-bikekit.com were VERY helpful .. and provided excellent service .. and I hope they are not treated at work in such a manner as this customer was.

Steer clear .. and buy from anyone else on this board that is recommended.

Sorry to post this ..

This disturbs me to no end.
Last edited by Pharther Phurther on Aug 23 2011 11:40pm, edited 1 time in total.

User avatar
mr.electric   10 kW

10 kW
Posts: 748
Joined: Jan 03 2007 12:12pm
Location: San Francisco
Contact:

Re: Terrible Experience from E-BikeKit.com !!!

Post by mr.electric » Aug 23 2011 1:52am

My experience with throttles is that red is positive, black negative and other is signal. If you fried several throttles and a controller trying to connect the throttle there must have been something else going on.
-Fat Sand Bike with 9c and 29ah pack

-Giants mascot scooter

JasonEBK   100 mW

100 mW
Posts: 41
Joined: Jun 07 2009 10:42am

Re: Terrible Experience from E-BikeKit.com !!!

Post by JasonEBK » Aug 23 2011 7:02am

Note: This isn't about $20. This is about an unreasonable individual with a bad attitude that refused to accept NO "we do NOT support that" for an answer.

Chris Koveleski is getting a full refund for the controller that he blew up (and shipping). He was offered a full refund before he blew it up and told to stop what he was doing and send it back (he doesn't mention that).

I admit I did not know how to adapt the old version components to the new controller boards and I thought it was likely similar. Knowing how to do that is not my job; never has been and never will be.

We provide excellent customer service and work very hard to do so. Chris would not take NO for an answer, he would not accept a refund and would not wait for David (our tech) to figure it out. He kept calling and calling and even texting David over the weekend (we were not open) on his personal cell phone. He could not wait for a proper answer and had to go messing around and made things worse. Then he says okay I understand and I'm sorry and I'll buy a new one (was offered 20% discount) only to change his mind and demand not only a new controller be shipped immediately but also now he wants us to send a new old-style throttle immediately.

ENOUGH

Here's a hint for everyone dealing with a small American company that goes out of it's way to accommodate it's customers and deliver a great product. Don't be an unreasonable customer. Don't harass the employees and don't start telling the business owner how to run his business.

Good people in the e-bike business like the women at Cycle9 are going out of business because making it work in this business is not easy. Customers like Chris Koveleski are a big part of that problem. They will literally suck the life out of a small business if allowed. Google "Pharther Phurther" and you'll find Chris criticizing other products and posting up criticisms in other forums. Google my name and E-BikeKit and you'll find a ton of positive reviews.

Me and the other people at E-BikeKit work really hard at what we do. I don't do it often but in rare situations if I think it's necessary I will deny business to an individual. I have every right to do it and I won't apologize for it. I hope the ES community can understand that.
Last edited by JasonEBK on Aug 23 2011 8:38am, edited 1 time in total.

BikeFanatic   1 kW

1 kW
Posts: 408
Joined: Nov 19 2011 10:58am
Location: Massachusetts

Re: Terrible Experience from E-BikeKit.com !!!

Post by BikeFanatic » Aug 23 2011 8:32am

We do understand Jason, don't worry about it. You sell a kit, a controller with a throttle. you are not there for support of
aftermarket parts, where did he get the controller from anyway.

I think you went beyond what you should have, and This person is obviously difficult/jerk, spoiled brat.

JasonEBK   100 mW

100 mW
Posts: 41
Joined: Jun 07 2009 10:42am

Re: Terrible Experience from E-BikeKit.com !!!

Post by JasonEBK » Aug 23 2011 8:49am

ianmcnally2 wrote:We do understand Jason, don't worry about it. You sell a kit, a controller with a throttle. you are not there for support of
aftermarket parts, where did he get the controller from anyway.

I think you went beyond what you should have, and This person is obviously difficult/jerk, spoiled brat.
Thanks. To be clear this is our controller. It is a New Model controller made specifically for use with our new kit with the new model connectors. I should have never assumed it was all the same wiring and that is my mistake here in telling Chris that "I believe it is the same wiring". That is why Chris is getting a full refund for the controller. Why he is being denied any further sales and service from us is for many other reasons.

BikeFanatic   1 kW

1 kW
Posts: 408
Joined: Nov 19 2011 10:58am
Location: Massachusetts

Re: Terrible Experience from E-BikeKit.com !!!

Post by BikeFanatic » Aug 23 2011 8:55am

Oh I see.
Maybe you should then just sell a new throttle to everyone when they buy a new controller. That what I would do.

User avatar
Ypedal   100 GW

100 GW
Posts: 12528
Joined: Dec 27 2006 12:55pm
Location: Moncton NB, Canada
Contact:

Re: Terrible Experience from E-BikeKit.com !!!

Post by Ypedal » Aug 23 2011 9:23am

why was the original controller being replaced in the first place ?

I have wired many, many, many motor A with controller B and throttle C, and the throttles are rarely fried if the combination is wrong , it just dont work, you try until you get a working combination... something else is going on here.
ES site status page:
http://www.ypedal.com/ES/ES.htm
----------------
http://www.ypedal.com

User avatar
oatnet   10 MW

10 MW
Posts: 2352
Joined: Apr 26 2007 3:03pm
Location: SoCal, USA

Re: Terrible Experience from E-BikeKit.com !!!

Post by oatnet » Aug 23 2011 11:23am

"They were not the same, and caused a situation that fried both the new motor controller and several throttle assemblies "

This does not make sense. If you fried throttles :shock: then you are doing something profoundly wrong. This is a DIY hobby - if YOU want to modify your kit, YOU have to know what you are doing, either by experience or research - or be willing to lose hardware gaining that experience. Again, it is YOUR responsibility to know the wire colors, what they mean, and verify the pinouts by testing.

I have seen ebikekit.com be a good vendor and supportive of our hobby; if you have trouble with them, drop the hobby now before you deal with the majority of bad vendors.

Calling a well-known vendor out in public, over a $15 throttle that you lack the skills to troubleshoot, only makes YOU look bad.
Member 117 of 26,000+

153v DUNE BUGGY © 164v Vectrix E-Moto © 72v Norco A-line/x5403 © 60v Specialized Enduro Comp/BMC © 72v x5tracycle © 48v TF IO/BMC © 36v Kepler FrictionDrive © Spot-Welding a123 © Pelican Front Packs © Vectrix Battery Replacement © MORE !!


Image大鸡巴 Motors
Knowledge is acquired through experience, everything else is just information - Albert Einstein
"Cheater?" I'm not competing, I'm Commuting!

User avatar
ambroseliao   100 kW

100 kW
Posts: 1225
Joined: Apr 27 2009 3:34pm
Location: Washington, DC, USA area
Contact:

Re: Terrible Experience from E-BikeKit.com !!!

Post by ambroseliao » Aug 23 2011 11:38am

Logging in for the first time and using this forum simply to smear a well known seller is bad form.

If you had a track record of being a long time participant in this forum and had bought lots of items from various vendors and had trouble with one particular vendor, then you might have something, but blowing up multiple throttles and complaining on ES about a vendor not supplying you with more for free is silly.

Ambrose
Last edited by ambroseliao on Aug 23 2011 12:03pm, edited 1 time in total.
http://www.ebikes.ca/ is the best!

TidalForce M-750X, Tidalforce S-750 with Crystalyte HS3540, 1x TF iO-X Cruiser. E+ 1000W hybrid bike. ebikes.ca DrainBrain & Cycle Analyst meters. GoPro HD Hero2 camera. Bosch Fat Packs, 37V 10Ah LiPO pack. Turnigy Multistar batteries
My blog: http://ebikerider.blogspot.com
Remember LiFEPo4 HVC is 3.65V and LVC is 2.7V

User avatar
Ykick   100 GW

100 GW
Posts: 5535
Joined: Nov 26 2009 6:10pm
Location: San Diego, California

Re: Terrible Experience from E-BikeKit.com !!!

Post by Ykick » Aug 23 2011 11:59am

From early 2010-present I've bought 3 full kits plus couple more hub motors and various items from EBK (Jason) and my experiences have been nothing but complete satisfaction.

All I can wonder is what on earth would bring a good guy like Jason to the point of refusing service to a customer? One can only wonder, eh???

Seriously bro, if you can't figure out throttle wiring with a DVM and/or you somehow screwed-up your controller you should pick something else to do with your time. You've offered no real details or authored posts for help wiring throttles to different controllers - all of this bad publicity you think you're bringing isn't looking too good for you.

As ypedal mentioned - I've also miss-wired many throttles and didn't cause any damage. Well, maybe except that time my bike shot across the room, LOL...
Talent must not be wasted.... Those who have talent must hug it, embrace it, nurture it and share it lest it be taken away from you as fast as it was loaned to you.

- Frank Sinatra

itchynackers   100 kW

100 kW
Posts: 1081
Joined: Dec 27 2009 11:11am
Location: Janesville, WI

Re: Terrible Experience from E-BikeKit.com !!!

Post by itchynackers » Aug 23 2011 12:01pm

I've hooked up throttles wrong (probably in every combination) and never fried anything. It just doesn't make sense. I've purchased a kit from Jason. I had questions, and he even called me on the weekend to make sure I had it figured out. He even sent me a gear cluster spacer for free! Honestly, this company probably has the best customer service/support I've ever seen.
9c 9x7f w/ 12awg phases
9c 8x8r w/ 10awg phases, temp sensor, vented
9c 6x10r w/ 10awg phases, temp sensor, liquid cooled, 3rd Place Pikes Peak 2012!

"Don't argue with the galactically stupid...they drag you down to their level and beat you with experience"

chroot   100 kW

100 kW
Posts: 1286
Joined: Nov 29 2009 4:03pm

Re: Terrible Experience from E-BikeKit.com !!!

Post by chroot » Aug 23 2011 1:25pm

I ordered EBK kit from Jason in past, His service was excellent and no trouble. Please don't destroy such small business like EBK.

EBK has policy, if you are doing DYI or not following the instructed from EBK and you are automatically void EBK's warranty. Like Jason said STOP what you are doing but you stubborn doing whatever you do cause more damage to the controller. It's your fault not listen to Jason. Even Jason offered you full refund for the controller and you told him NO. WTF? :|
Thank you Justin Lemire-Elmore - You are a HERO!

Tidalforce, Yuba Mundo V4 Cargo bike, Juiced Riders ODK V1 Cargo bike
English is my secondary language - ASL (American Sign Language) is my primary.

Pharther Phurther   1 mW

1 mW
Posts: 16
Joined: Aug 23 2011 12:53am

Re: Terrible Experience from E-BikeKit.com !!!

Post by Pharther Phurther » Aug 23 2011 3:37pm

First of all .. I have sent many customers and had great service from e-bike until this:

First Jason Kraft ... I had no bad attitude until you would not take responsibility for sending me an email that stated "The colors underneath I believe are the same too. You should be able to figure it out."

Do you deny that you sent me that email? Of course not.

chroot: I did listen to Jason which caused the mishap. It is when I asked Jason to send me a new throttle and he said to go buy one that I got a 'bad attitude'.

I was replacing a older e-bike motor controller with a new one. The new one does not have the older plugs .... and e-bike does not offer the newer harness so I had no choice but to match the color codes. Jason replied that it 'should' work in the email .. and it didn't.

David .. from E-Bike Tech support knew that the color codes were different prior to Jason's email to me ... and Jason did not. That is their lack of communication.

itchynackers: The "Black" wire from the motor controller bundled in the throttle harness in the new ebike motor controllers WILL FRY the throttle hall sensor everytime. The old color codes are green-red-black ... the new ones are NOT.

YKick: Try the color codes. You will blow it up too. Find a better reason to post with your free time as well ... Bro.

Again I would have gladly been a part of recording the conversation. I have nothing to hide ..

ambroseliao: Have been part of advanced transportation groups for longer than most of you ... matter of fact .. the pioneer of hub motors was a close friend .. and seen the original prototype in 1991. I have nothing to hide and Jason is more than welcome to reply to my comments and clarify.

Oatnet: Again .. Take Jason's advice and wire the same color codes and you will fry the throttles too! The ONLY modification was to WIRE the bike .. since the harness plugs were NOT available. I had NO choice. Again .. it was the lack of acknowledging responsibility for causing the problem .. and not sending me a new throttle .. not the $15 .. which I agree .. is petty.

Ypedal: Yes .. something is going on! The new controllers have a 'hot' black wire .. far different than the old controllers. I ask for color codes and got the wrong advice.

ianmcnally2: I would have bought a new harness .. but it was not available. I was a loyal returning customer .. so I didn't shop elsewhere or eBay.

Jason: I am sorry you think it is my attitude. I have tried very hard to explain to you that BOTH the throttle and the controller are a complete LOOP that is fried .. but your would not understand. It is like you have limited knowledge of the problem .. but now I am sure that David has explained it to you.

IanMcNally2: This is not a aftermarket part .. it is e-bikes motor controller and e-bikes throttle.

Jason Kraft : You sell one kit and then you introduce another kit with completely different plugs .. and a then you claim me as unreasonable when you tell me "we do NOT support that" after the facts of your misinformation?

Did I not ONLY ask you for a new throttle ( other than the controller refund ).. and what did you say?

Knowing as much about your product as the owner of a company .. unless your a supermodel .. is important. "Knowing how to do that is not my job" is ignorance.

Jason .. this statement is bull : " he would not accept a refund and would not wait for David (our tech) to figure it out." You never said ANYTHING about waiting for tech to figure it out. Your email was on August 16 about the color codes. I was not offered a refund before it fried. I tested the bike on August 19 .. and then called you .. then you talked to David and had him call me. Did you not?

David called me on the August 19th first. We were both trying to figure out what happened. He knew the color codes were wrong prior to the phone call and mentioned he has been working on the issue for two weeks. Jason .. Is this correct?

I was only offered a 20% discount and not a full replacement at first. I thought I was wrong until I found Jason's previous email that contained info on the color codes .. I posted that into the email hoping that Jason would realize it was more a technical issue on the new controller and offer a replacement.

Jason .. the controller was shot before our first conversation and before you offered a refund. I didn't know it at the time. That is why I have multiple hall throttles that smoked. I called you when I got a response from one of them .. which was because it was shorted. It was already too late. I'll mention that. It was the new throttle that I wanted shipped so I could get off and running soon with a older controller .. it's been too long from the ride .. I should not even have to explain.

I called David 3 times .. once was to ask him if he can receive txt pics. I sent him two txts of my cool bike. It was Monday I txt back about the exploded situation .. after my last call with Jason.

I never harassed David or Pat .. never said anything rude to them .. I did txt David that if Jason was upset .. it was my fault. Please post them here if you like .. I am open to what they state .. and will not refute the content.

Yes .. Please Google "Pharther Phurther" ... and read my posts about Adobe. There is only ONE product CS 5.5 for Mac OS X in the Adobe Forums regarding bugs / issues that have yet to be resolved since January ... that I have lead the way to discovering multiple bugs and I am proud of it .. and joined by over a 100 others asking Adobe for results. Also read the other Mac Users in that Forum also arguing about the lack of performance in the new Creative Suite 5.5. You will find no other forum(s) that I am accused of being a problem. Thanks for the misinformation Jason .. don't try to smear campaign me for my lack of compassion for your ignorance.

Post the facts in their entirety.

I will state that I do agree with several others here that e-bike-kit has had been great to me in the past. I don't know why I should I suffer for someone else's mistake .. or why Jason would not send me a simple throttle .. which I did 'demand' when I got furious. Bad form.

And ... Huh?

I have no idea who the "women at Cycle9" are .. what does this have to do with me? lol

Please inform me where I said .. "Do not buy from e-bike-com" and I will remove the post. I think I only complained about a situation .. not the company .. and provided as much technical info I could. Titling the post "Terrible Experience with Jason Kraft !!!" seems personal .. and it is not. Accusing me of such is. What a joke.
Last edited by Pharther Phurther on Aug 25 2011 11:14am, edited 3 times in total.

Pharther Phurther   1 mW

1 mW
Posts: 16
Joined: Aug 23 2011 12:53am

Re: Terrible Experience from E-BikeKit.com !!!

Post by Pharther Phurther » Aug 23 2011 4:12pm

I would also like to post this:

This thread has nothing to do with the new e-bike kits .. which I am sure are excellent. I like the new designed plugs .. and the kits are probably the best and easiest kit to install .. as well as priced fairly.

User avatar
oatnet   10 MW

10 MW
Posts: 2352
Joined: Apr 26 2007 3:03pm
Location: SoCal, USA

Re: Terrible Experience from by PharterPhatter!!!

Post by oatnet » Aug 23 2011 4:24pm

Again .. Take Jason's advice and wire the same color codes and you will fry the throttles too! The ONLY modification was to WIRE the bike .. since the harness plugs were NOT available. I had NO choice. Again .. it was the lack of acknowledging responsibility for causing the problem ..
I don't care if he told you the throttle wires were purple with Polka Dots and get plugged directly into the battery, it is still YOUR responsibility to throw a multimeter on the throttle to verify the pinouts he gave you. If you didn't, that is YOUR fault. If, in your lack of skill, you did something so spectacular as to actually fry a throttle - which is beyond the Murphy of everyone who has posted so far - that is on you.

Upgrades and modifications are YOUR responsibility, not ebike-kits. YOU chose the absolute Dofus of a technician who did the upgrade; the labor was free and you got what you paid for. You could have taken the kit to a professional, or even shipped it to Ebike-Kit, and paid them to work on it, but you were a cheap-ass, and did it yourself even though you obviously lack the most basic skills. HTF is that anyone else's fault but your own?

The fundamental problem here is that you believe that Jason has the lifetime responsibility for helping you upgrade your kit. He does not, although I'd expect he would bend over backwards if you weren't being a DICK. You proved your DICKhood to us by trying to trash a good vendor, who you couldn't bully into paying for YOUR mistakes. Try that bullshit with a Chinese vendor, and you will never hear from them again; Jason deserves a medal for still replacing the controller YOU fried, I woulda told you to piss off.

So brush off your skirt and Sack up, Mary. Be glad you got a free controller out of the deal.

-JD
Member 117 of 26,000+

153v DUNE BUGGY © 164v Vectrix E-Moto © 72v Norco A-line/x5403 © 60v Specialized Enduro Comp/BMC © 72v x5tracycle © 48v TF IO/BMC © 36v Kepler FrictionDrive © Spot-Welding a123 © Pelican Front Packs © Vectrix Battery Replacement © MORE !!


Image大鸡巴 Motors
Knowledge is acquired through experience, everything else is just information - Albert Einstein
"Cheater?" I'm not competing, I'm Commuting!

User avatar
johnrobholmes   1.21 GW

1.21 GW
Posts: 3963
Joined: Jul 07 2008 2:19pm
Location: Missouri
Contact:

Re: Terrible Experience from E-BikeKit.com !!!

Post by johnrobholmes » Aug 23 2011 4:37pm

Sounds like you need a multi-meter. Odds are the black wire you chose was for a battery indicator, full battery voltage.

Pharther Phurther   1 mW

1 mW
Posts: 16
Joined: Aug 23 2011 12:53am

Re: Terrible Experience from E-BikeKit.com !!!

Post by Pharther Phurther » Aug 23 2011 5:01pm

oatnet:

"I don't care if he told you the throttle wires were purple with Polka Dots and get plugged directly into the battery" ?

lol

Ok .. sure.

Let me understand this.

The owner of a electric bike company says "The colors underneath I believe are the same too. You should be able to figure it out."

green-black-red were the colors on both sides.

So it is my fault that I didn't use a multimeter to test the connections first?

OK. Sure. I am all ears ... What would I look for? You may to have lots of knowledge.

This was no upgrade .. it was a replacement motor controller from the same company I bought the first one from. Should have been simple.

I did ask for help. Nothing that happened was my mistake. If it was I would not have never asked for anything.

"you obviously lack the most basic skills" .. like following color codes? lol

Oatnet: It's interesting that you comment on something you were not present in. I described it the best I could. If I purchased a different controller from a different vendor I would have been careful and use a multimeter with a schematic. This replacement controller has NO schematic. The new plugs were NOT available. I would take anyone of you nasty posters and walk you through the actual events that happened and maybe you would have a realization .. or maybe the wrong wire will teach you a lesson.

If your going to attack someone .. try using better facts ( which I posted plenty of them ) .. or at least something funnier .. like the a pic of your bike and your custom logo "KOck NObber".

Pharther Phurther   1 mW

1 mW
Posts: 16
Joined: Aug 23 2011 12:53am

Re: Terrible Experience from E-BikeKit.com !!!

Post by Pharther Phurther » Aug 23 2011 5:14pm

johnrobholmes:

I did. It was after I tried two different hall throttles that I found two sources of 4.5 VDC. but nothing higher. I'm not sure that those could have cause the hall sensor to smoke ( you may know ) ... it's almost like with the red-green shunted / connected .. it sent full power up the black? or reverse? Not sure at all .. only on my last throttle I figured it out it was wrong when I saw the puff of smoke. Wire burnt right off the hall sensor. Everything fried is disconnected and new old controller installed and working so I will never know now.

chroot   100 kW

100 kW
Posts: 1286
Joined: Nov 29 2009 4:03pm

Re: Terrible Experience from E-BikeKit.com !!!

Post by chroot » Aug 23 2011 5:30pm

PhartherPhurther:

OK, If EBK doesn't carry the old style connector on the throttle and why don't you just use volt multimeter like other folks mentioned or get replacement throttle from LYEN or johnrobholmes or 3rd party vendors. They may have the old style throttle's connector will able work with your current controller.

Seriously, No need bad attitude toward to anyone and It is not worth your time.


*edited* I forgot addition, You supposed get LYEN tester and it would *HAVE* solve your problem instantly. It helped me lot. Here the links: viewtopic.php?f=31&t=20413
Thank you Justin Lemire-Elmore - You are a HERO!

Tidalforce, Yuba Mundo V4 Cargo bike, Juiced Riders ODK V1 Cargo bike
English is my secondary language - ASL (American Sign Language) is my primary.

Pharther Phurther   1 mW

1 mW
Posts: 16
Joined: Aug 23 2011 12:53am

Re: Terrible Experience from E-BikeKit.com !!!

Post by Pharther Phurther » Aug 23 2011 7:45pm

chroot: I did test the connectors .. but it was after it didn't work. More than one person mentioned it is odd that it would have fried the hall sensor. I found no more than 4.5 VDC with the multimeter on the connections. Even the tech at E-Bike said he was working on it for two weeks with limited success. My problem may have shed more light on the subject for them .. but since we are at bad terms ... I will never know.

Again I stress that e-bikekit has been very good to me in the past. I was upset that my 'heated' request for another throttle prompted me to post.

Also .. I was told by e-bike I was not the only e-bike customer with old - new controller problems .. I don't know the details but they may be all related.

I did order a replacement hall sensor throttle .. but three of my own are smoked.

Now .. really .. you and another claim I should have known voltages .. tested prior .. or don't trust color codes before I connect them .. with no schematic. Really? I wouldn't go where you are trying to go with those comments. It really sounds stupid and illogical.

My bad attitude surfaced when I realized that Jason didn't want to deal with it .. and tried to shut me down. You can say all you want .. and I would gladly take responsibility for every word said .. but this 'I don't want to deal with problems' attitude towards a customer is flawed. If you are friends that is fine. If you are a e-bike dealer .. great. I think the new stuff is going in a excellent direction. The web site and advertisement looks very professional.

I just will not put up with such an attitude .. regardless of the cost, and some of these comments don't expand upon any knowledge about the situation.

Thanks for the LYEN tip.

oatnet: I didn't "rewarded EBK's customer service" with a dump.

You continue to invent a scenario that doesn't exist. I have stated that both Pat and David were helpful .. did I not?

Jason was quite the opposite .. and I don't know why. He blames me and my attitude. Maybe you are friends .. which would explain your defense of his actions and your social expressions written in here your posts. Maybe you are a e-bike dealer .. good .. they look like great kits. Good luck with them if so.

Check all color codes before attempting any installation .. regardless of schematics or claims from sellers that they 'believe' ... because they could be wrong? Really? OK Oatnet .. That is brilliant. I must search for that in the "Tips" section of ES .. or why don't you post it there?

When I got the new controller ... the case looked different but the wires were the same colors. The plugs were different. I inquired about the color codes .. and thus we know the result. Yes .. it is never simple .. but I wonder how many fools like myself would assume the wires were still ok after the owner of the company said they 'believed' they were.

Where are you going with this Oatmeal?

As for a schematic .. hmm .. I would hope somebody has one. Somewhere. OMG .. What a nightmare!!!! None!

Oatmeal: My mom got promoted to the "Deluxe" model ... so the new logo she is on looks more like your mom back before she had you ... all smiles and no stretch marks.

User avatar
ambroseliao   100 kW

100 kW
Posts: 1225
Joined: Apr 27 2009 3:34pm
Location: Washington, DC, USA area
Contact:

Re: Terrible Experience from E-BikeKit.com !!!

Post by ambroseliao » Aug 23 2011 8:13pm

Man, I'm tired of this subject. I want to stop reading, but you keep replying with the same response over and over again.

Let me say that if I were to fry a throttle, which I've never done, I would stop and investigate why. If I couldn't figure it out ,or thought that I had found the problem, but fried a second one, I would definitely stop and not sacrifice another one, yet you did. Now you're putting up this stink because you want to blame EBK because they won't give you another one to fry?!?!?!? :shock:

Let's move on. Spend $15 and buy a throttle and get your ebike on the road again.
http://www.ebikes.ca/ is the best!

TidalForce M-750X, Tidalforce S-750 with Crystalyte HS3540, 1x TF iO-X Cruiser. E+ 1000W hybrid bike. ebikes.ca DrainBrain & Cycle Analyst meters. GoPro HD Hero2 camera. Bosch Fat Packs, 37V 10Ah LiPO pack. Turnigy Multistar batteries
My blog: http://ebikerider.blogspot.com
Remember LiFEPo4 HVC is 3.65V and LVC is 2.7V

slacker   10 kW

10 kW
Posts: 748
Joined: Aug 08 2009 11:01am
Location: usa

Re: Terrible Experience from E-BikeKit.com !!!

Post by slacker » Aug 23 2011 9:35pm

amen brother.smells like a cheap skirt.

Pharther Phurther   1 mW

1 mW
Posts: 16
Joined: Aug 23 2011 12:53am

Re: Terrible Experience from E-BikeKit.com !!!

Post by Pharther Phurther » Aug 23 2011 11:38pm

Chroot: You continue to not read the post. I believe that if the owner of EBK emails me that he believes the color code is the same .. as listed several times in this thread .. it would be considered as being "instructed from EBK". You fail to grasp this. If the issue is the definition of 'believes' then I should have been updated with better info with tech support whom informed me that for 2 weeks they have been trying to discover what was happening. which was 3 days later .. and after I called to tell them it didn't work per the instruction. What don't you understand? Jason said "Stop" after the fact. You do not know the timeline of the conversations .. and the controller was shot prior to when he said "Stop". You have know grounds to accuse me of being stubborn. I did not ever say no to a full refund. I only 'boldly' requested / a new throttle .. to which he said to buy one. I olny asked for one .. whereas I burnt up 2 before David at tech support said there is a problem using the black wire. When I tried David's suggestion of using the two other wires with different colors is when I discovered the problem .. and smoked the 3rd third throttle.

itchynackers: Somehow the the black wire on the new controllers are hot .. or some bad combination thereof.

Ykick: Apparently you didn't read enough and then posted comments. The summation of this thread is that color combinations are not always the same .. so beware of advice without a schematic or someone with less than 100% accurate knowledge of the controller. Still I receive comments such as yours about how great someone is .. and how bad I am. I refuse to let lame remarks and personal attacks shroud a problem that I should not pay for.

Ambrose: I logged in to this forum to buy another controller .. a throttle .. and other parts .. which I did. I am not persuading anyone to avoid purchasing from e-bikekit.com .. I am posting my review about buying a controller and receiving installation directions ..and when things went wrong .. I could not get a portion of the problem replaced.

Oatmeal: I asked for direction about the color codes .. so again if it "is YOUR responsibility to know the wire colors" I did the best I could .. which wasn't good enough. If I 'look bad' .. fine .. but I know what I said .. and Jason can correct me with the facts if I am wrong .. but I will not have facts spin-doctored .. and friends and fans of EBK try to smear me with inaccuracies and theories.

Just because I have no 'track record' here .. doesn't mean I have no right to describe my situation in detail.

Also: I posted a very simple description with no professional attack on EBK about using old controllers and new controllers and using the same color codes on the E-Bike Kit FB page. It also said to contact EBK tech for more info. It was polite and concise. Jason pulled it and deleted me as a poster. This occurred before any of these posts. It was after that and after of joining this forum that I started this thread.

So .. I was told to 'buy' a throttle that could have easily been replaced .. and then banned from informing others to be careful about color codes .. which I could not understand why he would do this. I did not say anything bad about EBK and I did not say to contact me. I posted to contact them.

I would like to thank all of you whom have ganged up on me. Some of you are quite ridiculous .. and have shown your true colors.

User avatar
ohzee   1 MW

1 MW
Posts: 1719
Joined: Jul 20 2011 1:13pm
Location: Columbus Ohio USA

Re: Terrible Experience from E-BikeKit.com !!!

Post by ohzee » Aug 23 2011 11:46pm

I agree let it go - life's not easy and this hobby is fun.
Last edited by ohzee on Aug 24 2011 12:14am, edited 1 time in total.

User avatar
spinningmagnets   100 GW

100 GW
Posts: 12705
Joined: Dec 21 2007 10:27pm
Location: Ft Riley, NE Kansas

Re: Terrible Experience from E-BikeKit.com !!!

Post by spinningmagnets » Aug 23 2011 11:56pm

Tried to replace a older controller with a new one.

I contacted e-bikekit.com prior to wiring it if the color codes were the same. ( green - black - red )

I asked both employee Pat and president Jason Kraft to advise me about the color codes for the new controllers.

Jason replied: " The colors underneath I believe are the same too. You should be able to figure it out. " August 16.

They were not the same, and caused a situation that fried both the new motor controller and several throttle assemblies
Everyone complains that airline seats are cramped and the food is bad. When I point out that first-class has much bigger seats and the food is pretty good, they always say "but...it costs more"

You bought one of the most affordable kits available right now. You sound annoyed that their customer service is not what you'd hoped. You noticed that the wire colors were not the same, and yet you plugged it in anyways, after the owner said he 'thought the colors were the same'. You could have posted here for free, to ask how to tell what unknown wires went to, its happened many times before...you are not the first.

Take a deep breath...calm down...I understand your frustration. Its tough these days for any business to survive, and E-bikekit.com is a well-known vendor. They are doing the best that they can, working under the thin profit margins they have to work with. My advice is to just let it go, buy a cheap volt-meter and a soldering iron, and then do a lot of homework here. Even experienced guys fry something once in a while around here. I certainly have.

Locked