Sabvoton SVMC072150 controller review, variable regen *PICS*

Get real world experience and user feedback on the electric bicycle products.
PeeHell   100 W

100 W
Posts: 171
Joined: Jul 30 2011 9:54am
Location: Montreal, Canada

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by PeeHell » Jun 17 2020 7:42am

Have you tried activating "regenerative charge", increasing the slide regen charge current and saving the setting with " parameter store" ?

Black6spdZ   1 W

1 W
Posts: 63
Joined: Jul 29 2011 5:59pm
Location: Waterford, MI
Contact:

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Black6spdZ » Jun 19 2020 1:53pm

I don't want "slide regen" that activates with 0 throttle, i just want a switch activated regen but my 72100 only has a low brake input

User avatar
Roye   100 µW

100 µW
Posts: 8
Joined: Jun 12 2020 5:22am

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Roye » Jun 20 2020 5:45am

Black6spdZ wrote:
Jun 05 2020 1:02pm
does anyone have documentation or photos of the internal pad locations for hi-brake, 0-5v regen input and/or motor temp input? My 72100 controller doesn't have any of those wires.. can't believe I paid >$200 for a controller with NO brake regen capability out of the box.. POS!
I have the same issue. When I put on regen, it regens all the time when not on throttle or the one-step-super-fast-PAS
How did you fix it?

Edit: Btw: where did you get that newer software?

Black6spdZ   1 W

1 W
Posts: 63
Joined: Jul 29 2011 5:59pm
Location: Waterford, MI
Contact:

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Black6spdZ » Jun 20 2020 2:46pm

Roye wrote:
Jun 20 2020 5:45am
Black6spdZ wrote:
Jun 05 2020 1:02pm
does anyone have documentation or photos of the internal pad locations for hi-brake, 0-5v regen input and/or motor temp input? My 72100 controller doesn't have any of those wires.. can't believe I paid >$200 for a controller with NO brake regen capability out of the box.. POS!
I have the same issue. When I put on regen, it regens all the time when not on throttle or the one-step-super-fast-PAS
How did you fix it?

Edit: Btw: where did you get that newer software?
the Chinglish translation of "slide regen" should have been called coast regen.

Volts   10 W

10 W
Posts: 68
Joined: Feb 12 2013 8:13am

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Volts » Jul 18 2020 8:15am

Has anyone here hijacked this controller for more power, either taken one of the phase wire out of the blue square sensor or soldered extra wires at the phase wire source point on the circuit board connecting straight to the motor phases?

User avatar
minde28383   10 kW

10 kW
Posts: 561
Joined: Apr 02 2010 7:11am

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by minde28383 » Jul 18 2020 11:23am

Not answer to your question but...
Unlocked it has 200 battery amps and 450a phase amps. I doubt you can request more amps through it without changing some parts.

in progress

User avatar
amberwolf   100 GW

100 GW
Posts: 30787
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by amberwolf » Jul 18 2020 3:58pm

Volts wrote:
Jul 18 2020 8:15am
taken one of the phase wire out of the blue square sensor or soldered extra wires at the phase wire source point on the circuit board connecting straight to the motor phases?
If you do this, the controller can't know how much current is passing, and can't protect itself against overcurrent, and could just blow up at any moment when using it. That's true of any controller you defeat the current monitoring on.

Just so you know.

Volts   10 W

10 W
Posts: 68
Joined: Feb 12 2013 8:13am

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Volts » Jul 18 2020 6:22pm

There’s a guy on you tube that’s done this and says I works, I don’t know how successful he was with it in the long term

User avatar
amberwolf   100 GW

100 GW
Posts: 30787
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by amberwolf » Jul 19 2020 12:07am

Sure, it'll "work", because you're preventing the controller from knowing how much current is actually flowing, so it cannot limit it and protect itself. (or your battery)

So sure, you'll get more power, up to the failure point of the ocmponents and design.

Plenty of people have done shunt mods of one type or another over the many years the forum has been here, on many kinds of controllers. Sometimes it works out great, and sometimes it blows up the controller. You can look up "shunt mod" and find various examples (others are under different terms).

User avatar
miunchy   10 mW

10 mW
Posts: 20
Joined: Nov 24 2016 1:28pm
Location: Vilnius, Lithuania

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by miunchy » Aug 14 2020 12:12pm

Hi guys! Has anybody managed to correct KTY83/122 sensor readings?
I think, that working halls somehow influencing the temp probe via shared ground wire inside a motor.
Has anybody tried to disconnect grounds inside motor and supply separate ground to KTY sensor for proper KTY sensor operating?
My rides: https://www.youtube.com/channel/UC4rx5u ... yCxNPJNpkw
Vector 16kW QS205 +hubsinks+ferro, Sabvoton 72150, Merida 1.5kW Magic Pie 4

Santacruz   10 W

10 W
Posts: 72
Joined: Jun 18 2015 6:28pm

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Santacruz » Sep 14 2020 9:07am

Hi all,
I have a question about power output of a 96120.
My setup comprises of 22s5p 26650 battery pack (Only charged to 90v), 96120 Sabvoton and Mxus 3k.
I have connected. throttle, low brake, second throttle for variable regen.
The things I have not connected is the 3 speed plug, brake high. Everything else is connected and I am not using a display, I am using a Cycleanalyst V3.
Can anyone tell me if the 3 speed plug has any effect not being connected. (I am wondering if I am stuck at mid power level), as the most I seem to pull is 65 amps or 6500w, which is very nice, but I feel there should be a lot more (Battery pack and all wiring is capable of over 200amp and BMS is 300amp model). Motor and controller barely get warm on a 12 km run (Home to work and again back at end of day). Battery pack never goes over 26 Celsius (measured at 4 different points). Average speed is 60 kph.
If it is just the motor, that is not a problem as I have a QS273 4T on order to replace present one.

Hardergamer   10 W

10 W
Posts: 96
Joined: Jan 07 2017 3:51pm

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Hardergamer » Sep 15 2020 3:45am

What turn is the 3k motor? and depending on how you have it programmed the controller will be in mid or low settings.
If you do not have a 3-speed switch? I would go into the app or PC program and set all 3 powers settings to max or whatever you like so you know what it is doing... Also, you can program it for "starting boost" which will give you extra pulling away power for 20 seconds.
Without knowing the wheel size etc, it is hard to say about speed, but with a 17"(23") MC wheel 4 turn 3K at 84V 50mph is the norm.

Santacruz   10 W

10 W
Posts: 72
Joined: Jun 18 2015 6:28pm

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by Santacruz » Sep 15 2020 5:08am

Hardergamer wrote:
Sep 15 2020 3:45am
What turn is the 3k motor? and depending on how you have it programmed the controller will be in mid or low settings.
If you do not have a 3-speed switch? I would go into the app or PC program and set all 3 powers settings to max or whatever you like so you know what it is doing... Also, you can program it for "starting boost" which will give you extra pulling away power for 20 seconds.
Without knowing the wheel size etc, it is hard to say about speed, but with a 17"(23") MC wheel 4 turn 3K at 84V 50mph is the norm.
Below I have listed my settings I am using.
However, speed is not the issue. The 60kph I do is just a nice comfortable cruising speed I use, there feels like plenty more is available, I just have not used it.
It is more, that I was expecting to draw more amps when accelerating, especially considering the bike is heavy (60+ kgs and I am no size zero model 120kgs ish), so that is quite a load to get moving.
I have also noted a few times, it is almost as if the bike has to warm up. First ride from standing overnight or during day and it seems a bit soft and under-powered, after about 5 mins, it then feels a lot more responsive. I don't think it is my imagination, it just seems odd.
But again, I just feel I should have been pulling a lot more amps under acceleration than I do.

Battery pack, 26650 cells, 22s5p. Connected in series with 10 x 3 mm nickle plated copper busbars (x 4) and 10mm x .2 nickle strips (x 5). Wiring is 2 x 8swg silicone cable. Negative going through 300amp "ant" BMS then to 200amp 60mv shunt, then to controller, positive through 200 amp relay to controller. (From full charge -90v- I get about 2 to 4 v sag under power).
Motor is a 4T. (with Statorade and Hub sinks)
While I understand the programming, some parts of it are confusing.
DC current - 120A
Boost current - 120A
Rated phase current - 120A
Max phase current - 300A
Protective phase current - 450A
The 3 speed is set to - boost.
Throttle mid V - 2.00
Throttle mid current - 150
Speed limit mode - no limit
Internal speed limit - 100%
Low speed limit - 70% (It will not let me go any higher on this one)
Mid speed limit - 100%

Wheel size is 2.15 x 19" ally motorcycle wheel with 2.50 x 19 tyre.

DriftTrike   1 mW

1 mW
Posts: 14
Joined: Sep 05 2016 5:44pm

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by DriftTrike » Sep 25 2020 7:48pm

randysway wrote:
Oct 14 2019 4:27pm
Just a quick FYI here - regarding regen (at least from my experience).

Variable Regen, High-Brake, and Low-Brake are each independently functioning systems. Ergo, none of them need to be activated for another to work.

Low-Brake - Cuts power to the motor when pulled low (ground)
High-Brake - Engages Regen, at max programmed level, when pulled high (12v to VBatt+)
Variable Regen - Engages proportional regen between 0 and max programmed level, when 0-5v is applied to aux throttle in.

NOTE: There are what, 8 different freaking applications in that Sabvoton doc archive that gets passed around? ONLY ONE OF THEM PROVIDES THE OPTION TO ENABLE VARIABLE REGEN!

After running the installer inside volume-en.zip (Needed for supporting libraries), use the executable 'SabVoton Motor Controller V2.0 (temp programmable).exe' to configure your controller.

After MONTHS of trial, error, and googling, this was the only way I was able to get variable regen working. (It was a blurb I stumbled accross somewhere on endless-sphere that got me here, when I find the post I'll cite it).

That be said, it works splendidly, doesn't reguire BL or BH connected, and only needs to be activated once. After activation, you can go back to using the Android app for configuration.

Cheers.
I have a Sabvoton 72150 with the latest firmware (updated via the Android App). I hooked up a thumb throttle to the regen brake connector. Then using my laptop with the v2.1 of MQCon Software I selected the Ebrake mode to "Ebrake-throttle" and set my Electric Brake Phase Current to 100amps. Save the parameters and power cycle the Sabvoton. When I hit the thumb throttle, I get zero braking force. When I have the Sabvoton hooked up to a computer or to my Android device, the system status will show that the electronic brake is engaged. My purple high brake and the low brake/reverse connectors are both not plugged into anything. What am I doing wrong? Anyone?

DriftTrike   1 mW

1 mW
Posts: 14
Joined: Sep 05 2016 5:44pm

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by DriftTrike » Sep 29 2020 2:46am

DriftTrike wrote:
Sep 25 2020 7:48pm
randysway wrote:
Oct 14 2019 4:27pm
Just a quick FYI here - regarding regen (at least from my experience).

Variable Regen, High-Brake, and Low-Brake are each independently functioning systems. Ergo, none of them need to be activated for another to work.

Low-Brake - Cuts power to the motor when pulled low (ground)
High-Brake - Engages Regen, at max programmed level, when pulled high (12v to VBatt+)
Variable Regen - Engages proportional regen between 0 and max programmed level, when 0-5v is applied to aux throttle in.

NOTE: There are what, 8 different freaking applications in that Sabvoton doc archive that gets passed around? ONLY ONE OF THEM PROVIDES THE OPTION TO ENABLE VARIABLE REGEN!

After running the installer inside volume-en.zip (Needed for supporting libraries), use the executable 'SabVoton Motor Controller V2.0 (temp programmable).exe' to configure your controller.

After MONTHS of trial, error, and googling, this was the only way I was able to get variable regen working. (It was a blurb I stumbled accross somewhere on endless-sphere that got me here, when I find the post I'll cite it).

That be said, it works splendidly, doesn't reguire BL or BH connected, and only needs to be activated once. After activation, you can go back to using the Android app for configuration.

Cheers.
I have a Sabvoton 72150 with the latest firmware (updated via the Android App). I hooked up a thumb throttle to the regen brake connector. Then using my laptop with the v2.1 of MQCon Software I selected the Ebrake mode to "Ebrake-throttle" and set my Electric Brake Phase Current to 100amps. Save the parameters and power cycle the Sabvoton. When I hit the thumb throttle, I get zero braking force. When I have the Sabvoton hooked up to a computer or to my Android device, the system status will show that the electronic brake is engaged. My purple high brake and the low brake/reverse connectors are both not plugged into anything. What am I doing wrong? Anyone?
Thanks to a kind member of the ES Facebook group, I was able to get the variable ebrake to work! My issue was that the over volt setting was too low. I have a 52v battery and the over volt was set to 60v (I rounded up from 58.8). I was advised to set the Over Volt to 10V above the fully charged pack. I set the overvolt to 70v and the ebrake started working. I'm not sure if the ebrake is actually sending power or not back to the battery to charge. Since there is no setting to toggle how much current gets sent back to the battery (like the Slide Regenerative Charge current setting), I'm guessing that it does NOT charge the battery. Does anyone know for sure?

dorong   1 µW

1 µW
Posts: 2
Joined: Mar 21 2020 4:50pm

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by dorong » Oct 03 2020 3:55pm

Hi
I need help i am unable to start the throttle ebrake
On my sabvoton 72150 controller.
I can see on the system status that it changes from "22:system running"
To "20:electronic brake" when I start to press on the ebrake throttle
and return to 22 when I release the ebrake trottle.
i have tried to change the electric brake phase current but this did not helped.
and many other parameters.
ebrake1.png
ebrake1.png (79.6 KiB) Viewed 108 times

dorong   1 µW

1 µW
Posts: 2
Joined: Mar 21 2020 4:50pm

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by dorong » Oct 03 2020 10:46pm

I found the solution
I needed to change the parameters slide regenerative charge current to zero

DtiK   100 mW

100 mW
Posts: 42
Joined: Feb 09 2020 10:31am

Re: Sabvoton SVMC072150 controller review, variable regen *PICS*

Post by DtiK » Oct 04 2020 9:30am

Can this controller make "aggressive" brake+regen when you lift throttle wide open? Or under predefined zero point voltage.

Actually I'm getting SVMC72080 but I think it has almost same software?

Post Reply