Kelly KLS 300A controller review

Get real world experience and user feedback on the electric bicycle products.
cwah   10 GW

10 GW
Posts: 4130
Joined: Jul 24 2011 5:42am
Location: Between paris and london

Re: Kelly KLS 300A controller review

Post by cwah » Jan 25 2016 3:24pm

I hope someday being able to pop a wheelie. I've never managed to do that on any of my bikes.

Even on a mac motor on 16" wheel and 2700W!

So getting this motor should have enough torque for wheelie? Maybe the way I am sitting on the bike makes it harder to wheelie as I'm very much on the front
Help me find my stolen electric brompton: http://bit.ly/1a0vbBC and Bosch Sinus B3 http://bit.ly/1eV0WQz

User avatar
eee291   10 kW

10 kW
Posts: 664
Joined: Nov 05 2015 4:35pm
Location: Austria, Burgenland: Güssing

Re: Kelly KLS 300A controller review

Post by eee291 » Jan 26 2016 2:00am

cwah wrote:I hope someday being able to pop a wheelie. I've never managed to do that on any of my bikes.

Even on a mac motor on 16" wheel and 2700W!

So getting this motor should have enough torque for wheelie? Maybe the way I am sitting on the bike makes it harder to wheelie as I'm very much on the front

Dude I weigh 130kg and I can pop a wheelie no problem.

I think your Kelly is configured wrong, all I had to do was put the motor current 100% and motor torque to to the maximum value something like 10000 or so.

cwah   10 GW

10 GW
Posts: 4130
Joined: Jul 24 2011 5:42am
Location: Between paris and london

Re: Kelly KLS 300A controller review

Post by cwah » Jan 26 2016 3:11am

Are you talking about the motor max output frequency (14) or motor pwm frequency (18) ?

I left both to default setting as I didm't think would have any impact on torque?

I am wondering if it's related to my motor? I have a leafmotor 1000W with 30mm magnet... could that be the reason?
Help me find my stolen electric brompton: http://bit.ly/1a0vbBC and Bosch Sinus B3 http://bit.ly/1eV0WQz

User avatar
eee291   10 kW

10 kW
Posts: 664
Joined: Nov 05 2015 4:35pm
Location: Austria, Burgenland: Güssing

Re: Kelly KLS 300A controller review

Post by eee291 » Jan 26 2016 4:52am

cwah wrote:Are you talking about the motor max output frequency (14) or motor pwm frequency (18) ?

I left both to default setting as I didm't think would have any impact on torque?

I am wondering if it's related to my motor? I have a leafmotor 1000W with 30mm magnet... could that be the reason?

It's not entirely the motors fault. With my PC programming I can change in the motor settings tab motor torque in ki (unit) the default is something like 6000 just change that to the max value witch is noted in the comment section when you click on it.


If you want I can still make a proper rewiew and give some tipps in the video or something to help you out.

Buying a Mxus motor on the es sphere is cheaper than buying some overpriced/overrated Aliexpress hub

cwah   10 GW

10 GW
Posts: 4130
Joined: Jul 24 2011 5:42am
Location: Between paris and london

Re: Kelly KLS 300A controller review

Post by cwah » Jan 26 2016 10:59am

Can you share screenshot? Maybe it's a config not available for my controller.

Where can I find a good cheap mxus delivered to the uk?
Help me find my stolen electric brompton: http://bit.ly/1a0vbBC and Bosch Sinus B3 http://bit.ly/1eV0WQz

User avatar
eee291   10 kW

10 kW
Posts: 664
Joined: Nov 05 2015 4:35pm
Location: Austria, Burgenland: Güssing

Re: Kelly KLS 300A controller review

Post by eee291 » Jan 26 2016 12:21pm

cwah wrote:Can you share screenshot? Maybe it's a config not available for my controller.

Where can I find a good cheap mxus delivered to the uk?

here are all my settings, hope this helps

Capture.PNG
kelly settings
Capture.PNG (69.47 KiB) Viewed 2419 times
nnn.PNG
more settings
nnn.PNG (35.97 KiB) Viewed 2419 times
....PNG
and thats all
....PNG (35.97 KiB) Viewed 2419 times

about the mxus just ask Samd, or post it in the wanted section or keep an eye out for a good deal here on ES

cwah   10 GW

10 GW
Posts: 4130
Joined: Jul 24 2011 5:42am
Location: Between paris and london

Re: Kelly KLS 300A controller review

Post by cwah » Jan 26 2016 12:24pm

Thanks I'm going to check against my settings. Will send a msg to samd
Help me find my stolen electric brompton: http://bit.ly/1a0vbBC and Bosch Sinus B3 http://bit.ly/1eV0WQz

User avatar
eee291   10 kW

10 kW
Posts: 664
Joined: Nov 05 2015 4:35pm
Location: Austria, Burgenland: Güssing

Re: Kelly KLS 300A controller review

Post by eee291 » Jan 27 2016 3:46am

One more thing if you want to really flip your bike just decrease the throttle response time :twisted:

evolutiongts   10 kW

10 kW
Posts: 747
Joined: Dec 31 2013 5:13pm
Location: Alhambra, CA

Re: Kelly KLS 300A controller review

Post by evolutiongts » Jan 27 2016 4:20am

Is the kelly controller easy to setup and get up and running?
http://www.electricrt.com
Electric Race Technologies

Schwinn 405 2WD Track Bike 18KW
EDGE 1500W Hub / MXUS 3K Turbo
ASI BAC 2000 / BAC 4000 Bluetooth
viewtopic.php?f=6&t=93079

10Kw KMX death trike
MUXUS 3K Turbo
Sabvoton 72V150A
Moto Wheels all around
Front Suspension Kit
viewtopic.php?f=6&t=83423

Giant Trance 4 Full Suspension
Cyclone 3000W
74V 3000W
http://endless-sphere.com/forums/viewto ... =6&t=59005

User avatar
izeman   10 GW

10 GW
Posts: 4685
Joined: Jun 21 2011 8:25am
Location: vienna, austria
Contact:

Re: Kelly KLS 300A controller review

Post by izeman » Jan 27 2016 4:58am

check that out: https://endless-sphere.com/forums/viewt ... 30&t=71942

maybe you would think about making your signature a bit smaller? relation between your text and signature is bit off *ggg*
Capture.JPG
Capture.JPG (56.86 KiB) Viewed 2377 times

snejky   100 mW

100 mW
Posts: 36
Joined: Jun 02 2015 11:49pm

Re: Kelly KLS 300A controller review

Post by snejky » Sep 29 2016 2:48am

3+2 blinks have my friend with shorted phase wires.(burned by overheating) :-)

Freemann   1 mW

1 mW
Posts: 12
Joined: Jan 23 2017 2:51am

Re: Kelly KLS 300A controller review

Post by Freemann » Jan 31 2017 8:54am

Recently I bought a KLS7230S,24V-72V,300A for my E-Scooter with a 48V3000W hub motor.
Few days ago I hooked up everything and the hub motor is "running".

My problem now is that the controller goes into "internal error" when the hub-motor hits >400rpm.

Tried a lot of settings, but nothing seems to work.

Here's some more info;
Motor: 48V 3000W
Motor poles: 63
Motor magnets: 70
BMS: TinyBMS 150A
Battery: 16S23P, low=52V, High=64V (cells: panasonic NCR18650b)

Monitoring while running I see 5-10A phase current, motor hall sensors are showing up nicely, controller sees a nice battery voltage, motor identification is working, TPS pedal value is idle ~45 and around "internal error" point ~120.
One of the things which caught my attentions is the controller temperature is, seen in kelly windows application, bouncing between 0 and 251 (could this be a faulty temp sensor in the controller?).
Also i'm unsure on how to configure the "motor poles" and "resolver poles" values. For now these are configured at 63 (motor poles) and 3 (resolver poles).

Hope somebody is able and willing to help me :)

Lowberry   10 mW

10 mW
Posts: 22
Joined: Jan 27 2016 10:01pm
Location: redding CA.

Re: Kelly KLS 300A controller review

Post by Lowberry » Mar 06 2017 8:08pm

I JUST PUT A kls-s 7230s in service.... it cames with a program that was causing a shut down with full throttle after a bit. it would cut power for a moment then resume.. changing the battery amp percent to 60 and the phase amp to 70 seems to make it ok... if anyone is having this give it a try. otherwise the controller is ok right now... although it did a few glitch things right at first... rode it in the yard the I stopped the when I added throttle it was suddenly in reverse??? changed directions and it was ok on the bench but the did it again... back to programming.. then I reset the identification angle again then it has been running forward. I can post my program numbers if someone is having trouble :mrgreen:

Lowberry   10 mW

10 mW
Posts: 22
Joined: Jan 27 2016 10:01pm
Location: redding CA.

Re: Kelly KLS 300A controller review

Post by Lowberry » Mar 09 2017 2:55am

evolutiongts wrote:Is the kelly controller easy to setup and get up and running?

yes it was for me

User avatar
charlesmcnall   1 mW

1 mW
Posts: 16
Joined: Jul 12 2016 1:05pm
Location: SLC, UT

Re: Kelly KLS 300A controller review

Post by charlesmcnall » Jun 27 2017 1:47pm

eee291 wrote:One more thing if you want to really flip your bike just decrease the throttle response time :twisted:
I was told by fany that below a certain amount the value is ignored by the firmware. Atleast that was true on my KLS96601-8080I
Overall the controller was a breeze to setup though.
Electric Ninja 250 http://evalbum.com/preview.php?vid=5243
Lemond Etape 1400W hub motor 48V 15ah - need to make EValbum
6hp Electric snowblower conversion http://evalbum.com/preview.php?vid=5250

Post Reply