power - current lost BAFANG bbs02

Yer bike busted? tell us all about it here.
Post Reply
100pies13   10 µW

10 µW
Posts: 5
Joined: Mar 23 2021 6:53pm

power - current lost BAFANG bbs02

Post by 100pies13 » Mar 23 2021 6:55pm

hi, does anyone advice me what is the problem with BAFANG bbs02 750w ewth a 14ah battery?
some days ago started to give me no full power=low wats, max current about 10 amps. When usually it was more than 1000w and more than 20 amps. No error codes on the display. Same thing happens with throtlle or PAS.

Million thanks

User avatar
amberwolf   100 GW

100 GW
Posts: 32163
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: power - current lost BAFANG bbs02

Post by amberwolf » Mar 24 2021 3:01pm

What specifically happened between the time it worked normally, and the time it did not?

What are you using to measure the wattage?

Does it actually ride differently, or is it just the wattage display that is different?

100pies13   10 µW

10 µW
Posts: 5
Joined: Mar 23 2021 6:53pm

Re: power - current lost BAFANG bbs02

Post by 100pies13 » Mar 24 2021 7:12pm

it rides slower, not as powerfull as before, From 1000w to 500w maximun.

I have checked the wire connections from the battry to the motor and they are fine. I have checked with another lcd and it feels the same. lost of power.

Is the controller of the motor?

Is the Bms of the battery?

What else?

thanks

User avatar
amberwolf   100 GW

100 GW
Posts: 32163
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: power - current lost BAFANG bbs02

Post by amberwolf » Mar 24 2021 9:04pm

100pies13 wrote:
Mar 24 2021 7:12pm
it rides slower, not as powerfull as before, From 1000w to 500w maximun.
One question of three answered, two to go:

What specifically happened between the time it worked normally, and the time it did not?

What are you using to measure the wattage?

100pies13   10 µW

10 µW
Posts: 5
Joined: Mar 23 2021 6:53pm

Re: power - current lost BAFANG bbs02

Post by 100pies13 » Mar 25 2021 5:34am

I measure the watts with the lcd

It started to become wrong probabily since a strong rain........ But It wroked fine for 2 months since then.

thanks, i really apreciate your efforts.

User avatar
amberwolf   100 GW

100 GW
Posts: 32163
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: power - current lost BAFANG bbs02

Post by amberwolf » Mar 25 2021 8:59pm

100pies13 wrote:
Mar 25 2021 5:34am
I measure the watts with the lcd
Ok. That is dependent on the system working correctly, which it isn't, so it is possible that reading is not accurate (cant' know without comparing to non-integrated meter readings). An external wattmeter that goes between battery and controller would give correct readings even if the system itself cant' for some reason. You probably don't need one right now, but they do come in handy for testing. :)
It started to become wrong probabily since a strong rain........ But It wroked fine for 2 months since then.
Even though it has been that long, it is likely still related, probably corrosion inside the drive housing in the electronics, or inside a connector or cable (where you can't see it).

Sometimes unplugging each connector, one at a time, examining it carefully in good light for any water intrusion or corrosion, and then plugging it back in, a few times each, may clean such corrosion from connector contacts (pins), but this doesn't always work even if that is what is wrong. But it generally doesn't hurt and is the easiest first thing to try.

If the water did get into the drive housing, and seeped into the electronics, it might have caused a problem with one of the shunt resistors. If there are two, and one no longer makes connection, then it would cut power in half as you see. The controllers should be potted against water, but this is not always done perfectly and so water can intrude between the potting and the PCB (which is where the shunts are). This is a pic of one version of a BBSxx controller puck, showing the two black rectangular shunt resistors, with what may be corrosion on the board around the general area:
viewtopic.php?f=3&t=83778&p=1627276#p1627254
Image

100pies13   10 µW

10 µW
Posts: 5
Joined: Mar 23 2021 6:53pm

Re: power - current lost BAFANG bbs02

Post by 100pies13 » Mar 27 2021 1:19pm

THANK YOU AMBERWOLF........... Today I update my controller and everything seem to be correct now, Full power is back.

:bigthumb:

User avatar
amberwolf   100 GW

100 GW
Posts: 32163
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: power - current lost BAFANG bbs02

Post by amberwolf » Mar 27 2021 11:42pm

100pies13 wrote:
Mar 27 2021 1:19pm
Today I update my controller
What does this mean?

100pies13   10 µW

10 µW
Posts: 5
Joined: Mar 23 2021 6:53pm

Re: power - current lost BAFANG bbs02

Post by 100pies13 » Apr 04 2021 1:16pm

amberwolf wrote:
Mar 27 2021 11:42pm
100pies13 wrote:
Mar 27 2021 1:19pm
Today I update my controller
What does this mean?
I have replaced the old controller with a new one and it works with full power again

Post Reply