Power Cutting Issue Sabvoton

Yer bike busted? tell us all about it here.
Post Reply
hemis   1 µW

1 µW
Posts: 2
Joined: Aug 11 2020 6:19pm

Power Cutting Issue Sabvoton

Post by hemis » Mar 27 2021 5:11pm

So I'm building a steath bomber clone type of bike using a sabvoton svmc 7280. My battery is 72v and bms specs are 80a continuous and 120a pea. When I first start ripping around on the bike everything is fine and I get the full power immediately, but after a few rips I lose most of the power and the bike feels very slow and lazy. If I turn the bike on and off the power comes back. Let me now if any more information is needed as I'm sure i've left something crucial out. Thanks, let me know!

User avatar
amberwolf   100 GW

100 GW
Posts: 32163
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Power Cutting Issue Sabvoton

Post by amberwolf » Mar 28 2021 12:52am

It could be the battery being unable to handle the power demands from it (poor quality cells, unbalanced, defective, insufficient current capability, etc).

It could be the motor or the controller overheating, and the controller rolling power back to prevent damage.

It could be incorrect settings in the controller causing the above. What settings, if any, have been changed from the default? What were the default settings?

If you can provide links to each the exact products you have purchased from the same sites you bought from, it will help us help you by giving us direct access to whatever information those sites have about them.

hemis   1 µW

1 µW
Posts: 2
Joined: Aug 11 2020 6:19pm

Re: Power Cutting Issue Sabvoton

Post by hemis » Mar 28 2021 4:21pm

I haven't charged the battery yet. Do you think if I charged the battery it would balance the cells? OR is it possible that I damaged the battery in not charging it when I first got it?

Post Reply