Cycle Analyst firmware download links.

Yer bike busted? tell us all about it here.
Post Reply
P3yot3   100 mW

100 mW
Posts: 37
Joined: Nov 03 2020 9:40am

Cycle Analyst firmware download links.

Post by P3yot3 » Jun 07 2021 8:57am

Hi all,

Does anyone know of any direct download links for CA firmware? My CA Setup Utility seems unable to connect to ebikes.ca website on both my laptop & PC - so I'm presuming their server is offline?

Thanks & regards.

P3yot3   100 mW

100 mW
Posts: 37
Joined: Nov 03 2020 9:40am

Re: Cycle Analyst firmware download links.

Post by P3yot3 » Jun 08 2021 8:42am

Here's what I've tried so far: disable firewall, re-downloading CASetup, running as admin, running on several computers, disconnecting & reconnecting cable, rebooting & powercycling - still can't download new firmware. It can read my CA just fine, it just can't connect to ebikes.ca firmware database.

In particular I'm after the firmware beta release: v3.15b1 2021-03-18 or above, which provides support for ERider T9 36 pole PAS configuration.

Anyone?.....

User avatar
neptronix   100 GW

100 GW
Posts: 15687
Joined: Jun 15 2010 5:56pm
Location: Utah, USA
Contact:

Re: Cycle Analyst firmware download links.

Post by neptronix » Jun 08 2021 9:48am

I'm able to download the firmware as of today. Give it another try, they may have had a one time glitch.
"Love and compassion are necessities, not luxuries. Without them, humanity cannot survive." - Dalai Lama

My first major build: 1.6kW 8T MAC motor on a Trek 4500 MTB.
Monster MTB: Leafmotor 1500w @ 4kW on a Turner O2 full suspension.
The monster scooter: Heavy duty Cannondale semi recumbent - under construction.
Blue Dream: Maxaraya FS semi recumbent and high efficiency mid-drive - under construction.

P3yot3   100 mW

100 mW
Posts: 37
Joined: Nov 03 2020 9:40am

Re: Cycle Analyst firmware download links.

Post by P3yot3 » Jun 08 2021 10:55am

neptronix wrote:
Jun 08 2021 9:48am
I'm able to download the firmware as of today. Give it another try, they may have had a one time glitch.
Hi neptronix, I just tried it again - still no-go I'm afraid.

Edit: I kept hitting the update button & after about the 15th attempt it suddenly connected! Yay!!

Thanks for the heads up neptronix - I can now begin my setup. Phew.

Post Reply