Votol EM-100 & EM-150 controllers

General Discussion about electric vehicles.
chronosgarage   10 W

10 W
Posts: 93
Joined: Oct 23 2020 8:19pm

Re: Votol EM-100 & EM-150 controllers

Post by chronosgarage » Mar 14 2021 11:47am

PrashanBhatta wrote:
Mar 10 2021 3:00am
My setup has a very low starting torque. It can't move without moving weird noise at the start. There is a setting for djusting initial torque but nothing changes on adjusting those values.
I finally found the solutions. I contacted a friend of mine who is a ebike technician. He set the parameters of my bike remotely. It turned out to be the problem with the phase wire connection, number of pole and hall angle.

I had to swap the position of the phase wire and changing the hall angle combination until he found the correct one.

My bike start smoothly now.

User avatar
eVroomer   1 mW

1 mW
Posts: 18
Joined: Jun 21 2019 2:50pm
Location: Sofia

Re: Votol EM-100 & EM-150 controllers

Post by eVroomer » Mar 14 2021 5:00pm

Hey guys, is there an easy way to tell if my Votol EM-100 is CAN or not?

tester1   1 µW

1 µW
Posts: 1
Joined: Mar 18 2021 12:38am

Re: Votol em-100 / 150 controllers

Post by tester1 » Mar 18 2021 12:50am

larsb wrote:
Nov 08 2018 12:46pm
I am certainly not an expert in serial communication but i checked and in some cases only rx, tx and ground is needed so the 3 wires and this connector is the programming one (even if it's not 4 wires) :D

QS must have optimised the cable and removed the 5V feed since i bought my controller (picture from user "ors150" cable)
image.jpeg
Can you please give me connection diagram for PL2302 to controller ?

Paulflieg   100 mW

100 mW
Posts: 37
Joined: Jan 11 2019 10:30am

Re: Votol em-100 / 150 controllers

Post by Paulflieg » Mar 22 2021 12:34pm

IMG_20210322_181536.jpg
USB - > votol
IMG_20210322_181536.jpg (1.74 MiB) Viewed 896 times
tester1 wrote:
Mar 18 2021 12:50am
larsb wrote:
Nov 08 2018 12:46pm
I am certainly not an expert in serial communication but i checked and in some cases only rx, tx and ground is needed so the 3 wires and this connector is the programming one (even if it's not 4 wires) :D

QS must have optimised the cable and removed the 5V feed since i bought my controller (picture from user "ors150" cable)
image.jpeg
Can you please give me connection diagram for PL2302 to controller ?
Do this! Or with Bluetooth ... 2nd picture, but then with !! 5V, connect. Hc05 modul
Attachments
IMG_20210322_181840.jpg
Bluetooth - > votol
IMG_20210322_181840.jpg (3.21 MiB) Viewed 896 times

Albundy   1 µW

1 µW
Posts: 1
Joined: Mar 23 2021 11:04am

Re: Votol EM-100 & EM-150 controllers

Post by Albundy » Mar 23 2021 11:48am

Hi all,

I apologize in advance for my level of English.

I have a Yadea G5 PRO scooter on which I will want to install an EM100 controller.

At this point, I can say that the scooter has the following characteristics:

3100W midd motor manufactured by Yadea.Hall angle 60 °.

2 batteries 60V, 32Ah, 45A max.

1.1V - 4.2V throttle operating range.

brake level: LOW

after scanning the whole topic, I plan to configure the controller as follows:

Setting 1:

Model: EM 100
Battery Voltage: 60V
Overvoltage: 72.5V
Undervoltage: 52.5V
Softvoltage: 55.5V
Undervoltage variation: 1
Busbar current: 45A
current phase: 9960

Throttle voltage set
Low protect value: 0.3V
Start voltage: 1.1V
The end of the voltage: 4,2V
high voltage protect value: 4,7V

Setting 2 :

Sport mode setup: not used
Downhill electric brake assist: not used
Speed limit setting: not used
Weakening flow conpensation: 34

three speed
Low 28/28
Mid 70/70
High 99/99
button 3 speed: on
Three speed default: Low
soft start: off

Setting 3 :


Pole pairs: 5
Motor type: ??
Hall shift angle: 60°
out put: to test
Moving assist and cruise: not used
double voltage: not used
reversing: not used

Can you give me your opinion on the configuration I am considering?

Thx !

Teddy105   10 µW

10 µW
Posts: 5
Joined: Mar 23 2021 11:41am

Re: Votol EM-100 & EM-150 controllers

Post by Teddy105 » Mar 23 2021 11:54am

Hello, does anyone have the newest version of the Votol em v3 program?
I currently run a em100s with a QS 17inch 273 5000w hub

Im achieving just over 105-106kmph on flat ground and up to 110kmph on hills (using gps)

I am content with this.

However has anyone figured out how to properly use cruise function? Ive been following this thread for awhile now and I am curious as I would like to use this?

I've been trying to change the start throttle voltage but it seems to kill throttle if I set to 0.75 or lower. at 0.80 it will run but have issues stopping and will start up at times without even a touch of throttle and is a pain to shut off. if I set it at anything past that up to 1.00 it will change it to 1.01 automatically. Currently looking to get slightly better throttle response.

leyva.ale   10 mW

10 mW
Posts: 25
Joined: May 16 2020 11:25pm

Re: Votol EM-100 & EM-150 controllers

Post by leyva.ale » Mar 23 2021 12:44pm

IronMan wrote:
Jan 04 2021 11:11am
So, its my first post but Ive been reading ALL of this thread... first and most important I must say that new 4th generation Votol EM-50/100/150/200/250/300 has NEW firmware (.bin) that behaves differently, in older votol (still in stock) the values in flux and % slots were put the same and was about double voltaje settings, BUT in these 4t gen boards only left side means what you think it means, right side is for other adjustments like jitter (timing of frequency, used to adjust the motor: when you hit it too low the motor spins suddenly, if you go to far the motor vibrates half throttle, the adjust range is 100-1200 and its usually right around 300n you notice the motor starts spinning real smooth and slow, with no fluctuation) this jitter is the second or right slot box of sport mode flux weakening, if u leave it at 0 motor wont start..
And so, many things changed and the problem isnt defective controller or bugy software.. the problem is that these people designing this hard stuff are real CHINESE people, and the info is lost along the way.. even inside Votol company..
I will do a real manual for this sh*t and ensure we all know what every part of this software does.. I even know how to use the calibration section of software and I must say EVERYTHING in this software works and works fine, and its hi-tech also..
I do have the new firmware update (bin file) at least one of it, and I would like to have the older one or a newer one, so.. hi to all of you, and replay so i know this thread isnt dead, any questions to me I'll answer no problem.. salute
Hello>
I have repaired recently an votol EM100 and keep for myself. I used to config older versions, but in this case, with the new firmware, i am completly lost. The english manual is unuseless. So i will aprecciate a lot some guideness here.
I ahve reading the wholw post and some things ar very clear, others not.
Any way, i have the .bin if someone need it. Justo form EM100, not EM150

runer74   1 µW

1 µW
Posts: 2
Joined: Mar 12 2021 3:30pm

Re: Votol EM-100 & EM-150 controllers

Post by runer74 » Mar 24 2021 3:18am

Good afternoon! Tell me how to connect the recovery? How does high brake and low brake work? need to close contacts or feed 12c? plus or minus?

leyva.ale   10 mW

10 mW
Posts: 25
Joined: May 16 2020 11:25pm

Re: Votol EM-100 & EM-150 controllers

Post by leyva.ale » Mar 24 2021 10:57pm

hello!

where can i get the bin file????
by other hand, the automatic cruise function is dead?, i cant make it works in the new version.... :(
i am a little lost too in ten configuration changes made, for example regarding sport mode. can i use 1/2/3 speeds without any of flux and add some little just for sport mode?
looks like changing flux values n sport mode affect the others too. its very confusing, i am full of question about this controller

Paulflieg   100 mW

100 mW
Posts: 37
Joined: Jan 11 2019 10:30am

Re: Votol EM-100 & EM-150 controllers

Post by Paulflieg » Mar 25 2021 6:21am

Albundy wrote:
Mar 23 2021 11:48am
Hi all,

I apologize in advance for my level of English.

I have a Yadea G5 PRO scooter on which I will want to install an EM100 controller.

At this point, I can say that the scooter has the following characteristics:

3100W midd motor manufactured by Yadea.Hall angle 60 °.

2 batteries 60V, 32Ah, 45A max.

1.1V - 4.2V throttle operating range.

brake level: LOW

after scanning the whole topic, I plan to configure the controller as follows:

Setting 1:

Model: EM 100
Battery Voltage: 60V
Overvoltage: 72.5V
Undervoltage: 52.5V
Softvoltage: 55.5V
Undervoltage variation: 1
Busbar current: 45A
current phase: 9960

Throttle voltage set
Low protect value: 0.3V
Start voltage: 1.1V
The end of the voltage: 4,2V
high voltage protect value: 4,7V

Setting 2 :

Sport mode setup: not used
Downhill electric brake assist: not used
Speed limit setting: not used
Weakening flow conpensation: 34

three speed
Low 28/28
Mid 70/70
High 99/99
button 3 speed: on
Three speed default: Low
soft start: off

Setting 3 :


Pole pairs: 5
Motor type: ??
Hall shift angle: 60°
out put: to test
Moving assist and cruise: not used
double voltage: not used
reversing: not used

Can you give me your opinion on the configuration I am considering?

Thx !
Hi,

I think you are trying the "old" setting logic !? The newer firmware requires different, partly illogical settings .... Do you have a new controller? Be sure to read the pages, from around 47 ... it will be very helpful! Do you want to tune your scooter or is it a repair? How much A can your battery / BMS provide?

rienesl   10 mW

10 mW
Posts: 28
Joined: Feb 13 2020 10:28am

Re: Votol EM-100 & EM-150 controllers

Post by rienesl » Mar 31 2021 7:14pm

There have been 3 or 4 requests for help about the settings recently. I don't have the time at the moment to answer them all individually, but have a look at page 53 and the 2nd last post (this has changed since last time for whatever reason. Unfortunately the posts don't have numbers, so I can not link to it directly. If someone is looking for it in the future, he might find this post on a different position). Most of it I explained there (new function of new settings, speed, cruise control, HDC, etc.). There is a follow up a few posts later on page 55, where I added some more details, determined later. If there are any further questions, I hope I will be online again at the weekend

Millhouse_5   1 mW

1 mW
Posts: 19
Joined: Nov 27 2020 6:58pm

Re: Votol EM-100 & EM-150 controllers

Post by Millhouse_5 » Apr 05 2021 1:11pm

Hey everyone, I'm having some issues getting a speedometer signal off my recently installed EM-100. I'm using the factory cluster from my Emmo Proton and it's very similar to the QS CT-22 (which seems at least somewhat popular). I've got a 6 pin connector which is for all my lights and signals, a 3 pin which I honestly don't think was plugged into anything with the old controller and a single wire, which i'm guessing is the speed wire.

I've tried plugging this into the speedometer plug on the controller and got nothing when set to both single wire, and hall speedometer modes. I also tried wiring it directly to the hall sensor wire and putting it in hall speedometer mode. Still nothing. anyone have any ideas as to what I might be doing wrong? Thanks

ColdRider   10 mW

10 mW
Posts: 21
Joined: Mar 30 2016 9:10pm
Location: Montreal ,Quebec ,Canada

Re: Votol EM-100 & EM-150 controllers

Post by ColdRider » Apr 08 2021 3:55pm

Allo hall of you votol user's
I am looking into getting me a new controller for my Cyclone 3K since i am about to build my new battery set ;
Planned for a 21s using INR-21700-P42A cells ,two packs for less V Sag overall ,any way here is my ? ;
My BMS's (each pack has one ) ANT 120A capable with all the trimmings .

Is the votol controller a good addition to my set up ? , is it easy to tune with a little work of course ,what about that over heating i read about , is that really happening frequently ? is there other controller of that type ( SineWave / Programable / good support ) that i should investigate ?

I have read alots on this thread and looked many controller (researched them ) , This is my last BIG part i need before assembly and i cant wait to ride again after having been very sick on F***** cancer , i beated it i want to ride now asap ,Thanks all for you great help
I am working on it !
BB Upgrade in progress
Safety Lighting System Planned

Will post them soon

rienesl   10 mW

10 mW
Posts: 28
Joined: Feb 13 2020 10:28am

Re: Votol EM-100 & EM-150 controllers

Post by rienesl » Apr 09 2021 7:45am

Millhouse_5 wrote:
Apr 05 2021 1:11pm
Hey everyone, I'm having some issues getting a speedometer signal off my recently installed EM-100. I'm using the factory cluster from my Emmo Proton and it's very similar to the QS CT-22 (which seems at least somewhat popular). I've got a 6 pin connector which is for all my lights and signals, a 3 pin which I honestly don't think was plugged into anything with the old controller and a single wire, which i'm guessing is the speed wire.
First of all, prey that you haven't fried your new display. The good news is, I can't read that you tried phase wire, so you have a good chance that it survived. First step when you buy a display is to disassemble it and check _ALL_ wires. Is the pad on the board with your expected function really soldered to the wire you expect? If it is all in Chinese, the camera function of google translate is doing the magic

Then you need to change not just XYT to hal (Page 3) , you need to change the function of the pin on the controller as well (page "port settings", port PB9, setting 13).

@cold rider:
the Votol is an amazing piece of hardware, and I haven't seen so many customisation options on any other controller. However, if you don't get support from your motor manufacturer about its parameters, you need to be careful with some of the settings (especially the flux weakening part) not to make permanent damage. On the other hand, if you are willing to invest some time, you will find your unique, personal setup that unlikely any other controller will offer you.

Nennko   1 mW

1 mW
Posts: 12
Joined: Aug 13 2020 3:19pm

Re: Votol EM-100 & EM-150 controllers

Post by Nennko » Apr 11 2021 2:34pm

Hi, guys!

I have a Votol 150-2 (for 96 volts) controller and QS 138 70h motor.

My target is to configure the controller in order to reach RPM up to 7600. I saw some Taiwan guys did that.

At the current settings, I am getting only 5400 and on the highest rotates motor is shaking working not stable. Who can assist me in this question?

As far as I understand, this is a matter of the values in the Flux-Weakening gaps or...?


Image
Image
Image
Image

PrashanBhatta   1 mW

1 mW
Posts: 10
Joined: Feb 11 2021 11:46pm

Re: Votol EM-100 & EM-150 controllers

Post by PrashanBhatta » Apr 13 2021 12:53am

chronosgarage wrote:
Mar 14 2021 11:47am
PrashanBhatta wrote:
Mar 10 2021 3:00am
My setup has a very low starting torque. It can't move without moving weird noise at the start. There is a setting for djusting initial torque but nothing changes on adjusting those values.
I finally found the solutions. I contacted a friend of mine who is a ebike technician. He set the parameters of my bike remotely. It turned out to be the problem with the phase wire connection, number of pole and hall angle.

I had to swap the position of the phase wire and changing the hall angle combination until he found the correct one.

My bike start smoothly now.
I am using QS3000 mid drive motor with these specs.
Magnet Height: 70mm, 40pcs, 5 pole pairs
Diameter of stator: 138mm
Rated Power: 3000W (peak power, pending)
Rated Voltage: 72V as default
Speed: 90KPH
No-load rpm: 4400rpm without flux weakening, 6500RPM with flux weakening. Max Torque: approx 56N.m (without Reduction ratio)
Reduction ratio: 1:4.7 (as default)
Max Efficiency: pending
Continuous Battery Current: pending (72V)
Peak Battery Current: 120A (72V)
Suggest Peak Phase Current: 450A
Thermic Probe: None (KTY83/122 is available for sample). Working Temperature: pending
Single Hall Plate with waterproof connectors
16mm² Cross Section of Phase Wire (not include insulation layer)
Hall Sensor Phasing

Are the config parameters good? Or do I have to change something?
Attachments
p1.PNG
p1.PNG (32.71 KiB) Viewed 507 times
p2.PNG
p2.PNG (39.79 KiB) Viewed 507 times
p3.PNG
p3.PNG (31.18 KiB) Viewed 507 times
p4.PNG
p4.PNG (37.31 KiB) Viewed 507 times

Nennko   1 mW

1 mW
Posts: 12
Joined: Aug 13 2020 3:19pm

Re: Votol EM-100 & EM-150 controllers

Post by Nennko » Apr 15 2021 8:09am

Now I definitely know that the rotates depend on the flux weakening values.

I was playing a bit and succeed in getting 5600 RPM instead of 5400RPM only playing with flux weakening.

So hence, I wish someone could help me setting up the best parameters instead of hundred tries on controller configurations tuning?

j bjork   100 kW

100 kW
Posts: 1068
Joined: Aug 31 2018 3:01pm
Location: Linköping, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by j bjork » Apr 15 2021 8:16am

Read the thread and set up the motor etc. before you try to get high rpm

Nennko   1 mW

1 mW
Posts: 12
Joined: Aug 13 2020 3:19pm

Re: Votol EM-100 & EM-150 controllers

Post by Nennko » Apr 15 2021 9:08am

j bjork wrote:
Apr 15 2021 8:16am
Read the thread and set up the motor etc. before you try to get high rpm
Clarify please what do you mean? All the configs are made in these 3 tabs

Image
Image
Image

j bjork   100 kW

100 kW
Posts: 1068
Joined: Aug 31 2018 3:01pm
Location: Linköping, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by j bjork » Apr 15 2021 9:18am

Sorry, it was the other guys settings I saw. Yours look better. But if you want high rpm dont use HDC, or set it higher.
I dont know your controller, maybe you tune the motor with the right fw values like the newer 72v controllers?

Nennko   1 mW

1 mW
Posts: 12
Joined: Aug 13 2020 3:19pm

Re: Votol EM-100 & EM-150 controllers

Post by Nennko » Apr 15 2021 9:25am

j bjork wrote:
Apr 15 2021 9:18am
Sorry, it was the other guys settings I saw. Yours look better. But if you want high rpm dont use HDC, or set it higher.
I dont know your controller, maybe you tune the motor with the right fw values like the newer 72v controllers?
That is totally fine, I switched off HDC yesterday (and set it to 7600 RPM) it didn't change anything, so I was trying to play with FW values and it had some influence.

To be frank I supposed to get even higher than the default 6000 RPM which is noticed in QS 138 with higher voltage. But now can't even get the standard values.

However, please share your configs for FW if you get maximum RPM despite the other voltage, I will experiment.

The issue is that the Votol manager is the only one contact person, he replies once or twice a year. They are aimed on B2B, and don't give much *hit on B2C

j bjork   100 kW

100 kW
Posts: 1068
Joined: Aug 31 2018 3:01pm
Location: Linköping, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by j bjork » Apr 15 2021 10:59am

I have posted them a few times in the thread, but here you go:

Image

Image

Image

Image

I have made some small changes since those pictures were taken, but this is basically it.
These settings probably dont work on the newer controllers (sw and hw version on page one)
It seems like flux-weakening compensation on page 2 is not the same thing, and the box to the right on flux-wekening in sport mode is used to tune the motor. Maybe the box to the right on the other flux-w settings too. But there are some info on that on the last few pages.
I reach at least 8000 rpm with these settings.

j bjork   100 kW

100 kW
Posts: 1068
Joined: Aug 31 2018 3:01pm
Location: Linköping, Sweden

Re: Votol EM-100 & EM-150 controllers

Post by j bjork » Apr 15 2021 11:11am

PrashanBhatta wrote:
Apr 13 2021 12:53am

Your motor settings is totally wrong.
It seems like you have the older controller (same as mine)
You can look at my settings, but maybe you shouldent go as high in currents and flux weakening as I do especially in sport mode.(I cant promise you wont brake things with those settings :wink: )

PrashanBhatta   1 mW

1 mW
Posts: 10
Joined: Feb 11 2021 11:46pm

Re: Votol EM-100 & EM-150 controllers

Post by PrashanBhatta » Apr 16 2021 1:43am

j bjork wrote:
Apr 15 2021 11:11am
PrashanBhatta wrote:
Apr 13 2021 12:53am

Your motor settings is totally wrong.
It seems like you have the older controller (same as mine)
You can look at my settings, but maybe you shouldent go as high in currents and flux weakening as I do especially in sport mode.(I cant promise you wont brake things with those settings :wink: )
Thanks for your suggestions. I had major problem with the hall shift angle on page 3. Now the motor is working fine and smooth.

But I still don't understand how the ports are mapped in page 'port setting'. I figured out that the PA0 is the pin 5 of hall connector. as shown in figure. could you provide me a proper port mapping to those pins in the connector.
Attachments
pa.PNG
pa.PNG (356.71 KiB) Viewed 424 times
pb.PNG
pb.PNG (159.33 KiB) Viewed 424 times
pc.PNG
pc.PNG (189.94 KiB) Viewed 424 times

Nennko   1 mW

1 mW
Posts: 12
Joined: Aug 13 2020 3:19pm

Re: Votol EM-100 & EM-150 controllers

Post by Nennko » Apr 16 2021 2:30am

j bjork wrote:
Apr 15 2021 11:11am
PrashanBhatta wrote:
Apr 13 2021 12:53am

I have made some small changes since those pictures were taken, but this is basically it.
These settings probably dont work on the newer controllers (sw and hw version on page one)
It seems like flux-weakening compensation on page 2 is not the same thing, and the box to the right on flux-wekening in sport mode is used to tune the motor. Maybe the box to the right on the other flux-w settings too. But there are some info on that on the last few pages.
I reach at least 8000 rpm with these settings.
Thank you mate for sharing with me those settings! I tried a few times them and some of combination and it deosn't work :(

I don't know what to think, is it a matter of configs or some bugs of the controller.

The issue that the motor doesn't rotate when the FW value is more than 2700. Trying hard to reach Votol to help me with it.
Last edited by Nennko on Apr 16 2021 2:33am, edited 1 time in total.

Post Reply