trying to ID a controller so I can add led/pas controller

General Discussion about electric bicycles.
Post Reply
darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 18 2018 3:52pm

Hi Forum,
I'm trying to identify my bike/trike controller so I know what kind of control panel display will work with it. Its a 48v controller. Image shows the label attached to it. Came with a 1000w motor.
Image attached and text shown in the image.
Why I want to know....
This e-trike is working with a thumb throttle. But I haven't gotten the PAS or an LCD/LED controller working with it. And that's why I want to know the provenance of the controller. I bought an 880 but I'm not sure if its compatible, or if I need to order an 890.
I'm sorry if this is in an FAQ. I'll gladly read that. I'd be glad to know what anyone can tell me about the text below besides the voltage and amperage. I'm guessing 2017040246 is the s/n and date of make.
Thanks so much for any help.
Darin

Text on controller reads (same as image attached)
DC MOTO CONTROLLER BY LITHIUM BATTERY
VOLTAGE: DC48V BRAKES:LOW LEVEL
CURRENT: 26A BOOSTER:1:1 820-SMD001
SPEET:SET1.1-4. 2VDUAL (bar code) 2017040246

Image
trike_controller_48v.png
trike_controller_48v.png (247.33 KiB) Viewed 1606 times

habendanio   1 µW

1 µW
Posts: 3
Joined: Jun 03 2018 2:56am

Re: trying to ID a controller so I can add led/pas controller

Post by habendanio » Jun 18 2018 4:11pm

I’ve got a similar controller. Does the PAS work if you peddle backwards? My Pas was originally mounted backwards.

darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

Re: trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 18 2018 4:21pm

I don't know if the PAS works yet. I assumed I'd have to have a display connected to it to select the amount of assist. Is that not the case?
Darin

darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

Re: trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 18 2018 5:48pm

Yes, the PAS works!

Its quite strong but in the right direction, not reversed!

So, now I just need to know how to control the level.

We're almost there forum!
Darin

darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

Re: trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 18 2018 8:06pm

Ok forum. I have added the power cut-off brakes. Got encouraged by the PAS working.

So my final/original question is really can I add a 800 or 880 LED display to this controller so that I can set the PAS level to a 1-3 or 1-4 level?

My controller has a red-white-black-yellow 4 pin connector free. And the pins on my 880 display are red-blue-black-yellow-green. I think one of these is for lights as there is a lights option on the display but I don't care about lights.

docw009   100 kW

100 kW
Posts: 1098
Joined: Aug 02 2015 7:43am
Location: Chicago area suburbs.

Re: trying to ID a controller so I can add led/pas controller

Post by docw009 » Jun 18 2018 10:13pm

Your 880 display is a 5 wire device that sends and receives serial data on the data1 and data2 wires. To get lights, it sends a data packet tp the controller to activate the lights. Other data packets will select the PAS level or the walk mode.
880LED.jpg
880LED.jpg (56.91 KiB) Viewed 1591 times
Since your controller only has 4 wires for the display, that probably means your controller won't work with an 880. Might work with an 800 or 810, which are 4 wire devices, but before you spend the money, what did the controller vendor suggest for the display?

You do want to be careful connecting up an arbitrary display to a 4 or 5 wire connector w/o knowing the wire order because two of those wires are battery voltage and ground. Put across the wrong pins, you'll blow the display.

darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

Re: trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 19 2018 4:02pm

I also have a 4 pin 810 display.

I measured the voltages on my mystery connector coming from the controller. With thumb controller switched on and activating it.
1 yellow - throttles from .8v to 2.2v with thumb controller input
2 red - no change with thumb controller input
3 black - no change with thumb controller input
4 white - throttle from 4.75 to 5.5 with thumb controller input

On the theory that black was ground I have this voltages across black:
black to white: 4.8v
black to yellow: .8v (increasing to 2.2 with throttle)
black to red: 4.3v

Does this help give anyone else confidence that I could hook up an 810 LED like this:
Controller 810 (red, green, black, blue)
1 yellow - throttles from .8v to 2.2v with thumb controller input blue or green?
2 red - no change with thumb controller input battery - red
3 black - no change with thumb controller input ground - black
4 white - throttle from 4.75 to 5.5 with thumb controller input blue or green?

Wife signed us up for 5 day bike trip that starts Friday. If I don't put in a display the PAS is super strong and will probably wipe out the battery too fast. I know from experience the thumb throttle will not last me a whole days ride 25 miles. So I sure appreciate anyone chiming in. My options for this week are:
1. risk this 810 display (no problem financially)
2. turn off PAS (disconnect) - run with just thumb drive.
3. use PAS but power down when not climbing.

Thoughts? I don't really mind too much buying a new controller and display, but that's not really realistic for a vacation starting Friday.

darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

Re: trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 19 2018 4:27pm

Or to phrase the question another way.

Assuming I don't have the right display for my controller.... but the PAS is too strong and I would like to set it to a lower value, how would I go about setting the PAS to a lower setting? I can't do it with the thumb throttle. And everything else is accounted for.

Except this red, yellow, white, black connector. What would that connector be for? It seems logical its for the LED/LCD display.

Darin

darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

Re: trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 19 2018 4:50pm

To continue explaining the situation.

This current offering on Amazon matches exactly what I got in my kit. Each component.
https://www.amazon.com/gp/product/B075L ... SO16&psc=1

There was no LCD or LED display.
There is/was a PAS.
48V 1000W 26" wheel.

So if I had to guess I'd say this was what was provided by my vendor. So my question is, with this purchase can you add a LCD or LED display or some other component (to be able to control the pas power level?).

Darin

docw009   100 kW

100 kW
Posts: 1098
Joined: Aug 02 2015 7:43am
Location: Chicago area suburbs.

Re: trying to ID a controller so I can add led/pas controller

Post by docw009 » Jun 19 2018 6:23pm

Posting the kit helps a little. You've got a 5 wire twist throttle that starts the controller. It only reads the battery voltage (red-yellow-green led indicators). It's a 48V kit. PAS and throttle works.

Mystery 4 wire connector is on the kit. This can't be for a LED display unless it has 48V on one of the pins. It doesn't. And you post that its voltages are mirroring what would be seen on the wires that go to the twist throttle. Seems like a duplicate connector for a throttle with an extra wire,

While it's possible that extra wire could support a PAS select, I'm not optimistic.

darinm   100 µW

100 µW
Posts: 8
Joined: Jun 18 2018 3:34pm

Re: trying to ID a controller so I can add led/pas controller

Post by darinm » Jun 20 2018 4:29pm

Thanks for the thoughts. Makes sense.

pwodock   1 µW

1 µW
Posts: 1
Joined: Aug 20 2018 6:13pm

Re: trying to ID a controller so I can add led/pas controller

Post by pwodock » Aug 21 2018 3:13pm

I have the same controller and wheel combo from Amazon. After much research, I have come to the conclusion that the available four pin connector needs to also accompany the available 2 pin light connector from the controller in order for the display to work. I believe the light connector provides the voltage to power the display (as well as a light) and the 4 pin display connector lines up with the controller connector that contains black (grnd), yellow (low), red (med) and white (high) sense wires. May need to try different combos i.e. black to black, yellow to blue, red to red, white to green. This is the display that appears to fit that description on Aliexpress: https://www.aliexpress.com/item/LED-DIS ... 65377.html
HTB1vnvlOVXXXXajXpXXq6xXFXXXC.jpg
4 pin connector for display and 2 pin for light

User avatar
tomjasz   10 GW

10 GW
Posts: 4106
Joined: Mar 29 2014 1:45pm
Location: Out riding, MN USA
Contact:

Re: trying to ID a controller so I can add led/pas controller

Post by tomjasz » Aug 25 2018 1:27pm

docw009 wrote:
Jun 18 2018 10:13pm
Your 880 display is a 5 wire device that sends and receives serial data on the data1 and data2 wires. To get lights, it sends a data packet tp the controller to activate the lights. Other data packets will select the PAS level or the walk mode.
880LED.jpg

Since your controller only has 4 wires for the display, that probably means your controller won't work with an 880. Might work with an 800 or 810, which are 4 wire devices, but before you spend the money, what did the controller vendor suggest for the display?

You do want to be careful connecting up an arbitrary display to a 4 or 5 wire connector w/o knowing the wire order because two of those wires are battery voltage and ground. Put across the wrong pins, you'll blow the display.
Thanks for that Doc! I didn't need to post the wiring. I have an older kit from Solarbike AU. It has an 880 display but without the 6KPH button.
The data 2 wire, yellow, in the original kit was snipped off and there was no yellow wire in the group to the controller. It worked great.
Now the replacement arrives to fix a sticky switch and the new display no longer activates the PAS function or show the battery power level. Any ideas?
Attachments
Screen Shot 2018-08-25 at 1.32.21 PM.png
ORIGINAL DISPLAY YELLOW SNIPPED
Thanks Justin_le we're here thanks to you. All the best to the mods for their tireless work keeping it on an even keel.

docw009   100 kW

100 kW
Posts: 1098
Joined: Aug 02 2015 7:43am
Location: Chicago area suburbs.

Re: trying to ID a controller so I can add led/pas controller

Post by docw009 » Aug 26 2018 6:34am

Tom, I'd swap in a spare LCD first just to see if the controller is working right.

User avatar
tomjasz   10 GW

10 GW
Posts: 4106
Joined: Mar 29 2014 1:45pm
Location: Out riding, MN USA
Contact:

Re: trying to ID a controller so I can add led/pas controller

Post by tomjasz » Aug 26 2018 3:11pm

docw009 wrote:
Aug 26 2018 6:34am
Tom, I'd swap in a spare LCD first just to see if the controller is working right.
Thanks, the display is new, just different with the added 6kph button. The old display worked if you hit the on button multiple times to turn on. All the functions were working, the user was just afraid one day it wouldn't turn on at all.
Thanks Justin_le we're here thanks to you. All the best to the mods for their tireless work keeping it on an even keel.

docw009   100 kW

100 kW
Posts: 1098
Joined: Aug 02 2015 7:43am
Location: Chicago area suburbs.

Re: trying to ID a controller so I can add led/pas controller

Post by docw009 » Aug 27 2018 12:22pm

Sorry. Didn't read your query close enough. They snipped off one of the data leads? That would likely be the receive data line from the controller. The 880 has to transmit the data to set up PAS level.

Let's assume the 880 has internal circuitry to run the power level display. After all, they put that into the simple LED throttles and the 810 display. Then your new 880 must be broken if no power LED's light up. Mode doesn't come on either?

User avatar
tomjasz   10 GW

10 GW
Posts: 4106
Joined: Mar 29 2014 1:45pm
Location: Out riding, MN USA
Contact:

Re: trying to ID a controller so I can add led/pas controller

Post by tomjasz » Aug 27 2018 2:39pm

docw009 wrote:
Aug 27 2018 12:22pm
Sorry. Didn't read your query close enough. They snipped off one of the data leads? That would likely be the receive data line from the controller. The 880 has to transmit the data to set up PAS level.

Let's assume the 880 has internal circuitry to run the power level display. After all, they put that into the simple LED throttles and the 810 display. Then your new 880 must be broken if no power LED's light up. Mode doesn't come on either?
The LED's work for lo medium and high PAS, but no PAS. And no power. The 880 we replaced had the yellow data snipped and worked without any connection, just the other 4 wires. Put the old one back on, hit one a dozen times and it comes on, PAS works as well as the meter showing battery level. Unfortunately the next time it took 50 pokes to turn on and got worse from there. Not of the info from Kunteng or anyone else seems to explain... Maybe changing data wires and use yellow to GREEN? It works with one data wire and the old display.

This is new to me, I had all BBSxx drives until recently. And a stroke brain doesn't help...

Thank you!
Thanks Justin_le we're here thanks to you. All the best to the mods for their tireless work keeping it on an even keel.

docw009   100 kW

100 kW
Posts: 1098
Joined: Aug 02 2015 7:43am
Location: Chicago area suburbs.

Re: trying to ID a controller so I can add led/pas controller

Post by docw009 » Aug 28 2018 7:29am

Swapping data leads from the 880? It's worth a try.

Thinking about the possible circuit risk ...if the yellow lead from the controller must be the data output, and that's snipped, then the green lead is an input, and you can put either lead from the 880 on it.

You might want to make sure the old 880 is a digital device. See if it powers up with only battery and ground. Put a meter on the green lead and see if it changes in level as you shift PAS. The 810, which only has an analog output starts at 1V for PAS1, 2V for PAS2, 3V for PAS4, and 4V for walk mode. I've made this measurement on my 810's.

User avatar
tomjasz   10 GW

10 GW
Posts: 4106
Joined: Mar 29 2014 1:45pm
Location: Out riding, MN USA
Contact:

Re: trying to ID a controller so I can add led/pas controller

Post by tomjasz » Aug 28 2018 11:57am

docw009 wrote:
Aug 28 2018 7:29am
Swapping data leads from the 880? It's worth a try.

Thinking about the possible circuit risk ...if the yellow lead from the controller must be the data output, and that's snipped, then the green lead is an input, and you can put either lead from the 880 on it.

You might want to make sure the old 880 is a digital device. See if it powers up with only battery and ground. Put a meter on the green lead and see if it changes in level as you shift PAS. The 810, which only has an analog output starts at 1V for PAS1, 2V for PAS2, 3V for PAS4, and 4V for walk mode. I've made this measurement on my 810's.

If you were to install a new controller and simple display, which pair would you use? Mark's bike has an MXUS 750W DD. 48V batteries.

Thank you, again...

T
Thanks Justin_le we're here thanks to you. All the best to the mods for their tireless work keeping it on an even keel.

docw009   100 kW

100 kW
Posts: 1098
Joined: Aug 02 2015 7:43am
Location: Chicago area suburbs.

Re: trying to ID a controller so I can add led/pas controller

Post by docw009 » Aug 28 2018 5:54pm

My biggest controller is the 40A S12S sold by BMSbattery. I see they have a 890 LED display for $10, but it's not clear if it's stand alone. Appears you need ab S-LCD1 to copy settings to it.

User avatar
ABritInNY   100 W

100 W
Posts: 116
Joined: Jul 12 2015 1:55pm

Re: trying to ID a controller so I can add led/pas controller

Post by ABritInNY » Jan 03 2019 6:27pm

pwodock wrote:
Aug 21 2018 3:13pm
I have the same controller and wheel combo from Amazon. After much research, I have come to the conclusion that the available four pin connector needs to also accompany the available 2 pin light connector from the controller in order for the display to work. I believe the light connector provides the voltage to power the display (as well as a light) and the 4 pin display connector lines up with the controller connector that contains black (grnd), yellow (low), red (med) and white (high) sense wires. May need to try different combos i.e. black to black, yellow to blue, red to red, white to green. This is the display that appears to fit that description on Aliexpress: https://www.aliexpress.com/item/LED-DIS ... 65377.html

HTB1vnvlOVXXXXajXpXXq6xXFXXXC.jpg
Yes me too, I bought a cheap 1000w fat front wheel full kit and it had a 26a ESC by lithium battery. There is PAS but no LCD or LED level control. There are only 2 spare connectors, one a 2 pin hall connector style plug is (from their literature) an led light and the other spare is the 4 pin SM whose function is under discussion. Ah well based on the evidence and what I've learned so far here, plus I found one on fleabay cheap(ish) for $13.40 shipped, so ill take a risk and plug in ;) Red to red, black to black, then 50/50 on the other 2 colour match combos... hope it doesn't blow lol
P.S I also think we can switch out the 3 led throttle for the newer style digital voltage display versions with keys pretty easily. The original throttle has a 6 pin SM but they have 5 pins in all, a 3 pin SM as usual for throttle and 2 pin SM for the lock, I"m not sure what the extra 6th wire on our throttle does? but I can probably use the original 6 pin connector and leave it blank
EEB frame set, 1500w Leafmotor 4t winding, Powervelocity 18fet/Lyen 18 fet 4110 ESC, 24s 30ah prismatic cell Lifepo4 batt w/60a-120a BMS, CA V3, Dropper Seat post.
Fusion 48v AGM (4x 12v 15ah) 1000w nom DD rear hub, 50a max ESC, 21sp FS Genesis overkill 650b conversion
Kayman Flash+ 350w Mxus geared hub, dual 36v 5.2ah batts 10.4ah 13a-15a ESC
Freway Vr01, 27sp Pedelec 250w Bafang geared hub, (2x) 36v 5.2ah batt, FVS ESC limited to 10a!! (yup sloow on roads but great on trails ;)

daluc   1 µW

1 µW
Posts: 2
Joined: Dec 23 2018 12:43pm

Re: trying to ID a controller so I can add led/pas controller

Post by daluc » Jan 03 2019 8:56pm

I purchased the same kit on Amazon and it only has the PAS at only one setting which I felt was to strong. I contacted the seller(CNE Bikes) to see if they would sell me any display so that I could change to different Pas settings. Their instruction booklet shows a led/lcd display although my kit did not come with that. Their response was that there is no display for the kit I bought.
As mentioned in earlier posts there are a few connectors that are not used ( a 2-wire and 4-wire). So I ordered a 810 display and a 790 display to try and give me 3 levels of pedal assist. The 4 wire 810 display came first so I tried to hook it up to the unused 4 wire connector. I keep the red with red, black with black and then tried different combos with the other two wires. I could not get the PAS to work and ended up with the throttle(dead) not working at all after 15/20 minuets of trying. I think you have to buy a new controller that will work with a matched dislpay.
So all I can say Is be careful of your wire swapping so you don't end up with a dead throttle like I did.

Post Reply