Hyperion EOS 1420i NET3 14s Balance Charger...

Batteries, Chargers, and Battery Management Systems.
User avatar
dave123   1 µW

1 µW
Posts: 1
Joined: Aug 25 2011 10:10am
Location: Israel

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by dave123 » Nov 10 2018 12:23pm

hello all, is someone sell EOS 1420i net3?

thanks in advance
Turbo Felt Compultion 3 equiped with:
EMP C80100 Sensored brushless motor
20ah (8x6s) Turnigy 48v Lipo batteries
Top Speed 83km/h in 4 sec, 30km distance
8000W mosfets units controlled by e-crazyman controller
weight 30kg
http://www.youtube.com/watch?v=xRVJI3nb ... e=youtu.be

mhoekstra   100 µW

100 µW
Posts: 9
Joined: May 14 2019 12:43am

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by mhoekstra » May 14 2019 12:47am

Hey Guys. I'm looking for some advice about my charger.

Today I left the charge-leads and balance-leads to my 10S pack connected to my Hyperion 1420i Charger, while disconnecting the input to the charger.

Very stupid.
Also the manual states that this is not a good thing.

Looks like the charger on itself is not affected by this mistake.
Unfortunately the (UART via USB) connection to my computer does not work as it should anymore.
It looks like it's constantly reconnecting. Sometimes I get some data, but most of the time it hangs.
Before this mistake it worked flawlessly.

Can anyone point me in the right direction, as to what could be defective in the charger?
Did anyone make the same mistake, and were you successful in repairing it?

john61ct   100 GW

100 GW
Posts: 6710
Joined: Dec 18 2018 2:06pm

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by john61ct » May 14 2019 4:24am

These were discontinued like 4 years ago right?

mhoekstra   100 µW

100 µW
Posts: 9
Joined: May 14 2019 12:43am

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by mhoekstra » May 14 2019 5:14am

john61ct wrote:
May 14 2019 4:24am
These were discontinued like 4 years ago right?
I think you're right. I just bought one on eBay and I'm very happy with it.

lucifuge1973   1 µW

1 µW
Posts: 1
Joined: Feb 24 2020 8:05pm

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by lucifuge1973 » Feb 24 2020 8:13pm

Curious to see if any one is still monitoring this thread. Y'all seem like a friendly bunch. Please forgive me for not being able to search through the whole thread to see if a response maybe have already been given. Hoping one of you fine gents can just answer this for me. I have 3 6s lipos (22.2v) at 5000 ah. Can I charge all three at once with just one balancer.If not can i eliminate the balancer and use a different charging method ie pb or some other setting that doesn't require the balancer. I have two 12 v supplies running this unit. It has become quite a pita to charge these packs separately. Thanks so much and sorry for necroing an old thread

jonyjoe303   100 W

100 W
Posts: 159
Joined: Aug 31 2017 9:44pm

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by jonyjoe303 » Mar 01 2020 12:28am

yes as long as the batteries are the same voltage when connected together. You need to make some sort of 3 way connecter to parallel all the batteries and connect all the balance connecters together.

They also sell a parallel balancing board (about 10 dollars) that you can use. Once all the batteries are connected together the charger sees one big battery and charges appropriately and keep it in balance.
balance board.jpg
balance board.jpg (26.94 KiB) Viewed 525 times

User avatar
ridethelightning   1 MW

1 MW
Posts: 1912
Joined: Jul 21 2013 9:48pm

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by ridethelightning » Jul 08 2020 12:57am

subscribed.
can anyone tell me what "output voltage too low" means? im trying to charge toasted 25rcells that got discharged flat. is that its nice little way of telling me they are trash?

User avatar
ridethelightning   1 MW

1 MW
Posts: 1912
Joined: Jul 21 2013 9:48pm

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by ridethelightning » Jul 08 2020 12:57am

subscribed.
can anyone tell me what "output voltage too low" means? im trying to charge toasted 25r cells that got discharged flat. is that its nice little way of telling me they are trash?

also, while i was charging 2x 1s 60p blocks, i piggied another 10p block on with aligator clips. all seemed normal for a while i went downstairs to wach a movie :)
came back to notice the aligator clip leads were burned through.

looks like got hot and shorted where they overlapped..
why the hell would so much current go to the 10p block all of a sudden, maybe they have internal short??
i think their voltages were similar to start, but after, the 10p was drained to 1.8v??

User avatar
ridethelightning   1 MW

1 MW
Posts: 1912
Joined: Jul 21 2013 9:48pm

Re: Hyperion EOS 1420i NET3 14s Balance Charger...

Post by ridethelightning » Jul 11 2020 8:03am

just an update: i discovered by accident that i can charge the necropacks in "store mode" until they reach 3.6v or so, then using normal charging for the rest...now i have to find out how to enter store mode, as i found it by accident when pressing the buttons.. :)

Post Reply