Sudden Battery Cutoff?

Get all your technical information about electric bikes here.
Post Reply
fluxgame   1 µW

1 µW
Posts: 2
Joined: Sep 11 2019 4:37pm

Sudden Battery Cutoff?

Post by fluxgame » Sep 11 2019 5:08pm

Hi, all. I'm new around these parts, though I've been lurking and reading posts for a while as I put together my first e-bike with a TSDZ2 mid-drive (48v, 750 watt, pedal-assist only) and a DIY 13s2p battery pack with Sanyo GA cells and a 30a BMS. I've only been out on a few rides so far, but it's been great with the exception of a problem I encountered today. Coming back from a big grocery run in 80ºF heat, my battery abruptly cut out and wouldn't turn back on. I shrugged and fell back to pedal power for the rest of the ride home and pushed the 80 lbs of bike + cargo up the 15% grade that I live on top of. Ugh. After putting my groceries away I went back to figure out what was wrong with the bike and it powered right on. I'm assuming that the battery got a bit hot and my BMS shut down, but I'm trying to figure out why that would have happened. I was, admittedly, running at max-assist (3x), but wasn't pedaling hard, so I'd be surprised if the motor was putting out over 500 watts for any appreciable time. So, maybe 10a draw, well within the limits of the pack and BMS. Any ideas?

User avatar
amberwolf   100 GW

100 GW
Posts: 27554
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Sudden Battery Cutoff?

Post by amberwolf » Sep 12 2019 12:59am

Does the BMS actually have a temperature sensor, that's mounted in between the cells?

Or on it's FETs?

If not, then it couldn't shut down from heat (though it could fail from it, it wouldn't recover from that).

If it does, well, even if the cells are capable of handling a high current load it doesn't mean they won't get hot doing it.

A 2p pack at 30A is pushing the cells to 15A (or more) each, which is going to heat them up. The actual load on teh system would have to be measured with a wattmeter or other reasonably accurate power meter or current meter, to know what it's actually drawing from the battery pack under the conditions you're seeing problems with.

Depends on their internal resistance (which depends on their actual condition, and their manufacturer specs), the actual load on them and how long and often that is applied, and on how the pack is designed and packaged (the center cells will usually get hotter than the outer ones, but if the pack is packaged with outer insulation/etc the outer ones will not be able to radiate their heat away either).



But...most likely one or more of the cell groups is not as capable as the others, and under that load is dropping below LVC, so the BMS shuts off output to protect the cells. They might then recover enough so that after you've disconnected the load from the output the BMS will reset, and work again, until enough load is placed on them to drag them below LVC again.

You can measure the voltage of each cell group both just sitting there and while under the load you had a problem with, to see which group is causing the problem.

If the group is low even just sitting there, and under load, it might just not be balance,d and you can leave it on the charger for several hours, days or weeks, depending on how far out of balance it is (or use a single cell charger to bring it up, or an external load on each other higher bank to bring them down to it's level, or a combination of those).

If it is not low just sitting there, but is under the higher load, then there is a cell or cells in the group that have high internal resistance. Or one or more cells in that group are disconnected from the group (or very poorly connected to it) so they aren't able to contribute current.

fluxgame   1 µW

1 µW
Posts: 2
Joined: Sep 11 2019 4:37pm

Re: Sudden Battery Cutoff?

Post by fluxgame » Sep 12 2019 7:01am

Thanks for the reply, that's quite helpful.

My BMS does have a remote temperature probe, which I mounted as close to the center of the pack as I could get it. That doesn't seem like the likely culprit though, since the motor controller is 750 watt, so it shouldn't pull more than 16a. The Sanyo GAs are rated to 10a continuous discharge, so my 2p setup should handle 20a continuous. Am I thinking correctly?

I checked all the cell groups in the pack for voltage this morning, they were all reading around 3.8v with one exception which was reading at 3.4v. I checked all the cells before I built the pack and they were all reading within 0.1v, so I'll throw it on the charger for a while to see if it'll balance out.

Do you have a suggestion for how to test under load? I certainly can't do it while I'm pedaling.

Jan-Erik-86   1 W

1 W
Posts: 63
Joined: Jan 23 2019 4:57am

Re: Sudden Battery Cutoff?

Post by Jan-Erik-86 » Sep 12 2019 10:28am

No need to measure more for now id say. Charge up and balace, go for a medium long ride, recheck cell balance. If that same cell is low, youve found your issue.

User avatar
amberwolf   100 GW

100 GW
Posts: 27554
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: Sudden Battery Cutoff?

Post by amberwolf » Sep 12 2019 5:51pm

fluxgame wrote:
Sep 12 2019 7:01am

My BMS does have a remote temperature probe, which I mounted as close to the center of the pack as I could get it.
Does it have any way to show you what that temperature is, realtime, or can you look at a log of the BMS's actions/data?

That doesn't seem like the likely culprit though, since the motor controller is 750 watt, so it shouldn't pull more than 16a.
The "watt rating" of a controller doesn't necessarily have much to do with it's current limit. I have an "800w" 48v controller that even before I modified it by adding another shunt would let me pull 35A continously. I don't remember that it even listed the current limit on it; I had to determine that experimentally.

Another "500w" controller I have says it has a 25A current limit, but it also lets me pull 35A continously, which it shouldn't do. But it does.

So if you don't actually measure the current, you won't know what it actually draws under any particular circumstance.

The Sanyo GAs are rated to 10a continuous discharge, so my 2p setup should handle 20a continuous. Am I thinking correctly?
But they'll still heat up. How much depends on the actual current, the actual cell characteristics (vs what the spec sheet says they should be), and the actual pack build and external and internal conditions. If you look up the specs for the cells you'll find an internal resistance range for them, whcih you can use to help calculate the heat generated at those high currents, and that will give you an idea of how hot the pack might get.

Let's play with numbers and say there's 2watts of heat inside each cell at max current draw. If there's 26 cells, each with 2watts of heat, it's 52 watts of heat being generated in there. That's a fair bit of heat. If the pack is enclosed with no airflow, that heat builds up, and the center will get hotter than the rest, depending on design and layout. Let's say it started at 80F, the ambient air temperature. I don't have the math handy but you can use that to calculate roughly how quickly the temperature will rise with 52w of heat input, and where it will end up at the end of the time your trip took (to the point of shutdown). If the pack sat in the direct sun for a while before your trip home, it could be many degrees hotter than that when starting out. (and heat build up inside it from the trip there, too, would be added, if it didn't get to radiate away).

My guess is still that it is not heat causing the problem, but the above is still useful info for you to know what is actually going on in there.


FWIW, another problem with insufficient parallel groups for the current load is that you get a lot more voltage sag than otherwise. One result of that is that your BMS will shut off the pack earlier than otherwise, because cells will sag lower than their "actual" state of charge indicates.

Something else is that the controller should also have an LVC, taht is higher than the BMS's LVC. It should stop applying power before the pack gets anywhere near the BMS shutdown point, because running the pack down every time to what the BMS thinks is dead is harder on the cells, giving them a lesser lifespan. A 48v controller should shutdown between 30-33v, where a 48v BMS probably won't shutdown until 28-29v.

I checked all the cell groups in the pack for voltage this morning, they were all reading around 3.8v with one exception which was reading at 3.4v. I checked all the cells before I built the pack and they were all reading within 0.1v, so I'll throw it on the charger for a while to see if it'll balance out.
3.7-3.8v is around half full, while 3.4v is a lot closer to empty, so it's very likely that the low cell group is what caused the shutdown, rather than heat.

Do you have a suggestion for how to test under load? I certainly can't do it while I'm pedaling.
You can, if you add test leads to the cell groups, parallel with your BMS sense/balance leads, and run those out externally to the pack. Then you can connect your multimeter to them, one pair at a time, with the meter on the handlebars or other place you can conveniently see it. Ride for a bit, see the voltage of a group under various loads, stop and change the leads to the next group, and so on.

You're looking more for relative voltage sag, each group compared to others, than the actual voltage they're at. So a group that sags half a volt more than other groups has a problem of one type or another, for instance.

Alternately, you can flip the bike upside down and use your brakes as an adjustable load. It won't be as useful as knowing what the real ride circumstances would show you, but you can test all the way up to stall point if you want to. Will add some wear to your brake pads though. ;)

But you can also just recharge, and make sure the pack is actually fully balanced afterward, then go ride and see if the imbalance recurs.

Post Reply