I need help, as i dont have anywhere to ask, and no one to help me

General Discussion about electric bicycles.
Post Reply
Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 13 2020 1:58pm

Hello, this is my first ebike build and i dont have a clue what could be rhe problem, im adding throttle but almost nothing helps . https://imgur.com/a/4zvbfoy



https://youtu.be/lXGZ-mxtYY8

https://youtu.be/feRsy8ailhM

markz   100 GW

100 GW
Posts: 10979
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 13 2020 2:03pm

Sensorless controllers are good, you probably have a SENSORED controller and you dont have the phase and hall wires hooked up right.
Buy a sensorless controller, connect up the LEARN wires, flick the throttle for the right direction. THEN solder in your phase and hall wires.

Other then that, perhaps some more information, did you buy a kit, what motor, what controller, where did you buy it from.

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 13 2020 2:11pm

Can i get your whatsupp please if you have time as i dont understand half of what you said dear sir. I boght it off a guy in Croatia , qs motor 1000w and some controler kt36/48svprcl-xfc15l4, i have connected all as stated in pictures everywire to every color.


User avatar
amberwolf   100 GW

100 GW
Posts: 30787
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by amberwolf » Jul 13 2020 3:31pm

Davidcroatia wrote:
Jul 13 2020 2:11pm
I boght it off a guy in Croatia ,
Was it working for him? (meaning, did you see it operating?)

Did you wire it exactly the same way he had it wired? If not, you should try that first, if it worked for him but not for you.

If you don't know how he had it wired, you first should ask him for a diagram or pictures of how he wired it, and then wire yours the same way.
qs motor 1000w and some controler kt36/48svprcl-xfc15l4, i have connected all as stated in pictures everywire to every color.
What *exactly* does "everywire to every color" mean?

If you mean that you connected all wires of the same color together, that can destroy the controller, as there are different voltages on some of those.


If you mean something else, please list clearly exactly which wires you connected to each other, or attach a picture to your post that clearly shows which wires are connected to each other.


Beyond that, I suggest looking at other "how to wire my controller" type threads, which give general guidelines and help figuring out that type of problem.



You dont' say what battery you are using. If it is not high enough voltage, or it is too high a voltage, it wont' work with your controller.


You also don't say exactly what your problem is. Stating clearly with as much detail as possible exactly what that is would help us help you.

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 13 2020 4:06pm

Oh, he is just a seller. I have found a guy that will fix it for 70 euro appx, problem is controller or hall sensors need calibrating, that is show how to operate, and he will solve problem for brake distancer, also solve problem for holes in triangle for battery , this is all techincal, i wish people are more like tesla , on youtube share knowledge more :) . Thanks guys you helped me a lot.

markz   100 GW

100 GW
Posts: 10979
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 13 2020 9:19pm

I don't do whatsapp. You have better luck trying to explain yourself more clearly in this forum.

You get no movement at all from the motor, then that could mean many things.

70 euro to fix, well atleast you found someone to fix, but its probably a very simple fix.

This is a good site, but it maybe wise to start somewhere, anywhere.
https://www.ebikes.ca/learn/troubleshooting.html
Testing a Throttle

Testing for a Defective Hall Sensor

Removing a motor stator from the hub
Testing for Blown Mosfets

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 14 2020 2:45am

The main problem is magnets need to be calibrated to work with controller, also he will put xt90 anti dparj connector, and add more holes for the battery case, add ring for a rear triangle so motor doesnt push on a brake, all of those thing i need right away beacuse i borrowed money for this kit and im driving wolt

User avatar
MadRhino   100 GW

100 GW
Posts: 7026
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 14 2020 3:02am

The motor wants to move on the first vid. My guess is either a bad connection or wrong phase/hall combo. Most of the time it is as simple as that.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

User avatar
amberwolf   100 GW

100 GW
Posts: 30787
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by amberwolf » Jul 14 2020 6:58pm

Davidcroatia wrote:
Jul 14 2020 2:45am
The main problem is magnets need to be calibrated to work with controller,
I've never heard of this, and am unaware of any controller that even has a way to do this. I suspect you mean something completely different from what you said, but I can't figure out what it could be.
ring for a rear triangle so motor doesnt push on a brake
I dont' understand what this means. Do you mean a torque arm? To prevent the motor from spinning the axle in the dropouts?

User avatar
amberwolf   100 GW

100 GW
Posts: 30787
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by amberwolf » Jul 14 2020 7:02pm

Davidcroatia wrote:
Jul 13 2020 4:06pm
problem is controller or hall sensors need calibrating,
Sounds like you probably mean that you need the right phase / hall combination for wiring the motor up. There are several threads here that show you exactly how to do that yourself, and even videos on Youtube if you don't like to read.
and he will solve problem for brake distancer,
If you mean spacers for a disc brake rotor, or caliper, that's a pretty standard thing that is posted about a lot here, and many bike shops have parts to do this.
this is all techincal, i wish people are more like tesla , on youtube share knowledge more :) .

There are about 13 years of shared knowledge of tens of thousands of people here on this forum, if you are willing to read any of it.

We could point you to specific things to read, but you must first give exact information about what you have, and what your problems are, in detail, before we can know what to tell you.

You must help us help you.

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 15 2020 12:33pm

Today that guy called me, he first said he needs to limit controller on 14amps continuos, that was the reason of shutting down, and not giving power.. Second as the rings from qs motor are too bih, rear dearaillour doesnt fit anymore so i will need to ride it without the rear dealllaiur and a chain. Third good nnews are that the holes for the battery and that controller are done. Fourth he didnt said anything yet for the spacer for the rear axle. Fifth he said i have done all good connecting the wires right colour etc, phase wires etc, but the controller wasnt calibrated .

User avatar
amberwolf   100 GW

100 GW
Posts: 30787
Joined: Aug 17 2009 6:43am
Location: Phoenix, AZ, USA, Earth, Sol, Local Bubble, Orion Arm, Milky Way, Local Group
Contact:

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by amberwolf » Jul 15 2020 1:00pm

Davidcroatia wrote:
Jul 15 2020 12:33pm
Today that guy called me, he first said he needs to limit controller on 14amps continuos, that was the reason of shutting down, and not giving power..
That means your battery has a problem. Either it's simply too small to handle the power, or it's defective, with mismatched unbalanced cells.
Second as the rings from qs motor are too bih, rear dearaillour doesnt fit anymore so i will need to ride it without the rear dealllaiur and a chain.
Sounds like he's using the wrong spacers, and doesn't know how to setup ebikes. Or else all the stuff you ahve is simply not compatible.
Fourth he didnt said anything yet for the spacer for the rear axle.

Spacers are usually what are used to make things fit so you don't have to get rid of derailer and chain, and/or to make disc brakes work. So yes, he has said something about them, in your "second" part above, you just don't know enough to know what he's telling you.
Fifth he said i have done all good connecting the wires right colour etc, phase wires etc, but the controller wasnt calibrated .
Well, you don't really calibrate a controller, for that kind of thing. He might mean something else, but that word doesnt' really apply.


Hopefully he really is helping you set this thing up right, and knows what he is doing, instead of what it sounds like.

But since you won't tell us anything useful, we can't help you figure out if you're getting things done right by this guy or not. I'ts possible you could have a much better final ride if you'd let us help you help yourself.

Post up what you get when you're done, and if it does what you want or not.

Good luck.

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 15 2020 1:30pm

Sorry my english language is not native, so i maybe mismatch some words. I have a controller that can do 15amp continuos and 30amp of max current. Conntroller was wrongly set up, so he hooked it up thru some box on a computer and limited it to a 14amp draw. So the draw is under 1000w, i think its 750w now. The battery is brand new and is correctly done, i mean it works fine. Screws from qs motor are really big so they have problems with clearance with rear derailleur. When he is done im gonna post pictures and videos of his job. I would like to put it all in this theme, so for future reference people know what problems i had with putting it on , the frame is cube and that could be the problem for rear derailluer because it is an older model of frame.

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 15 2020 2:58pm

Now this good guy tells me motor is not running well because controler brakes it and controlller heats up, maybe its not good set up or maybe its fried, im so sick of this already.

User avatar
MadRhino   100 GW

100 GW
Posts: 7026
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 15 2020 3:37pm

I guess we are back to phase/hall combination. :wink:

The colors of controller to motor wires (5 small hall and 3 big phase) are not matching generally. It is common to have to try and find the proper combination of colors to match the controller and get the motor running fine.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 15 2020 3:48pm

I sent him this, so how to diagnose which wire goes to which wire? Using electronic thing with probes ? Or following manual ?

User avatar
E-HP   1 MW

1 MW
Posts: 1653
Joined: Nov 01 2018 9:20pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by E-HP » Jul 15 2020 4:06pm

Davidcroatia wrote:
Jul 15 2020 3:48pm
I sent him this, so how to diagnose which wire goes to which wire? Using electronic thing with probes ? Or following manual ?
Image

User avatar
MadRhino   100 GW

100 GW
Posts: 7026
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 15 2020 4:16pm

Be careful not to short phases, best is to unpower the controller before making connection changes. Then, power the controller and give some throttle (not full) to check if it does spin the motor.

If you find a combination that spins the motor fine but backwards, swap 2 of the phase wires (any 2 but only 2) and leave them like that from now on, then find the proper hall wires combination to make it run forward.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 16 2020 1:53am

Hello. I just woke up. This guy will see today for wires are they connected good. Considering that some people have ocd, and pure logic, and putting other colors, of other wires, that have the same function, is misleading, also very bad.

In the meantime as i read whole forum pages, i wanted to ask what is the best 135mm motor? I think this is the strongest edition of qs motor 135mm http://www.qs-motor.com/product/1500w-e ... hub-motor/ , one friend that also drives wolt wants to buy one, and which controller would be good to use and why ? Some say I recommend sabvoton svmc72100 controller , but i have found also this one #Aliexpress HRK 1,112.67 | 2020 Sabvoton SVMC9650 48V-96V 50A 1.5KW bldc motor controller for QS motor
https://a.aliexpress.com/_d624Z97 so what would be your pick ? Considering it will be ridden on 48v 40a 24.5ah battery every day around 80km , or if two batteries around 160km of constant stopping and acceleration. Thanks .

User avatar
MadRhino   100 GW

100 GW
Posts: 7026
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 16 2020 3:28pm

Best controller. Best motor. For what?
I find the best made motor for 135mm dropout width is the 1500w leaf motor. Yet there are many reason to choose another, that would be best for a purpose. It is the same for controllers. More functions are making better controllers in theory, but what if you don’t need them? One may have a priority for simple and easy to upgrade power, or the size to fit the bike.

So IMO, there are different best for different purposes and requirements.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 16 2020 4:40pm

Can you tell me the difference between leaf 1500w and qs mmotor 1500w? Is it in torque? Heating ? Better overall quality ? Waterproofing? And dcan you leaas ccompare these 2 controllers as i am green in this

markz   100 GW

100 GW
Posts: 10979
Joined: Jan 09 2014 11:38pm
Location: Alberta Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by markz » Jul 16 2020 6:56pm

Leaf is better.
Has better efficiency, and is better.

User avatar
MadRhino   100 GW

100 GW
Posts: 7026
Joined: Sep 03 2010 5:28pm
Location: Montreal QC Canada

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by MadRhino » Jul 16 2020 8:10pm

Davidcroatia wrote:
Jul 16 2020 4:40pm
Can you tell me the difference between leaf 1500w and qs mmotor 1500w? Is it in torque? Heating ? Better overall quality ? Waterproofing? And dcan you leaas ccompare these 2 controllers as i am green in this
The difference is weight, Honeywell hall sensors, and overall better fabrication precision. But, those two motors are close enough that choosing one or the other won’t make noticeable difference.

Both controllers are the same made and run the same software. Considering your battery 40A output, I’d say take the smaller one for it is capable of more power than your battery limit already.
Make it fool-proof, and I will make a better fool.
Current bikes
Street:
Trek Session 10 mod. Variable geometry. 70mph
Dirt:
Santa Cruz V10. 50mph

Davidcroatia   100 W

100 W
Posts: 172
Joined: Jun 23 2020 5:18pm

Re: I need help, as i dont have anywhere to ask, and no one to help me

Post by Davidcroatia » Jul 18 2020 1:22am

Im worried more about installing leaf motor compared to qs motor. Qs motor needs metal ring behind kranz, also qs motor needs distancer for a brake. Also where could i order it in europe? I mean is leaf motor more of an American company or ?

Post Reply