BBSHD speed sensor torn off

Discussions related to motors other than hub motors.
This includes R/C motors, botttom bracket, roller and geared drives.
Post Reply
sleepless   1 mW

1 mW
Posts: 16
Joined: Nov 27 2017 3:39pm

BBSHD speed sensor torn off

Post by sleepless » Nov 27 2017 3:42pm

Hello!

today was my first ride with my new BBSHD. Somehow I managed to "loose" my speed sensor. In fact it's torn off (as you can see in the picture attached).
24167222_10208377147421217_932038912_o.jpg
24167222_10208377147421217_932038912_o.jpg (219.92 KiB) Viewed 823 times
Well, how can I replace it? I think just a new speed sensor won't help, right? I think I'd need to replace the cable also. But how and where can I get one?

The second question is: Can I ride without it (at least for now)? It seems to work first but after a while it shows an error. Turning on and off works (for a while). Is there a way without restarting all the time? I have to mention that I currently have no programming cable though.

I appreciate your help!

PS: I already posted this on electricbike.com but haven't got any response. Since it currently isn't moving at all anymore I hope you can help me solving this :(
Last edited by sleepless on Nov 27 2017 4:24pm, edited 1 time in total.

User avatar
Marin   1 kW

1 kW
Posts: 359
Joined: May 20 2015 4:51pm
Location: BC, Canada

Re: BBSHD speed sensor torn off

Post by Marin » Nov 27 2017 4:11pm

Various places have parts for sale

Lunacycle, Em3ev, biktrix,

Or the place you bought it
Marin ex-rental hybrid with 48v bionx...sold
Specialized hardrock with magic pie 4-5
Lunacycle with l/r mid drive coming soon
Kona Caldera with QS 30H (maybe), and phase runner
Giant Yukon bbs02
Kona Abra Cadabra bbshd
Wildfire fat bike bbshd

sleepless   1 mW

1 mW
Posts: 16
Joined: Nov 27 2017 3:39pm

Re: BBSHD speed sensor torn off

Post by sleepless » Nov 27 2017 4:21pm

Thanks for your reply. I know where I can get the speed sensor itself but the cable is broken. Please take a look at this picture. It's from the Luna install video:
luna.jpg
luna.jpg (200.92 KiB) Viewed 823 times
This little connector is missing as you can see in the picture in my original post. How can I fix it? Where can I get a replacement for this? I think I have to open the motor-case and install a new cable but where can I get one?

Thanks again!

dustNbone   10 kW

10 kW
Posts: 829
Joined: Mar 13 2016 9:59pm
Location: Vancouver, BC

Re: BBSHD speed sensor torn off

Post by dustNbone » Nov 27 2017 9:11pm

This has the correct connector on one end, I'd just splice that on your existing cable. Wire colors will all match up, just solder and heat shrink them together. Might want to put some liquid electrical tape stuff under the heat shrink for extra waterproofing, as that cable is usually routed through pretty yucky wet spots.

https://lunacycle.com/bafang-8-speedo-extension-cable/

They come in longer lengths as well, but the 8" one is cheapest

I don't see the sensor itself currently listed on Luna, but there's plenty of other suppliers of BBSxx parts. I don't have personal experience with any of them though, so I can't recommend one.

The system should work fine without it, but you'll get that error after the motor runs for a few seconds without getting a signal from the speed sensor.

If you set your desired power level before you set off riding, your throttle should work just fine. Not sure about the PAS because I physically disabled that soon after I installed my BBS02.

User avatar
tomjasz   10 GW

10 GW
Posts: 4082
Joined: Mar 29 2014 1:45pm
Location: Out riding, MN USA
Contact:

Re: BBSHD speed sensor torn off

Post by tomjasz » Nov 29 2017 1:08am

Another one of the items I always have in my kit as a backup!

California eBikes ships first class tracked, CHEAP.
Thanks Justin_le we're here thanks to you. All the best to the mods for their tireless work keeping it on an even keel.

dustNbone   10 kW

10 kW
Posts: 829
Joined: Mar 13 2016 9:59pm
Location: Vancouver, BC

Re: BBSHD speed sensor torn off

Post by dustNbone » Nov 29 2017 1:16pm

Lol and another one of the reasons I biffed the Bafang controller and replaced it with a Grinfineon and just a throttle. Never been so trouble free in my ebiking life!

I turn on the (built in) power switch and hit the throttle. Off she goes. Every time.

User avatar
fechter   100 GW

100 GW
Posts: 13968
Joined: Dec 31 2006 3:23pm
Location: California Bay Area, USA

Re: BBSHD speed sensor torn off

Post by fechter » Nov 29 2017 3:07pm

The connector looks intact in the first picture. I think you just need the sensor. Try unscrewing the ring on the end of your cable remains.
"One test is worth a thousand opinions"

Post Reply