• Howdy! we're looking for donations to finish custom knowledgebase software for this forum. Please see our Funding drive thread

Charger repair....help!

Warren

100 kW
Joined
Oct 5, 2010
Messages
1,639
Gad! I feel so stupid.
This day started out really well. I did one of my favorite rides in the country. I usually average 13-15 mph, on my roadbike these days. On my new e-bike

http://endless-sphere.com/forums/viewtopic.php?f=28&t=30854

I went 45.8 miles, 20.3 mph average, 10.2Wh/mi. I was so happy!

I have a 36 volt, 30 amp Ping pack, and a 5 amp charger..make that had.

I had joined the Powerpole connectors so the red and black connectors would be on opposite sides for the charger and the controller...pretty obvious difference...I thought. Even though I have charged the pack 4-5 times before, I attempted to plug the charger into the output cables of the battery, instead of the charge cables....backwards. :-(

The charger wasn't plugged into the wall yet. The connectors arced pretty good. The 30 amp fuse in the positive line for the pack never blew, but the glass fuse in the charger did. I put a new fuse in, and plugged it up. The red LED lite, but no orange LED, and no fan. The Kill-A-Watt meter, I run the charger through, showed no current flow. I opened it up, but I see no discolored components. I don't know where to start. Any suggestions?

Thanks, Warren
 
sounds like you have blown somthing near the output of the charger to me ...
i would start at the output of the charger looking for voltage and just keep heading upstream till i find the bad component

for example start at the bat side of charger if its reading 0v try farther back in the circuit till you find a voltage

another thing you might look for could be bad capps (bulged on the top or reading 0 ohm from point to point)

my advice would be get in there w/ a voltmeter and just probe till you find a likely bad component

best of luck in troubleshooting

ps some picks of the board and or charger model info may help myself of someone more knowledgeable then me to be able to help you
 
no pictures. if you plugged the charger into the battery with the polarity reversed it will blow up the output capacitor on the charger. can you show pictures? where was the fuse? should not be a fuse in the output of the charger.
 
no new news or pictures?
 
IMG_2839.JPG

the part i have circled looks to be a diode to prevent reverse polarity id make sure you didn't blow that by checking it for resistance.... look for 0 ohms in one direction and unlimited on the other or cheack for voltage b4 and after the diode (once the charger is working dont wory about the voltage differance across the diode it should drop about .5-.7v from one side to the other

if that reads OK just start probing back the circuit till you find a voltage.... i would probably check in the middle for a voltage on both sides of the coil (high in low out)

also a good thing to check is the caps on the output side (dont need any power on for this)
most of the time wen they go they will swell on top(not all the time) and or read 0 ohms across the pins (cap is fused inside)
if replacing a capacitor the replacement doesn't have to be the exact same rating..
for the voltage side feel free to go higher it wont hurt anything all it will do is make the max voltage it can take b4 it blows go up
for the capacitance (uf number) try to match it as close as you can it may have some influence on how the charger preforms


anyway ill shut up now and let you report back what you have found
 
you check the capacitor by putting it on the ohmeter scale and watch the cap charge up then reverse the probes and watch it discharge, the resistance rating will change rapidly as it charges and discharges. it should be obvious though if you reversed the capacitor. it should be swollen. imo
 
thanks for you clarification on the cap check i just meant ive seen caps blow so that they read 0 ohms constant as soon as you probe them

for checking caps i just use the cap setting on my meter normally but not all of us have a meter that reads capacitance

i have seen caps blow w/o swelling but yes they normally swell/mushroom on the top or just out right explode
 
Well, I finally got around to checking on this charger and in the process of checking it, I DEFINITELY blew the diode. :oops:

The really weird thing is that AFTER the diode blew, I plugged the charger back into the wall and the fan came on and the LED came on.

Too bizarre. So now, hopefully if I replace the diode, this charger will work again. Since the diode blew completely apart though I have no way of checking the value.

I've enlarged the picture and it looks like it is either "00", "30", or "80". I guess it could even be "90" though. :?

Since this charger came from hitekbikes.com, I sent an e-mail to Terry at Hitekbikes to see if he knows the value.

Any ideas here?
 
diodes at like a one way valve.... as long as it is rated for at least the battery packs terminal voltage eg a 48v pack charges to up to 60 volts

i would just grab a 120v or 100v diode to be way on the safe side....
now the other value you would need on a diode would be the current handaling capability

if ist a 2 amp charger throw a 6amp diode at it(i like overkill so it dosnt burn again)

the last thing you would need to know is diode type.
i would just throw a rectifyer diode at it as the voltage drop on it shouldnt matter over a larger pack size
 
Back
Top