• Howdy! we're looking for donations to finish custom knowledgebase software for this forum. Please see our Funding drive thread

Sabvoton 72150 controller low top speed issue

Joined
Jan 10, 2020
Messages
47
Hi, I've recently upgraded my e-bike with a new controller (sabvoton 72150) and motor (suringmax v3 3kw 4T) and so far it's been quite good (acceleration is nice). However, I am having 2 issues that I have not yet been able to solve. I would very highly appreciate any suggestions/tips from someone who has more experience than I do. Thank you in advance :thumb:

Issues:
1) Top speed is lower than expected (approx 66km/h @82v (no-load voltage) using 26" wheels)
2) The actual maximum current when accelerating appears to be significantly lower than the "MAX DC Current" that I set in the controller software (for example I set the max DC current in the controller settings to 70A and (using the app that came with my BMS I measure the amperage whilst accelerating and it's only 50 ish AMPS). When I increased the setting in the controller to 90A the max current measured via the BMS app increased to approx 66A whilst accelerating (conclusion: my battery can clearly produce the desired 70A). Assuming the measurement from the BMS is correct I don't know why this is happening. I have asked QS motor on Aliexpress but no answer yet. I will remeasure soon using a separate meter and check if the value displayed on the BMS App is correct or not.

Elaborating on top speed issue:

Current top speed (without field weakening) = 66km/h . My friend has the exact same motor, same battery voltage, heavier bike+human combo (approx 40kg heavier), running approximately the same power (with a different, generic Chinese 3kw nominal controller), and is achieving a top speed of approx 75km/h). I would expect to get a similar top speed. Perhaps I made a mistake setting up the controller, but so far I can't find any setting which could cause this (perhaps due to lack of knowledge).

The top speed has been tested at the aforementioned 66kmph when the battery was at 82.6V (that's the voltage under no load).

Some specs:
Controller: Sabvoton 72150
Battery: 20s10p Sanyo(Panasonic) NCR18650BL (200cells), approximate capacity 3100mah per cell, max discharge 7A (continuous) per cell
Motor: Suringmax V3 3000W, winding: 4T (https://nl.aliexpress.com/item/4000212162738.html?spm=a2g0s.12269583.0.0.49066f41tnMboI)
Wheel size: 26"
Motor wire thickness: 6mm2 copper, length between the controller and inside of motor approx 60cm
BMS: JBD Smart BMS 200A, 600A peak (https://nl.aliexpress.com/item/4001297015223.html?spm=a2g0s.9042311.0.0.27424c4dFeEdvd)

Overview of the main (relevant?) settings I have changed:
(see attached image(s))
-speed limit mode = "no limit".
- I am limiting the "MAX DC current" to 70 Amp because my battery is only rated for 70A (10 parallel, 7A max discharge per cell). The BMS's max amperage is set to 80A (to make sure this isn't the limiting factor).
Whilst acceleration the amperage is approx 67A, when I get to the top speed or close to the top speed, the amperage drops to approx 35A.
- Pn =23 (I have asked the motor manufacturer via Aliexpress, answer: "46 poles (23 pole pairs)" so that's why I changed it to 23)
- I have performed a "Hall test" using a laptop connected to the controller via USB, the hall test result was successful.
- I Changed the motor direction from "0.0" to "1.0" since the motor was spinning in the wrong direction.
- increased minimum throttle voltage to "1.2" (to prevent the wheel from spinning when no throttle is applied)

I have not touched the maximum phase amp settings since I don't know how to determine the values I should input in these fields.

JRZNC4T.png


Questions:

1) Any idea why the top speed is so low? Did I do something wrong in the settings?
2) Any idea why the AMPS measured with BMS appear so much lower than the setting I input in the controller settings? Am I doing something wrong or should I not trust the BMS's AMP reading? (will check with different meter tomorrow)
3) How do I determine the maximum phase amp settings? Is it ok if I don't change the values and only 'mess with' (change) the max DC Amp settings?

Thank you so much! :D Your input is very much appreciated
 
-" increased minimum throttle voltage to "4.2" (to prevent the wheel from spinning when no throttle is applied)"
Is this a typo?

Try resetting the controller and redo the hall test.

Jonno
 
" increased minimum throttle voltage to "4.2" (to prevent the wheel from spinning when no throttle is applied)"
Is this a typo?

EDIT:It was a typo indeed, I meant to say " increased minimum throttle voltage to "1.2" ". Thank you to Jonno for pointing it out

Initially, the minimum throttle voltage setting in the controller software was set to 1.1 volt and seeing as my throttle's output voltage (on the signal wire) when no throttle is applied is approx 1.12 volt the wheel started spinning without applying throttle since the controller thought I was applying throttle. I will replace the throttle with a better one soon. Hopefully that will have a lower (under standard setting) "no throttle voltage" so I can reset that setting to default value.
 
Then reset the controller and put the min throttle to 1.2v and Not 4.2v.Max throttle should be just under the WOT reading on your signal wire IE about 4.85v. hence 4.4v is not top speed.
Phase amps should be set to 2.5 to 3 times battery amps

Jonno
 
@Jonno Sorry, it was indeed a typo. Thank you for pointing it out.
What I meant to say: " increased minimum throttle voltage to "1.2"

And thank you for the info regarding phase amps :thumb:
 
The issue is with the top speed I am achieving (66km/h max with "max DC battery amps" set to 70A (@72v nominal)), it is lower than what I would expect to achieve at this voltage.
I am using a Suringmax v3 motor rated for 3000W nominal power (4T winding) which should achieve a speed of approx 84km/h without field weakening at my battery voltage (72v nominal).

When the wheel is off the ground (unloaded) it spins approx 10% faster than when riding the bike
there is no speed limit set on the controller ("speed limit mode"="no limit"). This is partially due to voltage sag of the battery pack, but also the max amps used at 'top speed' (66km/h) appear to be 'too low' to achieve a higher speed (if my assumptions/calculations are correct).

There is quite a bit of voltage drop due to me loading the cells near their max. continuous current spec.
Battery: 20s10p ncr18650bl (Sanyo) , rated for 7A per cell continuous discharge. Loaded at approx 3.5A per cell at top speed, and at approx 7A per cell whilst accelerating.

I have limited the "max DC battery amps" in the controller settings to 70A because I don't want my battery to overheat.
For some reason, the controller only uses 35A at the current top speed of 66km/h.

At this 35A current draw (at top speed) the battery voltage drops to approx 73v.
I would expect to achieve a top speed of approx 72km/h at this voltage.


I think the controller isn't using enough amps at top speed to go any faster than 66km/h. The power at top speed is approx 2.5kw (73*35=2555w) which (according to the cycling power/speed calculator mentioned below) is enough to reach approx 61km/h.

Whilst accelerating the controller does use close to the set maximum of 70A, it uses approx 66A whilst accelerating.
However, when I get to top speed the amperage drops to approx 35A (this is without field-weakening). I don't know why this happens, I would like the amperage to be approx 60A (this way I would have approx 60*70=4200W power available which should be how much I need to achieve 72km/h according to this cycling power/speed calculator https://www.gribble.org/cycling/power_v_speed.html?units=metric&rp_wr=90&rp_wb=30&rp_a=0.6&rp_cd=1.15&rp_dtl=0&ep_crr=0.01&ep_rho=1.22601&ep_g=0&ep_headwind=0&p2v=200&v2p=85). What setting should I change to achieve this? Do you know why the power is limited to approx 35A at top speed whilst I have the max DC battery amps set much higher at 70? If I turn on field weakening the amperage at top speed does increase (example: approx 50A at top speed when field weakening is set to 40A), field weakening is much less efficient from what I've read though..and the aforementioned speed of 73km/h should be possible without field weakening from my calculations (please correct me if I'm wrong) so I would prefer not to use field weakening if possible.

Edit: I have found a document regarding sabvoton controllers which mentions the max. e-rpm is 30000, which with my motor (46 magnets) --> max RPM=erpm/no_magnets = 30000/46=+/-652.17RPM ... which is approximately the speed the motor spins at under no load (wheel off the ground) without flux weakening. What I don't understand if the e-rpm is indeed only 30000 is that when I enable flux weakening the motor does spin faster (approx 750rpm with 50A flux weakening). How can the motor spin that fast if e-rpm were to be limited to only 30k? I don't think e-rpm changes when flux weakening is enabled, does it?
Perhaps this e-rpm does not apply to my controller (but the document suggests it's for all sabvoton controllers)...
Doc: https://drive.google.com/file/d/1NUSdwjR4qMyjSWR2SzmyNeQSQ7zsMt01/view?usp=sharing (page 19, bottom of page)

controller settings:
JRZNC4T.png


Thank you!
 
Does your speed switch make any difference to the performance?
 
@jonno no the speed switch is currently not connected. When speed switch is connected the highest speed setting reaches the aforementioned speed of 66km/h (loaded/on road speed). The other speed settings only limit the top speed further..
 
Did your 72150 come with a plug and play screen?
 
@jonno it did not come with a screen. I asked the seller and I am quite sure this version is not compatible with a display (if it is compatible it did not come with one). I am using a pc to connect to the controller via USB. I can also connect to the controller via bluetooth using an Android app.
 
Can you post a picture of all the cables exiting the controller please
 
@Jonno Yes. I have made a drawing of all the connections/wires because it is much clearer than a photo (many wires in a small space so hard to see)..

Please take a look and let me know if there are any questions:

XUSc01j.png
 
Try connecting the high speed wire to ground otherwise the controller thinks it is in mid speed.
You might need to alter the boost function as well.
 
@Jonno I will try that. I don't think it will help since when I had the speed switch connected and when the switch was in high speed mode the speed wasn't any higher than without the switch connected. Thank you for the suggestion though, I will try and let you know!

Available settings for "boost/3 speed" setting:
xBo4VpH.png

Note: I'm quite sure "boost mode" means "flux weakening enabled" since flux weakening only works when "boost mode" is enabled.
I have previously tried the "3 speed(switch)" mode with a speed switch connected (3 position switch). With no higher speed limit than the afore mentioned 66km/h as a result unfortunately.
 
@ Jonno I have tried (connected high speed wire to ground) but it made no difference to top speed (both in "3speed (switch)" mode and "boost" mode)...top speed still 66kph unfortunately
 
I am running a 96120, but my wiring is similar.
Looking at your program parameters (again similar to mine - except amps) I see that your (under motor tab) motor speed limit is set to 65%. What I have done with mine is (using no limit) set motor speed limit and mid speed limit to 100%. I would have set the low speed as well, but it won't allow 100%.
I also note under throttle tab, you have mid volt at 2.3 which is ok, but the throttle mid current looks very low (bit hard to read on screen). This should be set to 1 to 2 thirds the max phase current. Mine is set at 120amps. (I would try raising this a small amount at a time (5 to 10 amps), as this has quite an effect when the throttle is applied). I wonder if the low setting you have, restricts the amount of power over the throttle travel.
Also, how are you reading your speed? have you connected a hall wire to a speedometer, wheel pickup or using GPS?
If you are using a hall from the motor (or the spare hall wire for that purpose on the controller wiring (marked hall meter), then you can set your wheel diameter to 1666 and your speedo will show motor rpm. It's a good way to properly check you are getting the correct rpm. Then after testing, you just change it back to the correct size for the wheel you are using.
 
@Santacruz unrelated : Are you using e-brake on your controller? If so are you using an e-brake throttle or a switch? How did you manage to get it working? Thank you!
 
I tested with 120A mid throttle current(standard setting), low speed at 70% (max percentage it would allow), mid speed at 100%, "high speed" wire connected to ground, internal speed limit at 100%, both in "boost" mode and in "3 speed switch" mode. Still the same top speed unfortunately... :/
 
maarten_almighty said:
@Santacruz unrelated : Are you using e-brake on your controller? If so are you using an e-brake throttle or a switch? How did you manage to get it working? Thank you!

Yes, I am using a left half twist throttle. Just plugged in.
However, it needs to be set with a pc program.
I say that, as each time I have made alterations via bluetooth, it gets switched off and the bluetooth program does not have the throttle brake setting. So, now, I do all my changes via pc program. (MQCON V2.1)
This version also has the motor temperature setting.
 
maarten_almighty said:
I tested with 120A mid throttle current(standard setting), low speed at 70% (max percentage it would allow), mid speed at 100%, "high speed" wire connected to ground, internal speed limit at 100%, both in "boost" mode and in "3 speed switch" mode. Still the same top speed unfortunately... :/

I have my speed limit mode set to no limit and I do not have any of the (3 speed switch) wires connected.
 
I have also tried that before (speed limit set to "no limit" mode and nothing connected to speed setting/3 speed wires).. same result :/
I've asked QS motor (company that owns sabvoton) but no answer yet..
 
The controller now also appears to have 'died' :lowbatt: ... was test riding the bike under normal circumstances, max DC battery amps set to 70, was riding at top speed for approx 50 seconds when the issue started (had reached top speed 4 times before without any issues during the same test ride) (not using field weakening), pulling approx 35A (2.5kw).. (controller temp under 30deg. celsius), battery voltage normal (approx 79v unloaded voltage).
I've opened up the motor, all looks well, all magnets in place, coils look good (to be expected since motor never got hot), have tested motor's hall sensors (result=they are all working), also tested motor coils whilst I was at it (using controller tester, coils also good), have reset controller settings to factory settings after which I performed hall sensor test (but during the hall angle test the same issues appeared so the test could not be finished..) so reset did not help.. Looks like the timing of the controller is wrong.

When the motor is spun by hand it turns freely (no hiccups/doesn't feel less smooth anywhere in the rotation)...

When the wheel is turning with the controller on, the motor makes weird noises/appears to misfire the magnet groups at random times causing jolts and temporary braking of the motor, this also happens after I have let go of the throttle/the wheel is still turning due to its momentum...as soon as I turn off the controller (using ignition wire switch), whilst the wheel is still spinning.. the sound stops.

Videos of the issue:
https://i.imgur.com/SA0YQS9.mp4
https://i.imgur.com/uCnYlez.mp4


I'll try and get warranty from the seller but probably not gonna happen.. perhaps better to buy a kelly controller next time :cry: I guess I'm just unlucky with this particular controller as a lot of people seem to be happy with their Sabvoton..

I've checked all wires and connections, all in good condition, properly connected, good contact.
 
maarten_almighty said:
QS motor (company that owns sabvoton)
Wut?

My understanding is that the company no longer exists

and maybe never did, just a label for the various clones,

most of which now, like MQCON, bear no resemblance to the original ones.

So, are you saying that the controllers QS sells with that label, they actually make themselves?
 
@ john61ct You are most likely right regarding the clones. My comment regarding QS motor was more of an assumption..
 
OK, so that brings us to

What are the good purchase sources, so we can be (relatively) confident of the quality of "Sabvoton style" controller we receive?

I assume QS is a trustworthy supplier, but some confirmations would be great?

Others?

Any standouts from a customer service POV, help with tuning & tweaking?

Anyone know who manufactures the ones QS is selling?

If you buy a certain model# elsewhere that matches one QS sells, is that any assurance it is the same controller, from the same maker?
 
Back
Top